Reports Training-
Advanced Reports

Last Updated: 26 February 2013
TABLE OF CONTENTS

REPORTS – OVERVIEW .................................................................................................................. 8
  Report Module Categories ........................................................................................................ 9
UNDERSTANDING REPORT TEMPLATES ....................................................................................... 9
  A Guide to Report Template Names .......................................................................................... 10
  Statistics Templates ............................................................................................................... 12
UNDERSTANDING REPORT TYPES ............................................................................................ 12
  Report Types and their Associated Templates ....................................................................... 13
UNDERSTANDING REPORT DESIGN .......................................................................................... 19
  Report Templates: Basics ........................................................................................................ 19
  Palette .................................................................................................................................... 19
  Background Text .................................................................................................................... 20
    To insert Background Text .................................................................................................... 20
  Fields ..................................................................................................................................... 22
    To insert a Field .................................................................................................................... 22
  Editor ..................................................................................................................................... 23
  Blocks .................................................................................................................................... 24
    Headers ............................................................................................................................... 24
    Footers ................................................................................................................................. 26
    Detail Block ........................................................................................................................ 26
FORMATTING TASKS ...................................................................................................................... 26
  Edit Background Text ............................................................................................................. 26
  Add Extra Space (by Adding Lines) ........................................................................................ 28
  Reduce Space by Deleting Lines ........................................................................................... 30
  Adjust the Size of Your Fields or Background Text ........................................................... 30
  Move Fields or Background Text ............................................................................................ 31
  Add Text ............................................................................................................................... 32
  Add Fields ............................................................................................................................. 33
BIBLIOGRAPHIC REPORTS ............................................................................................................. 36
  Create a Report ...................................................................................................................... 36
  Advanced Bibliographic Reports: Fixed Layout Reports using F10 More .......................... 37
  Saved Files ............................................................................................................................. 42
  Customising the Fixed Layout Templates ............................................................................ 44
CIRCULATION REPORTS – ADDING CHARGES USING F10 MORE ........................................ 47
  Create a Report ...................................................................................................................... 47
  Customising the Template to Include Charges .................................................................... 49
  Borrower Record .................................................................................................................... 49
E-MAIL REPORTS ........................................................................................................... 51
Email Templates ........................................................................................................... 51
Setting Up ..................................................................................................................... 52
Supervisor Parameters ............................................................................................... 52
Setup Individual Email Systems by Location ............................................................ 54
Setup Individual Email Locations, Modules and Reports ........................................... 54
Borrower Settings ........................................................................................................ 55
Customising the Report ............................................................................................... 56
Edit the Template ........................................................................................................ 56
Save the Template ........................................................................................................ 56
Load the Template ........................................................................................................ 57
Creating the Report ...................................................................................................... 58
Where Statement ......................................................................................................... 58
Order .............................................................................................................................. 59
Printing the Emails ..................................................................................................... 60
Start the Scheduler ...................................................................................................... 60
Scheduling the Report ................................................................................................. 61
Check Print Progress ................................................................................................... 62
Email Address Validation Rules .................................................................................. 63
Troubleshooting .......................................................................................................... 63
Examples ...................................................................................................................... 63
Borrower Subject interests report via email (&BORINEM.QRP) .................................. 64
Letters (&1NADDEM.QRP) .......................................................................................... 64
Inter-Library Loans ....................................................................................................... 65
Email Order with GST defined (&OSEGST.QRP) ..................................................... 65
Email Reservations ...................................................................................................... 65
Damaged Item Notice (&STKMRR.QRP) and E-mail (&STKMRRRE.QRP) .............. 66
RUNNING REPORTS WITH E-MAIL ATTACHMENTS ................................................. 67
Supervisor Settings ..................................................................................................... 67
Create the Report ......................................................................................................... 69
Adding the Attachment ............................................................................................... 69
Email Text ...................................................................................................................... 71
Start the Scheduler ...................................................................................................... 73
Schedule the Report .................................................................................................... 73
Reports Training - Advanced Reports

SMS RESERVATIONS & OVERDUES NOTICES .................................................................................. 73
File Transfer Methods .................................................................................................................. 74
SMS Templates ............................................................................................................................. 75
SMS Reservations ......................................................................................................................... 76
  Load the Template ...................................................................................................................... 76
  Create the Report ....................................................................................................................... 77
  Create/Modify the Where Statement ......................................................................................... 77
SMS Overdues ............................................................................................................................... 78
  Load the Template ...................................................................................................................... 78
  Create the Report ....................................................................................................................... 79
  Create/Modify the Where Statement ......................................................................................... 80
Running the SMS Reports File (Reservations/Overdues): File Sharing ........................................ 81
  Scheduling the Report ............................................................................................................... 81
  Start the Scheduler .................................................................................................................... 83
Running the SMS Reports File (Reservations/Overdues): Emailing ................................................ 84
Running the SMS Reports File (Reservations/Overdues): Emailing ................................................ 84
  Supervisor Parameters .............................................................................................................. 84
  Setup Individual Email Systems by Location ........................................................................... 86
  Setup Individual Email Locations, Modules and Reports ........................................................ 86
Set Up SMS-Messaging Service Parameters ................................................................................ 87
  Start the Scheduler .................................................................................................................... 89
AUDITS AND AUDIT REPORTS .................................................................................................. 89
  Supervisor Settings: Setting Up Audits ................................................................................... 90
  Issues Audit ............................................................................................................................... 91
  Load the Template ...................................................................................................................... 92
  Authority Audit Reports ......................................................................................................... 93
  Borrower Audit Reports .......................................................................................................... 95
  Statistics Audit Reports ............................................................................................................ 98
  Creating a Statistics Audit Report ............................................................................................ 99
  Stockitem Audit Reports ....................................................................................................... 101
  Creating a Stockitem Audit Report .......................................................................................... 102
ACCOUNTS AND UPDATE REPORTS ......................................................................................... 104
  Create the Report ..................................................................................................................... 104
    Where Statement .................................................................................................................. 105
    Order By .................................................................................................................................. 105
    F10 More ............................................................................................................................... 106
    Edit the Template to Include Charges .................................................................................. 108
  Print Report (via Scheduler) ...................................................................................................... 108
Reports Training- Advanced Reports

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Borrower</td>
<td>109</td>
</tr>
<tr>
<td>Single Account</td>
<td>110</td>
</tr>
<tr>
<td>Email Reports</td>
<td>110</td>
</tr>
<tr>
<td>Status Updates</td>
<td>111</td>
</tr>
<tr>
<td>Reservation Statuses</td>
<td>111</td>
</tr>
<tr>
<td>AUTOMATIC BORROWER AND CIRCULATION UPDATES</td>
<td>112</td>
</tr>
<tr>
<td>Borrower Update Reports</td>
<td>112</td>
</tr>
<tr>
<td>Template</td>
<td>112</td>
</tr>
<tr>
<td>Create the Report</td>
<td>113</td>
</tr>
<tr>
<td>Set Where Parameters</td>
<td>113</td>
</tr>
<tr>
<td>Update Parameters (F10 More)</td>
<td>115</td>
</tr>
<tr>
<td>Notes</td>
<td>116</td>
</tr>
<tr>
<td>Memos</td>
<td>116</td>
</tr>
<tr>
<td>View Report</td>
<td>117</td>
</tr>
<tr>
<td>Print Report (via Scheduler)</td>
<td>117</td>
</tr>
<tr>
<td>Start the Scheduler</td>
<td>118</td>
</tr>
<tr>
<td>Scheduling the Report</td>
<td>118</td>
</tr>
<tr>
<td>Running Borrower Circulation Update Reports</td>
<td>121</td>
</tr>
<tr>
<td>Setting up the Reports</td>
<td>121</td>
</tr>
<tr>
<td>Print Report (via Scheduler)</td>
<td>127</td>
</tr>
<tr>
<td>Check the Suspended Borrowers</td>
<td>130</td>
</tr>
<tr>
<td>SAVING A REPORT TO FILE</td>
<td>132</td>
</tr>
<tr>
<td>Table</td>
<td>132</td>
</tr>
<tr>
<td>Report</td>
<td>133</td>
</tr>
<tr>
<td>LOADING TEMPLATES</td>
<td>135</td>
</tr>
<tr>
<td>SCHEDULING REPORTS</td>
<td>139</td>
</tr>
<tr>
<td>Print Report (via Scheduler)</td>
<td>139</td>
</tr>
<tr>
<td>Start the Scheduler</td>
<td>139</td>
</tr>
<tr>
<td>Scheduling the Report</td>
<td>140</td>
</tr>
<tr>
<td>Check Print Progress</td>
<td>141</td>
</tr>
<tr>
<td>LAUNCH REPORTS UNATTENDED</td>
<td>141</td>
</tr>
<tr>
<td>Sample Command Line Parameters</td>
<td>142</td>
</tr>
<tr>
<td>Report Functionality</td>
<td>142</td>
</tr>
</tbody>
</table>
APPENDICES .................................................................................................................................................. 143

Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation
Transactions Types (RepCirculation and RepReservations Only) ......................................................... 144

Appendix 2: Sample Overdue Date Line .................................................................................................. 145

Appendix 3: Operators ............................................................................................................................. 146
REPORTS - OVERVIEW

Reports are used for every conceivable purpose within Amlib, from printing up tables and updating borrower records to printing out overdue notices.

It is possible to create and run a huge variety of reports covering every single module. In addition, it is possible for you to customise these reports in both their design and functionality.

The creation of a report is covered in broad terms by the following flowchart:

- **Template**
  - Design and Function

- **Report Type**
  - Matching template to module and function

- **Create Report**
  - Report selection and description

- **Data**
  - Search conditions and parameters

- **Order**
  - Sequencing the results

- **Results**
  - View/printing results

Files with .QRP extension

- Created/edited in RepWin (REPWIN30.EXE)

Determined by *Where* parameters or by selecting a *Saved File*
Report Module Categories

The Reports module is split into the following categories:

<table>
<thead>
<tr>
<th>REPORT</th>
<th>DESCRIPTION</th>
<th>EXAMPLES</th>
</tr>
</thead>
<tbody>
<tr>
<td>RepAccounts</td>
<td>Accounts Reports</td>
<td>Account Reprints without creating a Financial record for the borrower.</td>
</tr>
<tr>
<td>RepAuthority</td>
<td>Authority Reports</td>
<td>Author, Series, Subject Heading Listings, etc</td>
</tr>
<tr>
<td>RepBibliographic</td>
<td>Bibliographic (Catalogue Data) Reports</td>
<td>New items displaying Title, Author, Subject Headings, Notes etc.</td>
</tr>
<tr>
<td>RepBorrower</td>
<td>Borrower Reports</td>
<td>Listings of borrowers, loan histories, address labels</td>
</tr>
<tr>
<td>RepCatalogue</td>
<td>Catalogue Report – for more tag displays use RepBibliographic</td>
<td>4 lines of data to show items by a particular author etc.</td>
</tr>
<tr>
<td>RepCirculation</td>
<td>Circulation Reports</td>
<td>Items on Loan, Overdue lists, slips, Letters, Invoices etc.</td>
</tr>
<tr>
<td>RepFinancial</td>
<td>Financial Reports</td>
<td>Budget categories and expenditure etc.</td>
</tr>
<tr>
<td>RepILLS</td>
<td>Inter Library Loan Reports</td>
<td>ILL notices including request &amp; renewal notices etc.</td>
</tr>
<tr>
<td>RepOrders</td>
<td>Order Reports</td>
<td>Orders, Supplier Listings</td>
</tr>
<tr>
<td>RepPeriodicals</td>
<td>Periodical Reports</td>
<td>Full journal listing, Suppliers, Renewal reminders, Claims etc.</td>
</tr>
<tr>
<td>RepReservation</td>
<td>Reservation Reports</td>
<td>Pick-up lists, reservation collection notices and expired reservations lists</td>
</tr>
<tr>
<td>RepStatistics</td>
<td>Statistics Reports</td>
<td>Statistics summary and detailed reports on library activity. Daily, Weekly, Monthly, Yearly etc. Issues by Borrower Type or by Form or Stats code. The Order MUST be correct!</td>
</tr>
<tr>
<td>RepStockitem</td>
<td>Stockitem Reports</td>
<td>Listing of items, Value of the collection</td>
</tr>
</tbody>
</table>
## A Guide to Report Template Names

<table>
<thead>
<tr>
<th>PREFIX</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>#, &amp;, $</td>
<td>System reports – these are supplied with <em>Amlib</em></td>
</tr>
<tr>
<td>RS, MM, MC</td>
<td>Customised reports – any reports beginning with letters are customised reports, specific to a library with their own wording</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>ABBREVIATION</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>AUTH</td>
<td>Authority templates</td>
<td>&amp;AUTHSBB2.QRP &amp;AUTHFUL.QRP</td>
</tr>
<tr>
<td>B</td>
<td>Borrower templates</td>
<td>&amp;BCT.QRP &amp;BCLT.QRP</td>
</tr>
<tr>
<td>BOR</td>
<td>Borrower templates</td>
<td>&amp;BORDATA.QRP &amp;BORSHT.QRP</td>
</tr>
<tr>
<td>BIB</td>
<td>Bibliographic templates</td>
<td>&amp;BIB.QRP &amp;BIB2.QRP</td>
</tr>
<tr>
<td>BORH</td>
<td>Borrower history templates</td>
<td>&amp;BORHIST.QRP &amp;BORHISC.QRP &amp;BORH10.QRP</td>
</tr>
<tr>
<td>CI</td>
<td>Circulation issues slips</td>
<td>&amp;CI1ISS.QRP &amp;CI1NEW.QRP &amp;CI1000.QRP</td>
</tr>
<tr>
<td>FIN</td>
<td>Financial templates</td>
<td>&amp;FINBUDG.QRP &amp;FINCURR.QRP &amp;FINTRAN.QRP</td>
</tr>
<tr>
<td>ILL</td>
<td>Inter-library loan templates</td>
<td>&amp;ILLEREM.QRP &amp;ILLLET.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Standard letter templates</td>
<td>&amp;N1ADD10.QRP &amp;N1ADDEM.QRP</td>
</tr>
<tr>
<td>NC, NEC, NEI</td>
<td>NetOpac programmed templates</td>
<td>&amp;NCTBRF.QRP &amp;NECTBRF.QRP &amp;NEITBRF.QRP</td>
</tr>
<tr>
<td>OD</td>
<td>Circulation templates: <em>Overdues</em></td>
<td>&amp;ODEMAIL.QRP &amp;ODLET.QRP &amp;ODLET1C.QRP &amp;ODLET1G.QRP</td>
</tr>
<tr>
<td>EMAIL, EML</td>
<td>E-mail templates</td>
<td>&amp;ODEMAIL.QRP &amp;RESEML.QRP</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>LET</td>
<td>Letter templates</td>
<td>&amp;ODLET1C.QRP ODLET1G.QRP</td>
</tr>
<tr>
<td>OR, OS</td>
<td>Order templates</td>
<td>&amp;ORSI.QRP &amp;ORSICL.QRP &amp;OSD100.QRP</td>
</tr>
<tr>
<td>PE</td>
<td>Periodical templates: <strong>Periodicals and Suppliers</strong></td>
<td>&amp;PE0010.QRP &amp;PE0100.QRP &amp;PE1000.QRP</td>
</tr>
<tr>
<td>PI</td>
<td>Periodical templates: <strong>Periodicals and Issues</strong></td>
<td>&amp;PI0001.QRP &amp;PI0100.QRP &amp;PI0010.QRP</td>
</tr>
<tr>
<td>PIC</td>
<td>Periodical templates: <strong>Periodicals, Issues, Copies</strong></td>
<td>&amp;PIC010.QRP &amp;PICCLAIM.QRP</td>
</tr>
<tr>
<td>PICS</td>
<td>Periodical templates: <strong>Periodicals, Issues, Copies, Stockitems</strong></td>
<td>&amp;PICS010.QRP &amp;PICS001.QRP</td>
</tr>
<tr>
<td>SU</td>
<td>Periodical templates: <strong>Suppliers only</strong></td>
<td>&amp;SU1000.QRP</td>
</tr>
<tr>
<td>RES</td>
<td>Reservation templates</td>
<td>&amp;RESBRF.QRP &amp;RESEML.QRP &amp;RESLIST.QRP</td>
</tr>
<tr>
<td>SAD</td>
<td>Stockitem audit templates</td>
<td>&amp;SADDET.QRP &amp;SADBRR.QRP</td>
</tr>
<tr>
<td>SPINE, SPN</td>
<td>Spine label templates</td>
<td>&amp;SPN9C.QRP &amp;SPINE9.QRP</td>
</tr>
<tr>
<td>STAC</td>
<td>Statistics Reports: <strong>Grouped by borrower class</strong></td>
<td>&amp;STAC511.QRP &amp;STAC520.QRP</td>
</tr>
<tr>
<td>STAG</td>
<td>Statistics Reports: <strong>Grouped by borrower group</strong></td>
<td>&amp;STAG531.QRP &amp;STAG540.QRP</td>
</tr>
<tr>
<td>STAT</td>
<td>Statistics Reports: <strong>General</strong></td>
<td>&amp;STAT100.QRP &amp;STAT210.QRP</td>
</tr>
<tr>
<td>STK</td>
<td>Stockitem Reports</td>
<td>&amp;STKTACT.QRP &amp;STKCF5.QRP</td>
</tr>
<tr>
<td>STKH</td>
<td>Stockitem History</td>
<td>&amp;STKHHIST.QRP &amp;STKHISU.QRP &amp;STKHCSC.QRP</td>
</tr>
<tr>
<td>STKTUR</td>
<td>Stockitem Turnover reports</td>
<td>&amp;STKTUR1.QRP &amp;STKTUR2.QRP</td>
</tr>
<tr>
<td>X</td>
<td>Reports that output to Microsoft Excel</td>
<td>&amp;XSTKFS.QRP &amp;XSTAT20.QRP</td>
</tr>
</tbody>
</table>
Statistics Templates

<table>
<thead>
<tr>
<th>NUMBER/LETTER</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>100</td>
<td>Summary by year</td>
<td>&amp;STAT110.QRP, &amp;STAT111.QRP</td>
</tr>
<tr>
<td>200</td>
<td>Summary by month</td>
<td>&amp;STAT200.QRP, &amp;STAT205.QRP</td>
</tr>
<tr>
<td>300</td>
<td>Summary by day</td>
<td>&amp;STAT300.QRP, &amp;STAT310.QRP</td>
</tr>
<tr>
<td>400</td>
<td>Summary by hour</td>
<td>&amp;STAT410.QRP, &amp;STAT411.QRP</td>
</tr>
<tr>
<td>500</td>
<td>More detailed reports - for example: containing borrower type, suburb, etc.</td>
<td>&amp;STAT500.QRP, &amp;STAT502.QRP</td>
</tr>
<tr>
<td>600</td>
<td>Detailed reports</td>
<td>&amp;STAT620.QRP, &amp;STAT630.QRP</td>
</tr>
<tr>
<td>1</td>
<td>Subdivides by location</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>t</td>
<td>Subdivides by type (statistical type)</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>b</td>
<td>Subdivides by borrower</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>f</td>
<td>Subdivides by form code</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>s</td>
<td>Subdivides by stats code</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>y</td>
<td>Subdivides by year</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>m</td>
<td>Subdivides by month</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>d</td>
<td>Subdivides by day</td>
<td>See screenshot below</td>
</tr>
<tr>
<td>h</td>
<td>Subdivides by hour</td>
<td>See screenshot below</td>
</tr>
</tbody>
</table>

UNDERSTANDING REPORT TYPES
## Report Types and their Associated Templates

<table>
<thead>
<tr>
<th>REPORT TYPES AVAILABLE</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ACCOUNT</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>No report types</td>
<td>Reprint of accounts</td>
<td>&amp;ACI100.QRP</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>AUTHORITY</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Authority (Default)</td>
<td>Lists of Authorities - for example: Subjects</td>
<td>&amp;AUTHBR2.QRP</td>
</tr>
<tr>
<td>See References</td>
<td>Lists of Authorities that use See References</td>
<td>&amp;AUTHSB2.QRP</td>
</tr>
<tr>
<td>See / See Also References</td>
<td>Lists of Authorities that use See Also References</td>
<td>&amp;AUTHSAB.QRP</td>
</tr>
<tr>
<td>Authority Audits</td>
<td>Authority audits - for example: Deleted Authorities</td>
<td>&amp;AUTHAUD.QRP</td>
</tr>
<tr>
<td>Authority with See and See Alsos</td>
<td>Lists of Authorities that use both See &amp; See Also References</td>
<td>&amp;AUTHFS2.QRP</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>BIBIOLOGRAPHIC</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bibliographic (Default)</td>
<td>List of Catalogues with Bibliographic data (for example: Subjects, Notes) using Where parameters to select the Tags</td>
<td>&amp;BIB2.QRP</td>
</tr>
<tr>
<td>Fixed layout Reports</td>
<td>List of Catalogues with Bibliographic data (for example: Subjects, Notes) using F10 More to select the Tags</td>
<td>&amp;BIBFL28.QRP</td>
</tr>
<tr>
<td>Bib with Image + stock</td>
<td>List of Catalogues with Bibliographic data &amp; some Stockitem set Fields with image included</td>
<td>&amp;CTITEMX.QRP</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>BORROWER</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Borrower (Default)</td>
<td>Borrower listings, counts</td>
<td>&amp;BORMED.QRP</td>
</tr>
<tr>
<td>Audit Reports</td>
<td>Audits - for example: Deleted, New borrowers</td>
<td>&amp;BORRAUD.QRP</td>
</tr>
<tr>
<td>Borrower History</td>
<td>Items the borrower has lent and returned + items generated in reports (overdues, reserves)</td>
<td>&amp;BORHIST.QRP</td>
</tr>
<tr>
<td>Borrower (purge) Financial</td>
<td>Deletion of Borrower financial records</td>
<td>&amp;BORFINP.QRP</td>
</tr>
<tr>
<td>Borrower (list) Financial</td>
<td>List of Borrower Financial - for example: money owing</td>
<td>&amp;BOFINITO.QRP</td>
</tr>
<tr>
<td>Name and Addresses x 1 across</td>
<td>Borrower Letter</td>
<td>&amp;N1ADD10.QRP</td>
</tr>
<tr>
<td>Name and Addresses x 1 across Email</td>
<td>Borrower Letter by email - for example: Welcome letter</td>
<td>&amp;N1ADDEM.QRP</td>
</tr>
<tr>
<td>Name and Addresses x 3 across</td>
<td>Address Labels</td>
<td>&amp;N3ADD20.QRP</td>
</tr>
<tr>
<td><strong>Borrower Interest Reports</strong></td>
<td>New items alert for Borrowers with Interests</td>
<td>&amp;BORINT.QRP</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td><strong>Borrower Interest Reports - Email</strong></td>
<td>New items email alert for Borrowers with Interests</td>
<td>&amp;BORINEM.QRP</td>
</tr>
<tr>
<td><strong>Borrower Profile Reports</strong></td>
<td>Borrower Profiles - for example: Age Groups</td>
<td>&amp;BORPROS.QRP</td>
</tr>
<tr>
<td><strong>Borrower Memos</strong></td>
<td>Report that allows print of text in Memos</td>
<td>&amp;BORMEMO.QPR</td>
</tr>
<tr>
<td><strong>Borrower Images</strong></td>
<td>Includes Image of Borrower - for example: Borrower card</td>
<td>&amp;BORCRDP.QRP</td>
</tr>
<tr>
<td><strong>Borrower Automatic Update</strong></td>
<td>Enables mass changing of Borrower Types, Classes, Groups and Status. Details are changed through the F10 More options</td>
<td>&amp;BORUPD.QRP</td>
</tr>
<tr>
<td><strong>Borrower Circulation Automatic Update</strong></td>
<td>Enables mass changing of Borrower Types, Classes, Groups and Status based on due date parameters in the ‘where’ statement. Details are changed through the F10 More options</td>
<td>&amp;BORCUPD.QRP</td>
</tr>
</tbody>
</table>

**CATALOGUE**

| No report types | Catalogue list with the Display lines | &CATFULL.QRP |

**CIRCULATION**

These templates are often customised for each individual site

<p>| <strong>Title, Author, Form, Item No, Location (Default)</strong> | Lists &amp; Letters with 8 items/borrower (often used with preprinted slips) | &amp;OD2000.QRP |
| <strong>Title, Call No, Stats Code, Item No, Location</strong> | Lists &amp; Letters with 8 items/borrower | |
| <strong>Res, Title, Author, Form, Item No, Location</strong> | Recall list for overdue items with attached reservations – Author in line 2 | &amp;CIRRESA.QRP |
| <strong>Res, Title, Call No, Stats Code, Item No, Location</strong> | Recall list for overdue items with attached reservations – Call No in line 2 | &amp;CIRRESC.QRP |
| <strong>Type, Group, Class, AuthForm, Item.locn</strong> | Lists &amp; Letters with 8 items/borrower displaying Type, Group and/or Class | &amp;BTCIRC.QRP |
| <strong>Continuous - Full Descriptions</strong> | Lists &amp; Letters with unlimited items | &amp;ODLST.QRP |
| <strong>Continuous - E-mail</strong> | Letters with unlimited items via Email | &amp;ODEMAIL.QRP |
| <strong>Offline files export</strong> | For Advanced Offline only to copy Borrower &amp; Item tables | &amp;OFFLINE.QRP |
| <strong>Offline process report</strong> | Report for Advanced Offline Process | &amp;AOLPROC.QRP |</p>
<table>
<thead>
<tr>
<th><strong>FINANCIAL</strong></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Account Listing</td>
<td>Listing of Budget Accounts</td>
<td>&amp;FINACCT.QRP</td>
</tr>
<tr>
<td>Allocation Codes</td>
<td>Listing of Budget Allocations</td>
<td>&amp;FINALL.QRP</td>
</tr>
<tr>
<td>Budget Summary</td>
<td>Analysis of Budget</td>
<td>&amp;FINBUDG.QRP</td>
</tr>
<tr>
<td>Currency Codes</td>
<td>Listing of Budget Currency Codes</td>
<td>&amp;FINCURRE.QRP</td>
</tr>
<tr>
<td>GL Codes Listing</td>
<td>Listing of General Ledger showing levels</td>
<td>&amp;FINGLQ.RP</td>
</tr>
<tr>
<td>Ledger Format</td>
<td>Account Transaction Totals for Budget</td>
<td>&amp;FINLEDG.QRP</td>
</tr>
<tr>
<td>Circulation Trans</td>
<td>Circulation Transactions</td>
<td>&amp;CFINDET.QRP</td>
</tr>
<tr>
<td>Aged Borrower (4 mths) Transactions</td>
<td>Borrower Monthly Transaction Totals (single line Accounting)</td>
<td>&amp;FINAGE4.QRP</td>
</tr>
<tr>
<td>Aged Borrower (6 mths) Transactions</td>
<td>Borrower Monthly Transaction Totals (single line Accounting)</td>
<td>&amp;FINAGE6.QRP</td>
</tr>
<tr>
<td>Aged Borrower (12 mths) Transactions</td>
<td>Borrower Monthly Transaction Totals (single line Accounting)</td>
<td>&amp;FINAGE12.QRP</td>
</tr>
<tr>
<td>Borrower Fin. Trans. Audit</td>
<td>Borrower Financial Transaction Audit (single line Accounting)</td>
<td>&amp;FBFAUD.QRP</td>
</tr>
<tr>
<td>Borrower Summary Fin. Trans. Audit</td>
<td>Borrower Financial Transaction Audit (single line Accounting)</td>
<td>&amp;FBSUM.QRP</td>
</tr>
<tr>
<td>Borrower Owing</td>
<td>Details of borrowers’ fines. For use with print letter format templates.</td>
<td>&amp;FINOWE.QRP</td>
</tr>
<tr>
<td>Borrower Owing Email</td>
<td>Details of borrowers’ fines. For use with e-mail templates.</td>
<td>&amp;FINOWEE.QRP</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>INTER-LIBRARY LOAN</strong></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Letters, Lists</td>
<td>&amp;ILLREM.QRP</td>
</tr>
<tr>
<td>E-Mail Request</td>
<td>Letters via Email to first supplying library</td>
<td>&amp;ILLEREM.QRP</td>
</tr>
<tr>
<td>E-Mail Request to all Suppliers</td>
<td>Letters via Email to ALL supplying libraries</td>
<td>&amp;ILLEREQ.QRP</td>
</tr>
<tr>
<td>ORDER</td>
<td>Description</td>
<td>Code</td>
</tr>
<tr>
<td>-------</td>
<td>-------------</td>
<td>------</td>
</tr>
<tr>
<td>Supplier, Order Header &amp; Order Line (Default)</td>
<td>Order Forms</td>
<td>&amp;ORDGST.QRP</td>
</tr>
<tr>
<td>Order Header, Order Line &amp; Received Stockitems</td>
<td>Run in update mode, posts Date Printed to Order Header</td>
<td>&amp;OSI100.QRP</td>
</tr>
<tr>
<td>Order Header, Order Line &amp; Order Items/Non-Items</td>
<td>Summary of Orders with Stockitems etc.</td>
<td>&amp;OON100.QRP</td>
</tr>
<tr>
<td>Supplier</td>
<td>Supplier Listing</td>
<td>&amp;OSU100.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header &amp; Order Line - E-Mail</td>
<td>Email Order</td>
<td>&amp;OSEGST.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header &amp; Order Line - EDIFACT</td>
<td>EDIFACT Order</td>
<td>&amp;OREDQ.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items</td>
<td>Order Status report</td>
<td>&amp;ORSI.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items to Claimed</td>
<td>Order Claims notices. Update Entity will set status to claimed for Order Lines</td>
<td>&amp;ORSICL.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items to Returned</td>
<td>Returns notice for Orders. Update Entity will set status to Returned for Order Lines</td>
<td>&amp;ORSIR.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items to Cancelled</td>
<td>Cancellation of Orders. Update Entity will set status to Cancelled for Order Lines</td>
<td>&amp;ORSICAL.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items E-mail</td>
<td>Order status report via Email</td>
<td>&amp;ORSIE.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items E-mail to Claimed</td>
<td>Order Claims notices via Email. Update entity will set status to claimed for Order Lines</td>
<td>&amp;ORSIECL.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items E-mail to Returned</td>
<td>Returns notice for Orders via Email. Update Entity will set status to Returned for Order Lines</td>
<td>&amp;ORSIER.QRP</td>
</tr>
<tr>
<td>Supplier, Order Header, Order Line &amp; Order Items/Non-Items E-mail to Cancelled</td>
<td>Cancellation of Orders via Email. Update Entity will set status to Cancelled for Order Lines</td>
<td>&amp;ORSIECA.QRP</td>
</tr>
<tr>
<td>Supplier, Invoice Header &amp;</td>
<td>Invoice details Update entity would post Report Date</td>
<td>&amp;OSINV.QRP</td>
</tr>
</tbody>
</table>
## Reports Training - Advanced Reports

### Invoice Line
- to Invoice screen

### Periodical
- **Periodical, Issue, Copy & Item (Default)**
  - Listings with Stockitems
  - &PICS001.QRP
- **Periodical, Issue & Copy**
  - Listings with Copies, Claim letter
  - &PICLAIM.QRP
- **Periodical & Issue**
  - Listing with Issues
  - &PI0100.QRP
- **Periodical**
  - Listings
  - &PE0001.QRP
- **Supplier**
  - Suppliers only
  - &SU1000.QRP
- **Periodical, Issue, Copy Email**
  - Claim letter by Email
  - &PICLE.QRP

### Reservation
- **Reservations (Default)**
  - Reservation notice or list (8 per notice)
  - &RESBRF.QRP
- **Expired Reservation Clear**
  - Clear reservations en masse
  - &RESEXPB.QRP
- **- E-Mail**
  - Reservation notice via email
  - &RESEML.QRP
- **Unlimited Reservation Format**
  - Reservation notice or list (unlimited)
  - &RESLIST.QRP

### Statistics
- **Statistics**
  - Most Statistics Reports
  - &STAT200.QRP
- **Access Audit**
  - Access to Authorities by Operator - for example: Viewed Attachments, view Authorities giving Date and Time
  - &SAAUDIT.QRP
- **Logon Audit**
  - Date and Time Operators logged onto certain modules
  - &SLAUDIT.QRP
- **Search Audit**
  - Search terms used within the Programs and the Type of search done
  - &SSAUDIT.QRP

### Stockitem
- **Stockitems (Default)**
  - Lists of items
  - &STKTACT.QRP
- **Item Audit**
  - Item Audits - for example: Items deleted
  - &SADBR.QRP
- **Item History**
  - Item History
  - &STKHIST.QRP
- **Memos**
  - Stockitem memo list
  - &STKMEMOS.QRP
- **Most Recent Return**
  - Last Borrower - for example: Damaged Item Notice
  - &STKMRR.QRP
- **Most Recent Return Email**
  - Last Borrower - for example: Damaged Item Notice
  - &STKMRRRE.QRP
<table>
<thead>
<tr>
<th>Spine Labels 1 label wide</th>
<th>Spine Labels - 1 label across</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spine Labels 2 label wide</td>
<td>Spine Labels - 2 labels across</td>
</tr>
<tr>
<td>Spine Labels 3 label wide</td>
<td>Spine Labels - 3 labels across</td>
</tr>
<tr>
<td>Spine Labels 4 label wide</td>
<td>Spine Labels - 4 labels across</td>
</tr>
<tr>
<td>Spine Labels 5 label wide</td>
<td>Spine Labels - 5 labels across</td>
</tr>
<tr>
<td>Spine Labels 6 label wide</td>
<td>Spine Labels - 6 labels across</td>
</tr>
<tr>
<td>Spine Labels 7 label wide</td>
<td>Spine Labels - 7 labels across</td>
</tr>
<tr>
<td>Spine Labels 8 label wide</td>
<td>Spine Labels - 8 labels across</td>
</tr>
<tr>
<td>Spine Labels 9 label wide</td>
<td>Spine Labels - 9 labels across</td>
</tr>
<tr>
<td>Spine Labels 10 label wide</td>
<td>Spine Labels - 10 labels across</td>
</tr>
<tr>
<td>Spine Labels 11 label wide</td>
<td>Spine Labels - 11 labels across</td>
</tr>
<tr>
<td>Spine Labels 12 label wide</td>
<td>Spine Labels - 12 labels across</td>
</tr>
</tbody>
</table>

&STKSPN7C.QRP
UNDERSTANDING REPORT DESIGN

Report Templates: Basics

RepWin is made up of:

- Background Text
- Fields
- Headers
- Footers
- Break Groups
- Input Items

Palette

It may be convenient to have the Palette available for selection purposes.

1. From the menu, select View > Palette – the Palette will then display:

2. It is possible to right-click on your mouse (in the middle of the screen) to change the tool being used
Background Text

- Text with no FIELD information included – for example: Street Address

To insert Background Text

1. From the menu, select Tools > Background Text

2. Position the tool where you want the text to be inserted (the text will be left-justified)

3. Click the left mouse button once – a white text box will be inserted

4. The cursor will remain in the text box so you can start typing the background text that you want to display each time the report is printed
5. Alternately, click out of the box and then double-click on the text box – the Format Background Text screen will display:

![Format Background Text](image)

6. Insert the text to be displayed in the Text: box

7. Font-style, font-size, justification, borders, etc, options can also be adjusted (this can also be done from the ruler at the top of the screen)

8. Click the OK button when complete
Fields

Fields can be Inputs (objects that are derived from the Amlib database – for example: Borrower Name, Address, etc.), a string value (combining Input items and background text), formulas and functions (many of which can be used on Inputs).

To insert a Field

1. From the menu, select Tools > Field
2. Position the tool where you want the field to be inserted (the field will be left-justified)
3. Click the left mouse button once – a white field box will be inserted
4. The cursor will remain in the field – at this point it is possible to select an Input option from the Content: drop-down box at the top of the screen – for example: BOR_SURNAME (Borrower Surname)

5. Alternatively, click out of the box and then double-click on the field box – the Format Fields screen will display:
6. This screen allows the formatting of the fields in the following ways (some formatting can also be done from the ruler at the top of the screen):

- **Character** - for example: **Font size**
- **Line Wrapping**: this sets whether or not the line can wrap to the next line, and the number of lines which can be used
- **Repeating Values**: this allows repeated values to be suppressed
- **Justification**: **Left**, **Center** or **Right**-justified
- **Format**: determine the way in which a field may be displayed – for example: date formats

7. Click the **OK** button when complete

**Editor**

1. From the ruler menu, select the **Editor** button (alternatively, you can select the **Editor...** button within the Format Fields screen) – the Formula Editor screen will display:

2. **Input** Items can be selected from the Data Items window, Formulas from the Formulas window (for example: and Functions from the Functions window (for example: **CurrentDate**)

3. Click the **OK** button when complete
# Blocks

Blocks form the backbone of the report and can come in the form of:

<table>
<thead>
<tr>
<th>TYPES</th>
<th>BLOCK</th>
<th>COMMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>Headers (Optional)</td>
<td><strong>Report Header</strong></td>
<td>Contains a Report Title – only appears at the very beginning of the Report</td>
</tr>
<tr>
<td></td>
<td><strong>Page Header</strong></td>
<td>Contains information to appear at the top of every page</td>
</tr>
<tr>
<td></td>
<td><strong>Group Header</strong></td>
<td>Contains information to appear at the beginning of every Break Group. Will only appear if Break Groups are defined</td>
</tr>
<tr>
<td>Footers (Optional)</td>
<td><strong>Group Footer</strong></td>
<td>Contains information to appear at the end of every Break Group. Will only appear if Break Groups are defined</td>
</tr>
<tr>
<td></td>
<td><strong>Page Footer</strong></td>
<td>Contains information to appear at the bottom of every page – for example: Page Numbers</td>
</tr>
<tr>
<td></td>
<td><strong>Report Footer</strong></td>
<td>Contains Report totals and summaries – only appears at the very end of the Report</td>
</tr>
<tr>
<td></td>
<td><strong>Detail Block</strong></td>
<td>Contains data that is sourced from the Amlib database. There is only one Detail Block per Report Template</td>
</tr>
</tbody>
</table>

Each block is essentially nested inside another block with the Detail Block sitting at its centre:

- **Report Header**
  - **Page Header**
    - Detail Block
  - **Page Footer**
- **Report Footer**

## Headers

These are optional and can be defined as follows:

- **Report Header**: Appears only once, containing a title
- **Page Header**: Contains messages, references, page numbers etc. and appears on each page
- **Group Header**: Appears before the first line of a group of records (these do not display until Break groups are defined)
The Statistics report below has numerous Group Headers:

- Each Header can have settings (for example: minimum height) and can be accessed by double-clicking the Header name – for example: Page Header

The first line after a header can also have settings defined – for example: Page Break Before

- Check this by double-clicking on the first line after the Header (in the grey space rather than on a field or background text box)
Footers

These are also optional and can be defined as follows: **Report Footer, Page Footer** and **Group Footer**.

- **Group Footers** may contain Totals for the group.
- **Page Footers** can contain Page Numbers or copyright information that would need to be shown on each page of the Report.

**Please Note:** It is possible to keep Group information from splitting across a page (where there is less than 1 page of information) – for example: to prevent a page break forming in the middle of an Overdue Slip.

- See: Formatting – Keep on Page

**Detail Block**

- Prints information from individual rows showing data from the Amlib database – there is only one Detail Block per report template

**FORMATTING TASKS**

**Edit Background Text**

For example: Changing the wording in an overdue letter.

1. Open the template you want to change – be sure to save a back-up copy first, in case you want/need to go back to it later
2. Double-click on the background text that you wish to change – the Format Background Text screen will display:

3. Click into the main Text: box, highlight and add/delete text as necessary – you can also change the font-size and style:

4. Click the OK button when complete
4. For long sentences, use your cursor to stretch your background text to the edge of the page and the text will automatically continue to the next line

**Add Extra Space (by Adding Lines)**

If you want to have spaces in your letter to separate some of the areas of text, you can add some extra lines to your template.

1. Open the template you want to change – be sure to save a back-up copy first, in case you want/need to go back to it later

2. From the menu, select **Tools > Line** or alternately, select the **Line** icon on the Palette:

3. Hover your mouse over the area in the template where you wish to put the line, until your cursor turns into the square line tool symbol (you may have to put your cursor on the top or bottom edge of an existing line)

4. Left-click to insert the extra line

---

**Please Note:** Be careful where you place your lines!
• If you add a line to the detail block, with most templates, this will add a line between each item that is listed:

Mr Anderson  
1 Landand St  
Library Town, WA  
6000  

Code not found

Dear Parent/Guardian,

OVERDUE NOTICE

The following books are overdue as of 10 Jul 2009:

<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>The planets [videorecording] / series producer, David McNab.</td>
<td>29/08/2007</td>
<td>$34.00</td>
</tr>
<tr>
<td>Planet of twilight / Barbara Blakely</td>
<td>29/08/2007</td>
<td>$11.00</td>
</tr>
</tbody>
</table>

We would ask that if the item(s) cannot be located, the sum of $400 be submitted to the school.

If you have any questions or would like to renew your items, please contact the library on 9222 2222.

Yours sincerely

Library Staff

• If you want to add space between the existing text around the details, add the extra lines to the bottom of the header above the Detail Block or to top of the footer directly following it:
Reduce Space by Deleting Lines

1. Click on the line to highlight it:

   ![Highlighted line]

2. Click the **Delete** button on your keyboard

Adjust the Size of Your Fields or Background Text

1. Click on the field/background text you want to change:

   ![Highlighted field]

2. Move your cursor to the edge you want to expand, until the cursor becomes a double-arrow: ↔

3. Then click on the edge of the field, drag it to where you want it to be:
Move Fields or Background Text

1. Click on the field or background text you want to change:

   **BOR NAME**
   **BA ADDR1**
   **BA ADDR2**
   **BA ADDR3**  **BAPCODE**
   **BA ADDR4**

   Dear Parent/Guardian,

   **OVERDUE NOTICE**

   The following books are overdue as of "DateToStrPicture(CurrentDate(), 'dd MMM yyyy')":

<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
</table>

2. Hover your mouse cursor over the highlighted background text or field until the cursor becomes a four-way set of white arrows:

3. Click and drag to the place where you want it to be:

   **OVERDUE NOTICE**

   The following books are overdue as of "DateToStrPicture(CurrentDate(), 'dd MMM yyyy')":

<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
</table>

   We would ask that if the items cannot be located, the sum of "\$NumberToStrPicture(TotalCst, "")

   If you have any questions or would like to renew your items, please contact the library on 9222 2222.

   Yours sincerely,
Add Text

1. Create a line, if needed:

```
<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>Due Date</td>
<td>Cost</td>
</tr>
</tbody>
</table>

We would ask that if the item(s) cannot be located, the sum of "| NumberToStrPicture| TotalCost, "$4
```

Yours sincerely,

2. From the menu, select Tools > Background Text or alternately, select the Background Text icon on the Palette:

![Background Text Icon]

3. Click in the line where you want your text to display – a white block will appear:

```
<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>Due Date</td>
<td>Cost</td>
</tr>
</tbody>
</table>

We would ask that if the item(s) cannot be located, the sum of "| NumberToStrPicture| TotalCost, "$4
```

4. Stretch out the background text box to fit the whole line – if it’s a large sentence, it will need the space across the whole line:

```
<table>
<thead>
<tr>
<th>TITLE</th>
<th>DATE DUE</th>
<th>COST</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item 1</td>
<td>Due Date</td>
<td>Cost</td>
</tr>
</tbody>
</table>

We would ask that if the item(s) cannot be located, the sum of "| NumberToStrPicture| TotalCost, "$4
```
TIP: If you can’t select your text box, try clicking on the line space behind it, then clicking onto the text box.

5. Select the background text box by double-clicking it – the Format Background Text screen will display:

6. Add in the text you want to the Text: box
7. Set the font size, style and add bold or italics as needed
8. Click the OK button when complete

Add Fields

1. Add a line if necessary
2. From the menu, select Tools > Field or alternately, select the Field icon on the Palette:

3. Click in the line where you want to place the field – a white block will appear:
4. Stretch the edges of the field if necessary – click off the field, then hover your mouse over the edge of the field to get the double arrows and then adjust the size:

5. Select the field with your mouse:
6. Click the Editor button on the toolbar – the Formula Editor screen will display:

7. From the Data Items box, select the field you want to add – in this example, we want to add the call number, which is **Line 6** in the Stockitem screen.

8. Double-click the item to display it in the top section of the screen:

8. Click the OK button when complete
BIBLIOGRAPHIC REPORTS

Create a Report

1. Launch the Amlib client
2. Go to Main > Reports > RepBibliographic – the Bibliographic Reports screen will display
3. Click the F1 New button – the Select Report Format screen will display
4. Highlight the report template you would like to use (for example: &BIB.QRP or &BIB2.QRP) and click the Select button
5. Type in a Description – for example: Harry Potter
6. Click the F3 Save button
7. Highlight the report and click the F7 Where button – the Bibliographic Reports – Where screen will display:

8. There are three unique parameters:
   - Auth Tag: Search for a particular MARC tag
   - Auth Key: Check for particular data contained in the MARC tag
   - Tags to Display: MARC tags to display in report

9. The statement can include the following settings:
   a. Auth Tag – for example: Auth Tag = 245 (Title)
   b. Auth Key – for example: Auth Key LIKE Harry Potter (looks for all matching items where the Title BEGINS with Harry Potter)
   c. Tags to Display – for example: Tags to Display IN 100, 245 (will display Author and Title in report)
d. (optional) Enter a start date: Date >= enter a date in DD/MM/YYYY format – for example: 01/01/2010

e. (optional) Enter a finish date: Date <= enter a date in DD/MM/YYYY format – for example: 10/10/2010 (a finish date is optional – if not inserted, the report will go up to the current date).

f. You may also want to limit by Catalogue Number(s)

10. Click the F3 Save button when complete

11. Click on the F9 Order button – the Bibliographic Reports – Order By screen will display:

![Bibliographic Reports - Order By]

Sorting of Bibliographic reports is different to other reports. The Auth Tag that you wish to sort by is set in the Where Parameters – for example: 245 (Title) and the Order is set to be sorted by is the Auth Key.

12. Use the arrow keys to select and move the fields to be sorted by – for example: Auth Key

13. Click the F3 Save button when complete

14. Click the F8 View button to view/print the report

Advanced Bibliographic Reports: Fixed Layout Reports using F10 More

This function is used for mapping data to fields in Fixed Layout reports – for example: the DVD Cover template (\&DVDCOV.QRP).

Each row of this table may be used to collect 1 of the 20 fields on the report template. These first 20 fields contain Tag or Subfield data (Fields 1-20), and the next 20 fields (Fields 1A – 20A) contain the associated Tag Descriptions (Go to Main > Authorities > MarcTags to see a complete list of Tag Nos and Tag Descriptions). The report outputs all the MARC data to the report. The inclusion of Fields 1A – 20A in the report is optional.
The table below explains how the user can specify which parts of the MARC tag to send:

<table>
<thead>
<tr>
<th>OPERATOR</th>
<th>DESCRIPTION</th>
<th>EXPLANATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>blank (Default)</td>
<td>The entire MARC tag is printed</td>
<td>If the column is left blank, then the entire MARC tag is printed</td>
</tr>
<tr>
<td>+</td>
<td>All data in the specified tag is printed no matter how many tags are included in the record</td>
<td>All Subject listings are printed, where there is only one or several or hundreds!</td>
</tr>
<tr>
<td>and sf in ('p', 'n')</td>
<td>Only the subfields specified to be printed within this Authority Tag</td>
<td>If 440 (Series) tag, only the Series name and number printed</td>
</tr>
<tr>
<td>and cat_sf in ('c')</td>
<td>Only the subfields specified to be printed within this Non-Authority Tag</td>
<td>If 260 (Publisher) tag, only the 'c' (Date) subfield printed (and not Place or Publisher)</td>
</tr>
</tbody>
</table>

The table below explains how the user can specify which parts of the MARC tag to send:

<table>
<thead>
<tr>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HEADING</strong></td>
<td>Report Line Number</td>
<td>Tag Number</td>
<td>eg + or <strong>blank</strong> or <strong>and sf in ('a', 'b')</strong></td>
<td><strong>blank or and cat_sf in ('a', 'b')</strong></td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>1</td>
<td>100</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>245</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>082</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>650</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>COMMENT</strong></td>
<td>Can be any number between 1 and 20</td>
<td>MARC Tag field number – for example: 245 (Title)</td>
<td>Specify which part of the MARC tag to send - see table below for more details</td>
<td>Specify which part of the MARC tag to send - see table below for more details</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Any Tag can be matched to any Line Number</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The table below explains how the user can specify which parts of the MARC tag to send:

<table>
<thead>
<tr>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HEADING</strong></td>
<td>Report Line Number</td>
<td>Tag Number</td>
<td>eg + or <strong>blank</strong> or <strong>and sf in ('a', 'b')</strong></td>
<td><strong>blank or and cat_sf in ('a', 'b')</strong></td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>1</td>
<td>100</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>245</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>082</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>650</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>COMMENT</strong></td>
<td>Can be any number between 1 and 20</td>
<td>MARC Tag field number – for example: 245 (Title)</td>
<td>Specify which part of the MARC tag to send - see table below for more details</td>
<td>Specify which part of the MARC tag to send - see table below for more details</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Any Tag can be matched to any Line Number</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Example 1 – Bibliography:

The template &BIBFL10.QRP is a Bibliography with up to 10 lines that can be defined. The template includes MARC Tag descriptors (include the 1A, 2A etc.):

1. Set the More window as follows – the Line numbers correspond to fields inserted on the template (in this example: Title and Author)
   a) Select the F1 New or F2 Insert button
   b) Type in field details – the columns are filled in as follows: ' 
      i. Report Line Number = 1 and 2
      ii. Tag Number = MARC Tag field number – for example: 245 (Title) and 100 (Author)
Alternatively, the report can be set up to show all 10 lines with all occurrences of Multiple Tags - for example: if more than one 651 Subject occurs, show all headings. You are also able to define which subfields are displayed for Authorities and Non-Authorities – for example: only show the Series Title and Number (subfields a and v of Tag 440, or only the Date in a Publisher (subfield c).

The following DVD Covers report uses this methodology.

**Example 2 – DVD Cover Report:**

1. Click the **F10 More** button – the **More** screen will display

2. Set the **More** window as follows – the Line numbers correspond to fields inserted on the template
   a) Select the **F1 New** or **F2 Insert** button
   b) Type in field details – the columns are filled in as follows:
      i. **Report Line Number** = can be any number between 1 and 20
ii. **Tag Number** = MARC Tag field number – for example: **245 (Title)**

iii. eg + or blank or and sf in ('a', 'b') =

iv. blank or and cat_sf in ('a', 'b') =

c) **Click the F3 Save button when complete**

### Library DVD

**Information Resource Centre**

**The lord of the rings. The fellowship of the ring [videorecording] / New Line Cinema presents a Wingnut Films production : producers, Barrie M. Osborne ... [et al.] ; screenplay writers, Fran Walsh ... [et al.] ; director, Peter Jackson.**

791.43/07  2

c2002.
4 videodiscs (DVD) (200 min.) ; sd., col. ; 4 3/4 in. + companion booklet (62 p.)
Saved Files

It is possible to use a Saved File for the Report – for example: the DVD Covers or New Items reports.

**Please Note:** If the report lacks an Auth Key set in the F7 Where statement, then the selection of a Saved File becomes mandatory.

1. Go to **Main > Reports > RepBibliographic** – the Bibliographic Reports screen will display.
2. Highlight the report.
3. Click the **F8 View** button.
4. If there is an Auth Key defined in the F7 Where statement, the following prompt will display: This type of report may use a Saved Files as the Source. Do you want to select the file now? – click the **Yes** button.

![Bibliographic Reports screenshot]

Last Updated: 26 February 2013
5. A list of Saved Files will display:

![Select Saved File window]

6. Select the Saved File you would like to use and click the OK button – the report will display in the Report – View window:

```
<table>
<thead>
<tr>
<th>Owner</th>
<th>File Name</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>FIONA</td>
<td>CHINESE1</td>
<td>3</td>
</tr>
<tr>
<td>FIONA</td>
<td>COMMUNITY ORGANISATIONS</td>
<td>20</td>
</tr>
<tr>
<td>TREVOR</td>
<td>CHEMISTRY CLASS SET</td>
<td>3</td>
</tr>
<tr>
<td>TREVOR</td>
<td>CHEINESE UNICODE (LOVE MAIL)</td>
<td>1</td>
</tr>
<tr>
<td>TREVOR</td>
<td>CLICKVIEW INTEGRATION IMPORT</td>
<td>72</td>
</tr>
<tr>
<td>TREVOR</td>
<td>DIACRITICS 31/1298</td>
<td>3</td>
</tr>
<tr>
<td>TREVOR</td>
<td>JUDY</td>
<td>12</td>
</tr>
<tr>
<td>TREVOR</td>
<td>LEWIS CARROLL ITEMS</td>
<td>10</td>
</tr>
<tr>
<td>TREVOR</td>
<td>LOCAL HISTORY NEW</td>
<td>12</td>
</tr>
<tr>
<td>TREVOR</td>
<td>MAORI MACRON RESOURCES</td>
<td>3</td>
</tr>
<tr>
<td>TREVOR</td>
<td>SOCCER BOOKS</td>
<td>18</td>
</tr>
<tr>
<td>TREVOR</td>
<td>TREY NEW TITLES</td>
<td>3</td>
</tr>
<tr>
<td>TREVOR</td>
<td>TREY READY TO ORDER</td>
<td>2</td>
</tr>
</tbody>
</table>
```

7. Review the report and if it looks okay, send it to print using the Print icon
Customising the Fixed Layout Templates

It is possible to alter the Fixed Layout report using the RepWin – for example: remove the Descriptors fields, format Field2 to be *italics* etc. The customised report should then be given a new name to distinguish it from the original – for example: **EBIBFL10.QRP** for an Eldorado Library specialized Report based on the &BIBFL10.QRP template.
Another alteration could be that the Labels are to be applied to Subjects only:

HINT: A useful formatting tool in RepWin is to highlight Fields that need to be aligned by pressing the Shift Key and clicking on the multiple Fields and the selecting **Format > Align Left Sides** from the menu.
Please Note: When loading the customised template via RepAddNew ensure that the Choose Type = Fixed layout Reports.

This Report will then be available in RepBibliographic:
CIRCULATION REPORTS - ADDING CHARGES USING F10 MORE

The **F10 More** button provides extra parameters to allow you to apply charges when running the reports. These charges will only apply if the **F6 Print** button is used and **RepStartSchedule** is started.

**Please Note:** User-defined charge types must be added to the Circulation Transaction Types table – see **Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation Transactions Types (RepCirculation and RepReservations Only)** for more information.

<table>
<thead>
<tr>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HEADING</strong></td>
<td>Report Line Number</td>
<td>Line 1 account history NAME</td>
<td>Line 1 overdue history NAME</td>
<td>Line 1 Financial record NAME</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>1</td>
<td>OVFINACC</td>
<td>OVDFINAL</td>
<td>OVDUEACC</td>
</tr>
<tr>
<td><strong>COMMENT</strong></td>
<td>Line 1 is used for History and Financial reporting purposes</td>
<td>If left blank, the system will put a Report Type of ACCOUNT in the Borrower History window if Create Hist (Y/N) = Y and Create Acc (Y/N) = Y and the report run via the Scheduler.</td>
<td>If left blank, the system will put a Report Type of OVERDUE in the Borrower History window if Create Hist (Y/N) = Y and Create Acc (Y/N) = N and the report run via the Scheduler.</td>
<td>If left blank, the system will put a Financial Type of OVERDUE in the Borrower Financial window indicating the (replacement) Cost for overdue items if Create Acc (Y/N) = Y and the report run via the Scheduler.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>HEADING</strong></th>
<th>Report Line Number</th>
<th>Line 2 Fee per Item $.c</th>
<th>Line 2 Fee per Notice $.c</th>
<th>Line 2 Fee Print Line</th>
<th>Line 2 not Used</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>2</td>
<td>2.00</td>
<td>5.00</td>
<td>Includes fees of:</td>
<td>&lt;Leave blank&gt;</td>
</tr>
</tbody>
</table>

| **COMMENT**  | Line 2 is used to add Fees to Reports | Enter amount to be charged for each overdue item [Optional] | Enter amount to be charged per notice (in addition to any item fee) [Optional] | Text will be added to the USER_LINE1 field in the Report [Optional] |

Create a Report

1. Launch the *Amlib* client
2. Go to Main > Reports > RepCirculation – the Circulation Reports screen will display:

3. Ensure the Create Acct (Y/N) column = Y

4. Highlight the report to which you wish to add charges – for example: Overdue Letter (with Fee)

5. Click on the F10 More button – the More screen will display:

6. Click the F1 New or F2 Insert button

7. Click the F10 More button – the More screen will open

8. Click the F1 New or F2 Insert button

9. Enter the following parameters – for example:
   - Report Line Number = 1
   - Line 1 account history NAME = OVFINACC
   - Line 1 Financial record NAME = OVDUEACC
   - Line 1 Fees type name = OVDUEFEE
It is also possible to apply charges at this stage on a per item/notice basis:

10. Click the **F1 New** or **F2 Insert** button

11. Enter the following parameters – for example:
   - **Report Line Number** = 2
   - **Line 2 Fee per Item** = 2.00
   - **Line 2 Fee per Notice** = 5.00
   - **Line 2 Fee Print Line** = **Includes fees of**:

12. Click the **F3 Save** button when complete

The above parameters will charge an overdue fee of **$2.00** per item + a **$5.00** per notice (admin) fee.

**Customising the Template to Include Charges**

**Please Note:** The report template must be altered to include the following fields: **FORM_CHARGES** and **USER_LINE1**.

- The new **&ODFEE.QRP** template includes **FORM_CHARGES** and **USER_LINE1**.

The **FORM_CHARGES** field can be added to the total charge [Field = **FORM_CHARGES**] or included as part of a **TotalCst**. You can also include the field **USER_LINE1** which will include the text you entered in the **F10 More** statement.

**Borrower Record**
After running the report with **F6 Print** and **RepStartSchedule**, a financial record will be written to the Borrower Financial Transactions screen using the parameters set up in **F10 More**:

If the report also has **Create Hist (Y/N) = Y** then a history record will also be written to the Borrower History screen using the parameters set up in **F10 More**:
E-MAIL REPORTS

Several Reports can now be used via Email. See some examples at the end of this document.

Email Templates

Borrower Reports (RepBorrower)

- Send letter via Email: &N1ADDEM.QRP
- Send interest lists via Email: &BORINT.QRP

Circulation Reports (RepCirculation)

- Send reminders via Email: &ODEMAIL.QRP

ILLs Reports (RepILLS)

- ILL Email Reminder: &ILLEREM.QRP
- ILL Email Reminder – All Suppliers: &ILLERMS.QRP
- ILL Email Request: &ILLEREQ.QRP
- ILL Email Request – All Suppliers: &ILLERQS.QRP

Orders Reports (RepOrders)

- Email Order GST: &OREGST.QRP
- Email Order including Tax: &OSEMAIL.QRP
- Order Status Notice via Email: &ORSIE.QRP
- Order Returns Notice via Email: &ORSIER.QRP
- Cancellation Notice via Email: &ORSIECL.QRP
- Claims Notice via Email: &ORSIECL.QRP

Periodical Reports (RepPeriodicals)

- Claims Notice via Email: &PICLE.QRP

Reservation & Bookings Reports (RepReservation)

- Email notification of Reserve: &RESEML.QRP
- Email notification of Booking: &BKGEML.QRP
Setting Up

Supervisor Parameters

To begin, some settings need to be set in the Supervisor module (this need only be done once):

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. Select the Other tab
4. Scroll down set the following: E-mails are sent using the following method: (M)API or (I)nternal or (S)MTP. Set to S, I or M

Generally (S) SMTP is recommended, especially as it is simple and it has advantages over the others. It also means that the email client does not need to be open on the PC running the notices and allows greater flexibility with regard to setting up “from” and BCC/CC parameters.

Then the following parameters should also be set (a full table is included below):

- **SMTP Blind Carbon Copy e-mail address**: you can specify the BCC address to send a copy of all notices (so that you can verify that they have been sent)
- **SMTP sender e-mail address**: the email address to display on the notice sent to the borrower (For example: library@oclc.org, it can be the same as the BCC address)
- **SMTP Server name**: the address of the SMTP mail server being used. This might be a server address or an IP address

5. Click the **F3 Save** button when complete
6. Exit and restart the Amlib client to allow the settings to take effect

The complete set of parameters to consider:

<table>
<thead>
<tr>
<th>Description</th>
<th>Explanation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Emails are sent using the following methods (M)API, (I)Internal or SMTP</td>
<td>Generally (S) SMTP is recommended, especially if the organisation is not using a Microsoft Exchange Server. It also means that the email client does not need to be open on the PC running the notices AND can display the “from” name from one of the parameters below rather than the email address from the email client.</td>
<td>Set to S, I or M</td>
</tr>
<tr>
<td>SMTP Blind Copy e-mail address</td>
<td><strong>Optional</strong>: If using the SMTP for emails. Enter only if copies of the email are to sent to a chosen email address – for example: Testing purposes</td>
<td><a href="mailto:library@amlib.com">library@amlib.com</a></td>
</tr>
<tr>
<td>SMTP sender e-mail address</td>
<td><strong>Optional</strong>: If using the SMTP for emails, enter the Address you wish to indicate as the sender</td>
<td><a href="mailto:enquiries@amlib.com.au">enquiries@amlib.com.au</a></td>
</tr>
<tr>
<td>SMTP server login</td>
<td><strong>Optional</strong>: From your Systems Administrator if required</td>
<td></td>
</tr>
<tr>
<td>SMTP Server name or IP address</td>
<td>If using the SMTP for emails, enter the <strong>Server Name</strong> or <strong>IP Address</strong> of the Server installed with the e-mail communication protocol, responsible for receiving and forwarding email messages</td>
<td>ServerName – for example: server.amlib.com.au</td>
</tr>
<tr>
<td>SMTP server password</td>
<td><strong>Optional</strong>: From your systems administrator if required</td>
<td></td>
</tr>
</tbody>
</table>
| SMTP server requires a login?                                               | If **Y**, supply a SMTP server logon and password  
If **N**, leave SMTP server logon and password blank                                                                                       | **Y/N**                       |
The above tasks create **Sender** and **BCC** for **ALL** emails generated by the system. However, it is possible to set up separate SMTP parameters (Sender and CC) for individual locations, modules and reports.

**Setup Individual Email Systems by Location**

1. In any **Installation** screen module, select **Installation** > **Choose Location** and choose a **Location**
2. Repeats steps 2-5 above. If you would like to use the **DEFAULT** settings, then the relevant fields for each location should be left **blank**
3. Once complete, you must exit and restart the **Amlib** client to allow the settings to take effect

**Setup Individual Email Locations, Modules and Reports**

We recommend leaving the email set-up for particular locations until after initial testing has been completed. Once the initial testing has been done, then:

1. In any **Supervisor** module, select **Library Menu** > **LocRepSMTP** – the **SMTP Parameters by Location** table will display
2. Select the **F1 New** or **F2 Insert** button
3. Using the drop-down boxes available in each column, select the **Location**, **Report Screen**, and **Report Type**
4. Then type in the individual **Sender’s Email** and **Carbon Copy Email** addresses
5. Click the **F3 Save** button when complete
6. Exit and restart the **Amlib** client to allow the settings to take effect

**Please Note:** It is not possible to alter a pre-existing entry in the **SMTP Parameters by Location** table – entries must be deleted (using **F4 Delete**) and then re-entered.
Borrower Settings

For borrowers to receive their overdue notices via email, the borrower record will need to have the following:

- **Email** address – for example: **sarah-jane.smith@oclc.org**
- **Use for Notices** = **Y** (for Yes)
Customising the Report

Edit the Template

The email report templates can be customised using Report Writer (RepWin30.exe) – a copy of which can be found in the Amlib/Utility folder on your Amlib server (see separate installation instructions). It is also possible for Amlib Support staff to modify an existing report if necessary.

Start off with an existing System Report (for example: &ODEMAIL.QRP) and adjust the wording as required – see separate Editing Text in Reports procedure. Be sure to save this customised report with a new name (without the & at the front).

- **Please Note:** Do not add logos and keep the layout simple for emails.

```
To: TIM F CHAPUR
Borrower No: 66511352502

LIBRARY OVERDUE REMINDER NOTICE

The following items are overdue. Please return them by 29/06/2000 or you will incur a fine.

<table>
<thead>
<tr>
<th>Title</th>
<th>Call No</th>
<th>Date Due</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dead man's walk : a novel.</td>
<td>F MCH</td>
<td>12/05/2000</td>
</tr>
<tr>
<td>Madeline at cooking school</td>
<td>JN MAD</td>
<td>05/04/2000</td>
</tr>
</tbody>
</table>

To respond to the notice you may:
* Return these items to any branch library
* Phone and ask to renew unreserved items

Yours sincerely,

Library Manager.
```

Save the Template

- Save the template into the Amlib/Reports folder on the Amlib server. This will make the template available for use to all users. Alternatively, you may save it into a local folder on your PC – but please be aware, that the template (once loaded) will only be available for use on that PC.

- Ensure that the template is saved with a name that clearly identifies it as a customised email template – for example: BRODEMAIL.QRP
Load the Template

1. Go to Main > Reports > RepAddNew – the Report Files window will display
2. From the Report Entity drop-down, select the Report Screen (module) you would like to load a template for – for example: Circulation
3. Click the F1 New button – the New Report File... screen will display
4. Type in a Description – for example: Overdue Notice (Email)
5. Browse to the Amlib/Reports folder on your Amlib Server and locate the template to be loaded (if the template has been loaded onto your PC – then navigate to the local folder)
6. Click on the Open button
7. Choose Type – ensure you select the relevant email type – for example: Continuous - E-mail
8. You can leave Default Stats Code blank
9. Update History (Y/N) = Y
10. Update Entity (Y/N) = N
11. Click the F3 Update button
12. Close out of the Report Files screen

The template is now loaded and available for use in a Report.
Creating the Report

1. Go to a reports screen – for example: Main > Reports > RepCirculation
2. Click the F1 New button – the Select Report Format screen will display:

![Select Report Format](image)

3. Highlight an email template (for example: Overdue Notice (Email) using the &ODEMAIL.QRP print template) and click the Select button
4. Type in a Report Description – for example: Overdue Notices by Email
5. If you would like the borrower record to retain a record of any notice sent, then ensure that Create Hist (Y/N) = Y
6. If there are replacement costs involved, ensure that the Create Acct (Y/N) = Y
7. Click the F3 Save button

Where Statement

1. Select the report from the list and click on the F7 Where button
2. The statement must include the following settings:
   - Bor Email Address IS NOT NULL (Paste without placing a value in 3)
   - Bor Use Email = Y
   - Additional parameters can then be added
3. Click the F3 Save button
1. Select the report from the list and click on the F9 Order button
2. Use the arrow keys to select fields to Order By – for example: Borrower Bar No
3. Click the F3 Save button when complete
Printing the Emails

Using the Scheduler has two benefits over running reports via F8 View: It allows you to schedule regularly run reports so that staff do not have to do it manually each time, and it allows for further functions as part of the report such as updating Borrower/Stockitem history, creating financial accounts, changing records in the database and adding report information to your statistics. Email reports MUST be run via the Scheduler.

This section will take you through setting up a report to use RepStartSchedule.

Start the Scheduler

1. From the Report screen (Main > Reports > RepCirculation or RepReservation), select Application > RepStartSchedule

2. The Report Scheduler screen will display:

3. Select your printing options: Ensure Email is ticked

4. Also decide if a report is scheduled by another user do you still want to print it? = Yes/No

5. Then click the OK button

6. After selecting “OK”, if you go back into the Application menu you will see that RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is now running
Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report screens (Ctrl + L) and start at the beginning of these instructions.

Scheduling the Report

1. With your report highlighted, click the **F6 Print** button – the Print box will display:

2. Select from the following options:
   a. **From**:
      - Database (to search the entire database)
   b. **To**:
      - Email (to email it to patrons – this option will only display if the report has been created from an appropriately loaded template)
   c. **Frequency**:
      - Once Only (if this is the only time you’re going to print this report)
      - Daily (if you plan to send it every day)
      - Weekly (if this is a once a week item)
      - Monthly (if this is to be printed every calendar month)
• Every ___ days (if you want to set a specific schedule)

d. **Schedule:**

  • **First Print Date** (the day you want this report to begin its schedule)
  • **First Print Time** (specifies the exact minutes the report will run)

e. **Selected Printer:**

  • You can specify any active printer on the network to print to – including virtual printer drivers such as a third party software that allows you to print to PDF (For example: **CutePDF Writer**)

3. Once you have selected all of your settings, click the **OK** button

**Check Print Progress**

1. You can check the progress of your reports at any time by going into **Main > Reports > RepPrintProgress** – the **Print Progress** screen will display:

![Print Progress Screen]

2. If your library uses the scheduler for a lot of reports, you can select a frequency type from the **Filter** drop down menu at the top:

![Filter Drop Down Menu]

3. You can also click through the three tab options at the top to see the ones that are **Waiting**, **Running**, or have already been **Printed**:

![Tab Options]

4. Your report will show up in the **Printed** tab when it is complete:
Email Address Validation Rules

When email reports are being sent a certain amount of validation is going on. Email addresses are rejected if illegal characters are found.

If the email address is invalid and if the barcode of the patron can be found by the process, the Borrower ID is written to a saved Borrower File, which can be checked later.

If the barcode of the patron cannot be found, no file can be created but an error message is written to the amdberror.log in the Amlib folder.

If the SMTP protocol is being used then any errors encountered will be logged. Neither MAPI nor the internal method support error reporting in an accessible way.

1. Must be at least 5 characters long. Shortest theoretical address is a@b.c
2. Must contain an “@”
3. Must have one or more characters before the “@”
4. Must contain a “.”
5. No more than 4 characters after the last “.”
6. No “_” after the “@”
7. Only one “@”
8. No invalid chars – the following ranges are invalid:
   - Less than ASCII 48 (except 45 and 46)
   - ASCII 57 to 65 (except 64)
   - ASCII 90 to ASCII 97 (except 95)
   - ASCII > 122

Please Note: 45 = "+", 46 = ".", 64 = "@" and 95 = "/" 

The formatting of the email is checked against these rules, but the address may it still be invalid.

Troubleshooting

Some users may experience some initial problems with SMTP emails not being sent. This can be the result of your anti-virus agent blocking programs that relay (mass) email or your mail server blocking relay (mass) emails.

- There is now a complete Setting-Up Email and Troubleshooting Guide

Examples
Borrower Subject interests report via email (&BORINEM.QRP)

Emails the items included for the Interests set in Borrower > XReferences > Subject Interests. The Borrower email address and Use for Email details need to be entered in the Borrower window. Where parameters can include a Borrower Type (for example: T for Teachers) and Received Date (for example: > Current Date – 1 month)

<table>
<thead>
<tr>
<th>Interest by email</th>
<th>15/07/2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>To: Judy Still</td>
<td></td>
</tr>
<tr>
<td>From: &lt;your library name&gt;</td>
<td></td>
</tr>
<tr>
<td>The items listed below have recently been added to our collection.</td>
<td></td>
</tr>
<tr>
<td>Regards</td>
<td></td>
</tr>
<tr>
<td>Library Staff</td>
<td></td>
</tr>
<tr>
<td>READING: Chocolate.</td>
<td></td>
</tr>
<tr>
<td>Form: BK</td>
<td></td>
</tr>
<tr>
<td>Title: A gourmet's book of chocolate / Lesley Mackley</td>
<td></td>
</tr>
<tr>
<td>Author: Mackley, Lesley.</td>
<td></td>
</tr>
<tr>
<td>Shelf Set: 641.3174 MAC</td>
<td></td>
</tr>
</tbody>
</table>

Letters (&1NADDEM.QRP)

It is possible to change the text of the letter and send it out to selected borrowers. It could be useful for advertising promotions, notifying staff, welcoming letter, confirming opening times etc.

1. To change the text of the letter click on the Text for Letter button
2. A dialogue box will display where the text of the note or letter can be typed
3. Select the F3 Save button when complete

- Note: The F5 Query button can be selected to return the screen to the display at the last save. Therefore any changes made after the last save will not be retained.

The template for this email report has to be set to use the Type of Name & Address x 1 across Email.

<table>
<thead>
<tr>
<th>To: Mr and Mrs C Chieve</th>
<th>7/07/2004</th>
</tr>
</thead>
<tbody>
<tr>
<td>From: Library Staff</td>
<td></td>
</tr>
<tr>
<td>The Author George Pederson will be visiting our library during Bookweek. Please ensure you contact the library by July 1st if you are thinking of joining this session.</td>
<td></td>
</tr>
<tr>
<td>Kind regards</td>
<td></td>
</tr>
<tr>
<td>Gaye</td>
<td></td>
</tr>
</tbody>
</table>
Inter-Library Loans

It is possible to email inter-library loan reminders via email. The External Libraries table (select \texttt{Application > StockExternalLibs}) in the \texttt{Stockitems} module would need to be updated with the email addresses.

\begin{tabular}{|l|l|}
\hline
\textbf{To} & Subiaco Public Library \\
\textbf{From} & EASIVILLE \\
\textbf{Arr} & Inter-Library-Loans Officer \\
\hline
Will you please supply the following item(s) requested by our readers? \\
\textbf{B. Smith (Librarian)} \\
\textbf{Author / Cost} & SMITH, JAMES \\
\textbf{Title / Class} & HORSESON P 591 \\
\textbf{Bib / ISDN} & \\
\hline
\end{tabular}

Email Order with GST defined (&OSEGST.QRP)

A number of reports may be produced regarding order status. Email of Orders is now possible.

\begin{center}
\begin{tabular}{|l|c|c|c|c|}
\hline
\textbf{LIBRARY SERVICE - ELECTRONIC PURCHASE ORDER} & \\
\textbf{Address:} & \\
\textbf{Telephone:} & \\
\hline
\textbf{Order To:} & Angus & Robertson & & \\
& Perth 6000 & Order No: & 11 & \\
\textbf{E-mail:} & sube@angus&robertson.com.au & Order Date: & 1/08/2002 & \\
\hline
\textbf{Notes:} & \\
\hline
\textbf{Ln} & \textbf{Title/Author (Description)} & \textbf{ISBN} & \textbf{Qty} & \textbf{Unit Cost} & \textbf{GST} & \textbf{Total Cost} \\
\hline
1 & Young World & & 1 & $24.50 & $2.45 & $26.95 \\
2 & Young Animals set & & 1 & $904.55 & $90.45 & $995.00 \\
\hline
\textbf{Total} & & & & & & $1,021.95 \\
\hline
\end{tabular}
\end{center}

Email Reservations

- File Name = &RESEML.QRP
- Report Entity = Reservations
- Report Type = - Email
- Update Entity (Y/N) = Y

Reservation statuses assist in Reports. When an item with reservations on it is returned, the reservation for the first item in the queue changes to a status of \texttt{RETURN}.

Reservation reports can be run with the Update column set to \texttt{Y}, which when used in relation with the \texttt{F6 Print} button updates the status to \texttt{PRINTED}.

This ensures that the next batch of Reservation reports are only sent to those people where the item is newly \texttt{RETURN}ed. For those items that are on the Shelf when reserved, it would be wise to use the RESGET memos (set in \texttt{Supervisor > Locations > Borrower Barcode for Memos}) to alert staff to get
them the reserved items from the Shelves and wand them through Returns. Alternatively, a pick list may also be run in the Reservations report screen.

**To:** TIM F CHAPMAN  
**Borrower No:** 60011352302  
**07-09-00**

**LIBRARY RESERVATION COLLECTION NOTICE**

The following item(s) were reserved by you are being held for you at the library:

**Beating the distance** / 
Chase, Diana.  
Please collect by: 14-Sep-2000

**Damaged Item Notice (&STKMRR.QRP) and E-mail (&STKMRRE.QRP)**

These most recent return reports are for sites who return items from the Borrower’s records when they are damaged but still want to bill people for the costs of the damaged item. It will display the LAST borrower who had the item. If a site does not return the item when it is damaged (and keeps the item on loan), then Circulation reports can still be used.

**To:** TIM F CHAPMAN  
**Borrower No:** 60011352302

**LIBRARY OVERDUE REMINDER NOTICE**

The following items are overdue. Please return them by 29/06/2000 or you will incur a fine.

<table>
<thead>
<tr>
<th>Title</th>
<th>Call No</th>
<th>Date Due</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dead man's walk : a novel.</td>
<td>F KCM</td>
<td>12/05/2000</td>
</tr>
<tr>
<td>Madeline at cooking school</td>
<td>JK MAD</td>
<td>05/04/2000</td>
</tr>
</tbody>
</table>

To respond to the notice you may:
* Return these items to any branch library
* Phone and and return unreserved items

Yours sincerely,

Library Manager.
RUNNING REPORTS WITH E-MAIL ATTACHMENTS

Reports with the option to send attachments via e-mail will have the Manage Email Attachments button enabled (button text is black).

E-mail attachment parameters must first be set up in Supervisor settings. Once the correct template is selected, attachments such as MS Word documents can be sent with the e-mail messages.

**Supervisor Settings**

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. Select the Other tab
4. Scroll down and enter the E-mail Attachment Path = file path to your e-mail attachments. ALL e-mail attachment files must be saved to this location.
5. Enter the E-mail Maximum Attachment Size = maximum size of attachments in Kb (1Mb = 1024 Kb).
6. Select the F3 Save button
7. Make sure to copy these settings to your other locations – select **Installation > Advanced Copy** – the Advanced Parameter Copy screen will display:

![Advanced Parameter Copy Screen]

8. Select the following options:
   
   a. Tick the **E-mail Attachment Path** and **E-mail Maximum Attachment Size (kb)** parameters
   
   b. Tick all the locations in the **Destination Location(s)** box

9. Select **F6 Copy**

10. Exit the **Amlib** client (**Ctrl-E** or **Ctrl-X**) and restart to ensure these settings are propagated to the rest of the system
Create the Report

1. Create the report – for example &N1ADDEM.QRP (see separate individual procedures for more information about creating email reports)

Adding the Attachment

1. Highlight the report to which you would like to add an attachment

2. Select the Manage Email Attachments button – the Manage Email Attachments screen will display (the attachment path set in the Supervisor settings will be visible in the Attachment Path field):

3. Click the F1 New button – the Select a File to Attach screen will display

4. Browse to the location of the attachment folder

5. Select the file and click the Open button
6. The document will appear in the **File Name** box (with an arrow next to it):

7. Select the **F3 Save** button (the arrow will disappear once saved)

8. To add further attachments, repeat 3 – 7 above

**Please Note:** The size restriction set previously in **Main > Supervisor > Installation** refers to the maximum size allowed for an attachment or the total size of ALL the attachments (if there are multiple attachments).

9. To delete attachments: highlight the attachment you wish to delete and click the **F4 Delete** button

10. Once the list of attachments is complete, ensure that you click the **F3 Save** button to save your changes – close out of the screen by clicking the red cross in the corner
Email Text

If you would like some specified text to appear in the body of the e-mail you are sending, you can enter this in the Text for Letter area.

1. Highlight the report you are using, and select the Text for Letter button

2. The Letter Text dialogue box will display:

3. Type (or copy and paste) in your text

4. Select the F3 Save button when complete – then close out of the screen by clicking on the red cross
Please Note: When sent, your chosen text will appear in the body of the message:

To: Mr John D Smith
From: Library Staff

The town of Chelsea would like to welcome you to Chelsea Public Library.

As a member you have access to a wide variety of resources, including books, magazines, DVDs, CDs and online databases.

You can also visit us online at: www.chelsea.gov.au/library

Renewals and request can be made via our library website - you can also check your loans, set up your own reading profile, and suggest items for the library to purchase.

The library also regularly conducts workshops and events: for more details, please see the Library Newsletter attached to this email.

If you have any questions, please contact our library staff on (03) 9919 - 8777 or email: library@chelsea.gov.au

Library Staff
Start the Scheduler

1. From the menu, select **Application > RepStartSchedule** – the **Report Scheduler** screen will display

2. Ensure that the **E-mail** box is **ticked**

![Report Scheduler](image)

3. Click on the **OK** button

Schedule the Report

1. Highlight the report you are using and select the **F6 Print** button – the **Print** screen will display:

![Print](image)

2. Check/Change any **Print** settings

3. Click on the **OK** button

4. Check progress in **Application > RepPrintProgress**

**SMS RESERVATIONS & OVERDUES NOTICES**
Amlib utilizes the Reports module to produce exported text files for Reservation and Overdue notifications.

The SMS mobile phone messaging system works on a ‘campaign’ basis, where a text file is exported from Amlib. The file is then sent and imported to the SMS-messaging service supplied by a third party (Talking Technologies, Telstra, etc.). The information in the export file from Amlib is used for the content of the SMS message.

The field format requirements of the templates being used will differ between SMS messaging providers – generally the file is required to be in .TXT format.

Amlib employs two SMS messaging templates (which may need to be customised fit the specifications of a particular provider):

- &RESSMS.QRP  Reservations Module
- &ODSMS.QRP  Circulation Module

The report templates can be used to print a report in .TXT format using the Amlib Report Scheduler. The .TXT file may saved in a local directory (for example: C:\SMS Messaging) or a network directory (for example: Q:\Library\SMS Messaging).

**File Transfer Methods**

The most effective way to share files between the two systems is to set up a Windows File Share.

A user account with appropriate permissions to read, write and delete the transfer files will need to set-up; this account will be accessed by both systems.


If this is not possible; the .TXT file may be emailed to the SMS messaging provider (see final section).
SMS Templates

Both overdues and reservation SMS messaging employ the use of a dedicated template. In some circumstances, it may be necessary to edit these templates to adjust the content and sequencing of the fields in use to suit the specifications of the SMS messaging provider.

The templates can be found in the **Amlib/Reports** folder located on your Amlib server, and can be modified using **RepWin30.exe** (located in the **Amlib/Utility/Repwin** folder on your Amlib server).

The simplest method for editing these templates, is to copy them into the **Amlib/Utility/Repwin** folder and then drag-and-drop the template to be edited on the **RepWin30.exe** program file – this will cause the template to automatically open in the editor.

1. Highlight the fields in the **Detail Block** and click on the **Editor** button to reconfigure the content and sequencing – being careful not to remove the delimitation (usually “,”) necessary for creating the required .TXT files.

**Reservations**: &RESSMS.QRP

![Image](image1)

The **Editor** button may be used to modify the content configuration.

**Overdues**: &ODSMS.QRP

![Image](image2)
SMS Reservations

The template may be saved in `Amlib/Reports` folder on your `Amlib` server or on a local drive.

**Load the Template**

1. Launch the `Amlib` client
2. Go to `Main > Reports > RepAddNew` – the `Report Files` window will display
3. Select `Reservation` from the `Report Entity` dropdown
4. Click the **F1 New** button – the `New Report File...` screen will display
5. **Description** = `Reservation Notices (SMS)`
6. Browse to the `Amlib/Reports` folder on your `Amlib` Server and select the `&RESSMS.QRP` file (if the template has been loaded onto your PC – then navigate to the local folder)
7. Click the **Open** button
8. **Choose Type** = `Unlimited Reservation Format`
9. **Update History** = Y
10. **Update Entity** = Y
11. Click the **F3 Update** button
12. Close out of the `Report Files` window

The template is now loaded and available for use in a Report.

![Reservation - New Report File...](image-url)
Create the Report

1. Go to Main > Reports > RepReservation – the Reservation Reports screen will display
2. Click the F1 New button – the Select Report Format screen will display
3. Highlight Reservation Notices (SMS) and click the Select button
4. Type in a Description – for example: SMS Reservations Notices
5. Click the F3 Save Button

Create/Modify the Where Statement

The ‘Where Statement’ for this report should be based on the normal reservation notification report. However, with this report an additional line should be added to the ‘Where’ to ensure that it only selects the borrowers who have nominated to receive notification via SMS. Generally, borrowers without a mobile phone number should be collected in a separate reservations print run that produces paper notices.

1. Highlight the SMS Reservation Notice and click the F7 Where button – the Reservation Reports – Where screen will open
2. Create the following Where conditions:
   o Only Show First in Queue (Y/N) = Y (otherwise ALL reserves on an item will show)
   o Res Item Status = RETURN – this status will change to PRINTED once this report is run, to prevent duplicate emails being sent.
   o Bor Mobile/Cell Number IS NOT NULL (Paste without placing a value in 3)
   o Bor use Mobile/Cell (Y/N) = Y
   o (Optional) Res Collect Location = Temp Loc [select using the Special button] – this ensures that the item is at the collection location
   o (Optional) Res Collect Location = (enter your location code – for example: CHELSEA) – this will limit the notices sent to items for collection at the selected location
3. Click the **F3 Save** button when complete

![Reservation Reports](image)

**SMS Overdues**

The template may be saved in **Amlib/Reports** folder on your **Amlib** server or on a local drive.

**Load the Template**

1. Launch the **Amlib** client
2. Go to **Main > Reports > RepAddNew** – the **Report Files** window will display
3. Select **Circulation** from the **Report Entity** dropdown
4. Click the **F1 New** button – the **New Report File...** screen will display:

![Circulation - New Report File](image)

5. Type in a Description – for example: **Overdue Notice (SMS)**
6. Browse to the Amlib/Reports folder on your Amlib Server and select the &ODSMS.QRP file (if the template has been loaded onto your PC – then navigate to the local folder)

7. Click the Open button

8. Choose Type = Continuous – Full descriptions

9. Update History = Y

10. Update Entity = N

11. Click the F3 Update button

12. Close out of the Report Files window

The template is now loaded and available for use in a Report.

Create the Report

1. Go to Main > Reports > RepCirculation – the Circulation Reports screen will display

2. Click the F1 New button – the Select Report Format screen will display:

   ![Select Report Format](image)

3. Type in a Description – for example: SMS First Overdue Notice

4. Click the F3 Save button
Create/Modify the Where Statement

The ‘Where Statement’ for this report should be based on the normal reservation notification report. However, with this report an additional line should be added to the ‘Where’ to ensure that it only selects the borrowers who have nominated to receive notification via SMS. Generally, borrowers without a mobile phone number should be collected in a separate reservations print run that produces paper notices.

1. Highlight the SMS Overdue Notice and click the F7 Where button – the Circulation Reports – Where screen will display:

![Circulation Reports - Where](image)

2. Create the following Where conditions:
   - Issue Date Due Back <= Current Date [alter as required]
   - Bor use Mobile/Cell = Y
   - Bor Mobile/Cell Number IS NOT NULL (Paste without placing a value in 3)
   - Bor Location = <specify location code> [optional]

3. Click F3 Save button
Running the SMS Reports File (Reservations/Overdues): File Sharing

If using the Windows File Sharing method to supply the required .TXT file to your SMS-messaging service, then the report will need to be scheduled to run to save the file to the specified directory.

Reports can be scheduled to run once Daily, several times Daily, or several times Weekly.

Scheduling the Report

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation Reports screen will display:

2. Select the SMS Reservations Notice or SMS Overdues Notice report

3. Click the F6 Print button – the Print screen will display:

4. Set the conditions as follows:
Reports Training - Advanced Reports

- **From** = Database
- **To** = File
- **Frequency** = Daily or Weekly (if the report is to be run only on certain days a week, select Weekly and nominate the day via the First Print Date)
- **First Print Date** = <set date for first scheduled occurrence – for example: 30/08/2010>
- **First Print Time** = <set time for first scheduled occurrence – for example: 8:30 AM>
- **Overwrite Saved Files** = ticked [the same file is then used to generate the notices]
- Click the **OK** button when complete

5. Save the file in .TXT format (**Save as type:** Text Document) in the drive location to be used for file transfers (usually Windows File Sharing) – for example: C:\SMS Message, using the following file name: SMS_res_notice or SMS_over-notice

6. If you would like to print a report several times **Daily** or **Weekly**, repeat steps 3 – 5 with altered **First Print Dates and Times**

7. Check **Application > RepPrintProgress** to ensure all reports are scheduled correctly (see example of screen below)
Start the Scheduler

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation Reports screen will display

2. From the menu, select Application > RepStartSchedule – the Report Scheduler screen will display:

   ![Report Scheduler Screen]

3. You must check both the Save to File and E-mail options

4. Click on the OK button

5. When the scheduled report run is complete the following text file will be available to be transferred to the SMS-Messaging provider for further processing

Please Note: Please ensure that the Scheduler is started PRIOR to the printing time – otherwise the report WILL NOT PRINT!
Running the SMS Reports File (Reservations/Overdues): Emailing

If you are required to supply the SMS-messaging service with your SMS report via email, the email can be sent from directly within the system as an attachment.

The process is similar to that in the previous section, however, the email specifications for the SMS-messaging service must also be provided.

**Supervisor Parameters**

To begin, some settings need to be set in the Supervisor module (this need only be done once):

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. Select the Other tab
4. Scroll down and set the following: E-mails are sent using the following method: (M)API or (I)nternal or (S)MTP. Set to S, I or M

Generally (S) SMTP is recommended, especially as it is simple and it has advantages over the others. It also means that the email client does not need to be open on the PC running the notices and allows greater flexibility with regard to setting up “from” and BCC/CC parameters.

Then the following parameters should also be set (a full table is included below):

- **SMTP Blind Carbon Copy e-mail address**: you can specify the BCC address to send a copy of all notices (so that you can verify that they have been sent)
- **SMTP sender e-mail address**: the email address to display on the notice sent to the borrower (For example: library@oclc.org, it can be the same as the BCC address)
- **SMTP Server name**: the address of the SMTP mail server being used. This might be a server address or an IP address
5. Click the F3 Save button when complete

6. Exit and restart the Amlib client to allow the settings to take effect

The complete set of parameters to consider:

<table>
<thead>
<tr>
<th>Description</th>
<th>Explanation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Emails are sent using the following methods (M)API, (I)nternal or SMTP</strong></td>
<td>Generally (S) SMTP is recommended, especially if the organisation is not using a Microsoft Exchange Server. It also means that the email client does not need to be open on the PC running the notices AND can display the “from” name from one of the parameters below rather than the email address from the email client.</td>
<td>Set to S, I or M</td>
</tr>
<tr>
<td><strong>SMTP Blind Copy e-mail address</strong></td>
<td>Optional: If using the SMTP for emails. Enter only if copies of the email are to sent to a chosen email address – for example: Testing purposes</td>
<td><a href="mailto:library@amlib.com">library@amlib.com</a></td>
</tr>
<tr>
<td><strong>SMTP sender e-mail address</strong></td>
<td>Optional: If using the SMTP for emails, enter the Address you wish to indicate as the sender</td>
<td><a href="mailto:enquiries@amlib.com.au">enquiries@amlib.com.au</a></td>
</tr>
<tr>
<td><strong>SMTP server login</strong></td>
<td>Optional: From your Systems Administrator if required</td>
<td></td>
</tr>
<tr>
<td><strong>SMTP Server name or IP address</strong></td>
<td>If using the SMTP for emails, enter the Server Name or IP Address of the Server installed with the e-mail communication protocol, responsible for receiving and forwarding email messages</td>
<td>ServerName – for example: server.amlib.com.au</td>
</tr>
<tr>
<td><strong>SMTP server password</strong></td>
<td>Optional: From your systems administrator if required</td>
<td></td>
</tr>
<tr>
<td><strong>SMTP server requires a login?</strong></td>
<td>If Y, supply a SMTP server logon and password if N, leave SMTP server logon and password blank</td>
<td>Y/N</td>
</tr>
</tbody>
</table>

The above tasks create **Sender** and **BCC** for **ALL** emails generated by the system. However, it is possible to set up separate SMTP parameters (Sender and CC) for individual locations, modules and reports.
Setup Individual Email Systems by Location

1. In any Installation screen module, select Installation > Choose Location and choose a Location.

2. Repeats steps 2-5 above. If you would like to use the DEFAULT settings, then the relevant fields for each location should be left blank.

3. Once complete, you must exit and restart the Amlib client to allow the settings to take effect.

Setup Individual Email Locations, Modules and Reports

We recommend leaving the email set-up for particular locations until after initial testing has been completed. Once the initial testing has been done, then:

1. In any Supervisor module, select Library Menu > LocRepSMTP – the SMTP Parameters by Location table will display.

2. Select the F1 New or F2 Insert button.

3. Using the drop-down boxes available in each column, select the Location, Report Screen, and Report Type.

4. Then type in the individual Sender’s Email and Carbon Copy Email addresses.

5. Click the F3 Save button when complete.

6. Exit and restart the Amlib client to allow the settings to take effect.

Please Note: It is not possible to alter a pre-existing entry in the SMTP Parameters by Location table – entries must be deleted (using F4 Delete) and then re-entered.
Set Up SMS-Messaging Service Parameters

1. Go to Main > Reports > RepReservation or RepCirculation – the Reservation or Circulation Reports screen will display.
2. Select the SMS Reservations Notice or SMS Overdues Notice.
3. Click the F10 More button – the More screen will open.
4. Click the F1 New button.
5. Enter the following parameters:

<table>
<thead>
<tr>
<th>COLUMN</th>
<th>HEADER</th>
<th>COMMENT</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Report Line Number</td>
<td>Always 3</td>
</tr>
<tr>
<td>2</td>
<td>SMS</td>
<td>Always SMS</td>
</tr>
<tr>
<td>3</td>
<td>SMS Message</td>
<td>Message body – becomes the message in the email (50 chars)</td>
</tr>
<tr>
<td>4</td>
<td>Email Address</td>
<td>The email address of the SMS-messaging service (50 chars)</td>
</tr>
<tr>
<td>5</td>
<td>Delete File</td>
<td>After Sending - Y or N</td>
</tr>
</tbody>
</table>

Note: Since Lines 1 and 2 are already used for other reporting purposes, the email function uses Line 3.

6. Click the F3 Save button when complete.

7. Highlight the report and click on the F6 Print button – the Print screen will display.
8. Set the conditions as follows:
   - **From** = Database
   - **To** = File
   - **Frequency** = Daily or Weekly (if the report is to be run only on certain days a week, select Weekly and nominate the day via the First Print Date)
   - **First Print Date** = <set date for first scheduled occurrence – for example: 30/08/2010>
   - **First Print Time** = <set time for first scheduled occurrence – for example: 8:30 AM>
   - **Overwrite Saved Files** = ticked [the same file is then used to generate the notices]
   - Click the OK button

9. **Save as type**: Text Document to a specified drive location – for example: C:\SMS Message, using the following file name: SMS_res_notice or SMS_rver-notice. (A copy of the file will be saved here, unless the Column 5 was set to Delete the File at Step 5 above.)

10. If you would like to print a report several times Daily or Weekly, repeat steps 3 – 5 with altered First Print Dates and Times

11. Check **Application > RepPrintProgress** to ensure all reports are scheduled correctly (see example of screen below)
Reports Training- Advanced Reports

Start the Scheduler

1. Go to **Main > Reports > RepReservation** or **RepCirculation** – the Reservation or Circulation Reports screen will display
2. From the menu, select **Application > RepStartSchedule** – the Report Scheduler screen will display:

3. You must check both the **Save to File** and **E-mail** options
4. Click on the **OK** button
5. When the scheduled report run is complete the following text file will be available to be transferred to the SMS-Messaging provider for further processing

**Please Note:** Please ensure that the Scheduler is started **PRIOR** to the printing time – otherwise the report **WILL NOT PRINT**!

**AUDITS AND AUDIT REPORTS**

The audit reports list stockitems/authorities/borrowers that have been deleted, inserted (added) or updated (modified/changed) within a specified time period.
In addition to the audits, there are a number of Statistics Reports Audits that look at Operator logons and alterations, as well as searches performed in each module.

**Supervisor Settings: Setting Up Audits**

The Audit must be switched on first, before the data can be collected. To check this:

1. Launch the *Amlib* client
2. Go to **Main** > **Supervisor** > **Installation** > **Other** tab
3. There are several types of audit:
   - Create an audit for all Authorities (Y/N)
   - Create an audit for all Borrowers (Y/N)
   - Create an audit for all issues prompted with messages (Y/N)
   - Create an audit for all Stockitems (Y/N)
4. If you would like to keep audit details, ensure that these are set to **Y** (particularly the last)
5. Make sure you also check your settings by individual **Location**:
   a. Select **Installation** > **Choose Location**
   b. Select location and click on the **OK** button
   c. Select the **Other** tab

**Please Note:** Any record/s that were deleted, inserted or updated prior to the audit being switched on will not be recorded.
Issues Audit

Issues Audit records all messages that are displayed in issues. If you do not use this particular function, make sure the audit is switched off (see Supervisor Settings above):

- Create an audit for all issues prompted with messages (Y/N) = N

As the logs fill up quickly and must be regularly maintained (old entries deleted daily or weekly).

To access the Issues Audit:

1. Open the Supervisor module
2. Select Library Menu > Issues Audit – the Issue Audit table will display
3. Select the F6 Print button to print up the list

To delete entries from the table:

1. Open the Supervisor module
2. Select Library Menu > Issues Audit – the Issue Audit table will display
3. Highlight the entries in the list to be deleted
4. Click the F4 Delete button – this will mark the entries for deletion
5. Click the F3 Update button to delete the marked entries
Load the Template

Some audit report templates may need to be loaded before they can then be used in a report. You can also use this method to double-check the Choose Type of an already loaded template.

1. Go to Main > Reports > RepAddNew – the Report Files window will display
2. Select the appropriate Report Entity: either Authority, Borrower, Statistics or Stockitem – in the example below: Report Entity = Stockitem
3. Click the F1 New button – the New Report File pane will open
4. Type in a Description – for example: Audit Full Details
5. Click on the Browse button to view the Amlib/Reports folder on your Amlib Server and locate the template to be loaded – be sure to change the Files of type: drop-down to System Report Templates (*.qrp)
6. Select the template to be loaded and click on the Open button
7. Change the Choose Type to select an Audit type:
   a. Authority: Authority Audits
   b. Borrower: Audit Report
   c. Stockitem: Item Audit
   d. Statistics: Access Audit, Logon Audit or Search Audit
8. You can leave Default Stats Code blank
9. Update Entity (Y/N) = N
10. Click on the F3 Update button
11. Close out of the Report Files window

The template is now loaded and available for use in a Report.
Authority Audit Reports

- Reports can be set up in Main > Reports > RepAuthority

There is only one type of audit report available:

1. Audit report: &AUTHAUD.QRP

   1. Go to Main > Reports > RepAuthority – the Authority Reports screen will display
   2. Click the F1 New button – the Select Report Format screen will display
   3. Highlight the &AUTHAUD.QRP template and click the Select button

   ![Select Report Format](image)

4. Type a Report Description – for example: Audit New Authorities

5. Click the F3 Save button

   ![Authority Reports - STAFF at Chelsea Library](image)

6. Highlight the Audit report and click the F7 Where button – the Authority Reports – Where screen will display

7. Enter your Where parameters – there are three audit types:
2. **D**: Deleted  
3. **I**: Inserted  
4. **U**: Updated  

The Where parameters will depend on what you are after. Typically you would set the **Date** and **Audit Type (I/U/D)**. You may also include tag numbers or span of numbers (for example: > 600 AND < 700).

8. Click the **F3 Save** button when complete  

9. (Optional) Click the **F9 Order** button – you can then set the order for the report to print in. You can sort by **Date** and **Tag** (or vice versa if you’re looking for a particular tag). Click the **F3 Save** button when complete.
10. Click the **F8 View** button to view the report

11. Select the **print** icon to print the report

---

**Authority Audit Report**

<table>
<thead>
<tr>
<th>Tag</th>
<th>Indicators Authority / Database Key</th>
<th>Operator</th>
<th>Date/Time</th>
<th>Audit</th>
</tr>
</thead>
<tbody>
<tr>
<td>650</td>
<td>Being Rich - Lifestyle&lt;br&gt;BEING RICH LIFESTYLE</td>
<td>JOHN PR</td>
<td>Apr 8, 2010 12:04 PM</td>
<td>I</td>
</tr>
<tr>
<td>650</td>
<td>Runny&lt;br&gt;MUMMY</td>
<td>JOHN PR</td>
<td>Apr 9, 2010 5:06 PM</td>
<td>I</td>
</tr>
<tr>
<td>650</td>
<td>Jax&lt;br&gt;JAY</td>
<td>JOHN PR</td>
<td>Apr 19, 2010 5:06 PM</td>
<td>I</td>
</tr>
<tr>
<td>650</td>
<td>Olympic Games&lt;br&gt;OLYMPIC GAMES</td>
<td>JOHNPR</td>
<td>Jul 7, 2010 5:56 PM</td>
<td>I</td>
</tr>
<tr>
<td>650</td>
<td>Science fiction -- television&lt;br&gt;SCIENCE FICTION TELEVISION</td>
<td>JOHNPR</td>
<td>Oct 19, 2010 9:37 PM</td>
<td>I</td>
</tr>
</tbody>
</table>

**Borrower Audit Reports**

- Reports can be set up in **Main > Reports > RepBorrower**

There is only one type of audit report available:

5. **Audit: &BORRAUD.QRP**

1. Go to **Main > Reports > RepBorrower** – the **Borrower Reports** screen will display

2. Click the **F1 New** button – the **Select Report Format** screen will display

3. Highlight the **&BORRAUD.QRP** template and click the **Select** button

4. Type a **Report Description** – for example: **Borrower Audit**
5. Click the **F3 Save** button

![Borrower Reports - STAFF at Chelsea Library](image)

6. Highlight the Audit report and click the **F7 Where** button – the Borrower Reports – Where screen will display

7. Enter your Where parameters – there are three audit types:

   6. **D**: Deleted
   7. **I**: Inserted
   8. **U**: Updated

   The Where parameters will depend on what you are after. Typically you would set the **Audit Date** and **Audit Type (I/U/D)**. You may also want to limit by **Location**, **Borrower Type**, etc.

![Borrower Reports - Where](image)

8. Click the **F3 Save** button when complete

9. (Optional) Click the **F9 Order** button – you can then set the order for the report to print in. You can sort by **Audit Date** and **Barcode** (or vice versa if you’re looking for a particular patron). Click the **F3 Save** button when complete.
10. Click the **F8 View** button to view the report

11. Select the **print** icon to print the report

```
&authdraud.sp

**AUTHORITY AUDIT REPORT**

Audit New Authorities

<table>
<thead>
<tr>
<th>Tag</th>
<th>Indicators</th>
<th>Authority / Database Key</th>
<th>Operator</th>
<th>Date/Time</th>
<th>Audit</th>
</tr>
</thead>
<tbody>
<tr>
<td>650</td>
<td></td>
<td>Being Rich - Lifestyle</td>
<td>JOHNFR</td>
<td>Apr 8, 2010 12:04 PM</td>
<td>1</td>
</tr>
<tr>
<td>650</td>
<td></td>
<td>Rummy</td>
<td>JOHNFR</td>
<td>Apr 19, 2010 6:06 PM</td>
<td>1</td>
</tr>
<tr>
<td>650</td>
<td></td>
<td>Jax</td>
<td>JOHNFR</td>
<td>Apr 19, 2010 6:06 PM</td>
<td>1</td>
</tr>
<tr>
<td>650</td>
<td></td>
<td>Olympic Games</td>
<td>JOHNFR</td>
<td>Jul 7, 2010 6:56 PM</td>
<td>1</td>
</tr>
<tr>
<td>650</td>
<td></td>
<td>Science fiction - television</td>
<td>JOHNFR</td>
<td>Oct 18, 2010 9:37 PM</td>
<td>1</td>
</tr>
</tbody>
</table>
```
Statistics Audit Reports

- Reports can be set up in Main > Reports > RepStatistics

There are three types of audit reports available:

1. Access Audit: &SAAUDIT.QRP

This report displays access to the Authority and Catalogue modules by Operator showing alterations made.

<table>
<thead>
<tr>
<th>Date</th>
<th>Operator</th>
<th>Module</th>
<th>Location</th>
<th>Oper Sec</th>
<th>Object Sec</th>
</tr>
</thead>
<tbody>
<tr>
<td>24-Jul-2006</td>
<td>STAFF</td>
<td>AUTHORITY</td>
<td>EAS</td>
<td>53</td>
<td>0</td>
</tr>
<tr>
<td>17-Aug-2006</td>
<td>AMTASS</td>
<td>AUTHORITY</td>
<td>EAS</td>
<td>53</td>
<td>50</td>
</tr>
<tr>
<td>22-Aug-2006</td>
<td>AMTASS</td>
<td>AUTHORITY</td>
<td>EAS</td>
<td>53</td>
<td>0</td>
</tr>
<tr>
<td>22-Aug-2006</td>
<td>AMTASS</td>
<td>Viewed Attachments</td>
<td>EAS</td>
<td>53</td>
<td>0</td>
</tr>
</tbody>
</table>

2. Logon Audit: &SLAUDIT.QRP

This report displays the date and time Operators logged onto the Authority and Catalogue modules:

<table>
<thead>
<tr>
<th>Date</th>
<th>Operator</th>
<th>Module</th>
<th>Location</th>
<th>IP_Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>01-Sep-2006</td>
<td>STAFF</td>
<td>AUTHORITY</td>
<td>LB</td>
<td></td>
</tr>
<tr>
<td>01-Sep-2006</td>
<td>STAFF</td>
<td>AUTHORITY</td>
<td>LB</td>
<td></td>
</tr>
<tr>
<td>01-Sep-2006</td>
<td>STAFF</td>
<td>CATALOGUE</td>
<td>LB</td>
<td></td>
</tr>
<tr>
<td>01-Sep-2006</td>
<td>STAFF</td>
<td>AUTHORITY</td>
<td>LB</td>
<td></td>
</tr>
<tr>
<td>01-Sep-2006</td>
<td>STAFF</td>
<td>CATANET</td>
<td>10.0.0.47</td>
<td></td>
</tr>
</tbody>
</table>

3. Search Audit: &SAUDIT.QRP

This report displays Search terms used with the Authority and Catalogue modules and the type of search done:

<table>
<thead>
<tr>
<th>Date</th>
<th>Operator</th>
<th>Module</th>
<th>Location</th>
<th>Oper Sec</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>10-Aug-2006</td>
<td>STAFF</td>
<td>CATANET</td>
<td>LB</td>
<td>109</td>
<td>Catalogue Ref Number</td>
</tr>
<tr>
<td>11-Aug-2006</td>
<td>STAFF</td>
<td>CATANET</td>
<td>LB</td>
<td>109</td>
<td>EIR Title</td>
</tr>
<tr>
<td>11-Aug-2006</td>
<td>STAFF</td>
<td>CATANET</td>
<td>LB</td>
<td>109</td>
<td>BR Any Authority</td>
</tr>
</tbody>
</table>
Creating a Statistics Audit Report

1. Go to **Main > Reports > RepStatistics** – the Statistics Reports screen will display

2. Click the **F1 New** button the Select Report Format screen will display:

3. Highlight an audit **template** (Access, Logon or Search) and click the Select button

4. Type a **Report Description** – for example: **Logons Used 2010**

5. Click the **F3 Save** button

6. Highlight the Audit report and click **F7 Where** – the Statistics Reports – Where screen will display

7. Enter your Where parameters – there are two module types:

   - **AUTHORITY**
   - **CATALOGUE**
The Where parameters will depend on what you are after. Typically you would set the Date and Module parameters, and perhaps Location (Operator Logon Location).

8. Click the F3 Save button when complete

9. (Optional) Click the F9 Order button – you can then set the order for the report to print in. You can sort by Operator and Module (or vice versa if you’re looking for a particular item). Click the F3 Save button when complete.

10. Click the F8 View button to view the report

11. Select the print icon to print the report
Stockitem Audit Reports

- Reports can be set up in Main > Reports > RepStockitem

There are three types of audit reports available:

1. Audit Brief Details: &SADBR.QRP

This report displays a small amount of information for each item:

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Call No.</th>
<th>Location</th>
<th>Accession Date</th>
<th>Audited Date</th>
<th>Last Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glass pattern book / Carolyn Relei</td>
<td>07485 REL</td>
<td>EAS</td>
<td>15/01/2002</td>
<td>15/01/2002</td>
<td>00.00</td>
</tr>
</tbody>
</table>

2. Audit Medium Details: &SADDET.QRP

This report includes some additional fields: location, publisher, form and stats codes:

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Call No.</th>
<th>Location</th>
<th>Accession Date</th>
<th>Audited Date</th>
<th>Last Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glass pattern book / Carolyn Relei</td>
<td>07485 REL</td>
<td>EAS</td>
<td>15/01/2002</td>
<td>15/01/2002</td>
<td>00.00</td>
</tr>
</tbody>
</table>

3. Audit Full Details: &STKAUD.QRP

This report displays many additional fields for each item:

<table>
<thead>
<tr>
<th>Item Description</th>
<th>Call No.</th>
<th>Location</th>
<th>Accession Date</th>
<th>Audited Date</th>
<th>Last Active</th>
</tr>
</thead>
<tbody>
<tr>
<td>Glass pattern book / Carolyn Relei</td>
<td>07485 REL</td>
<td>EAS</td>
<td>15/01/2002</td>
<td>15/01/2002</td>
<td>00.00</td>
</tr>
</tbody>
</table>
Creating a Stockitem Audit Report

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
2. Click the F1 New button – the Select Report Format screen will display:

3. Highlight an audit template (brief, medium or full details) and click the Select button
4. Type a Report Description – for example: Audit 2010
5. Click the F3 Save button

6. Highlight the Audit report and click the F7 Where button – the Stockitem Reports – Where pane will open
7. Enter your Where parameters – there are three audit types:
   - D: Deleted
   - I: Inserted
   - U: Updated

The Where parameters will depend on what you are after. Typically you would set the Audit Date and Audit Type (I/U/D) parameters, and perhaps PermLoc (Permanent Location).
8. Select the **F3 Save** button when complete

9. (Optional) Click the **F9 Order** button – you can then set the order for the report to print in. You can sort by **Audit Date** and **Title** (or vice versa if you’re looking for a particular item). Click the **F3 Save** button when complete.

10. Click **F8 View** to view the report

11. Select the **print** icon to print the report
ACCOUNTS AND UPDATE REPORTS

Financial accounts can be added to borrower records via Reports. In order for this to work, you need to have the Create Acct column set to “Y” and you need to run your reports through F6 Print and RepStartSchedule.

Schools can use this to create a Final Account Due for departing students (where items on loan have not been returned and/or lost).

Create the Report

1. Launch the Amlib client
2. Go to Main > Reports > RepCirculation – the Circulation Reports window will display
3. Click the F1 New button – the Select Report Format screen will display
4. Highlight an appropriate Report (you may have a standard letter/email template you wish to use, or a modified overdue letter/email template added to the reports module) and click the Select button
5. Type in a Report Description – for example: Final Overdue Account
6. Ensure the Create Hist (Y/N) column = Y (for Yes)
7. Ensure the Create Acct (Y/N) column = Y (for Yes)
8. Click the F3 Save button to save the Report
Where Statement

1. Click the **F7 Where** button – the Circulation Reports – Where screen will display:

![Circulation Reports - Where Screen](image)

2. Enter an appropriate Where Statement – for example:
   a. **BorType = SEN** (for Seniors)
   b. **Issue Date Due Back < Current Date** (select via the **Special** button)

3. Click the **F3 Save** button when complete

Order By

1. Click the **F9 Order** button – the Circulation Reports - Order By screen will display:

![Circulation Reports - Order By Screen](image)
2. Set an appropriate order using the arrow keys to move fields from the **Columns** table in to the **Order By** table – for example:
   
   a. **Bor Class**
   
   b. **Bor Surname**
   
   c. **Bor Given**

3. Click the **F3 Save** button when complete

---

**Please Note**: User-defined charge types must be added to the **Circulation Transaction Types** table – see *Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation Transactions Types (RepCirculation and RepReservations Only)* for more information.

<table>
<thead>
<tr>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HEADING</strong></td>
<td>Report Line Number</td>
<td>Line 1 account history NAME</td>
<td>Line 1 overdue history NAME</td>
<td>Line 1 Financial record NAME</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>1</td>
<td>OVFINACC</td>
<td>OVDFINAL</td>
<td>OVDUEACC</td>
</tr>
<tr>
<td><strong>COMMENT</strong></td>
<td>Line 1 is used for History and Financial reporting purposes</td>
<td>If left blank, the system will put a Report Type of ACCOUNT in the Borrower History window if <strong>Create Hist</strong>(Y/N) = Y and <strong>Create Acc</strong>(Y/N) = Y and the report run via the <strong>Scheduler</strong>. It is possible to specify your own name – see example (max: 8 chars). Can use to specify 1st, 2nd, etc. overdue – for example: OVDUE1, OVDUE2</td>
<td>If left blank, the system will put a Report Type of OVERDUE in the Borrower History window if <strong>Create Hist</strong>(Y/N) = Y and <strong>Create Acc</strong>(Y/N) = N and the report run via the <strong>Scheduler</strong>. It is possible to specify your own name – see example (max: 8 chars). Can use to specify 1st, 2nd, etc. overdue – for example: OVDUE1, OVDUE2</td>
<td>If left blank, the system will put a Financial Type of OVERDUE in the Borrower Financial window indicating the (replacement) Cost for overdue items if <strong>Create Acc</strong>(Y/N) = Y and the report run via the <strong>Scheduler</strong>. It is possible to specify your own name – see example (max: 8 chars).</td>
</tr>
</tbody>
</table>
1. Click the F10 More button – the More screen will display:

2. Click the F1 New or F2 Insert button

3. Enter the following parameters:
   a. Report Line Number = 1
   b. Line 1 account History NAME = OVFINACC
   c. Line 1 overdue History NAME = OVDFINAL
   d. Line 1 Financial record NAME = OVDUEACC
   e. Line 1 Fees type name = OVDUEFEE (applicable only if Charges apply – see below)

It is also possible to apply charges at this stage on a per item/notice basis:
4. Click the F1 New or F2 Insert button
5. Enter the following parameters:
   a. **Report Line Number = 2**
   b. **Line 2 Fee per Item = 2.00**
   c. **Line 2 Fee per Notice = 5.00**
   d. **Line 2 Fee Print Line = Includes fees of:**
6. Click the F3 Save button when complete

**Edit the Template to Include Charges**

Please Note: The report template must be altered to include the following fields: **FORM_CHARGES** and **USER_LINE1**.

- The new **&ODFEE.QRP** template includes **FORM_CHARGES** and **USER_LINE1**.

<table>
<thead>
<tr>
<th>STK1_LINE1</th>
<th>STK1_DUE</th>
<th>STK1_COST</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Footer: EOR_BAR_NO</th>
</tr>
</thead>
<tbody>
<tr>
<td>USER_LINE1: FORM_CHARGES</td>
</tr>
</tbody>
</table>

“We would ask that if the item/s cannot be located, the sum of ' || NumberToStrPicture(TotalCst,)

The **FORM_CHARGES** field can be added to the total charge [Field = **FORM_CHARGES**] or included as part of a **TotalCst**. You can also include the field **USER_LINE1** which will include the text you entered in the F10 More statement.

**Print Report (via Scheduler)**

If you only want to print a report then the quickest method is to use F8 View and print from the Report – View window.

Using the Scheduler (via the F6 Print button) has several benefits over running reports via the F8 View button: It allows you to schedule regularly run reports so that staff do not have to do it manually each time, and it allows for further functions as part of the report such as updating Borrower/Stockitem history, updating the Reservation Status and adding report information to your statistics. This report MUST be run via the Scheduler.
Borrower

Once the report is printed each Patron will have an entry in the Borrower Financial Transactions window that will show the cost of the item:

Each Patron will also have an entry listed in the Borrower History window that will show that the report was run off:

A prompt will display with the following message if the item is returned: **FINANCIAL DETAILS – XXXX was previously charged $XX.XX Auto Charge for Overdue Item for this Item. Cancel the charge?**
Single Account

Creating an invoice against a single account can be done via the Where statement in the report.

Email Reports

If you’re planning to use email notices for those with email at your library, you need to ensure that patrons receiving notices by email aren’t also getting hardcopies, and that those who do not have email addresses are still receiving hardcopies.

To do this you need to adjust the Where statement of your hardcopy notice report to include: Bor Use Email = N. For the reports you are setting up to be sent by email you need to use: Bor Use Email = Y.
Status Updates

There are other reports that can affect changes in Amlib. For all of these to work, you must have the Update column in the report screen set to “Y” and they must all be run through F6 Print and RepStartSchedule.

Reservation Statuses

When an item is placed on reserve, a Reservation Status is placed against that item. The status is important as the reports use this status as a determinant for what to print and what not to.

<table>
<thead>
<tr>
<th>STATUS</th>
<th>EXPLANATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>ISSUE</td>
<td>Item was on loan when reserved (reserve placed via Amlib client)</td>
</tr>
<tr>
<td>ON LOAN</td>
<td>Item was on loan when reserved (reserve placed via Opacs)</td>
</tr>
<tr>
<td>SHELF</td>
<td>Item was on shelf (available) when reserved</td>
</tr>
<tr>
<td>RETURN</td>
<td>Item has been returned AFTER reservation placed</td>
</tr>
<tr>
<td>TRANSFER</td>
<td>Item was on transfer when reserved</td>
</tr>
<tr>
<td>ORDER</td>
<td>Item was on order when reserved</td>
</tr>
<tr>
<td>READY</td>
<td>Reservation on item has been CANCELLED through an expiry report and is now ready for the next reader</td>
</tr>
<tr>
<td>PRINTED</td>
<td>Item was included in a scheduled Reservation report with Update Res Status = Y</td>
</tr>
</tbody>
</table>

Reservation Reports - WHERE
AUTOMATIC BORROWER AND CIRCULATION UPDATES

Borrower Update Reports

Borrower update reports can now be run to change borrower status, add memos and delete the address 3 field (for those borrowers that are changing to adult status).

In the following example, we are changing the Borrower Type of Young Adult members to an Adult Type and deleting the Guardian Address.

Template

1. Launch the Amilb client
2. Go to Main > Reports > RepAddNew – the Report Files screen will display:

3. Locate and highlight the &BORUPD.QRP template
4. Click the F2 Modify button – the Borrower - Modify Report File... screen will display:

5. Check the following settings:
a. **Choose Type** = Borrower Automatic Update

b. **Update Entity (Y/N)** = Y

6. Click the **F3 Update** button when complete

### Create the Report

1. Go to **Main > Reports > RepBorrower** – the **Borrower Reports** screen will display

2. Click the **F1 New** button – the **Select Report Format** list will display:

   ![Select Report Format](image)

3. Highlight the **&BORUPD.QRP** template and click the **Select** button

4. A new report will be added to the list of reports

5. Type in a **Description** – for example: **Update Borrower Address 3**

6. The **Update Entity (Y/N)** column setting must be set to **Y**

7. Click the **F3 Save** button when complete

### Set Where Parameters
Your where parameters can be set according to the changes you need to make to your database, and which group(s) of people these changes apply to.

The Where statement here selects those borrowers with a YA borrower type who are now over 18.

*If you are unsure of how to set your where parameters for the update you wish to carry out, please contact Amlib support.*

1. Highlight the Report
2. Click the F7 Where button – the Borrower Reports – Where screen will display:

3. Enter the following details:
   a. **BorType** – for example: BorType = YA
   b. **BirthDate** – for example: BirthDate <= Current Date – 18 Years (use the Special button to insert Current Date – 216 months)
4. Click the F3 Save button when complete (the Where screen will close)
Update Parameters (F10 More)

The **F10 More** button is used to set up the new values and whether a Memo is to be sent.

A report employing **F10 More** parameters must be run via the **Scheduler**.

<table>
<thead>
<tr>
<th>COLUMN 1</th>
<th>COLUMN 2</th>
<th>COLUMN 3</th>
<th>COLUMN 4</th>
<th>COLUMN 5</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>HEADING</strong></td>
<td>Report Line Number</td>
<td>Column</td>
<td>New Value</td>
<td>Send Memo</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>1</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
<tr>
<td>2</td>
<td>&lt;leave blank&gt;</td>
<td>&lt;leave blank&gt;</td>
<td>&lt;leave blank&gt;</td>
<td>Y</td>
</tr>
<tr>
<td><strong>COMMENT</strong></td>
<td>Line 1 is used for updates</td>
<td>Borrower field – can be Borrower Types (T), Classes (C) Groups (G) or Status (S)</td>
<td>The new value – must be a valid code for the selected column</td>
<td>If Y, create the memo in <strong>Text for Letter</strong>, found at the top of the Borrower Reports screen</td>
</tr>
</tbody>
</table>

1. **Highlight** the report
2. Click the **F10 More** button – the More screen will display
3. Click the **F1 New** or **F2 Insert** button
4. Enter the following Line 1 parameters (see Notes below):
   a. **Report Line Number = 1**
   b. **Column = T**
   c. **New Value = A** (for **Adult**)
   d. **Send Memo = Y** (optional)
5. Click the **F3 Save** button when complete
6. Enter the following Line 2 parameters (see Notes below):
   a. **Address 3 = Y** (this will delete the Borrower’s Guardian Address)
7. Click the **F3 Save** button when complete
**Notes**

**Updates:** The new value is the new Borrower Type (or Borrower Status, Borrower Class or Borrower Group) that you wish to change the Borrowers to.

In the example given above, the Borrower Type would be changed to **Adult**, or **A**. The value entered in this column will depend on your Borrower Type settings. If you unsure, check your settings before proceeding: Go to **Main > Borrower > BorrowerTypes**:

![Borrower Types](image)

**Send Memo:** If you wish to add a memo to each borrower record that is changed, type a **Y** in the **Send Memo** column. Otherwise, type **N** in the **Send Memo** column.

**Delete Guardian Address:** Type a **Y** in the **Address 3** column if you wish to have the guardian address deleted (for example in the case where YA members are changed to A members, for these records you may prefer to have the guardian address deleted as this is no longer required).

**Memos**

If you have placed a **Y** in the **Send Memo** column, then the Memo text must then be set up.

1. **Highlight** the report

![Memos](image)

2. Click the **Text for Letter** button – the **Letter Text** screen will display:
3. Type in the text that you would like to see in the Borrower Memo – for example: **Borrower to sign register and present ID.**

4. Click the **F3 Save** button when complete

5. Click on the **[X]** to close the screen

**View Report**

Once the report is set up, you can then preview the report as follows:

1. Highlight the report and click the **F8 View** button – a prompt with the following message will display: **This type of report may use a Saved File as the Source. Do you want to select the file now?**

2. Click the **No** button to run this report against all borrowers

3. The report will open in the Report – View window:

   ![Automatic Borrower Update - Update Borrower Address 3](image)

<table>
<thead>
<tr>
<th>Bar Code</th>
<th>Name</th>
<th>Field</th>
<th>New Value</th>
<th>Meme</th>
</tr>
</thead>
<tbody>
<tr>
<td>0210</td>
<td>NORRIS, Peter D</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
<tr>
<td>5021</td>
<td>MATTHEWS, John A</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
<tr>
<td>0201</td>
<td>LOVE, Andrew J</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
<tr>
<td>0303</td>
<td>RENSHAW, Kim L</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
<tr>
<td>0204</td>
<td>GILES, Michael J</td>
<td>T</td>
<td>A</td>
<td>Y</td>
</tr>
</tbody>
</table>

4. If you wish to print a hardcopy, click on the **print** icon

**Print Report (via Scheduler)**

**Borrower Update reports MUST be run via the Scheduler.**
Start the Scheduler

1. From the Reports screen, select **Application > RepStartSchedule**

![Image of RepStartSchedule](image)

2. The Report Scheduler screen will display

3. Select your printing options: ensure **Save to File** is ticked (you can tick all three if you intend on printing up multiple reports using multiple formats during a session)

![Image of Report Scheduler options](image)

4. Then click the **OK** button

5. After clicking **OK**, if you go back into the Application menu you will see that **RepStartSchedule** is now greyed out with a tick next to it – this indicates that the Scheduler is now running

![Image of Application menu with RepStartSchedule](image)

Scheduling the Report

1. With your report highlighted, select the **F6 Print** button – the **Print** dialogue box will display

2. Select from the following options:
   a. **From:**
• Database (to search the entire database)

b. To:
• File (to save a report as a file)

c. Frequency:
• Once Only

3. Once you have selected all of your settings, click the OK button – the Report – Save As screen will display:

4. Select a Save in: location and type in a File name:

5. Click the Save button when complete

The report will then “print”.

Updated Borrower Record:
Memo that appears in Circulation:
Running Borrower Circulation Update Reports

The **Borrower Circulation Automatic Update** (&BORCUPD.QRP) template was created for the purpose of automatically changing the status of borrowers based on the inclusion of due date parameters in the Where statement of the report. The application of this would be to change borrowers with overdues past a certain due date to a SUSPENDED status.

To set up the process correctly, the following reports would need to be scheduled in this order:

1. **Borrower Automatic Update** (&BORUPD.QRP) to set all borrowers with suspended status to a status of OK.
2. **Borrower Circulation Automatic Update** (&BORCUPD.QRP) to set all borrowers with the given due date parameters to a status of suspended.

In the event that any borrowers with suspended status return or pay for all their overdues, the scheduling of the reports in this way ensures that those borrowers will be re-instated to a status of OK. The running of the **Borrower Circulation Automatic Update** then re-calculates which borrowers still fit the criteria for suspension, so that these borrowers still have their SUSPENDED status.

When the **Borrower Circulation Automatic Update** report is run, a borrower file is also created which contains all the records for borrowers that have had their status changed.

**Setting up the Reports**

**Create the Borrower Circulation Automatic Update Report**

1. Launch the Amlib client
2. Ensure that the borrower circulation update template is correctly set in **Main > Reports > RepAddNew** – **Entity** = Borrower:
   - **Report Type** = **Borrower Circulation Automatic Update**
   - **File Name** = &BORCUPD.QRP (not to be confused with &BORUPD.QRP)
3. Go to **Main > Reports > RepBorrower** – the **Borrower Reports** screen will display
4. Click the **F1 New** button – the **Select Report Format** screen will display
5. Highlight the **Borrower Circulation Automatic Update** (&BORCUPD.QRP) and click the **Select** button

6. Type in a **Description** – for example: **Borrower Update – Auto Suspension**

7. Ensure the **Update Entity (Y/N)** column = **Y**

8. Click the **F3 Save** button when complete

9. Highlight the report and click the **F7 Where** button – the **Borrower Reports – Where** screen will display

10. Set the due date parameter based on your criteria for suspension of borrowers. You may also choose to include parameters if you wish to exclude certain borrowers (for example: **housebound** borrower type or specific location)

11. Click the **F3 Update** button when complete

F10 More

1. Click the **F10 More** button – the **More** screen will display

2. Click the **F1 New** or **F2 Insert** button
3. Enter the following parameters:
   - Report Line Number = 1
   - Column = S (for Status)
   - New Value = SUSP (for Suspended)
   - Send Memo = Y

   ![Image of Borrower Update - Auto Suspension - More](image)

   The column is set to S in order to change the Status. The new value is the status you are changing your borrowers to – this will depend on the settings you have in Main > Borrowers > Borrower – Application > Borrower Status:

   ![Image of Borrower Status Codes - STAFF at Chelsea Library](image)

   The Send Memo can be set to either Y or N. If set to Y, the memo will be attached to each borrower’s record as a borrower memo.

4. Click the F3 Save button when complete
Memo

If you set the Send Memo column to be Y in the F10 More screen you will need to fill in the content of your memo.

1. Highlight your report and click the Text for Letter button – the Letter Text screen will display

2. Enter the memo text

3. Click the F3 Save button when complete and click on the red [X] to close the window

Create the Borrower Automatic Update Report

1. Click the F1 New button – the Select Report Format screen will display

2. Highlight the Borrower Automatic Update (&BORUPD.QRP) and click the Select button

3. Type in a Description – for example: Borrower Update – Clear Suspensions

4. Ensure the Update Entity (Y/N) column = Y

5. Click the F3 Save button when complete
6. Highlight the report and click the **F7 Where** button – the **Borrower Reports – Where** screen will display

7. Enter the Borrower Status to be checked (and cleared) – for example: **BorStatus = SUSP**

8. Click the **F3 Update** button when complete

F10 More

1. Click the **F10 More** button – the **More** screen will display

2. Click the **F1 New** or **F2 Insert** button

3. Enter the following parameters:
   - **Report Line Number = 1**
   - **Column = S** (for **Status**)
   - **New Value = OK** (for **Unrestricted**)
   - **Send Memo = D** (this will delete the memo if it no longer applies)
   - **Address 3 = <leave blank>**
The Column is set to S in order to change the Status. The new value is the normal OK status you would have your borrowers default to – this will depend on the settings you have in Main > Borrowers > Borrower – Application > Borrower Status:

4. Click the F3 Save button when complete
Print Report (via Scheduler)

Borrower Update reports MUST be run via the Scheduler.

Start the Scheduler

1. From the Reports screen, select Application > RepStartSchedule

2. The Report Scheduler screen will display

3. Select your printing options: ensure Save to File is ticked (you can tick all three if you intend on printing up multiple reports using multiple formats during a session)

4. Then click the OK button

5. After clicking OK, if you go back into the Application menu you will see that RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is now running
Scheduling the Report

**IMPORTANT!** In order to ensure that only those borrowers with outstanding items are/remain suspended, the reports **MUST** be run in the following order:

1. **Borrower Automatic Update** ([&BORUPD.QRP](#)) to set all borrowers with **SUSPENDED** status to back to **OK**.

2. **Borrower Automatic Circulation Update** ([&BORCUPD.QRP](#)) to set all borrowers with the given due date parameters to a status of **SUSPENDED**.

The reports can be run manually run or scheduled to run daily/weekly (as long as they are run in the correct order).

1. With your report highlighted, select the **F6 Print** button – the **Print** dialogue box will display.

2. Select from the following options:
   a. **From**:
      - **Database** (to search the entire database)
   b. **To**:
      - **File** (to save a report as a file)
   c. **Frequency**:
      - Any frequency can be used: **Once Only**, **Daily**, **Weekly** or **Monthly**
   d. **Schedule**:
      - **First Print Date** (defaults to current date)
      - **First Print Time** (defaults to current time)

**IMPORTANT!** In order to ensure that only those borrowers with outstanding items are/remain suspended, the reports **MUST** be run in the correct order!
3. Once you have selected all of your settings, click the OK button – the Report – Save As screen will display:

![Report - Save As](image)

4. Select a Save in: location and type in a File name: - for example: Borrower Update - Clear Suspensions or Borrower Update – Set Suspensions

5. Click the Save button when complete

Check Print Progress

1. You can check the progress of your reports at any time by going into Main > Reports > RepPrintProgress

2. You can also click through the three tab options at the top to see the ones that are Waiting, Running, or have already been Printed

3. Your report will show up in Printed when it is complete
Check the Suspended Borrowers

If required, borrowers that have been suspended with the Borrower Circulation Automatic Update report can be checked from a borrower file.

1. Launch the Amlib Client
2. Go to Main > Borrowers > Borrower – the Borrower Details screen will display
3. From the menu, select File > DisplayFile – the Borrower Saved Query Results screen will display:

4. Borrower Circulation Automatic Update will be listed under the report name – for example: Borrower Update – Auto Suspension
5. Highlight the saved file and click the F9 Select button to see a Borrower List of the borrowers who have been suspended:
6. Double-click on a name to bring up the **Borrower Details**:
SAVING A REPORT TO FILE

You can save your reports to a file, for email or formatting, or just to keep it in an electronic format rather than paper. The two ways of doing this are by Table or Report.

Table

1. Access a module and perform a search – the results will display in a List
2. Highlight the items you would like to save to file
3. Type Ctrl-C to copy them
4. Open up MS Excel or Word
5. Type Ctrl-P to paste the selection into a table or page

After getting a table of results in one of the modules, you can highlight them all to select them and do Ctrl + Insert to copy them. Then you can paste the items into Excel or Word.

This method works best if you don’t have a large number of results.
Report

There are several Excel report templates available which can be used to save to a file.

In this example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem module:

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
2. Click the F1 New button – the Select Report Format screen will display
3. Highlight the &XSTKCSV.QRP template and click the Select button
4. Type in an appropriate Description and click the F3 Save button
5. Enter an appropriate F7 Where search – for example: Title LIKE Harry Potter

![Stockitem Reports: Where]

6. Order the Report – for example: Title | ASC
7. Select Application > RepStartSchedule – the Report Scheduler screen will display
8. Ensure that Save to File is ticked and click the OK button

![Report Scheduler]

9. Click the F6 Print button – change the To: option to File and click the OK button
10. A Report – Save As dialogue box will display:
   a. To save it for a Word document, leave the Save as type: as Rich Text Format (RTF)
   b. To be able to open it in Excel, change the Save as type: to Text Document

11. You can check the progress of your report in Reports > RepPrintProgress

12. If you’ve saved the report to open in Excel (Text Document) then you will need to follow these steps so it is displayed correctly:
   a. Open Microsoft Excel
   b. Use File > Open to open the text file you’ve saved – ensure that the Files of type: = All Files (*.*)
   c. The Text Import Wizard will display:
d. Excel will recognise your file as **Delimited**, so click the **Next** button

e. Delimiters: select **Semicolon** and add a pipe | in the **Other** box

f. Click the **Next** button and then the **Finish** button

13. Your data will be transferred into the **Excel** sheet and you can now use the formatting tools to customise it:

![Excel Import Wizard](image)

LOADING TEMPLATES
Your new/customised template needs to be saved somewhere that can be accessed by every workstation, such as the Amlib/Reports folder on your Amlib server.

To add them into the Amlib client:

1. Launch the Amlib client
2. Go to Main > Reports > RepAddNew – the Report Files window will open
3. From the Report Entity drop-down, select the appropriate module for your report – for example: Circulation
4. Click the F1 New button – the New Report File... window will display
5. Type in an appropriate Description – for example: Overdue Notice (Letter)
6. **Template** – click on the **Browse** button – the **Choose Report** window will display:

![](image)

7. Navigate to the **Amlib/Reports** folder on your **Amlib Server** (if the template has been loaded onto your PC – then navigate to the local folder)

8. **Files of type**:
   - Select **Custom Report Templates (*.QRP)** for customised templates
   - Select **System Report Templates (*.QRP)** for all standard system templates

9. Locate the template to be loaded and highlight it

10. Click the **Open** button – the template will be selected the **Choose Report** window will close

11. **Choose Type** – it is **essential** that the appropriate type be chosen that this will inform how your template operates and the information that is sent to it – in this example: **Continuous - Full descriptions** has been selected

![](image)

12. **Message** – leave blank

13. **Default Stats Code** – it is possible to collect statistics on the number of times that this report is run by adding an entry into the **Statistics Codes** table (**Main > Supervisor > StatsParams**) and then adding the **Stat Type** into the **Default Stats Code** box

14. **Default Detail Stats Code** – it is possible to collect statistics on the number of individual notices that a particular report generates by adding an entry into the **Statistics Codes** table
(Main > Supervisor > StatsParams) and then adding the Stat Type into the Default Detail Stats Code box (not available for all modules)

15. Update History (Y/N) – it is possible to retain a record of the report having been generated – for example: the above Overdue Letter report can add a record of the overdue being printed to the Borrower History of affected patrons

16. Update Entity (Y/N) – this field can be used to update the status or alter a parameter of a record – for example: an account may be generated for an overdue circulation report

17. Click the F3 Update button

18. Close out of the Report Files window

The template is now loaded and available for use in a Report.
SCHEDULING REPORTS

Print Report (via Scheduler)

If you only want to print a report then the quickest method is to use the F8 View button and print from the Report – View window.

Using the Scheduler (via the F6 Print button) has several benefits over running reports via the F8 View button: it allows you to schedule regularly run reports so that staff do not have to do it manually each time, and it allows for further functions as part of the report such as updating Borrower/Stockitem history, updating the Reservation Status and adding report information to your statistics. Email and SMS reports MUST be run via the Scheduler.

This guide will take you through setting up a report to use RepStartSchedule.

Start the Scheduler

1. From any Reports screen, select Application > RepStartSchedule – the Report Scheduler screen will display:

2. Select your printing options: ensure Printing, E-mail and/or Save to File is ticked (you can tick all three if you intend on printing up multiple reports using multiple formats during a session)

3. Also decide If a report is scheduled by another user do you still want to print it? = Yes/No

4. Then click the OK button

5. After clicking OK, if you go back into the Application menu you will see that RepStartSchedule is now greyed out with a tick next to it – this indicates that the Scheduler is now running:
Please Note: If you need to restart the scheduler at any point, you will need to log out of all Report screens (Ctrl + L) and start at the beginning of these instructions.

Scheduling the Report

1. With your report highlighted, select the F6 Print button – the Print dialogue box will display:

2. Select from the following options:
   a. From:
      • Database (to search the entire database)
   b. To:
      • Printer (to generate print reports)
      • E-mail (to generate email reports – this option will only be available to reports that have been created from an appropriately loaded template)
      • File (to save a report as a file)
   c. Frequency:
      • Once Only (if this is the only time you’re going to print this report)
      • Daily (if you plan to send it every day)
      • Weekly (if this is a once a week item)
      • Monthly (if this is to be printed every calendar month)
      • Every ___ days (if you want to set a specific schedule)
   d. Schedule:
      • First Print Date (the day you want this report to begin its schedule)
      • First Print Time (specifies the exact minutes the report will run)
   e. Selected Printer:
You can specify any active printer on the network to print to – including virtual printer drivers such as a third party software that allows you to print to PDF (For example: CutePDF Writer)

3. Once you have selected all of your settings, click the OK button

Check Print Progress

1. You can check the progress of your reports at any time by going into Main > Reports > RepPrintProgress – the Print Progress screen will display:

7. If your library uses the scheduler for a lot of reports, you can select a frequency type from the Filter drop-down menu at the top:

8. You can also click through the three tab options at the top to see the ones that are Waiting, Running, or have already been Printed:

9. Your report will show up in Printed tab when it is complete:

LAUNCH REPORTS UNATTENDED
The Report module has been modified so that it can be started from a command line to run all currently scheduled reports and then exit.

Several sites have requested that we build a report Service to run unattended on a server. Currently there are no plans to do this. This enhancement will make it possible for sites to schedule the report exe to start up, print scheduled reports (including emails) and then shut down.

**Sample Command Line Parameters**

[Exe path] [login] [password] [database] [location] [default window]

For example: `D:\Amlib\Amlib\Programs\Reports.exe staff Amlib LIVE LIB RepPrintProgress`

In the above example:

- [Exe path] `D:\Amlib\Amlib\Programs\Reports.exe`
- [Login] `staff`
- [Password] `Amlib`
- [Database] `LIVE`
- [Location] `LIB`
- [Default Window] `RepPrintProgress`

The Database Login e.g. LIVE must be in **Upper Case** in the Command Line path as well as in the `C:\Windows\Amlib.ini` (configuration settings) found on the PC on which the Automatic Reports Scheduler is to be launched.

The Location code will be validated. It must be correct within the Command Line.

Substitute the above Command Paths and Login details to reflect your own Command Paths and Login details. These details can then be entered into a Windows/Scheduled Task pane. We can send separate notes on this if required.

**Report Functionality**
If Reports is started using a command line that includes RepPrintProgress as the default window argument, the Reports module starts up and opens the Print Progress window. The *scheduler* is started and ALL scheduled reports that are listed to be launched *prior* to the current date/time will be processed.

Once there are no more reports to process the application shuts down.

It is important to understand that the *Reports* application will stay open as long as it takes to process all jobs where the date and time is EARLIER than the current time. The Report exe does NOT look ahead and stay open for jobs that will become due at some future time.

Example:

- Print Job #1 scheduled for 29th March 2007 at 2:00am
- Print Job #2 scheduled for 29th March 2007 at 3:30 am

If the Report.exe is loaded at 3:00 am Print Job #1 will be processed but Print Job #2 will NOT be processed, unless Print Job #1 takes more than 30 minutes to run.'

**Please Note:**

Currently only Report.exe does anything with the default window parameter, but the Database and Location parameters can be used with any Amlib executable.

The passed Location code is validated. If it is OK then the application logs on to that Location, otherwise the Location selection dialogue is displayed.

For example launch Amlib automatically without logging in manually by setting the Amlib desktop Icon to have the Properties set to the User’s login details. For example:

![Amlib Desktop Icon Properties](image)

**APPENDICES**
Appendix 1: Add the User-Defined Financial Record and Fees Type Names to the Circulation Transactions Types (RepCirculation and RepReservations Only)

Please Note: Any user-defined names in column 4 and 5 (Line 1 Financial record NAME and Line 1 Fees type name) in the **F10 More** screen must also be added to the **Circulation Transaction Types** table.

1. Go to **Main > Finance > CircFinTypes** – **Circulation Transaction Types screen** will display:

2. To add a new Transaction Type:
   a. Click the **New** or **Insert** button
   b. **Trans Type** – type in the user-defined name – for example: **OVDUEACC** or **OVDUEFEE**
   c. **Transaction Description** – for example: **Overdue Account** or **Overdue Fee**
   d. **CR or DB** = **DB**
   e. Click the **Save** button when complete
Appendix 2: Sample Overdue Date Line

- **LIST – OUTSTANDING OVERDUES**
  - Less than or equal to Current date minus 42 days ≤
  - Greater than Current Date minus 35 days >

- **INVOICE**
  - Less than or equal to Current date minus 28 days ≤
  - Greater than Current date minus 21 days >

- **OVERDUE LETTER 1**
  - Less than or equal to Current date minus 14 days ≤
  - Greater than Current date minus 14 days >

- **OVERDUE SLIP**
  - Less than or equal to Current date minus 7 days ≤

- **Current Date**

The diagram illustrates the conditions for different stages of overdue invoices based on the current date.
## Appendix 3: Operators

<table>
<thead>
<tr>
<th>OPERATORS</th>
<th>LIKE</th>
<th>LIKE</th>
<th>IN</th>
<th>IN</th>
<th>=</th>
<th>≠</th>
<th>&lt;</th>
<th>&lt;</th>
<th>&gt;</th>
<th>&gt;</th>
<th>F12</th>
</tr>
</thead>
<tbody>
<tr>
<td>For Reports &amp; Where Searches</td>
<td>Begins with</td>
<td>Does not begin with</td>
<td>Include these multiple codes - for example: J,A</td>
<td>Do not include these multiple codes</td>
<td>Equal to...</td>
<td>Not Equal to...</td>
<td>Less than</td>
<td>Less than or Equal to</td>
<td>Greater than</td>
<td>Greater than or Equal to</td>
<td>PRINT SCREEN</td>
</tr>
</tbody>
</table>