OVERVIEW .............................................................................................................................................. 6

STOCKITEM SCREEN .............................................................................................................................. 8

THE STOCKITEM WINDOW ....................................................................................................................... 9

STOCKITEM MENUS .................................................................................................................................. 13

APPLICATION MENU ............................................................................................................................... 13
Stockitem Forms........................................................................................................................................ 13
Stockitem Origins.................................................................................................................................... 13
Stockitem Stats.......................................................................................................................................... 13
StockCallSets........................................................................................................................................... 13
StockExternalLibs.................................................................................................................................... 13
Stock Loan Types ..................................................................................................................................... 13
Stock Loc Floor......................................................................................................................................... 13
StockLocations.......................................................................................................................................... 13
Stockitem AutoLink - See separate section under Maintenance.............................................................. 13
StockKeyword........................................................................................................................................... 13
StockLoanTypes....................................................................................................................................... 13
StockTakes................................................................................................................................................ 13
StockWandChange.................................................................................................................................... 14
Where ..................................................................................................................................................... 14

ITEM MENU .................................................................................................................................................. 14
Reserve Item............................................................................................................................................... 14
Average Cost Item.................................................................................................................................... 15
Create Catalogue....................................................................................................................................... 15
Current Bookings...................................................................................................................................... 16
Current Reserves...................................................................................................................................... 16
Depreciate Item.......................................................................................................................................... 16
History.................................................................................................................................................... 17
ILLS [Inter Library Loans].......................................................................................................................... 18
ItemCreateDefaults .................................................................................................................................. 19
Memos..................................................................................................................................................... 20
Select All Groups...................................................................................................................................... 21
Select Query Group(s)................................................................................................................................. 21
Select My Group....................................................................................................................................... 21
New Item.................................................................................................................................................. 21
RefreshFromCat....................................................................................................................................... 22
RefreshFromCatConfirm............................................................................................................................... 22
ReserveAllocate....................................................................................................................................... 22
Saved Where Searches................................................................................................................................. 23
QuerySettings.......................................................................................................................................... 23
Continue Query.......................................................................................................................................... 23
KeepQueryVia............................................................................................................................................ 24
Keyword Search Parameters..................................................................................................................... 24
NoSort Query............................................................................................................................................ 24
Restart Query............................................................................................................................................ 24
SetSearchSize.......................................................................................................................................... 24
Set the Search Size.................................................................................................................................... 25

CREATING AN ITEM AFTER MANUAL CATALOGUING......................................................................... 26

WORK SHEET METHOD ............................................................................................................................ 27
Adding Stockitems..................................................................................................................................... 31
Multiple Copies......................................................................................................................................... 33

IMPORTING NEW ITEMS .......................................................................................................................... 34

IMPORT MARC CATALOGUE DATA .......................................................................................................... 34

Last Updated: 25 February 2013
STOCKITEM FORM AND STATS CAT DEFINITIONS ................................................................. 35
Form Codes .................................................................................................................. 35
Stats Codes ............................................................................................................... 36
ACCESSING THE DATA FOR THE DOWNLOAD ................................................................... 37
BIBLIOGRAPHIC DATA .................................................................................................. 37
REVIEWING RECORDS TO BE IMPORTED (OPTIONAL) ...................................................... 39
Find ................................................................................................................................ 40
CATALOGUE UPDATE OPTIONS ..................................................................................... 41
F6 MARC LOG ................................................................................................................ 43
CHECKING NEW STOCKITEMS ........................................................................................ 43
ADD A NEW ITEM WITHOUT A CATALOGUE .................................................................... 45
ADD EXTRA COPIES FOR THE SAME CATALOGUE RECORD .............................................. 47
CREATING & MAINTAINING STOCK PROCESSES ............................................................... 48
MOVEMENT OF TAGS TO DISPLAY A SUBJECT IN STOCKITEM ........................................... 50
SEARCHING WITHIN STOCKITEM .................................................................................... 52
Colour ............................................................................................................................ 53
CATALOGUE .................................................................................................................. 53
WHERE SEARCHING ......................................................................................................... 55
Special Button ................................................................................................................. 57
Saving a Where Search .................................................................................................. 59
Query to File ................................................................................................................... 60
CREATING SPINE LABEL REPORTS .................................................................................... 62
Load the Template ......................................................................................................... 62
Create the Report ......................................................................................................... 63
Wand Into File .............................................................................................................. 65
Run the Spine Label Report ............................................................................................ 66
Clearing the File ............................................................................................................. 68
MASS MEMO ITEMS ....................................................................................................... 69
CREATE THE MEMO TYPE .............................................................................................. 69
WAND INTO FILE .......................................................................................................... 71
MASS MEMO THE ITEMS ............................................................................................... 71
MASS MEMO DELETION .................................................................................................. 73
MASS DELETION OF STOCKITEMS/SAVING TO FILE ......................................................... 75
Stockitem List ................................................................................................................ 75
STOCKITEM FIELD LABELS ............................................................................................ 77
CUSTOMISING THE STOCKITEM TABLE ......................................................................... 79
STOCKITEM SEARCH DEFAULTS ...................................................................................... 80
STOCK CALL SETS .............................................................................................................. 82
CREATING MASTER/SUBSIDIARY ITEMS (KIT LOANS) ......................................................... 84
CREATING A MASTER RECORD ....................................................................................... 84
CIRCULATING LINKED ITEMS .......................................................................................... 86
RETURNING MASTER-SUBSIDIARY ITEMS ....................................................................... 88
Supervisor Settings ....................................................................................................... 93

Last Updated: 25 February 2013
# How to Find the Valuereports

**Setting Up Floating Collections** ......................................................... 94

**Stockwand Change** ............................................................................... 97

  Stockwand Change – setting Values to change ......................................... 97
  Using the Special Button ......................................................................... 98
  Executing the Changes ........................................................................... 98
  Saving a StockWandChange .................................................................... 100
  Reusing a StockWandChange set of Parameters ....................................... 100

**Mass Item Change** .................................................................................. 100

  Create a Saved File of Items to be Changed ........................................... 100
  Mass Change the Saved File .................................................................... 102

**Stockitem Autolink** ................................................................................ 105

**Reports for Stockitem** ............................................................................ 109

  Print Using a Report .................................................................................. 109
  Saving a Report to File .............................................................................. 110
  Table ......................................................................................................... 110

**How to Find the Value of the Collection** ............................................... 111

  Reports That go to Excel .......................................................................... 114
  Ills Reports ................................................................................................ 118
  Stockitem Reports ...................................................................................... 118
  Audit Reports ............................................................................................. 118
    System Settings ....................................................................................... 118
    Creating a Stockitem Audit Report ......................................................... 119
  Items Never Borrowed (Dusty Items) ........................................................ 121
    Create Report .......................................................................................... 121
    Where Search and Order By Parameters ............................................... 122
    View Report ............................................................................................. 123

**Appendix 1: Saved Files** ....................................................................... 124

  Create a Saved File ................................................................................... 125
  Create (or Save to) a Saved File from a List .......................................... 127
  Save a Single Item .................................................................................... 130
  View an Existing Saved File ................................................................. 131

---

Last Updated: 25 February 2013
OVERVIEW

Item Processing includes creating items when Cataloguing records are entered into the database – either manually or through an Authority import (Marc TakeUp). It also includes maintaining and deleting the items.

Amlib uses the Stockitem Module for the item collection. Each item of stock is displayed separately on the Stockitem screen, displaying the details for each item.

Generally libraries outline their own Workflow depending on the staff allocated to the tasks and procedures important to each specific site. It is suggested that these steps are outlined within a Procedure Manual – useful for new staff or for job rotation.

When processing each new item, it is worthwhile considering the prime purpose behind the time and effort required to process the item. For example, is it being entered onto the system primarily for circulation or a reference item? This will determine the depth of processing.

A sound knowledge of how the Stockitem Window is configured and how to Search correctly will enhance decisions.

Questions to consider include:

- How will the item be circulated?
- How will it be found?
- Where is it located? Consider the Permanent Location
- Does it need further identification for the Location – including a Floor Location or special Call Number
- Has it a Catalogue entry? Most items need this for keyword searching.
- Is there anything special about the item that needs recording in the notes or Subjects?
- Should a Memo be added?
- Does management need statistics on its use? Generally the Form and Stats code are used for collating counts on the collection’s usage
- Will it be available for search on the Netopacs?

Once the items are part of the collection, certain changes and maintenance are required from time to time:

- Adding extra items to an existing Catalogue record
- Changing items – including Stock Wand Change and Mass Change
- Deleting items
- Adding Memos – individually or en masse
- Transferring items to another location
- Stocktake

How the Stockitem is set up can vary according to the parameters and defaults set in:

- Supervisor
- Stockitem Application Menus
- Stats definitions

Some items require special processing:
- **Special Loan Value – Loan Types**
- **Master/Subsidiary Items**
- **EBooks**
- **AV and Equipment items**
- **Interlibrary Loans**

Searches and Reports will also be covered including:

- Reporting directly from the Stockitem Screen for a simple *Bibliography*
- Pasting a Stockitem Table into *Excel*
- *Where* Searches
- *Stock Keyword* (Ctrl K)
- *Inventory* items
- *Spine label* printing
- *Value* of the Collection

Reports and Processing can be assisted by using:

- *Stockitem Files*
Stockitem Screen

**Item No:** Usually the Barcode.

**Catalogue** information: Originates from the Catalogue data. Line displays set in Stockitem Form – F9 Display.

**Stats Code:** Used mainly in the statistics gathering process but may also be used as enquiry points.

**Description:** Free text. Label can be changed.

**Location:** Permanent/Temporary Locations for Stockitems.

**Received and Accessioned Dates:** Format is DD/MM/YYYY – for example: 07/10/2012. < = > symbols can be used for queries – for example: item before a certain date.

For Loan: (Y/N) Default is Y.

**Loan Type:** Parameters set according to type e.g. Overnight only.

**Opac?** Show this item in Opac (Y/N)

**Alert:** Message generated in circulation regarding the item (Y/N)

**Library Group:** Associated with Login Location – determines privileges within Group security if used by your Site e.g. if Multi Campus School. Able to apply security to View, Update, Insert, Delete, Batch, Attach, Hold, Loan, Check-in and/or Transfer.

**Circulation** details: If on loan, current borrower, No. of reserves, order

**Vol:** Usually used for Volume No or could automatically display data from a Marc Tag/Subfield

**Form:** Physical description of the Stockitem. Typical Forms codes could be CD, BK, VID.

**Ed:** Edition information. Can automatically display data from a Marc Tag/Subfield – for example, Tag 250a or Tag 260c.

**Call Set:** If used enable Call numbers to be categorised based on Dewey Nos.

**Convert Val:** Usually ref for conversion data. Label can be changed.

**Origin/Source:** Usually Supplier or Source of funding.

**Current Cost:** Do not enter $ symbol.

**Floor Location:** Names of floor locations in your Library – Optional but can appear in the Opac under the Permanent Location description.

**Search Size** (for example: 200) and Table Information – for example: Sequence No 6 in Set of 41

**Process:** Special process associated with the item – for example: MISSING, DAMAGED. Linked to Opac? And Alert fields – for example: Alert = Y but Opac = N. A Date displayed once a process has been included. This is useful for Reporting purposes – for example: Report Missing items entered as Missing 2 years ago.
THE STOCKITEM WINDOW

1. Launch the Amlib client
2. Go to Main > StockItems
3. This Window has many fields which are explained below:

**Item No:** Usually the Barcode. Able to enter a system generated barcode which begin with STOCK. Validation checks are made, which relate to the Supervisor>Library Menu > Check Digits table. New validations can be set.

**Cat Ref:** Displays the Catalogue Reference Number

**Query via:** Sets the Search options – see more information in separate section

- Use the **Query Via** options to determine the type of search to be performed

<table>
<thead>
<tr>
<th>OPTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td>Browse (phrase) search for data displayed within the Stockitem module</td>
</tr>
<tr>
<td>Cat</td>
<td>Browse (phrase) search for data displayed within the Catalogue module</td>
</tr>
<tr>
<td>Keyword</td>
<td>Keyword search <strong>one</strong> of the six bibliographic lines within the Stockitem screen (<strong>Title, Author, Subject, Publisher, Series or Call No</strong>) – for example: typing a keyword into the Subject line will perform a keyword search on just the Subject fields</td>
</tr>
<tr>
<td>Any</td>
<td>Keyword search <strong>any</strong> of the six bibliographic lines within the Stockitem screen (<strong>Title, Author, Subject, Publisher, Series or Call No</strong>) – for example: even if the keyword is typed into the <strong>Title</strong> line, all six fields (<strong>Title, Author, Subject</strong>, etc) will be searched</td>
</tr>
<tr>
<td>Previous Queries</td>
<td>The last 5 searches are kept in case they need to be re-performed. Use the -1 to -5 buttons to select a previous search</td>
</tr>
</tbody>
</table>

**Lines 1 – 6** – display a Summary of Bibliographic data from the Catalogue record. Line displays set in Stockitem > Form > Display. The labels and tags to display can be customised. See separate section on how this is set up.

Usually set as:

- **Line 1:** TITLE
- **Line 2:** AUTHOR
- **Line 3:** PUBLISHER
- **Line 4:** SERIES
- **Line 5:** SUBJECT
- **Line 6:** CALL NO
If changes are made within the Catalogue these lines can automatically be updated. This depends on the Supervisor>Installation>Stockitem setting for the Location. For example update all lines except Line 6 (Call No)

Vol: Can display Volume – for example of an Encyclopedia set or can show the Series No. Free text up to 8 characters in length. The Vol Field can be set up so that Marc tag is inserted automatically – for example: 490v. This is set up in Stockitem > Form > Display. Note – if this is set all new items will be applied if applicable. However a Stockitem Autolink would need to be used to update existing items. See separate section on Autolink

Ed: Free text. Allows up to 8 characters in length. Can be set up so that Marc tag is inserted – for example: Tag 250a to show the Edition or Tag 260c to show the publishing year

Sts Code: The code may be alphabetic (up to 6 characters) with description (up to 50 characters). Usually used to verify the Collection and can be used as a Query point, and for Collection Counts, Statistic Reports, Stocktakes and other reports. The Loan parameters can be set based on the Stats code if required. New codes and changes can be made from Stockitem >Application > Stockitem Stats

Form: Usually a physical description (Format) or General Material Designation (GMD) of the Stockitem – for example: Book, Periodical, Video, Map, Online, etc. Is usually the category used to set Loan parameters. Plays a vital role within Circulation and may also be used in Statistics. New codes and changes can be made from Stockitem >Application > StockitemForms

Call Set: If used it enables Call numbers to be categorised into groups based on the Numbers used for Line 6 – for example 520 Astronomy etc. Allow you to search or print reports by the Call number set – for example value of the Science collection for this year. New codes and changes can be made from Stockitem >Application > StockCallSets. See separate section
**Description:** Free-text fields: Often used to indicate copy number – label can be customised in *Supervisor > Installation > Stockitem*. Does not access Codes

**Convert Val:** Free-text fields: Often used to note old values from a conversion which can then be later cleared – label can be customised in *Supervisor > Installation > Stockitem*. Does not access Codes

**Location Perm:** Branch, Library, Campus or Department Name. Codes supplied from Locations set up in *Main>Supervisor>Locations*

**Location Temp:** Branch, Library, Campus or Department Name – changes to Return Location. Codes supplied from Locations set up in *Main>Supervisor>Locations*

**Floor Location:** Names of specific areas that may contain separate collections within the main location – for example: DISPLAY, AV COLLECTION, STACK, CLOSED RESERVE etc. Optional. Codes set up in *Main>Stockitem>Application>StockLocFloor*

**Origin/Source:** Usually used to indicate Supplier or Source of funding. Codes set up in *Main>Stockitem>Application>Stockitem Origins*

**For Loan:** Displays if the item is generally allowed as a Loan. Usually set according to Form or Stats Code (Allow Loan column). Can be altered automatically – for example, if the Process is changed to a Process that is set for Not for Loan like Damaged

**Loan Type:** It is possible to have Loan Type that over-write the normal Loan privileges based on Borrower Type and Stockitem Form or Stats codes. For example OVERNIGHT ONLY. These special Loan Types are set in *Stockitem>Application>StockLoanTypes*. See separate section

**Opac?:** Show this item in the Netopac/Opac *(Y/N)*. Often hidden if there is a Process – for example MISSING

**Alert:** If set to Y, a Message will be generated in circulation regarding the item *(Y/N)* – for example if there is a process of MISSING

**Process:** Special process associated with the item – for example: **MISSING, DAMAGED**. A Date displayed once a process has been included. This is useful for Reporting purposes – for example: Report Missing items entered as Missing 2 years ago. Codes set up in *Main>Stockitem>Application>StockProcess*. See Separate section

**Received:** Date item was received into the Library. Format is **DD/MM/YYYY** – for example: **07/10/2012**. No need to type the / symbol. In Received date <= > symbols can be used for queries – for example: item after or before or equal to a certain date

**Accessioned:** Date item was accessioned. Often this is the same as the received date. Sometimes the item is accessioned by a Cataloguing agency or State Library and the item then sent to the library. In this case Accessioned and Received dates could be different. Format is **DD/MM/YYYY** – for example: **07/10/2012**. No need to type the / symbol.

**Current Cost:** The item current cost. Original cost is kept in *Stockitem>Item> History*. Do not enter $ symbol
**Library Group:** Associated with Login Location – determines privileges within Group security if used by the Library. For example, if Multi Campus School able to apply security to View, Update, Insert, Delete, Batch, Attach, Hold, Loan, Check-in and/or Transfer

**ILL Library:** If the item is an Inter Library Loan enter the code. These codes are set up in Main>Stockitem>Application>StockExternalLibs

**ILL Ren:** Enter Y or N if the Inter Library Loan item is allowed renewal

**ILL Due:** Enter the date when the Inter Library Loan item is due back at its home Library

**ITEM TYPE:** This defaults to N - Can be N for Normal, M for Master or S for Subsidiary. See separate section on Master and Subsidiary items

**Memos:** Displays the Number of Memos applied to the item

**On Loan:** If On Loan it will display as Y with the Borrower’s name also inserted

| On Loan | SMITH, SARAH | Due   | 23/08/2011 11:59 PM |

**Due:** If On Loan it will display as the date and time due

**On Order:** If the item is On Order it will display as a Y

**Res:** Displays the No of Reserves for the item

**Last modified:** Displays the date was last changed

**By:** Displays the Operator who last changed the item

**Set:** The total Number of results for this set within the search – restricted by the search size. See separated section

**Seq:** The sequence of the item in the Table of search results for the search – for example – the item may be 7th in the set of 24

**? Size:** The Search size that is currently used to restrict the search number found as a result. See separate section on Search Size

**Issues:** The Number of times issued. This is also found in the Stockitem > Item > History : Times Issued
STOCKITEM MENUS

1. Launch the Amlib client
2. Go to Main > StockItems
3. There are 5 Menus within Stockitem:
   - **Main** – giving you access to all the other modules
   - **Application** – the majority of the codes/settings used within the Stockitem module are set up here (for example: Stockitem Form Codes and Stockitem Process Codes)
   - **Item** – which contains additional Stockitem-related functionality (for example: Reserve Item, History and Memos)
   - **XReferences** – links to other modules and associated functionality
   - **File** – access to Saved Files and associated functionality

**Application Menu**

Set up/check your codes, descriptions and labelling for the relevant groups in the Stockitem module **Application** menu. These can be classified specifically by the site but generally:

**Codes are maintained including:**

- **Stockitem Forms** – Creating and maintaining codes for GMD or formats – used for circulating and sets the Display and Validations
- **Stockitem Origins** - creating and maintaining codes for the Source/Origins
- **Stockitem Stats** – creating and maintaining codes for Collections - used for gathering Statistics
- **StockCallSets** – creating and maintaining codes for Call sets
- **StockExternalLibs** - creating and maintaining codes for Inter Library Loan Libraries
- **Stock Loan Types** - creating and maintaining codes for special Loan Types
- **Stock Loc Floor** - creating and maintaining codes for specific Locations within the Main Permanent Location

**StockLocations** – viewing the parameters set for the Locations used for Stockitems. The creating and maintaining of the codes is done in **Main>Supervisor>Locations**

Other Application Menu items are used for maintaining Stockitems:

- **Stockitem AutoLink** - See separate section under Maintenance
- **StockKeyword** – See separate section under Searching
- **StockLoanTypes** – See separate section
- **StockTakes** – See separate section
StockWandChange – see separate section under Maintenance

Where – see separate section under Searching

Item Menu

Reserve Item

When this menu option is selected, a Location List will display for the selection of the Collection Location. The highlighted location is the Login Location.

The Borrower will need to be identified e.g. The Borrower Barcode wanded into the Bar Code field or a search can use Surname, Given name etc.

Once the Borrower is identified, the Reservation screen will load. All items linked to the same Catalogue will display. A message will display to confirm the reservation (e.g. multiple copies or the same Catalogue item).
Proceed with Reserve? Y/N

**Note:** All items attached to the Catalogue record will be reserved as a first returned reservation using this method

**Average Cost Item**

Enables the Average Cost based on the StatsGroup Average Price to be entered. For example the Average Cost of a Hardback Non Fiction item for 2012 may be $24.95. This is the cost inserted after confirmation.

To check the Average Price table, see Stockitem/Application/StockStatsGroup. The relevant Stats code can be given a relevant StockStatsGroup code.

**Create Catalogue**

If a Catalogue does not exist for the item, this menu option creates a Catalogue for the Stockitem. It will insert the data from the Stockitem screen to the Catalogue record for Title, Author and Call Number (if these lines are complete in the Stockitem record). A Catalogue Number will display on the Stockitem screen in the Amlib Cat field and a confirmation message will display. Only the Title, Author and Call No will be merged into the Catalogue if they are present in the Stockitem.

Note: It is advisable to create the Catalogue first and then create a Stockitem to ensure a full Catalogue entry with Subjects and Notes is created.
Current Bookings
Displays any bookings if appropriate

Current Reserves
 Displays the Reservations placed on the current item. Reserves can be cancelled or Collect Location changed. The Queue position can also be altered if required.

**Cancel**: Highlight the borrower to be cancelled and select **F4 Cancel**. Reselecting F4 Cancel until F3 Save is selected can reverse the cancellation. This will create an entry in Stockitem/History - History Type of Res.Hist and Comments Cancelled by Stk App on YYYYMMDD Operator.

All/First: To check whether the Reservation has been placed against the First available copy (using the Any option when reserving an item) or A for All copies (using the Every option when reserving an item)

Depreciate Item
The current item will be depreciated according to the item’s Form, Stats code and last depreciation date.

As the item is depreciated, the system considers:

- Method of Depreciation e.g. Straight Line or Reduced Balance
- The Stats Group code which has the Percentage Rate, Minimum price restrictions
- Last Depreciation date (items depreciated in the last 12 months will not be included or new items accessioned in the current year will not be subject to Depreciation)
- Rounding formulas as set in Stockitem, Application, StockOrigins for the particular Source.

A message will display, confirming the Depreciation price.
Once the Depreciation is confirmed, the History of the Item is Updated, and a Depreciation Date is entered.

Items can be depreciated en masse from Stockitem> Application > StockStatsGroup

**Get Price from Cat**

Enables the Item Cost to be entered from a Marc tag subfield as defined in the Import Items table within the Authorities > Application > MarcItemDefs

<table>
<thead>
<tr>
<th>Location</th>
<th>Price</th>
<th>Process</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>020</td>
<td>0</td>
</tr>
</tbody>
</table>

When the *GetPriceFromCat* is selected a pop-up alert will alert the user of the change.

**History**

History data kept for each Stockitem includes a Summary of History at the top of the Window which includes:

<table>
<thead>
<tr>
<th>Stockitem Circulation History</th>
</tr>
</thead>
<tbody>
<tr>
<td>Times Issued: 18</td>
</tr>
<tr>
<td>31111017623390</td>
</tr>
</tbody>
</table>

**Times Issued**: The number of times the item has been issued since System inception or Current Period if the AutoLink has been run to set a new period

**Times Reserved**: The number of times the item has been reserved since System inception or Current Period if the AutoLink has been run to set a new period

**Times Renewed**: The number of times the item has been renewed since System inception or Current Period if the AutoLink has been run to set a new period

**Previous Period**:

**Times Issued**: The number of times the item has been issued prior to setting a new period by running the AutoLink
**Times Reserved:** The number of times the item has been reserved prior to setting a new period by running the AutoLink

**Times Renewed:** The number of times the item has been renewed prior to setting a new period by running the AutoLink

**StockTake:** Date the item has been counted for a Stocktake. This can include it being manually counted during an Online or Offline Stocktake or issued or returned during a Stocktake

**Last depreciation:** Date the item was last Depreciated either through a global Depreciation or by Depreciating an individual Stockitem, from Stockitem, Item, Depreciate Item

**Last Activity:** Date the item was last active in Circulation activity where the item is physically entered – This is triggered if an Item is active in Issues, Returns or used in In-house Circulation (Process In-house). It does not trigger if reserved, transferred or counted in Stocktake (Stocktake flag is used instead)

**Original Cost:** The cost of the Item when entered on the Database. This is used in Depreciation, Straight Line calculations. The Original Cost can be altered by clicking the Change Cost Button. The current cost of the item is shown on the main Stockitem screen.

The Circulation Activity window displays the current loan status and current Reserves of the item and previous circulation events. The Issue Comments give details of the Location, User, Borrower and Due Date and Time. The Return Comments give details of the Location and Date and Time of Return. The Last Activity indicates Date and Time of the last Issue or Return.

It also shows a history of Price alterations made during Depreciation (global and individual) and by using the Change Cost button for Original Cost. It will also record a change of cost made manually to the Current Cost on the Stockitem window.

**ILLS [Inter Library Loans]**

The Stockitem > Application > StockExternalRefs table needs to be created prior to creating the first ILL record. This Table is referenced when creating ILLs. It is possible to connect to the ILLs Facility (VDX Virtual Directory Exchange – separate Notes available on setting this up).
Note: Many sites prefer the Author and Title information in Capital letters to distinguish the ILLs items from the host library's catalogue. There is an UPPER button in the ILL Window to allow the formation of an ILL record with Capitals.

**ItemCreateDefaults**

These are the Defaults that will be inserted into the Stockitem when the ILL record is created. These can be altered at anytime and the Defaults saved using Update Defaults [F6].

- Form: The Form code that will be entered into Stockitem for ILLs
- Stats: The Stats code that will be entered into Stockitem for ILLs
- Source: The Source code that will be entered into Stockitem for ILLs
- Loan Type: The Loan Type code that will be entered into Stockitem for ILLs. The Loan Type will override normal Loan periods set for the Form
- Opac?: Show in Opac? Y/N
- Alert?: Alert Operator? Y/N Usually links to the Process. If the ILL fields are filled in at the bottom of the Stockitem screen (ILL Library, ILL Renew, ILL Due) an alert will be displayed on the screen. If the Alert? Field is set to Y, two alerts will be shown
- Perm Locn: If ticked the Supplying Library will display in the Permanent Location Field on the Stockitem
- Temp Locn: If ticked the Supplying Library will display in the Temporary Location Field on the Stockitem
- Patron Reqd: If set to Y, the Borrower field must be entered before the ILL is Inserted. If set to N, the Borrower field is optional. A reserve is automatically placed for a Borrower if entered in the Borrower Field
On receipt of the item

Change the temporary barcode to match the barcode of the item. Add the date received (this may not be automatically populated – depends on the Validations set up for the Form code used in Stockitem).

Fill in the ILL Library, ILL Ren (Y/N) and ILL Due if required at the base of the Stockitem screen. This will ensure a message will display in relation to the Inter Loan Library when the item is Returned through Amlib Circulation.

When the item is updated, a message will be displayed about its reservation a borrower barcode has been entered on the ILLS screen.

On return of the item

Press **F4 Delete** in the Stockitem to delete the item from the database. This deletes the corresponding ILLs record.

**Memos**

Memos may be attached to a Stockitem from the Stockitem screen or from Issues. Memos can be set to display whenever the Stockitem is activated within the system. Any number of memos may be attached to a Stockitem.

**Note:** To assist in creating Memos, it is suggested that the Memo Types table be checked and completed in Supervisor>LibraryMenu>Memo Types. Memos can be categorised for enquiry, reporting and to save time when creating a memo e.g. to search for a list of items with a Memo type of damaged

**New Memo**

1. Select **F1 New**
2. Defaults for Show, Date (of Activation) and EndDate (Expiry date) are entered automatically but can be adjusted if desired. When the EndDate is reached the system will automatically delete the memo. The Memo ‘life’ in days depends on the Memo Type or the default as set in Supervisor/LibraryMenu/Intallation/Stockitem/Delete a Stockitem Memo when it is ### days old
3. Enter a **Memo Type** (Optional) Enter .<TAB> for a list of defined Memo Types
4. Enter the **text** for the memo if required (as using a Memo type will automatically add text
5. Select **F3 Save**
Memos can be created to give details of various parts of the kit, that can be checked when the kit is returned.

Select All Groups

When Group Restrictions are applied in Supervisor/Installation, the log on location and Library Group Permits determine the search results. The groups to search over can also be specified using select all groups. Before or after entering a search term, go to Item menu and Select all groups. The groups to choose from will be those you have permission to access in group permits. Use OK to accept all groups. When queried the search will find items from those groups.

Select Query Group(s)

When Group Restrictions are applied in Supervisor/Installation, the log on location and Library Group Permits determine the search results. Before or after entering a search term, go to Item menu and Select query groups. The groups to choose from will be those you have permission to access in Group Permits. Select a group to search and OK. When queried the search will find items from that group only.

Select My Group

When Group Restrictions are applied in Supervisor/Installation, the log on location and Library Group Permits determine the search results. Before or after entering a search term, go to Item menu and Select my group. The group you are logged in as will appear as the group to search. When queried the search will find items from that group only.

New Item

A new Stockitem can be generated from the Stockitem Application. New Stockitems can also be generated from the Catalogue application (e.g. after manually creating a catalogue entry), which then transfers the user to the Stockitem Application. They can also be generated automatically from a Marc download.

**WARNING:** Stockitems created without a Catalogue Reference will have no Keywords created because Keyword codes are associated with Marc Tags
The compulsory fields to enter are dependent on the validation rules for Stockitem Forms. Note that the dates for Accession and Received will automatically generated as a current date only if these fields are mandatory fields in Stockitem Forms validation rules.

If the Stockitem were to have a Catalogue attached, it would be advisable to create the Catalogue first and then the Stockitem. This eliminates the need to Refresh the item from the Catalogue and it automatically enters the Catalogue display in the Stockitem when the Catalogue is saved.

Only when all fields are valid and complete will the system insert the new Stockitem.

**RefreshFromCat**

Updates the data shown in lines 1 to 6 from the associated catalogue record. The data is a summary of the Bibliographic data from the Catalogue screen. Line displays are set in Stockitem>Application, Form> Display. If changes are made within the Catalogue screen that are to be included on the Stockitem screen, use Refresh from Catalogue from the Item menu.

**RefreshFromCatConfirm**

Updates the Stockitem data stored in Lines 1 to 6 to that of the associated catalogue data. At each line number a confirmation is required so that it is possible to reject a refresh for a particular line.

**ReserveAllocate**

Used to add reservations to copies where other items sharing that same Catalogue Reference have reservations. For example, if an item added to the Database shares a Catalogue with other copies that have reservations.

1. Add items in the usual way.
2. If the other items with the same Catalogue records have Reservations, a message will display.
3. Go to Item Menu>ReserveAllocate.
4. A ReAllocate Stockitem Reservation screen is displayed.
5. **Highlight** the items in the Table that you wish to add to the new item and select **F2 Add To**.
6. This will add all the highlighted reserves from the existing item/s to the new item.
7. Select **F3 Save**.
8. To trigger the reservation, the new item can be placed through Returns.

**Saved Where Searches**

The Saved Where Searches option gives you a list of previously created Where searches that have been saved. The current Operator displays in the Operator field and it is possible to find other Operators from the drop down box.

From this Window, it is possible to count or to execute which runs the Query

**QuerySettings**

<table>
<thead>
<tr>
<th>Continue Query</th>
<th>KeepQueryVia</th>
<th>KeyWordOrAnd</th>
<th>KeyWordAndOr</th>
</tr>
</thead>
<tbody>
<tr>
<td>KeyWordAndAnd</td>
<td>NoSortQuery</td>
<td>RestartQuery</td>
<td>SetSearchSize</td>
</tr>
</tbody>
</table>

**Continue Query**

Continue Query [F11] is used when you want to see the next set of results of a Query. This set is determined by the SetSearchSize option.
The Continue Query option can only become active if the parameter set in Supervisor, Application, Installation, System, “Read Only Cache” option is set to No

KeepQueryVia

Keeps the last Query Via option for subsequent queries.

Keyword Search Parameters

Defaults can be changed for Boolean Operands for searching on the same lines and those on different lines. For example to find words within a line with AND searches and words on different lines are OR searches - click on the Item drop down menu, select Query Settings and select KeywordAndOr.

KeywordOrAnd Title: MONEY SIMPLE Subject: FINANCE

will produce a list of items which has either money OR simple in the title AND finance as a subject heading

KeywordAndOr Title: MONEY SIMPLE Subject: FINANCE

will produce a list of items which have money AND simple in the title OR finance as a subject heading

KeywordAndAnd Title MONEY SIMPLE Subject: FINANCE

will produce a list of items which have money AND simple in the title AND finance as a subject heading

NoSort Query

Executes the Query without sort criteria.

Because there is no sort option, the report is tabled much faster than a table that has to be sorted

Restart Query

Restart Query is used when you want to restart the current query, to check the beginning of the tabled results.

SetSearchSize

- The results of the Table from a search will display in a set (for example: 250 items) and the next set can be viewed by selecting the F11 button or Table > ContinueQuery
- The set size can be altered if required – for example: from 250 items to 1000 items
- The default settings can be changed in the Main > Supervisor > Installation – System tab Default search cache size setting
Set the Search Size

1. From the Stockitem menu, select Item > Query Settings > SetSearchSize, from the Borrower Details menu, select Borrower > SetSearchSize or from the Catalog menu, select Catalogue > SetSearchSize

2. The Set Results Search Size screen will display:

3. Select a search size from the list
CREATING AN ITEM AFTER MANUAL CATALOGUING

It is a good idea to search for a Catalogue to see if the item has been entered already, and just needs an Item attached. Searching for an Item can be done in Catalogue using the ISBN or in Stockitem (for example: Author or Title Search). The ISBN can even be wanded if the Barcode reader has been ISBN enabled.

It is preferable to create a catalogue first and then create the holding record (Stockitem). If the Stockitem is processed first, not all the Tags are made when the Catalogue is created from the Item menu. For example: Subject Headings are not transferred across.

Keywords are created through association with MARC tags – for example: a Subject keyword would apply to all tags defined from 600 through to 699: e.g. **Topical term (650)**, **Personal name (600)**, **Geographic (651)** etc. Therefore when creating your entry, it is important to have a Catalogue record as well as a Stockitem because keyword searching will be important.

There are three manual entry methods available:

1. **Work Sheet Method**

   After choosing a template related to the form of the data (for example: fiction/non-fiction etc.) the required fields can be filled in. Authority listings can be accessed when appropriate (for example: for standard entry of Authors, Subjects, Publishers etc).
2. **Editing existing records**

   It is possible to duplicate an existing record and alter the relevant data.

3. **New record from scratch**

   No Lead Through method. Tags can be inserted and built up to create a full record.

**Please Note:** Before beginning to use the Worksheet manual entry, you need to check the tags that will be automatically displayed. This is done in **Main > Catalogue > CatLeadThruSets**.

**Work Sheet Method**

1. Launch the *Amlib* client

2. Go to **Main > Catalogue > Catalogue** (or the icon) – the **Catalog** screen will display:

![Catalogue Screen](image)

3. From the menu, select **Catalogue > Catalog Create** – the **Select Template** prompt will display:

![Select Template](image)

4. Click on the button for an appropriate Lead Thru set – for example: **Fiction** – the **Work Sheet** will open with a number of preset MARC tags already displayed:
5. An item’s bibliographic details can now be entered – as you move through the Work Sheet, the headings (descriptors) change, so it is possible to observe the type of data required in the subfield of the tag.

6. Where the data is Authority based (for example: Author, Subject Heading, Series, etc.) a listing of Authorities can be viewed and selected – for example: to search for a particular Author, type the first few letters of the surname, highlight the row and double-click the row or press the F1 Check button.

7. The Existing Authority Options screen will open displaying all matching Authorities and the number of Catalogue records which use each Authority:
8. To select an Authority in the table, simply double-click on it: the contents of the tag being checked will then change to match the selected Authority (the text will also change colour from black to green)

9. Once selected (or if there is no matching Authority), click on the red [X] to close the selection table (if there were no Authorities found the contents of the tag being checked will turn red, if there were Authorities found but none were selected the contents will turn pink)
10. To enter additional tags, click the **F2 Insert** button – the **Select For Creation** table will open (the preset tags allow for up to 40 entries):

![Select For Creation Table](image)

11. Find the required tag and double-click it to select it – a new entry with the selected **Tag No** will appear in the **Work Sheet**

12. When the record is complete, click the **F3 Save** button

13. If new Authorities are to be created, a prompt with the following message will display: **Some new Authorities will be created. Continue with Save?** (the new Authorities will be highlighted in **red**, so you can check them)
14. Click the Yes button – the Created Catalogue – Select Next Action prompt will display:

![Created Catalogue - Select Next Action](image)

15. If you intend to create your holdings immediately, then highlight the Create a Stockitem and click the OK button (alternatively you can select the Display the created Catalogue if you wish to review the actual Catalogue record)

Adding Stockitems

This section continues from the section above. If you don’t immediately choose to create a stockitem record, you can select XReferences > StockItems from the Catalog menu to initiate the process.

1. A prompt with the following message will display: No Stockitems exist for the Catalogue. Do you wish to create a new Item?

![Stockitem](image)

2. Click on the Yes button – a New Stockitem prompt will display with the following message: Please choose a Form Type for the new Stockitem

![New Stockitem](image)
3. Choose the appropriate Form type and click on the OK button – the Stockitem main screen will enter creation mode (the F2 Insert button will appear bolded) and a number of fields will be pre-populated:

![Stockitem Main Screen]

4. Complete the other fields as required – for example: Stats Code, Current Cost, Floor location, etc – to access a list of codes in a field press <Tab>

   For example: in the Stats Code field, pressing <Tab> will display a list of your Stats Codes and Descriptions – double-click on an entry to select it:

   ![Select Code Window]
5. Scan in barcode in the Item No field (if you wish to create a system-generated barcode, leave this field blank)

6. Click on the F2 Insert button when complete – a prompt with the following message will display: The Item has been Inserted.

![Stockitem](image)

7. Click the OK button

### Multiple Copies

To enter multiple copies of the same catalogue item:

1. Scan in a new barcode into the Item No field – the F2 Insert button will once again become active *(bolded)*

2. Change any other details as required – for example: Stats Code, Copy No and Floor location

3. Click the F2 Insert button when complete
IMPORTING NEW ITEMS

Most sites download their Catalogue data (from places like SLWA and SCIS). *Amlib* stores the data in **USMARC** format, which is now the international standard. This is made up of hundreds of **MARC Tags**, which identify data. In the same way that Dewey numbers become familiar, common tags become known.

<table>
<thead>
<tr>
<th>SOME COMMON TAGS</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>020</td>
<td>ISBN</td>
</tr>
<tr>
<td>082</td>
<td>Dewey classification number</td>
</tr>
<tr>
<td>100</td>
<td>Personal name main entry (usually author)</td>
</tr>
<tr>
<td>245</td>
<td>Main title</td>
</tr>
<tr>
<td>260</td>
<td>Publication information</td>
</tr>
<tr>
<td>300</td>
<td>Physical description</td>
</tr>
<tr>
<td>440</td>
<td>Series</td>
</tr>
<tr>
<td>500</td>
<td>General notes</td>
</tr>
<tr>
<td>520</td>
<td>Summary</td>
</tr>
<tr>
<td>650</td>
<td>Subject headings (Topical)</td>
</tr>
<tr>
<td>700</td>
<td>Personal name (Added entry)</td>
</tr>
<tr>
<td>856</td>
<td>Electronic location and access (URL)</td>
</tr>
</tbody>
</table>

Import MARC Catalogue Data

There are generally four main stages in the download process.

- **DATA** Downloaded from SCIS or sent from elsewhere
- **HOLDING FILE** Loads the data to the Screen for checking
- **UPDATE** \([F3]\) begins the updating process after setting the defaults
- **NEW RECORDS** Check the new data
  - Stockitems: adding barcodes, supplier, checking location etc. to items in file
  - Catalogues
  - Authorities
STOCKITEM FORM AND STATS CAT DEFINITIONS

It is worthwhile checking the Form and Stats Cat definitions. By setting Cat Definitions for Forms and Stockitem codes, the correct Stats and Form codes are given to items as they are created. The Default codes do not need Cat Definitions as they will automatically be inserted unless an alternative rule applies.

Form Codes

1. Go to Main > StockItems > StockitemForms – the Form Codes screen will display:

2. From the menu, select Window > CatDefs – the Form Codes for Catalogues screen will display:

3. Select a Tag, type in the Must Contain and/or Must Not text and click the Paste button

4. Click F3 Save when complete
Stats Codes

1. Go to Main > StockItems > StockitemStatsCodes – the Stats Codes screen will display:

![Stats Codes Screen](image1)

2. Highlight the Stats Code and click the F8 Cat Defs button – the Stats Codes for Catalogues screen will display:

![Stats Codes for Catalogues](image2)

"**NOTE:** You can use these parameters for another form code by entering the new form code here.

3. Select a Tag, select Numbers or Tags definitions, type in the Must Start With and/or Must Not Start With text and click the Paste button.

![Tag Selection](image3)
4. Click **F3 Save** when complete

A setup for Schools might be:

<table>
<thead>
<tr>
<th>NF</th>
<th>DEFAULT as set up in <strong>Supervisor</strong> &gt; <strong>Installation</strong> &gt; <strong>Stockitem</strong> tab or set in Marc Take up</th>
</tr>
</thead>
<tbody>
<tr>
<td>F</td>
<td>Tag 82 must not contain numbers.</td>
</tr>
</tbody>
</table>

A setup for Public Libraries might be:

<table>
<thead>
<tr>
<th>ANF</th>
<th>DEFAULT as set up in <strong>Supervisor</strong> &gt; <strong>Installation</strong> &gt; <strong>Stockitem</strong> tab or set in Marc Take up</th>
</tr>
</thead>
</table>
| AF | Tag 99 must not contain numbers.  
     Must contain F but not contain J before the first space. |
| JK | Tag 99                                                                                           
     Must contain JK before the first space |
| JNF| Tag 99 must contain numbers  
    Must contain J but not contain JK before the first space.  |
| JF | Tag 99 must not contain numbers  
    Must contain J but not contain JK before the first space.          |

**Accessing the Data for the Download**

1. Launch the *Amlib* client
2. Go to **Main** > **Authorities** > **MarcTakeUp** (alternatively use **Ctrl + M**) – the **Marc Import** screen will display:

   ![Marc Import Screen](image)

3. Click the **F1 Open** button to display the **Open** dialogue box
4. Locate the file to be processed by using the **Look in**: drop-down box – for example: if the file is on the C: drive, the **Look in**: box may say **Local Disk (C:)**
5. Once the file name has been located, use your mouse to select it and click on the **Open** button

*There are two processing options: Bibliographic Data or Authority Data – this guide covers the import of Bibliographic Data.*

**Bibliographic Data**
This option is to load records which are Bibliographic Data in machine readable format which can be imported into Catalogue, Authority and Stockitem (where appropriate) applications of Amlib.

1. The Marc Import – Open screen will display:

   ![Marc Import - Open Screen]

   **Please Note:** If the Import file (Bibliographic or Authority) contains more than 9999 records, it is recommended that Open and Update is selected (ticked) so that all records can be loaded into the database. This eliminates the need to load in sections. The maximum records that can be viewed in the Holding file is 9999 records.

2. Complete the options using the above table:

   a. **Marc Options** = Bibliographic Data
   
   b. **Open and Update** = ticked, unless you want to review each individual MARC record
   
   c. **Load Range** = All (unless the file sizes are quite large)

3. Click on the **OK** button

**Bibliographic Options**

1. The Bibliographic Options screen will display:
2. If the Marc Details are set to import Full Catalogue & Stockitem data, the Item Default and Item Prices sections will also display: Click the OK button once you have completed modifying your settings

**Please Note:** Form and Stats Code defaults from the Main > Supervisor > Installation > Stockitem tab display automatically in the fields. If there are no defaults entered, the field will be blank. Location displays as the Login Location. Entry of these fields is optional. As the import of data is processed, the Stockitems will be given the default values if there are no catalogue definitions for the Form or Stats codes of the items. Form and Stats Code Cat definitions are found in Main > StockItems > StockitemForms or StockitemStatsCodes table for the particular code.

**Reviewing Records to be Imported (Optional)**

It is possible for the importer to review (and edit) the MARC data being imported.

1. If the importer has decided to review the records being imported (see Bibliographic Data step above), the Marc Import screen will display:
2. If you do wish to edit the data (prior to import), use the editing buttons on the right to change or delete the individual tags

   **Please Note:** Editing of the data prior to import is not essential. Changes can be made after the data has been imported into the Catalogue. Remember that not all the tags will necessarily be Imported, so if editing is considered necessary, change only the tags you know will be imported!

3. Use the F7, F8, F9 and F10 buttons to move between records

4. Once the data has been reviewed, click the F3 Update button

**Find**

It is possible to use the find function to locate any matching text, tag number or specific Subfield in the Holding File data being displayed. For example: use this facility to check all Author entries or Subject headings.

1. Type in the Tag, Subfield or String to find and click the Find Next button

2. It will then find any matching data in the record currently being displayed:
Catalogue Update Options

1. The Update Options screen will then display, allowing you to select the Cat(atalogue) and (Stock) Item Options:

   - **Cat Options**: When an incoming Catalogue is match with an existing Catalogue
   - **Item Options**: When an existing Catalogue is replaced all existing items

2. Enter the options you would like, then click the OK button – the Saved Files screen will display:
3. Type the names of the files into which all the newly created Catalogues, Authorities and/or Stockitems will be saved (if you do not want to check new items – for example: Authorities, do not enter a filename)

4. Click the OK button

**HINT:** These files assist in finding the newly created Catalogues, Authorities and/or Stockitems after the import. The Filenames are created so that you can identify the file later. A suggested Filename could be the type of data – for example: SCIS or EXCHANGE, the date and the initials of the staff member processing the data.

5. If confirmation of duplicate items has been requested in the parameters, a Catalogue Match screen will display every time a duplicate item is found:

6. **Are the above two records the same?** Click the Yes, No or Replace button

<table>
<thead>
<tr>
<th>OPTION</th>
<th>EXPLANATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yes</td>
<td>The catalogue entry that exists on the database will remain as displayed in the top box. A new Stockitem would need to be added if appropriate. The imported record will not be included in the New File created for Catalogue or Authorities</td>
</tr>
<tr>
<td>No</td>
<td>A new catalogue will be created with the data from the Imported data being used for the new catalogue record. The imported record will be included in the New File created for Catalogues or Authorities</td>
</tr>
<tr>
<td>---</td>
<td>---</td>
</tr>
<tr>
<td>Replace</td>
<td>The existing catalogue entry will remain but the data will be replaced with the data from the imported recorded. The imported record will not be included in the New File created for Catalogue but there may be some additions to the Authorities file</td>
</tr>
</tbody>
</table>

7. An **Update** prompt will display, indicating the progress of the import:

![Update Progress](image)

8. When the update is finished an **Update** prompt will display, showing the number of records Updated:

![Update Completed](image)

9. Click the **OK** button

10. You will be able to view the log by selecting the **F6 Log** button

**F6 Marc Log**

This log lists any errors that were experienced in the process of importing the file and also what action was taken with certain items. Most of the errors that display in the log are caused by the tag numbers not being defined on the Amlib database. This may be because we did not wish to use them in the Catalogue data but were present in the data file.

**Checking New Stockitems**

1. Launch the *Amlib* client
2. Go to **Main > StockItems > Stockitem** – the **Stockitem** screen will display
3. From the menu, select **File > DisplayFile** – the **Stockitem Saved Query Results** screen will display:
Highlight the file you wish to access and click the F9 Select button – a Stockitem List of the imported items will display:

4. You can now check to ensure that the item details are correct
5. Double-click the first entry – the selected item will display in the Stockitem screen
6. Add the correct Item No (barcode), Current Cost, Sts Code, Form code, Origin/Source (if required) and generally check other details

7. To access a list of codes in a field press <Tab>
For example: in the Stats Code field, pressing -<TAB>- will display a list of your Stats Codes and Descriptions – double-click on a entry to select it.

8. Click on the F3 Update button when complete – a prompt with the following message will display: The Item has been Updated.

9. Click on the OK button

**ADD A NEW ITEM WITHOUT A CATALOGUE**

It is sometimes necessary to create a Stockitem record that is not attached to a catalogue record – for example: a piece of equipment. **Note**: These items will **NOT** be keyword searchable.

1. Launch the Amlib client

2. Go to Main > StockItems > Stockitem – the Stockitem screen will display

3. From the menu, select Item > NewItem – the New Stockitem table will display, prompting you to choose a Form Type for the new Stockitem:

4. Select the Form Type (for example: EQ – Equipment) and click the OK button – the Stockitem screen will enter creation mode (with Form code selected):
5. Add the required details

6. Click the **F2 Insert** button when complete

7. If you haven’t wanded in a barcode, a prompt will display requesting if you would like to insert a system-generated Barcode:
8. Click the Yes button – a prompt will display with the following message: **The Item has been Inserted.**

9. Click the OK button

The Stockitem has been created.

**ADD EXTRA COPIES FOR THE SAME CATALOGUE RECORD**

To enter extra copies of the same catalogue record:

4. Launch the *Amlib* client

5. Go to **Main > StockItems > Stockitem** – the Stockitem screen will display

6. Search for the original item to copy using **F5 Query**

7. Scan in a new barcode into the **Item No** field – the **F2 Insert** button will become active (bolded)

8. Change any other details as required – for example: **Stats Code, Copy No** and **Floor** location

10. Click the **F2 Insert** button when complete – a prompt will display with the following message: **The Item has been Inserted.**

11. Click the **OK** button

The extra stockitem has been created.
CREATING & MAINTAINING STOCK PROCESSES

This table allows you to identify various Stockitem processes e.g. WITHDRAWN, IN PROCESS, MISSING, LOST etc. This field is optional. If the table is not defined, the field will not appear in the Stockitem window.

1. Launch the Amlib client
2. Open the Stockitem module
3. Select > Application > StockProcess – the StockProcess screen will open
4. Click the F1 New button – enter a description of the Process code and set the parameters (see table below) and then click the F3 Save button.

<table>
<thead>
<tr>
<th>Process</th>
<th>Show in Opac (Y/N)</th>
<th>Operator Alert (Y/N)</th>
<th>For Loan (Y/N)</th>
<th>Remove on Return (Y/N)</th>
</tr>
</thead>
<tbody>
<tr>
<td>A/C PAID</td>
<td>N</td>
<td>Y</td>
<td>Y</td>
<td>N</td>
</tr>
<tr>
<td>DAMAGED</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>P</td>
</tr>
<tr>
<td>DAMAGED SENT AS LBD</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>P</td>
</tr>
<tr>
<td>DISPLAY</td>
<td>Y</td>
<td>Y</td>
<td>Y</td>
<td>P</td>
</tr>
<tr>
<td>ILL SENT BACK</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>P</td>
</tr>
<tr>
<td>IN PROCESS</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>Y</td>
</tr>
<tr>
<td>LOST</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>Y</td>
</tr>
<tr>
<td>LOST AND PAID FOR</td>
<td>N</td>
<td>Y</td>
<td>N</td>
<td>N</td>
</tr>
<tr>
<td>MISSING</td>
<td>N</td>
<td>Y</td>
<td>Y</td>
<td>P</td>
</tr>
<tr>
<td>MISSING 2011 STRK</td>
<td>N</td>
<td>Y</td>
<td>Y</td>
<td>P</td>
</tr>
</tbody>
</table>

Checking to see if NR ACCOUNT is still in use...
<table>
<thead>
<tr>
<th><strong>Process</strong></th>
<th><strong>Description of Process that will display in the Stockitem screen</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Show in Opac (Y, N)</strong></td>
<td>The Stockitem with this particular process will/will not appear in Opac</td>
</tr>
<tr>
<td><strong>Operator Alert (Y, N)</strong></td>
<td>If a Stockitem number is identified (e.g. by Barcode) the operator will/will not be alerted that the item has a particular Process e.g. Missing</td>
</tr>
<tr>
<td><strong>For Loan (Y,N)</strong></td>
<td>The Stockitem with this particular process will/will not be available for Loan</td>
</tr>
<tr>
<td><strong>Remove on Return (Y,N,Prompt)</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Y</strong></td>
<td>Process code will be removed from the Stockitem</td>
</tr>
<tr>
<td><strong>N</strong></td>
<td>Process code will <strong>NOT</strong> be removed from the Stockitem and will remain unchanged</td>
</tr>
<tr>
<td><strong>P</strong></td>
<td>A message will display with the option to remove the Process from the Stockitem</td>
</tr>
</tbody>
</table>

Within the Stockitem Window, there is a date field associated with the Process code. This is useful when checking or reporting items. When a Process is added, a message will display confirming the Default Fields to be altered.
Pressing Yes or <ENTER> will result in the Fields above automatically updated and the current Date will automatically be populated in the Field next to the Process. These changes will not be saved until the Update [F3] button is selected.

When the Process is removed and Updated [F3], the For Loan > Opac? And Alert Fields can be automatically updated (revert back to the Stockitem Default) and the Process Date is removed.

If a process code is set to display an alert on return a prompt message allows you to remove the process code. This will happen in either Returns or Chute Returns, depending on the options set for the Process Field. If you choose NO the Process code and date will remain on the Stockitem record.

If you choose YES the process code and date fields will be deleted automatically from Stockitem.

**MOVEMENT OF TAGS TO DISPLAY A SUBJECT IN STOCKITEM**

1. Access the Catalogue record in Catalogue
2. Search for the Title or ISBN
3. Highlight the Tag to move and use the arrow keys to move the Tags up or down – the one first will be the one that is displayed in the Stockitem

Please Note: This sequencing possible within the record depends on what is set in the Main > Supervisor > Installation - Catalogue tab: Allow tags to be sequenced anywhere within a catalogue (Y/N) parameter.

- If it is left at the default Y, staff will be able to use the up and down arrows on the Catalogue record to reposition any MARC Tag within that record.
- If it is changed to N, this will then restrict the ability for adjusting the sequence of a MARC tag in a specific record to its specific range only. This means that if there is only one MARC tag to that record it cannot be moved, but if there is more than one MARC tag, for example subject headings, then these can be moved within this group only.
SEARCHING WITHIN STOCKITEM

- Most White fields of the Stockitem screen are searchable. Cat Ref No is also Searchable
- Use the Query Via options to determine the type of search to be performed

<table>
<thead>
<tr>
<th>OPTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item</td>
<td><em>Browse</em> (phrase) search for data displayed within the Stockitem module</td>
</tr>
<tr>
<td>Cat</td>
<td><em>Browse</em> (phrase) search for data displayed within the Catalogue module</td>
</tr>
<tr>
<td>Keyword</td>
<td><em>Keyword</em> search one of the six bibliographic lines within the Stockitem screen (Title, Author, Subject, Publisher, Series or Call No) – for example: typing a keyword into the Subject line will perform a keyword search on just the Subject fields</td>
</tr>
<tr>
<td>Any</td>
<td><em>Keyword</em> search any of the six bibliographic lines within the Stockitem screen (Title, Author, Subject, Publisher, Series or Call No) – for example: even if the keyword is typed into the Title line, all six fields (Title, Author, Subject, etc) will be searched</td>
</tr>
<tr>
<td>Previous Queries</td>
<td>The last 5 searches are kept in case they need to be re-performed. Use the -1 to -5 buttons to select a previous search</td>
</tr>
</tbody>
</table>

Keyword Search

1. Ensure the Query Via option selected is *Keyword*
2. Type in a word (for example: sport) in the Subject field and click the F5 Query button – a Stockitem List table will display with all the items that include sport as part of the subject – for example: Sport, Sports medicine, Sport - Australia, etc

**HINT:** To access a list of codes in a field type: .<Tab> . For example: in the Stockitem Sts Code field, typing .<Tab> will display a list of your Stockitem Stats Codes and Descriptions. Double-click to make a selection.

3. Double-click on a line to show the full details of that item:
4. You are then able to move through the table using the arrow keys F7 <<, F8 <, F9 >, F10 >> or F6 Table to get back to the Stockitem List table display.

5. It is possible to save the records to file using the File menu, or go to other applications for the items – for example: Catalogues, Authorities, Periodicals – by selecting XReferences from the menu.

Colour

Colour is used in certain modules to assist in browsing the list:

- **Red**  
  Items are *overdue*

- **Black**  
  Items are *on loan*

- **Green**  
  Items are *available for loan*

- **Grey**  
  Items are *on order*

- **Magenta**  
  Items are *on reserve*

If the item has a Process the Process will display in Red.

Catalogue

1. It is possible to XReference from a Stockitem record to the Catalog record to see the complete Bibliographic details for an item (including all Subject Headings, Notes, Added Authors, etc.) : select XReferences > Catalogue
2. It is also possible to XReference from the Catalog record: use the Holdings button or from the menu, select XReferences > Stockitems
WHERE SEARCHING

This function is available in the *Stockitem* and *Borrower* modules only. It is possible to search for items or borrowers using a range of fields and operators. This is a great way to get simple Counts – for example: for *State Government Library* statistics which the Public Libraries need to report on a yearly basis.

The Where search query results can be displayed in a List or saved to a File.

The Where search itself can also be saved.

1. You can access Where searches in the *Stockitem* and *Borrower* modules by selecting Application > Where... (in the Stockitem module) or Application > BorrowerWhere (in the Borrower module) – the Where Search screen will display:

   ![Where Search Screen]

2. **Choose Search column**: it can be helpful to have a look at the main Stockitem (or Borrower) screen if you’re confused about which fields contain what information.

3. **Choose Operator**: these are the same as in the Reports module

<table>
<thead>
<tr>
<th>OPERATOR</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIKE</td>
<td>Where the required data in this field begins with the text entered</td>
<td>LIKE ELD (for Eldorado)</td>
</tr>
<tr>
<td>LIKE</td>
<td>Where the required data in this field does not begin with the text entered</td>
<td>LIKE ELD (for all except Eldorado)</td>
</tr>
<tr>
<td>IN</td>
<td>Useful for selecting multiple codes</td>
<td>IN A,J,YA (for all of these types)</td>
</tr>
<tr>
<td>IN</td>
<td>Useful for multiple codes not to be</td>
<td>IN ILL,LS (to exclude these types)</td>
</tr>
<tr>
<td>Included</td>
<td>= Where the text entered is exactly equal to the data required</td>
<td>= A (borrowers with a code of A for Adult)</td>
</tr>
<tr>
<td>---------</td>
<td>---------------------------------------------------------------</td>
<td>------------------------------------------</td>
</tr>
<tr>
<td>≠</td>
<td>Where the text entered is not equal to the data required</td>
<td>≠ J (borrowers who do not have a code of J)</td>
</tr>
<tr>
<td></td>
<td>Useful for NOT EQUAL TO NULL – choose this operator, do not enter any data and click the Paste button</td>
<td></td>
</tr>
<tr>
<td>&lt;</td>
<td>Where the text entered is less than the data required</td>
<td>&lt; 01/10/10 (less than 1 Oct 2010)</td>
</tr>
<tr>
<td>≤</td>
<td>Where the text entered is equal or less than the data required</td>
<td>≤ 01/10/10 (less than or equal to 1 Oct 2010)</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>&gt;01/10/10 (greater than 1 Oct 2010)</td>
</tr>
<tr>
<td>≥</td>
<td>Equal or greater than the text entered</td>
<td>≥ 01/10/10 (greater than or equal to 1 Oct 2010)</td>
</tr>
</tbody>
</table>

4. **Type the Where condition:** this can be a date, a code, letters, numbers, etc

<table>
<thead>
<tr>
<th>BUTTON</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>Adds the Where condition to the Query Description table</td>
</tr>
<tr>
<td>Special</td>
<td>This button contains useful fields that can be used for any mathematical operand (i.e. =, ≠, &lt;, ≤, &gt;, ≥) – for example: Current Date</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the highlighted Where condition from the Query Description table</td>
</tr>
<tr>
<td>AND</td>
<td>Includes the AND separator to the Where conditions in the Query Description table (this is the default)</td>
</tr>
<tr>
<td>OR</td>
<td>Includes the OR separator to the Where conditions in the Query Description table</td>
</tr>
<tr>
<td>(</td>
<td>Adds a beginning bracket to the Where condition in the Query Description table</td>
</tr>
<tr>
<td>)</td>
<td>Adds a closing bracket to the Where condition in the Query Description table</td>
</tr>
</tbody>
</table>

5. Once your Where condition is set up you can either:

   a. Count the number of results by clicking the the **F6 Count** button:

   ![Where Search](image)

   ![231 Stock Item(s) were found.](image)

   ![OK](image)

   b. Get the list of results by clicking the **F5 Query** button:
6. If you wanted to find ALL of something (for example: Borrower, StockItems, items on loan) then you could run a query such as:

   c. **BarCode IS NOT NULL** (all Borrowers)
   
   d. **ItemNo IS NOT NULL** (all StockItems)
   
   e. **Issue Due Date Back IS NOT NULL** (all items on loan)

The NULL value is achieved by simply leaving a blank space in the field. **3 Type the Where Condition and Press Paste** – as soon as the Paste button is clicked a NULL value is entered into the Query Description table.

**Special Button**

The **Special** button can be used for a number of things including the creation of relational dates (dates that aren’t fixed but operate from the concept of a **Current Date** or the **Start of Month**).

For example: if you would like to look at dates from a week ago or further back, you could enter the following Where condition:

- **Issue Date Due Back <= Current date – 7 Days**

1. Select **Issue Date Due Back** from the **1 Choose Search Column** box
2. Select the < operand from the **2 Choose Operator** box
3. Click the **Special** button – another **Where** screen will display
4. Select the Special operand from the table – for example: **Current Date**
5. Adjust the relational value of the selected operand by using the + or – buttons and the **Days** or **Months** boxes – for example: **- 7 Days**
6. An example of the expressed condition will be visible in the box at the top of the screen:

![Image of the expressed condition]

7. Click the **Paste** button when complete – the where condition will then appear in the **Query Description** section at the bottom of the screen:

![Image of the query description]
Saving a Where Search

It is possible to save a Where search:

1. Click the **F2 Insert** button – the **Saved Queries** table will display:

   ![Saved Queries Table](image)

   1. Type a description of the Where clause, then press **Save**.
   2. **Move to the Description field** and type in a description.
   3. Select the **F3 Save** button – a prompt will display with the following message: **The Query File has been created.**
   4. **Click the **OK** button**

2. Type in a Description and select the **F3 Save** button – a prompt will display with the following message: **The Query File has been created.**

   ![Query Saved Prompt](image)

3. Click the **OK** button

4. Once saved, you can access saved Where searches by clicking the **F4 Select** button in the **Where** screen, selecting the **Saved Query** from the list and then clicking the **F9 Select** button.

![Saved Queries Table](image)
Query to File

It is possible to save the Where search results to a file, which can then be used in other operations (including reports).

1. After choosing your Where parameters, select the **F7 QtoFile** button – the *Saved Query Results* table will display:

![Stockitem Saved Query Results](image)

2. You can either use a pre-existing list file or create a new list file:
   a. To use a pre-existing file: select a list entry from the table and click **F9 Select** (click **F2 Empty** first if you would like to clear any pre-existing list items – look at the Qty column to ascertain this.).
   b. Alternatively, a new file can be added by: clicking on the **F1 New** button, typing in the Details (for example: *Chelsea Fiction*) and then clicking on the **F3 Save** button. Then highlight the file and click on the **F9 Select** button.

This Saved File can now be used as part of a report or procedure.

**All Stockitems**

- Item No IS NOT NULL

**All Junior Items**

- Sts Code LIKE J
  - or
- Call Number LIKE J (if you put J at the beginning of your call numbers for Junior items)

**Stockitems with a Specific Form Code**

- Form = BK

**Items with Cost over $500**

- Current Cost > 500
Items Never Borrowed

- Times Borrowed = 0

Dusty items – Items not used within a certain period of time (for example: Items not used in the last 12 months)

- For Loan = Y AND
- Last Active < Current Date – 12 Months

Items available for loan from a Specific Collection (for example: DVDs)

- For Loan (Y/N) = Y AND
- On Loan = N AND
- Form = DVD (substitute your own code here, or use Sts Code or Floor)

Items with More than 3 Reserves

- Res > 3

Items Received within a Specific Period

- Received < 1/7/2012 AND
- Received > 1/06/2012

Items Received Since the Beginning of the Month

- Received ≥ Start of Month

Stocktake – Missing items (minimum statements required)

- Stock Take Date IS NULL AND
- On Loan = N
CREATING SPINE LABEL REPORTS

Most spine label reports require the loading of a customised spine label. The following guide takes you through the entire process for loading the customised template, creating a new report, creating a Saved File of items to print and running the report.

Save the Template

- Save the template into the Amlib/Reports folder on the Amlib server. This will make the template available for use for all users. Alternatively, you may save it into a local folder on your PC – but please be aware, that the template (once loaded) will only be available for use on that PC.
- Ensure that the template is saved with a name that clearly identifies it as a customised spine label – for example: PRSPINES.QRP

Load the Template

1. Launch the Amlib client
2. Go to Main > Reports > RepAddNew – the Report Files screen will display
3. From the Report Entity drop-down select: Stockitem
4. Click the F1 New button – the Stockitem – New Report File screen will display:

![Stockitem - New Report File](image)

5. Type in a Description – for example: MyLibraryName Spine labels (5 wide)
6. Click on the Browse button and navigate to the Amlib/Reports folder on your Amlib Server and locate the template to be loaded (if the template has been loaded onto your PC – then navigate to the local folder)
7. Select the file and then click on the Open button
8. Choose Type – ensure you select Spine Labels (with the matching number of columns to those in your template) – for example: Spine Labels 5 label wide
9. You can leave Default Stats Code blank
10. Update Entity (Y/N) = N
11. Click the F3 Update button to save the new template
12. Close out of the Report Files window

The template is now loaded and available for use in a Report.

Create the Report

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
2. Select the F1 New button – the Select Report Format table will display:

   ![Select Report Format Table]

3. Locate the template you just loaded via RepAddNew, highlight it and click on the Select button
4. You will be returned to the Stockitem Reports screen – locate the report you just created and highlight it (the entry will be in bolded red and the Report Type = the Report Description of the template you loaded)

   ![Stockitem Reports Screen]

5. The spine label settings should be typed into the Report Description field – for example: 5,6,w,a. DO NOT type in any other descriptive characters as this will stop the report from functioning correctly – your Description should be similar to that in the example above. The Report Description is composed of four positions using the following criteria:

   a. The first position: how many labels to ignore before printing is commenced. In the example there would be 5 labels missed before printing. On a 5 column wide spine label printout, printing would then start from the first label on the second line). To print on a new sheet of labels, the value would be 0.
b. The **second** position: each line has a maximum of X characters before going to the next line (in the example, the line would be *6 characters* wide).

c. The **third** position – t or w

   i. **w**: Wrap the remainder of the Call Number to the next line(s)

   ii. **t**: Truncate the remainder of the Call Number

      (The example will **wrap** the remainder to the next lines)

   ```
   w
   591.
   994994
   56890
   SMI
   t
   591.
   994994
   SMI
   ```

d. The **fourth** position: a, b or s

   i. **a**: Puts a full stop at the end of the line

   ii. **b**: Put a full stop at the beginning to the next line

   iii. **s**: Sets the **space** as the break and ignores other Punctuation

   ```
   a
   591.
   994
   SMI
   b
   591
   .994
   SMI
   s
   591.994
   SMI
   ```

6. Select the **F3 Save** button

   Once saved the line will be **bolded red** as the report does not have a **F7 Where** search. Typically this report is used only with a Saved File (therefore requiring no Where search). However, a **F7 Where** search of **Received Date = Current Date** could be used for those items received on that day only.
Wand Into File

Items can be wanded into a selected file. This is useful if you wish to use the group of items in a Report (for example: Spine Labels):

1. Go to Main > StockItems > Stockitem – the Stockitem screen will display

2. From the menu, select File > WandIntoFile – the Wand Into File screen will display:

![Wand Into File Screen]

3. Click the F4 Select button – the Stockitem Saved Query Results table will display

4. You can either use a pre-existing list file or create a new list file:
   
   a. To use a pre-existing file: select a list entry from the table and click F9 Select (click F2 Empty first if you would like to clear any pre-existing list items – look at the Qty column to ascertain this.).

   b. Alternatively, a new file can be added by: clicking on the F1 New button, typing in the Details (for example: Spine Labels) and then clicking on the F3 Save button. Then highlight the file and click on the F9 Select button.
5. This will return you to the **Wand Into File** screen – the name of the selected list file will now appear in the **Saved File:** field:

![Wand Into File](image)

8. You can now start wandning in items: as each item is wanded, the **Barcode** and **Title** display in the window (they will be automatically saved into the selected Saved File)

9. After all the items have been wanded close the window by clicking the [X] in the top right-hand corner

**Run the Spine Label Report**

1. Go to **Main > Reports > RepStockitem** – the **Stockitem Reports** screen will display
2. Locate the report you created as part of the Create a Report procedure above and highlight it.

3. Select the F8 View button – the Select Saved File stable will display:

4. **Select** the File Name (that you wanded your items into) and click the OK button.

5. A Report - View screen will display:

   - The above example, shows a report starting at the first label: Report Description = 0,6,w,a
The following example shows a list starting at the tenth spine label: Report Description = 9,6,w,a

Please Note: When the print button is clicked, a prompt with the following message may display: Report margins are less than printer offsets...Text may be clipped. Continue?

The message is the result of the report template having particularly narrow borders. Users should click OK button and check printouts to ensure that no clipping has occurred.

Clearing the File

After successfully printing the spine labels, the file can be emptied, ready for the next batch.

1. In the Stockitem module, select File > DisplayFile from menu – the Stockitem Saved Query Results screen will display

2. Highlight the SPINE LABELS file and click the F2 Empty button – a prompt with the following message will display: Are you sure you want to remove all entries from the ‘SPINE LABELS’ saved file?

3. Click the Yes button

4. Click the F3 Save button when complete
MASS MEMO ITEMS

Create the Memo Type

If a memo type is not already defined, this will need to be created.

1. In *Amlib* navigate to Main > Supervisor > Supervisor screen
2. Select LibraryMenu > MemoTypes
3. Select F1 New
4. Enter a Memo Type Code – for example PR08
5. Enter a Description – this is the default text of the memo

6. Valid for Holdings – if the memo is to go on Stockitems select Y if it is to only go on borrowers select N
7. Valid for Members – if the memo is to go on Borrowers select Y if it is to go only on Stockitems select N
8. Show as Default – if the memo is to pop up in circulation upon wanding enter Y if the memo is not required to pop up select N. If the memo is only required to show in NetOpacs My Details select O
9. Enter a number of days before the memo expires, or if the memo is never to expire enter 9999
10. F3 Save then log out of *Amlib* and back in
Create a Saved File Stockitems

To add the Memo to a group of items it is easiest to create a saved file first. Though not absolutely necessary, this allows you to view the items or borrowers in a table first, preventing errors. This example uses a Stockitem file but the process is the same from the Borrower Module.

1. In Amlib navigate to **Main > Stockitems > StockitemWhere**

2. Create a where statement for your Items – for example the following will find all of the items in the Premiers Reading Challenge. Your Where statement will be based on the items you want to memo:

3. Select **F7 QtoFile**
4. Select **F1 New** to create a file and enter a file name

5. Then **F3 Save** and **F9 Select**

6. A dialogue box will advise how many items are in the file

![Wand into File](image)

**Wand into File**

An alternative method of creating a file (of Stockitems) would be to wand the physical items into a file.

1. In *Amlib* navigate to **Main > Stockitem > Stockitem**
2. Select **File > WandIntoFile**
3. **F4 Select**
4. Select **F1 New** and give the file a name
5. **F3 Save** then **F4 Select**
6. Wand the items to have the memo placed on them and when finished close the window

![Mass Memo the Items](image)

**Mass Memo the Items**

1. Navigate to **Main > Stockitems > Stockitem**
2. Select **File > Display File**

3. Highlight the saved file and **F9 Select**

4. Highlight the items to have memos applied to them. To select more than one item, press the **Ctrl** key and click the particular items with the left mouse button for individual items. To select a range of items, highlight the first item in the range. Find the final item for the range and press the **Shift** key and click with the left mouse button

5. Select **Table > MassMemoltems**

![StockItem List - 115 rows - Items to Memo](image)

6. In the **Memo Type** field you can either type the Memo Code or enter a full stop in the field and then hit the **Tab** key to select the memo type from the list. The Memo type field is optional but entering this assists with deletions and reporting

7. The default text will then automatically display in the Message window, amend as necessary noting that the memo can be up to 250 characters

![Mass Memo Data](image)

**Please note:** dates are the current date as well as the expiry date from the Memo Types screen though they may be altered in this screen.

8. When the memo is complete select **F3 Save**

9. A confirmation will display, select **OK**
Memos can be applied to Borrowers in a similar way. Highlight Borrowers in a Table and select Mass Memo Borrower from the Table Menu.

**Mass memo deletion**

It is possible to delete memos from Stockitems en masse by selecting items from a table of Stockitems.

1. As above create a Stockitem or Borrower saved file
2. Select **Borrower > DisplayFile** or **Stockitem > DisplayFile** and select the file to display in the Table
3. Highlight the items/borrowers to have their memos deleted. To select more than one item, press the Ctrl key and click the particular items with the left mouse button for individual items. To select a range of items, highlight the first item in the range and press the Shift key and click with the left mouse button.
4. Select **Table > MassMemoDelete**

5. Select the deletion options according to the table below for Memo Type and date
6. Select **OK**
Options can be chosen from the Mass Memo Delete Window:

<table>
<thead>
<tr>
<th>BUTTON/FIELD</th>
<th>EXPLANATION</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Memo Date</strong></td>
<td></td>
</tr>
<tr>
<td>Ignore the date when deleting Memos</td>
<td>No check of the Date is performed when deleting the Memos from the items highlighted in the Table</td>
</tr>
<tr>
<td>Only Delete Memos within a Date range</td>
<td></td>
</tr>
<tr>
<td>Minimum Date</td>
<td>The date entered in this Field (e.g. 01/11/03) will be used as a beginning range for deleting the Memos from the items highlighted in the Table</td>
</tr>
<tr>
<td>Maximum Date</td>
<td>The date entered in this Field (e.g. 31/03/04) will be used as an ending range for deleting the Memos from the items highlighted in the Table</td>
</tr>
<tr>
<td><strong>MemoType</strong></td>
<td></td>
</tr>
<tr>
<td>Ignore the type when deleting memos</td>
<td>No check of the MemoType is performed when deleting the Memos from the items highlighted in the Table</td>
</tr>
<tr>
<td>Only delete memos with the below type</td>
<td>Only Memos with the Memo Type entered in the Memo Type Field (e.g. YAO) will be deleted from the Stockitems highlighted in the Table</td>
</tr>
</tbody>
</table>

7. Once memos are successfully deleted, a message box will appear, detailing how many Memos were deleted.
MASS DELETION OF STOCKITEMS/SAVING TO FILE

Items can be deleted easily from a Saved File. These items can be wanded into the File. This is useful for Public Libraries who have to return items to SLWA, and who want to delete them from their catalogue. It is also useful for schools when a weed of resources is performed (for example: after a Stocktake).

This can be done individually within the Stockitem module by calling up the item and clicking the F4 Delete button. If it is the last copy for the Catalogue, you will be prompted to delete the Catalogue entry as well.

Items can be deleted en masse from a Stockitem List (each item that is to be deleted needs to be highlighted) or alternatively from a Saved File.

- See: Appendix 1: Saved Files for more information

Stockitem List

1. Launch the Amlib client
2. Go to Main > Stockitem > Stockitem – the Stockitem screen will display
3. Initiate a F5 Query or Stockitem Where search to bring up a list of items to be deleted (alternatively, you may decide to use a Saved File as the basis of your deletions – select File > Display File > select a saved File > F9 Select)

4. Highlight the items to be deleted
5. From the Stockitem List main menu, select Table > Mass Item Deletion – the Mass Delete Items screen will display:

Last Updated: 25 February 2013
6. Add a **tick** in the **Catalogue: Delete Catalogue if Last ?** box

7. Click the **OK** button – the following prompt will appear:

8. Click the **Yes** button

9. The items (and any associated Issue Catalogue records) will be deleted
STOCKITEM FIELD LABELS

Some Stockitems (particularly equipment) do not conform to the standardised labels in use by the system. However, it is possible to modify the labels displayed for a particular Form type.

Please Note: The default Stockitem Form type used throughout the system (including the blank Stockitem screen) is set in Main > Supervisor > Installation – Stockitem tab: Default Item Form = for example: BK.

1. Launch the Amlib client
2. Go to Main > StockItems > StockitemForms – the Form Codes table will display:

3. Highlight a Form – for example: EQ and select the F9 Display button – the Stock Display Tags screen will display:

To use a preferred instance of multiple tags enter the indicators in the form (nnn) immediately after the tag

**Note:** You can use these parameters for another form code by entering that form code here.
4. Adjust as per the following example:

- Line 1: **Label** = Equipment | **Tags to Display** = 245
- Line 2: **Label** = Model No | **Tags to Display** = 300
- Line 3: **Label** = Manufacturer | **Tags to Display** = 260 710
- Line 4: **Label** = Description | **Tags to Display** = 500
- Line 5: **Label** = Subject | **Tags to Display** = 650 651 600
- Line 6: **Label** = Call Number | **Tags to Display** = 984 082

**Please Note:** Tags to display should type in order of preference (the first tag containing a value will then display).

5. Click on the **F3 Save** button when complete

6. To refresh the data displayed for a particular stockitem, select **Item > RefreshFromCat**

7. Click the **F3 Update** button to save changes
CUSTOMISING THE STOCKITEM TABLE

Once the Stockitem List has been displayed, the columns can be moved by stretching from the heading:

- Click the heading just on the line until an icon displays with the two arrows – when this displays the column can be dragged and dropped where required

The Stockitem List columns themselves can be set permanently on the Supervisor Installation screen:

1. Go to Main > Supervisor > Installation – Stockitem tab
2. Locate the Order of columns to display within Stockitem setting
3. Type the fieldnames for the columns you wish to have displayed first – for example: **STK_LINE6, STK_LINE1, STK_FORM, STK_STATS_CODE**
4. Click the F3 Save button when complete
5. Exit and restart the Amlib client for the settings to take effect

<table>
<thead>
<tr>
<th>TITLE IN LIST</th>
<th>COLUMN NAME</th>
<th>TITLE IN LIST</th>
<th>COLUMN NAME</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td><strong>STK_LINE1</strong></td>
<td>Volume</td>
<td><strong>STK_VOLUME</strong></td>
</tr>
<tr>
<td>Author</td>
<td><strong>STK_LINE2</strong></td>
<td>Temp Location</td>
<td><strong>STK_LOC_TEMP</strong></td>
</tr>
</tbody>
</table>
**Stockitem Search Defaults**

It is possible to set the Stockitem screen *Query Via* search defaults which display when the screen is first opened – for example: some sites may want it set to *Item*, some to *Keyword*. This depends who logs into the Amlib client.

To set the default:

1. Go to **Main** > **Supervisor** > **UserNames** – the *User Names* screen will display
2. Highlight the *User Name* you wish to check and select the **F8 Choose** button – the *User Security* screen will display
3. From the menu, select **ActualMainMenu** > **Stockitems** > **QueryDefaults**
4. Select the current QueryBy option – the Menu Chosen will display to the selected QueryBy option – for example: StockItems.QueryViaKeyword

5. Click the red Take button – this will delete the option from theCurrentUserMenu list

6. From the menu, select ActualMainMenu > StockItems > QueryDefaults and the new QueryBy option – the Menu Chosen will display to the selected QueryBy option – for example: StockItems.QueryViaItem

7. Click the green Give button – this will add the option to theCurrentUserMenu list

8. To check the new settings, go to theCurrentUserMenu and ensure only one of the QueryBy options is selected (we recommend also having the KeepLastSetting option selected as well).
9. Exit and restart the Amlib client for the new settings to take effect

**STOCK CALL SETS**

Setting up of Call Sets is completely optional. It enables items within a particular call number range to be easily linked together for reporting and retrieval purposes. It’s a great method of keeping detailed ‘holdings’ information of your library collection. For example check on the number and value of Science items received in the current Financial year. Call sets work only with numeric values in Line 6 of the Stockitem.

Once the Call Sets are established it is possible to quickly search or report on Call Sets using Main > Reports > RepStockitem, rather than having to specify a separate call number ranges. All new items will be given a Call Set if the Line 6 Call Number has Numbers.

To setup Call Sets:

1. Launch the Amlib client
2. Go to **Main > StockItems > StockCallSets** – **Stock Call Numbers** screen will display
3. User the F1 New (or F2 Insert) button to enter ranges
   - Enter a **Range ID** Code – code up to 8 characters
   - Enter the **Call From** - beginning Call No (Greater or equal to this call number)
   - Enter the **Call To** - ending Call No for the range (Less than)
   - Enter the **Description** for the Range ID
4. Click the F3 Save button when complete
5. Click the F7 Set button to set all the items to the Call Sets defined in the table
## Stock Call Number Ranges

These are set by for all locations or just current group if applic.

<table>
<thead>
<tr>
<th>Range Id</th>
<th>Call From (Greater or Equal)</th>
<th>Call To (Less than)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GEN 900</td>
<td>000</td>
<td>002</td>
<td>Generalities</td>
</tr>
<tr>
<td>COMP 903</td>
<td>006</td>
<td></td>
<td>Computers</td>
</tr>
<tr>
<td>DICT 919</td>
<td>019</td>
<td></td>
<td>Dictionaries</td>
</tr>
<tr>
<td>LIB 920</td>
<td>030</td>
<td></td>
<td>Libraries</td>
</tr>
<tr>
<td>LNC 930</td>
<td>040</td>
<td></td>
<td>Encyclopaedias</td>
</tr>
<tr>
<td>GEN 940</td>
<td>100</td>
<td></td>
<td>Generalities</td>
</tr>
<tr>
<td>PHIL 100</td>
<td>200</td>
<td></td>
<td>Philosophy &amp; Psychology</td>
</tr>
<tr>
<td>REL 200</td>
<td>300</td>
<td></td>
<td>Religion</td>
</tr>
<tr>
<td>SOC 300</td>
<td>370</td>
<td></td>
<td>Sociology</td>
</tr>
<tr>
<td>EDUC 370</td>
<td>380</td>
<td></td>
<td>Education</td>
</tr>
<tr>
<td>COMM 380</td>
<td>390</td>
<td></td>
<td>Communication</td>
</tr>
<tr>
<td>CUST 390</td>
<td>398</td>
<td></td>
<td>Custom &amp; Folklore</td>
</tr>
<tr>
<td>FOLK 398</td>
<td>399</td>
<td></td>
<td>Folklore</td>
</tr>
</tbody>
</table>
CREATING MASTER/SUBSIDIARY ITEMS (KIT LOANS)

It is possible to link stock items to one (Master) item. All the linked (or Subsidiary items) show as on loan when the Master is on loan. This is useful for sites that want to set up kits or videos (with programs catalogued separately) and do not wish to loan out the separate items independently.

Example 1: Videos with Multiple Programs

**Title:** ABC for Kids

**SUBSIDIARY ITEMS**
- Big red car (20 mins)
- Wiggle time (30 mins)

Example 2: Kits

**SUBSIDIARY ITEMS**
- Teacher’s Guide Book
- Video
- 24 plastic animals
- Sound cassette
- Worksheets
- Game

Kits can be added as a Master with Subsidiary items, or alternatively as a single item. Use the former for those instances where you would like the ancillary items to be searchable on the catalogue. Otherwise a Memo on the stock item which lists the ancillary items would suffice.

Creating a Master Record

1. Launch the Amlib client
2. Go to **Main > StockItems > Stockitem** – the Stockitem module will display
3. If you are creating a new stockitem: Enter the barcode that you wish to use for circulating the loan. If the item is a kit or box, scan the barcode into the Item No field. Otherwise, just do a **F5 Search** in the Stockitem module to locate the item which you would like to be the Master Item

**HINT:** A description relating to the item as a Master can be added to assist in listing Master Items.

4. From the menu, select **XReferences > SelectAsMaster**.
5. The following prompt will then display: **The Item has been selected as Master.**

![Select As Master dialog box](image)

6. Once the item has been selected as a Master, the **ITEM TYPE:** will change from **N** (Normal) to **M** (Master):

![ITEM TYPE:M](image)

7. Click the **F1 Clear** button – the system will remember the last item to be made a Master Item.

8. It is then possible to link other items to this Master Item. You can either create a new stockitem record (attached to the same catalogue record), or use **F5 Search** to locate the stockitem in question (which can be linked to the same Catalogue record – or a separate record if you would like it to be searchable as a unique entity).
9. Once the stock item to be linked is displayed on the screen, from the menu, select XReferences > Create Link – a prompt will then display, asking you to confirm the **Link this Item with the Current Master**:

![Create Link Prompt](image)

10. Click the **Yes** button to create the link – the following prompt will then display: **The item has now been Linked**.

![Linked Item Prompt](image)

11. The Stockitem will now have an **ITEM TYPE**: of **S** (Subsidiary):

![Stock Item Details](image)

**Circulating Linked Items**

- When borrowing out linked Items, only the Master Item will display in the **Issues** module:
Subsidiary items can be circulated independently of the Master – the following Alert will display if a Subsidiary item is circulated: This is a Subsidiary item. It is not usually issued using its own barcode – normally the Master record must be issued. Do you want to issue just this item?

When the item is returned another Alert notice will display (see below for more details)

Once the Master Item is out on loan, all linked items also show that they are out on loan to that borrower. In the Borrower module, from the menu, select XReferences > ShowItemsOnLoan to see the full list of items on issue to that borrower (including linked items):

To check the Master of any Stockitem with an ITEM TYPE of S, from the Stockitem module menu, select XReferences > CurrentMaster – the following prompt will display denoting the current Master record:
To check a listing of linked items, from the Stockitem module menu, select XReferences > RelatedItems – a Stockitem List of Related Items will display:

Returning Master-Subsidiary Items

This procedure applies to checking in or scanning through the returns module any items that have been set up with a Master-Subsidiary relationship (for example, kits with several parts or boxes of books and other library items).

1. Launch the AmLib client
2. Go to Main > Circulation > Returns – the Returns screen will display
3. Check in the box or Master item – a prompt will display with the following message: This is the Master Item. Return All Parts

4. If you are sure that all items are present, click the Yes button (otherwise click the No button)
5. If you clicked the Yes button, the returned item will display in the Returns screen:

![Returns screen](image)

6. To return only some parts of the box or set, click the No button – the Subsidiary Return Check screen will display:

![Subsidiary Return Check](image)
7. Use the list to check if all contents are present. If not, use the options on the screen (pictured below) to process these items according to your library procedures:

<table>
<thead>
<tr>
<th>FIELD</th>
<th>EXPLANATION/OPTIONS</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Code</td>
<td>A process code can be entered in this field to be automatically added to items with a Y in the Add Process? column.</td>
<td>A message will appear at the issues screen to indicate that the item has a process code (see screen shot below). Click the OK button to proceed with the issue.</td>
</tr>
<tr>
<td>Alert</td>
<td>If set to Y a message will display at issues if the item is checked out to another borrower, to alert the operator to the Process Code on the item.</td>
<td></td>
</tr>
<tr>
<td>OPAC</td>
<td>If set to Y, the item will show on the OPAC.</td>
<td>If the item is missing, setting the OPAC to N will mean that library users will not see the item displayed and this will prevent them from asking for an item that is not available.</td>
</tr>
<tr>
<td>For Loan</td>
<td>If set to Y, this will allow the item to be borrowed if presented at the circulation counter.</td>
<td>For missing items or parts of a set, this may be set to N to stop the item from being borrowed until the process code is removed or the item is returned to its set.</td>
</tr>
<tr>
<td>Memo Type</td>
<td>Information contained in these fields will determine the memo placed on selected items. A Memo Type can be selected from the list of Memo Types. Additional or alternative text can be added in the Text field.</td>
<td>A Memo Type of BULK LOAN may have been created and selected in this screen. The Text may include the details of the set that was originally loaned out.</td>
</tr>
<tr>
<td>Text</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Return?</td>
<td>The system will check in/return any items with a Y in this column</td>
<td>If items are present, they can be checked in and those not present are marked with an N so they remain checked out and undergo normal overdue processes. Alternatively, all items may be checked in (mark items with a Y in this column) and a Process Code may be used instead.</td>
</tr>
<tr>
<td>Add Memo?</td>
<td>A memo will be added to those items marked with a Y in this column</td>
<td>A standard memo for bulk loans may be added to those items that are not present – to indicate what set they were originally loaned in, and that the parts had not been returned.</td>
</tr>
<tr>
<td>Add Process?</td>
<td>A Process Code (see above) will be added to any items with a Y in this column</td>
<td>Items may have a process of ‘missing part’ to indicate on the catalogue that they are part of set that is now incomplete.</td>
</tr>
</tbody>
</table>

8. Click the green OK button at the bottom of the screen to process the items as indicated
9. Items that were marked as Y for return will display on the returns screen:

10. If some items were marked as N for return, these will display as on loan to the original borrower:
11. Items that were marked with a Y for Process Code, will contain the corresponding Process in the Stockitem record:

![Stockitem record with Process highlighted]

12. If items were marked with a Y for Memo, the memo will display on the Stockitem record:

![Memo details for Stockitem]

- When returning a linked item, if you attempt to return the Subsidiary Item rather than the Master Item, the following prompt will display: This is a Subsidiary item. **It cannot be returned using its own barcode – the Master record must be returned.**
Supervisor Settings

It is possible to change the System settings so that when a Master Item is checked in via the Returns module, it automatically shows Subsidiary Return Check list of the Subsidiary Items:

1. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
2. Select the Circulation tab
3. Scroll down and adjust the following setting: Show subsidiary items when returning a master item (Y/N) = Y
4. Click the F3 Save button
5. Exit and restart Amlib client for the settings to take effect

Alternate Method

HINT: Alternatively, you can attach a memo to the Master Item, so that a message displays with an indication of how many items are attached so that this can be checked:
Delinking Items

- To break the link: from the Stockitem module menu, select XReferences > BreakLink – a prompt with the following message will display: The Item has been unlinked from ‘XXXX’

Please Note: You will be unable to delete a Master stockitem record if it has linked items. The Master cannot be removed as a Master until the items are first disconnected.

SETTING UP FLOATING COLLECTIONS

It is possible to set certain Stockitem Stats codes or Form codes to be set as a Floating Collection.

These Floating collections can be set in either the Stockitem Form Code table or the Stockitem Stats Code table. It does not matter whether your system is set to loan by Form code or Stats code. This function will only work when the item in question is currently out on loan and then is returned.

From Stockitem, Application, Stockitem Forms change the value in the Floating? Column to a Y if this code is to be included as part of a Floating Collection.
Floating Locations can also be set to the Stockitem/Stats codes

When the item is initially borrowed the Permanent and Temporary locations display showing the current Permanent Location
However, on Return of that item the Permanent and Temporary locations then display for the Library location of Return. No prompts display.

The Stockitem has the Permanent and Temporary Location set to the Return Location
STOCKWAND CHANGE

This facility is used to define a set of changes and apply those changes to all items:

1. Individually from the Barcode (select Start and begin wanding the Item Numbers) [F6]
2. From a File [F7]
3. From a Saved Where Search [F8]

Stockwand Change – setting Values to change

1. Launch the Amlib Client
2. Go to Main > StockItems> StockWandChange – the Stockitem Wand Change screen will display
3. Choose the Column to Change box 1: select a parameter – for example: Process
4. Type the new Value into box 2

Please Note: A list of codes can be accessed from box 2 by entering a full stop and pressing the Tab key on your keyboard. The Special button can be used for assigning Date ranges using the Current Date which can be very useful.

5. Click the Paste Button
6. The values to change will display in the Columns at the base of the screen
Using the Special Button

Useful for selecting the Current Date and perhaps minus (or Add) a number of days of Months.

1. Click the red Special button – the Update prompt will display:

![Update Prompt]

2. Select/enter your date parameters
3. Click the Paste button

Executing the Changes

The Changes can be applied in one of 3 methods:

1. **Individually from the Barcode:**
   a) Click the F6 Start button – the Start prompt will display containing a confirmation message:

   ![Start Prompt]

   b) To proceed, click the Yes button
   c) Begin wanding the Items into the Item No field for the changes to be applied
2. **From a Saved File:**
   a) Click the F7 FrFile button – the Stockitem Saved Query Results screen will display
   b) **Highlight** the relevant File (saved previously) and click the F9 Select button – the Mass Change from file prompt will display with the number of items to change defined as well as the File selected:

   ![Mass Change from file](image)

   c) Review the message and if the information is correct click the Yes button to proceed
   d) A prompt with the following message will display when complete:
      **The XX Stockitems have been Updated.**

3. **From a Saved Where Search:**
   a) Select the F8 FrWhere button – the Saved Queries screen will display
   b) **Highlight** the relevant saved Where Search (Saved previously) and click the F9 Execute button – the Mass Change from Saved Where prompt will display with the number of items to change defined as well as the Where Search selected:

   ![Mass Change from Saved Where](image)

   c) Review the message and if the information is correct click the Yes button to proceed
   d) A prompt with the following message will display when complete:
      **The XX Stockitems have been Updated.**
Saving a StockWandChange

A Stockwand Change can be saved for future use:

1. With the Stockwand Change parameters displayed click the **F2 Insert** button – the **Saved Stock Wand Changes** screen will display:

![Saved Stock Wand Changes](image)

2. Type a **Description** in the field at the bottom of the screen
3. Click the **F3 Save** button

Reusing a StockWandChange set of Parameters

1. Go to **Main > StockItems > StockWandChange** – the **Stockitem Wand Change** screen will display
2. Click the **F4 Select** button – the **Saved Stock Wand Changes** screen will display
3. Highlight the required StockWand Change
4. Click the **F9 Select** button
5. The parameters will display where the items can be selected by wanding, from a File or from a Saved Where search

**MASS ITEM CHANGE**

Create a Saved File of Items to be Changed

1. Launch the *Amlib* client
2. Select **Main > StockItems > StockitemWhere** – the Stockitem Where Search screen will open
3. Set the **Where** statement to search for the items you wish to change – for example: Form = BK
4. Click the **Paste** button

![Stockitem Where Search - STAFF at Chelsea Library](image)

5. Click the **F7 QtoFile** button - this will open **Stockitem Saved Query Results** screen

![Stockitem Saved Query Results](image)

6. Click the **F1 New** button
7. In the **Details** column type in a **file name** – for example: **Form Codes BK Changes**
8. Click the **F3 Save** button
9. Then click the **F9 Select** button – this will place all the stockitems into the file
10. A pop-up will appear, telling you how many items were saved into the file
11. Click on the **OK** button

**Mass Change the Saved File**

1. From the **Stockitem** screen main menu, select **File > DisplayFile**

![Stockitem Screen](image1)

2. The **Stockitem Saved Query Results** screen will open

![Stockitem Saved Query Results](image2)

3. Highlight the Saved File created earlier and click the **F9 Select** button – this will display the items in a **Stockitem List**

![Saved File Count](image3)
4. From the main menu, select **Table > MassItemChange**

5. The Mass Change of stock within a File screen will appear

6. In box select the field you wish to change

7. In box 2 type the new value for that field

8. Click the **Paste** button – this display the setting change in the table
Please Note: If changing a code you will only be able to enter pre-existing Codes. New codes must be setup in Stockitem prior to attempting the Mass Change. If an incorrect code is selected then a Select screen will appear, where you can then select a pre-existing code.

9. Click the **F3 Update** button

10. A **Stockitem – Mass Item Update** popup will appear, informing you how many items will be changed during the update:

11. Click the **Yes** button to start the process

12. The stockitems will then be changed
STOCKITEM AUTOLINK

This facility allows a Global refresh of Stockitems according to the option chosen. The option is selected from the table. This can be done on selected items from a saved file or against the database by entering a Start and End of Unique numbers (e.g. 1 to 99999) entered.

Please Note: Ensure that you have recent Amlib backups prior to running Autolink. Many of these facilities, though useful, are powerful and make global changes. They should be run in consultation from Amlib Support and as directed. During the following step all users should NOT be using the Stockitem Module for anything BUT searching.

<table>
<thead>
<tr>
<th>OPTION</th>
<th>EXPLANATION</th>
</tr>
</thead>
<tbody>
<tr>
<td>*Rebuild keys using Stockitem data (uses Stock Stopwords)</td>
<td>This would only be used if the Stopword listing had been changed in Authority, Application, KeywordStopList. Enter a range of Unique numbers to Rebuild (e.g. 1 to 100000). You will then be asked to enter the Line Number (e.g. Line 1, Title, Line 4 Series) to Rebuild. Once this is selected, the Rebuild will commence. A message will display indicating the number of items Rebuilt.</td>
</tr>
<tr>
<td>*Non Catalogued items Only (Same as Rebuild Keys)</td>
<td>This would only be used for Stockitems with no Catalogue data, if the Stopword listing had been changed in Authority, Application, KeywordStopList. Enter a range of Unique numbers to Rebuild (e.g. 1 to 100000). You will then be asked to enter the Line Number (e.g. Line 1, Title, Line 4 Series) to Rebuild. Once this is selected, the Rebuild will commence. A message will display indicating the number of items Rebuilt.</td>
</tr>
</tbody>
</table>
| **Rebuilt.** | Rebuilt.  

**Refresh ALL items from catalogue using (excludes Periodicals and Orders)**  

Refreshes all Stockitems that are different to the Catalogue data. This needs to be used with caution, as there may be a reason behind making the Stockitems different (e.g. Primary Campus having different Call Nos. to Senior Campus but sharing the same Catalogue Number). Enter a range of Unique numbers to Rebuild (e.g. 1 to 100000). A message will display indicating the number of items refreshed.  

Note: Single items can be Refreshed from Catalogue from the Stockitem, Item menu |
| --- | --- |

**Remove Excess History**  

Can be set to delete history entries from Stockitem records based on Installation parameters.  

For large libraries from time to time it may be necessary to delete history records from the Borrower and Stockitem modules. The history records contained within the stockitem history are directly linked to the borrower history. Deleting the Stockitem ‘RETURN’ history also deletes the corresponding ‘RETURN’ entry in the borrower history. Borrower Types that have the ‘Keep History’ parameter set to ‘Y’ **do not** have their READING history deleted in this process. The Stockitem History Deletion Autolink function will only delete history records as determined in **Supervisor > Installation > Circulation > Keep the last ### History records** |
| --- | --- |

**Change of Stats Period – Issues, renewals, reserves by item**  

Creates a new Statistics Period so that the new statistics can be compared to the previous period. This history can be viewed in the Stockitem /Item/ History menu. **This needs to be used with Caution as when run several times, the History can only be viewed for 2 periods - Current Period and Previous Period. The possibility of checking what has never been borrowed since System inception will be lost. Use only under guidance of Amlib Support.** |
| --- | --- |

**Get File**  

Enables the refresh to be restricted to a Saved File. When this is selected, a list of Stockitem Files display where the relevant File can be selected |
| --- | --- |

**Please Note:** Facilities marked with an asterisk (*) will prompt for lines to be refreshed from Catalogue

---

**Run the Stockitem Autolink**

1. In *Amlib* navigate to **Main > Stockitems > Stockitem**
2. Select Application > StockitemAutolink
3. In the Options section tick the task to be completed

4. To perform the task against the entire database enter 1 next to Start and 99999 next to End OR to perform the task only on a saved file select the GetFile button

5. Select the Start button (note the and the End count will then refresh to the number of records to be affected)

6. Tick the lines that are to be refreshed. These are the 6 lines of the Stockitem screen and/or Volume, Edition and Call Set fields. Only tick those Stockitem lines that are to be rebuilt from Catalogue (note that the Remove Excess History option does not display this screen, all others do)
7. The process will then run, displaying the updates as it runs. This is a system intensive process so avoid making any other demands on the system until it is complete.

8. At the end of the process a message will display, indicating the number of items processed, select OK.
REPORTS FOR STOCKITEM

Print using a Report

1. In the Stockitem List (or Borrower List), select: Table > Report F7 – the List Reports screen will display:

2. Select a specific style – for example: Author, Title, Call No and Form

3. Click the F9 Order button to select the sequence in which the items display – for example: Title, Call No. etc

4. Use the Caption box to add a heading to your report – for example: Weeding List

5. Click the F8 View button to display the report
6. The print button can then be used to print the report

Saving a report to file

You can save your reports to a file, for email or formatting, or just to keep it in an electronic format rather than paper. The two ways of doing this are by Table or Report.

Table

1. Access a module and perform a search – the results will display in a List
2. Highlight the items you would like to save to file
3. Type Ctrl + C to copy them
4. Open up MS Excel or Word
5. Type Ctrl-P to paste the selection into a table or page
How to find the value of the collection

Several templates can be used in the Stockitem Reports screen to determine the value of the collection.

The choice of report will determine the Sort option. The one used in the example is by Form and Stats.

1. Launch the Amlib client
2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
3. Click the F1 New button – the Select Report Format screen will display:

   ![Select Report Format]

4. Highlight this report Count by Form & Stats (&STKCFS.QRP) and click the Select button
5. Type in a Report Description – for example: Value of the Library Collection
6. Click the F3 Save button

7. Click the F7 Where button – the Stockitem Reports – Where screen will display
8. The Where parameters will depend on what you want to list:

   a. To report on the entire collection:
      i. Select ItemNo from box 1
      ii. Select is not equal to (≠) from box 2
      iii. Leave box 3 blank
      iv. Click the Paste button

   b. To report on what has been received this year:
      i. Select Recd from in box 1
      ii. Select >= in box 2
      iii. Type the date for the start of the year (for example: 01/01/2011) in box 3
      iv. Click the Paste button

   c. To report on just one Location:
      i. Select PermLoc from box 1
      ii. Select = in box 2
iii. Enter the relevant Location code in box 3 – for example: CHELSEA or LIB

iv. Click the Paste button

d. Click the F3 Save button when complete

9. The order will be fixed, so the F9 Order button should be greyed out:

10. If you wish to view the Report before printing, click the F8 View button:
11. Once the first page is displayed, click the print icon to send the report to the printer.

12. Alternatively, click the F6 Print button to schedule the report, and select Application > RepStartSchedule from the menu (the Scheduler must be active in order for the scheduled report to print).

All the reports give details of:

- Total of items in each category (Count is the No of Stockitems) Unique Cats is the Count of the No of Catalogues referenced by the Stockitems) – for example: there may be one Unique catalogue that has 16 Stockitems referenced.
- Total number of Issues, Reserves, Renewals and Value
- Grand totals for all locations

**REPORTS THAT GO TO EXCEL**

There are several MS Excel report templates available which can be used to save to a Windows file.

In this example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem screen:

1. Launch the Amlib client
2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
3. Click the **F1 New** button – the *Select Report Format* screen will display

4. Highlight the **&XSTKCSV.QRP** file and click the **Select** button – a new entry will appear in the *Stockitem Reports* table

5. Type in an appropriate **Description** – for example: *Harry Potter Items*

6. Click the **F3 Save** button

7. Highlight the report and click the **F7 Where** button – the *Stockitem Reports – Where* screen will display

8. Enter an appropriate search condition(s) – for example: *Title LIKE Harry Potter*

9. Click the **F3 Save** button

10. Highlight the report and click the **F9 Order** button – the *Stockitem Reports – Order By* screen will display

11. Use the arrow keys to add fields to the *Order By* column – for example: *Title | ASC* using the arrow keys

12. Click the **F3 Save** button

13. From the menu, select **Application > RepStartSchedule** – the Report Scheduler prompt will display:

![Report Scheduler](image)

14. Ensure that **Save to File** is ticked and click the **OK** button
15. Highlight the report and click the **F6 Print** button – the **Print** screen will display:

![Print Screen]

16. Change the **To:** option to **File** and click the **OK** button – the **Report – Save As** dialogue box will display:

![Report - Save As]

17. **Save As** options:
   
a. To save it for a **Word** document, leave the **Save as type:** as **Rich Text Format (RTF)**
   
b. To be able to open it in **Excel**, change the **Save as type:** to **Text Document**

18. You can check the progress of your report in by selecting **Reports > RepPrintProgress** from the menu

19. If you’ve saved the report to open in **Excel** (Text Document) then you will need to follow these steps so it is displayed correctly:
   
a. Open **MS Excel**
   
b. Use **File > Open** to open the text file you’ve saved – ensure that the **Files of type:** = **All Files (*.*)**
   
c. The **Text Import Wizard** will open
d. Excel will recognise your file as **Delimited**, so click the **Next** button

e. **Delimiters**: select **Semicolon** and add a pipe | in the **Other** box

f. Click the **Next** button and then the **Finish** button

20. Your data will be transferred into the Excel sheet and you can now use the formatting tools to customise it:
ILLs Reports

- ILL Email Reminder (&ILLEREM.QRP)
- ILL Email Reminder – All Suppliers (&ILLERMS.QRP)
- ILL Email Request (&ILLEREQ.QRP)
- ILL Email Request – All Suppliers (&ILLERQS.QRP)

Stockitems Reports

- To Excel – Count by Form (&XSTKFS.QRP)
- To Excel – Count by Location & Stats (&XSTKCLS.QRP)
- To Excel – Count by Stats Code (&XSTKCS.QRP)
- To Excel – Stockitem List – Title Author Call No Form Stats (&XSTCSV.QRP)

Audit Reports

System Settings

The Audit must be switched on first, before the data can be collected. To check this:

1. Go to Main > Supervisor > Installation > Other tab
2. There are several types of audit:
   - Create an audit for all Authorities (Y/N)
   - Create an audit for all Borrowers (Y/N)
   - Create an audit for all issues prompted with messages (Y/N)
   - Create an audit for all Stockitems (Y/N)
3. If you would like to keep audit details, ensure that these are set to Y (particularly the last)
4. Make sure you also check your settings by individual Location:
   a. Select Installation > Choose Location
   b. Select location and click on the OK button
   c. Select the Other tab

Please Note: Any record/s that were deleted, inserted or updated prior to the audit being switched on will not be recorded.
Creating a Stockitem Audit Report

1. Go to **Main > Reports > RepStockitem** – the **Stockitem Reports** screen will display

2. Click the **F1 New** button

3. Highlight an audit template – brief (**&SADBR.QRP**), medium (**&SADDET.QRP**) or full details (**&STKAUD.QRP**) – and click the **Select** button

4. Type in a **Report Description** – for example: **Audit 2010**

5. Ensure the **Create Fin (Y/N)** column is set to **N**

6. Click the **F3 Save** button
7. Highlight the report and click the F7 Where button – the Stockitem Reports – Where screen will display

8. Enter your Where parameters – there are three audit types:
   - D: Deleted
   - I: Inserted
   - U: Updated

   The Where parameters will depend on what you are after. Typically you would set the Audit Date and Audit Type (I/U/D) parameters, and perhaps PermLoc (Permanent Location).

9. Select the F3 Save button when complete

10. (Optional) Click the F9 Order button – you can then set the order for the report to print in.

    You can sort by Audit Date and Title (or vice versa if you’re looking for a particular item).

    Click the F3 Save button when complete.
11. Click F8 View to view the report

12. Select the print icon to print the report

**Items Never borrowed (Dusty Items)**

Create Report

1. Go to **Main > Reports > RepStockitem** – the Stockitem Reports screen will display

2. Select the F1 New button – the Select Report Format screen will display

3. Highlight the report template you would like to use – if you want to use Last Active date then try &STKTITL.QRP. If you would like to search against the History Type/Date then use one of the history count templates (**&STKHCQRP** or **&STKHCSC.QRP**)

4. Click the OK button

5. Type in a Report Description – for example: **Items Never Borrowed**

6. Ensure the Create Fin (Y/N) column is set to N
7. Click the **F3 Save** button

**Where Search and Order By Parameters**

1. Highlight the report and select the **F7 Where** button – the Stockitem Reports – Where screen will display.

2. Never Borrowed: enter the following Where search:
   
   a. **Item No IS NOT NULL**
   
   b. **Times Borrowed < 1**
   
   c. **IsOnLoan = N**
   
   d. **PermLoc = (optional)**
   
   e. **Form = (optional)**
   
   f. **StatsCode = (optional)**
3. Last Borrowed: enter the following Where search:
   a. Item No IS NOT NULL
   b. LastActive <= Current Date – 12 Months (via the Special button)
   c. PermLoc = (optional)
   d. Form = (optional)
   e. StatsCode = (optional)

4. Last Borrowed by History: enter the following Where search:
   a. Item No IS NOT NULL
   b. History Type IN ISSUE,RETURN (or History Type = ISSUE if you just want to count when an item last went out)
      You can use ISSUE, RENEW OR RETURN
   c. If using History Type = Issue, you may want to exclude any alterations made to the due date after renewals: History Contents NOT LIKE Due Date Altered
   d. History Date <= Current Date – 12 months (via the Special button)
   e. PermLoc = (optional)
   f. You can further restrict your list to a particular Form or Stats Code - for example:
      Form = DVD or StatsCode = FIC

5. Click the F3 Save button when complete

6. Select the F9 Order button – the Stockitem Reports – Order By screen will display

7. Use the arrow keys to enter the following Order By statement (&STKTITL.QRP only):
   a. Call Number ASC
   b. Click the F3 Save button when complete

View Report

1. Highlight the report you wish to run and select the F8 View button

2. A prompt with the following message will display: This type of report may use a Saved File as the Source. Do you want to select the file now?

   ![Select File for View](image)

3. If you would like the report to run using the entire database (rather than a Saved List) then select the No button
4. The report will then display:

<table>
<thead>
<tr>
<th>Item Number</th>
<th>Item Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>980470914</td>
<td>Arabian nights' entertainments / edited with an Introduction by Robert L. Mack</td>
</tr>
<tr>
<td>980472349</td>
<td>Help your child with reading and writing: A parents' handbook / Lesley Clark</td>
</tr>
<tr>
<td>980475101</td>
<td>Teach yourself Turkish / G.L. Lewis</td>
</tr>
<tr>
<td>980471370</td>
<td>Macquarie Aboriginal naming book: an Australian guide to naming your home or boat</td>
</tr>
</tbody>
</table>

5. Select the **print** button to print the report

**APPENDIX 1: SAVED FILES**

The *Amlib* client allows the use of various Saved Files (a file containing a list of patrons, stockitems, catalogue records, etc).

A **File** menu is available in many modules – for example: **Borrower**, **Stockitem** and **Catalogue**.

These Saved Files can be useful for global changes – for example: Altering Class and Types at the beginning of the year, changing **Juniors** to be **Young Adults**, etc. They can also be used to change items *en masse* to be Closed Reserve or to have a certain Process. Catalogue Files can be given a particular Authority – for example: **Subject Heading**. They can also be used to check or report on newly imported records for Borrowers or Stockitems.

Saved Files can also be used for reporting purposes. For example: return a file of books, (**General** > **ReturnFromFile**) or to print Spine Labels using a list of items contained in the Saved File, etc.

It is even possible to loan out a Saved File – for example: **The Environment File** which may contain 25 books, 3 DVDs and 5 flash drives all on the Environment theme.

They can also be used for Periodical Circulation Lists.

There are many functions within the *Amlib* client that use (or can use) a Saved File as part of the process.

This includes the following:
• Reports
• Mass updates
• Catalogue Maintenance tasks
• Subscription Circulation Lists
• Marc record importing

Saved Files can be created in the following modules:

• Authorities
• Borrower
• Catalogue
• Stockitem

Create a Saved File

Please Note: Many saved files are created as part of another process. The following shows you how to create a Saved File independently of a process.

1. Launch the Amlib client
2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > Stockitem)
3. From the menu, select File > DisplayFile

4. The Stockitem Saved Query Results screen will display:
5. Click the **F1 New** button

6. Type a description in the **Details** column – for example: **Harry Potter Books**

7. **Allow other operators to access this file (Y/N):** enter a **Y** (for **Yes**) or **N** (for **No**) – the default is **Y**

8. Click the **F3 Save** button when complete

The Saved File has been created and is now ready for use.
Create (or Save to) a Saved File from a List

Please Note: Many saved files are created as part of another process. The following shows you how to create a Saved File as part of a search.

1. Launch the Amlib client

2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > Stockitem)

3. Enter your search parameters and click the **F5 Query** button

4. The results will display in a List:
5. Select the items you would like to Save to File – use your mouse to **highlight** a *single* item, or hold down the **Ctrl** key and use your mouse to **highlight** *multiple* items (if saving ALL items, then there is no need to select anything)

6. From the menu, select **File > SavedMarked** (if you would like to save ALL items, then select **File > SaveAll**)

7. The **Stockitem Saved Query Results** screen will display:
8. It is possible to add the selected items to an existing Saved File or to create a new Saved File as follows:
   a. Click the F1 New button
   b. Type a description in the Details column – for example: **Harry Potter Books**
   c. **Allow other operators to access this file** (Y/N): enter a Y (for Yes) or N (for No) – the default is Y
   d. Click the F3 Save button when complete

9. Highlight the Saved File you would like to use and click the F9 Select button
   **Please Note:** If selecting an existing Saved File, it is possible to delete the pre-existing saved items from the file by clicking the F2 Empty button

10. A prompt will display with the following message: **The 'XXX' file contains XX stockitems.**

The selected items have now been saved to file.
Save a Single Item

Please Note: It is possible to save the item currently being displayed to a Saved File.

1. Launch the Amlib client
2. Navigate to the appropriate module – for example: Stockitem (Main > StockItems > Stockitem)
3. Locate and display the item to be saved
4. From the menu, select File > AddToNewFile

5. The Stockitem Saved Query Results screen will display:

6. It is possible to add the selected items to an existing Saved File or to create a new Saved File as follows:
   a. Click the F1 New button
   b. Type a description in the Details column – for example: Harry Potter Books
c. Allow other operators to access this file (Y/N): enter a Y (for Yes) or N (for No) – the default is Y

![Image of Stockitem Saved Query Results]

The selected item has now been saved to file.

View an Existing Saved File

1. Launch the Amlib client

2. Navigate to the appropriate module – for example: **Stockitem (Main > StockItems > Stockitem)**

3. From the menu, select **File > DisplayFile** – the Stockitem Saved Query Results screen will display:

   ![Image of Stockitem Saved Query Results]

4. Highlight a Saved File and click the **F9 Select** button – the results will display in a List:

   ![Image of Stockitem List - 20 rows - Harry Potter Books]