# TABLE OF CONTENTS

OVERVIEW .................................................................................................................. 6

STOCKTAKE – STEPS IN THE PROCESS ........................................................................ 7

PREPARING FOR A STOCKTAKE .................................................................................. 8
  Stocktaking Decisions............................................................................................... 8

ITEMS WITHOUT CALL NUMBERS ............................................................................ 9
  Locate Items without Call Numbers ....................................................................... 9
  Save the Where Search ......................................................................................... 10
  Stockitem Wand Change ....................................................................................... 10

BEGINNING A NEW STOCKTAKE ............................................................................. 13
  New Stocktake in Progress ................................................................................... 13
    Stocktake Range .................................................................................................. 13
    Count in Theory ................................................................................................... 15
  Grouping Stocktakes .............................................................................................. 15
    Fiction/Non-Fiction .............................................................................................. 16

SET FLAGS (CLEAR PREVIOUS STOCKTAKE DATE FROM ITEM HISTORY) .............. 17
  General Information .............................................................................................. 17
  To Set the Flags ..................................................................................................... 18

COUNTING ITEMS .................................................................................................... 18
  Circulation Module (Issue/Returns) ....................................................................... 19
  Stocktake Module .................................................................................................. 19

ONLINE STOCKTAKE ............................................................................................... 20
  On Line Counting .................................................................................................. 20
    Barcode Errors .................................................................................................... 21
    Actual Count ........................................................................................................ 21

OFFLINE COUNTING ................................................................................................. 22
  Portable Barcode Reader or Scanning Device .......................................................... 22

BARCODE ERROR STATUSES ENCOUNTERED ...................................................... 23
  Not in the Database Items ..................................................................................... 23
  Invalid Check Digit ............................................................................................... 24
  Out of Range .......................................................................................................... 24
  Part of Other Stocktake ......................................................................................... 24

REPORTING ON MISSING ITEMS .......................................................................... 25
  Check Individual Items .......................................................................................... 25
  Reports .................................................................................................................... 25
APPENDIX A: STOCKITEM WAND CHANGE BUTTONS

OTHER WHERE SEARCHES

CLOSING OFF THE STOCKTAKE

OTHER WHERE SEARCHES

APPENDIX A: STOCKITEM WAND CHANGE BUTTONS

APPENDIX 2: OFFLINE MODULE FACILITY
APPENDIX 3: OTHER USEFUL REPORTS

Counts of Collections (Where Search) .............................................................. 52
Save Where Search ............................................................................................ 52
Accessing Saved Searches .................................................................................. 52
Opac Form Description (Form/Stats Combination Counts) .................................. 53
Call Set Count Report ......................................................................................... 54
Statistics (Summary) ........................................................................................... 56
Stats Parameters .................................................................................................. 56
Where Parameters ................................................................................................ 56
Order Parameters .................................................................................................. 57
Statistics Detailed Report .................................................................................... 58
Report Formats for Stockitem Counts ................................................................. 58
Procedure to Save reports as .Txt File and Import into Excel ............................... 59
Never Borrowed (via Stockitem Where) ............................................................... 62
Last Borrowed 12 Months Ago (via Stockitem Where) ......................................... 62
Usage Reports ...................................................................................................... 62
Sending List of Barcodes to SLWA (W.A. Public Libraries) .................................. 65
OVERVIEW

Purpose of a Stocktake

Are run for Library management purposes to determine whether the data on the database of the computer reflects the items on the shelves and vice versa.

Stocktakes are conducted from the Stockitem module and simply populates the Stocktake Field in the History window as each item is counted.

Stocktake Range

A Stocktake is initiated by creating an entry in the Stock Takes table. The counting is based on a range of user-defined parameters. This is usually Call Numbers (Line 6).

It is possible to set a new Stocktake range for the whole collection but only report on a small section of the library. For example, the report parameters can be set to view only the missing items in a particular location –i.e: Fiction only, Junior Fiction only, Non-Fiction Call No’s up to the 400s, Junior Campus, Chelsea Branch only, etc.

Loaning and Returning

Items issued or returned during the Stocktake will have their flags set to count. Therefore, it is not essential to recall all items for stocktaking purposes. Creating a separate report can identify items on loan that have not been counted, if necessary.

Stocktake Date in History of Item

Before commencing the Stocktake, this field can be cleared if desired, by Setting Flags. It is important that this option is not chosen during the Stocktake as this will clear the Stocktake Date field for all counted items!
STOCKTAKE - STEPS IN THE PROCESS

**PREPARATION FOR STOCKTAKE**
- Are there any items without Call Nos?
- Optional Mass change to give a Call No

**SET STOCKTAKE RANGE AND CLEAR FLAGS**
- Set Call No Ranges for Stocktake
- Optional Clear Flags – deletes Stocktake dates in Stockitem

**COUNTING**
- Online using Upload button
- Offline from a File (e.g. Text file) and then using Upload

**REPORTING MISSING ITEMS**
Where Searches – save these. Could include:
- Missing items
- Missing items already Missing e.g. from last year
- Items Counted
- Print Reports from the Table Menu

**CHECKING MISSING ITEMS**
- From Printed lists

**MASS CHANGE OF MISSING ITEMS**
- Create a New Process e.g. Missing Stk 2015
- Use Stockwand Change, accessing Saved Where Searches

**MASS DELETE OF ITEMS ALREADY MISSING**
- Optional Delete from Saved Where search of items already Missing
PREPARING FOR A STOCKTAKE

Stocktaking Decisions

- How will the counting be done?
  Wireless Scanner, RFID readers, Portable barcode readers, laptops, PCs, etc.

- Which parts of the stock is to be counted?
  All items, fiction only, all items excluding periodicals, a certain Location, DVDs, CD-ROMs and Digital Collections etc.? This will be important when the reports are created.

- What about items on loan?
  These will be counted if they are returned during the Stocktake period. You will not want the outstanding items to be made Missing but you may want to get a listing of them, particularly long term loans.

- When is the best time to do the Stocktake?
  Least disruption to services. Staff involved etc.

  Portable scanners have less impact on the client base as there are no cords to trip over or bulky items to move around.

  As the items that are issued are also counted, there is no need to actually halt lending practices.

- How long will the Stocktake take?
  This is always difficult to answer, as the counting may only take a few days but sorting out the mysteries is the lengthiest process in a Stocktake.

  If the time between the actual counting and reporting of missing items is lengthy, it is possible to set a date received in the reports, so that new items within this period will not have to be counted and will not display as missing.

- Which locations are to be included in the Stocktake? Are there other locations that can be impacted by the Stocktake preparation?
  If the flags are set, it clears the Stocktake date from ALL Stockitems. Therefore if the Library site is a multi-campus site, it may be safer not to clear the flags (dates), but have the Stocktake reports show the dates prior to when the Stocktake was commenced.
ITEMS WITHOUT CALL NUMBERS

Stocktake counting is usually based on Call Numbers of Stock items. There may be some items which – for whatever reason – may not have a call number.

Items without Call Numbers will not be included in the Count in Theory and will not be included in the Stocktake because they are “Out of Call Number range”.

Therefore, it will be necessary to assign these items a call number for stocktaking purposes (if only temporarily).

Locate Items without Call Numbers

1. Launch the Amlib client
2. Go to Main > StockItems > StockitemWhere – the Where Search screen will display:

3. Enter the following Where statement: Call Number IS NULL
   a. In box 1, select Call Number
   b. In box 2, select =
4. Click the Paste button (without entering a value in box 3)
Save the Where Search

It is possible to save the above Where Search for future use:

1. Click the F2 Insert button – the Saved Queries screen will display:

![Saved Queries Screen]

2. Type a Description in the box at the bottom of the screen – for example: Items without Call Nos

3. Click the F3 Save button – a prompt with the following message will display: The Query File has been created.

4. Click the OK button

Stockitem Wand Change

A Mass Update can then be performed which will insert a “dummy” call number (for example: XXX) into each stockitem. These call numbers can then be deleted/changed at a later date.

1. Launch the Amlib client

2. Go to Main > StockItems > StockitemWandChange - the Stockitem Wand Change screen will display:

![Stockitem Wand Change Screen]
3. Enter the following Where statement:
   a. In box 1, select **Call Number**
   b. In box 2, type **XXX** (or whatever the dummy call number is to be)

4. Click the **Paste** button

5. Click the **F8 FrWhere** button – the **Saved Queries** screen will display:

5. Select the **Where Search** saved previously – for example: **Items without Call Nos**

6. Click the **F9 Execute** button – a prompt with the following message will display:
   The XXX Stockitems found using the 'ITEMS WITHOUT CALL NOS' Saved Where Search will be Massed Changed. Change:
   1. Call Number to 'XXX'
   Proceed with Mass Change from Saved Where?

7. Click the **Yes** button

8. The items will be processed – a prompt with the following message will display when complete:
   The XX Stockitems have been Updated.

9. Click the **OK** button
Please Note: Processes are able to be saved by clicking the F2 Insert button. These can then be chosen again using the F4 Select button and the list of saved queries will display.

![Stock Wand Change Image]

Please Note: If all the buttons are not available across the top of the Stock Wand Change screen, these can be made available to the user via the Supervisor module.

- See Appendix A: Stockitem Wand Change Buttons for more information
BEGINNING A NEW STOCKTAKE

New Stocktake in Progress

1. Launch the Amilb client

2. Go to Main > StockItems > StockTake – the Stocktakes In Progress screen will display:

   ![Stocktake screenshot]

   **NOTE**: USE KEY FORMATS for FROM & TO

3. Click the F1 New button – a new line will be added to the table with the following settings:
   
   a. Ref. No. (Reference Number): this will be automatically generated
   
   b. The Closed column will be set to N (this means the Stocktake is active)
   
   c. The Data Line will default to 6 (this refers Line 6 of the stockitem record – which is usually the field containing the Call Number – and is the field we recommend you use for testing your KEY Data against)

Stocktake Range

4. Enter the KEY Data From and To range of parameters for the Stocktake – for example:

   - From: 0 To: ZZZ (for ALL items) [recommended]
   - From: 000 To: 999 ZZZ (for all non-fiction items)
   - From: AAA To: ZZZ ZZZ (for all fiction items)
5. Click the **F3 Save** button when complete

**Please Note:** Some non-fiction items sometimes have a letter in front of their call number (for example: **A820** for Australian Literature). These items would not be included in the following example number range: **From: 000 To: 899 ZZZ**. We recommend setting up a separate Stocktake line to account for these items (see **Grouping Stocktakes** below).
Count in Theory

- Once the range has been saved, the Count in Theory number displays:

![Image of Stocktake interface]

- This is the system count of items within that range that should exist in the database
- As items are counted, the number in the Actual Count increases to reflect those counted
- It also sets a Stocktake Started date:

![Image of Stocktake interface]

Grouping Stocktakes

It is possible to run multiple simultaneous Stocktakes, each capturing Stocktake information on a particular part of the collection.

Stocktake can be set by Call Numbers categories – as the following example shows:
### Fiction/Non-Fiction

#### Stocktake in Progress

**On Line / Off Line Counting progress**

If you are using Group Security then only your group counts will show.

<table>
<thead>
<tr>
<th>Ref No</th>
<th>Closed</th>
<th>Data Line</th>
<th>Key Data From</th>
<th>Key Data To</th>
<th>Count in Theory</th>
<th>Actual Count</th>
<th>Started</th>
<th>Latest</th>
<th>Last Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>N</td>
<td>6</td>
<td>200</td>
<td>300</td>
<td>421</td>
<td>122</td>
<td>18/07/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>N</td>
<td>6</td>
<td>300</td>
<td>500</td>
<td>1252</td>
<td>173</td>
<td>18/07/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>N</td>
<td>6</td>
<td>500</td>
<td>700</td>
<td>4035</td>
<td>272</td>
<td>18/07/2003</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>N</td>
<td>6</td>
<td>700</td>
<td>999</td>
<td>544</td>
<td>340</td>
<td>18/07/2003</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Stocktake in Progress**

**On Line / Off Line Counting progress**

If you are using Group Security then only your group counts will show.

<table>
<thead>
<tr>
<th>Ref No</th>
<th>Closed</th>
<th>Data Line</th>
<th>Key Data From</th>
<th>Key Data To</th>
<th>Count in Theory</th>
<th>Actual Count</th>
<th>Started</th>
<th>Latest</th>
<th>Last Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>N</td>
<td>6</td>
<td>0</td>
<td>999 ZZZ</td>
<td>1121</td>
<td>0</td>
<td>14/10/2011</td>
<td>20/10/2011</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>N</td>
<td>6</td>
<td>A</td>
<td>ZZZ</td>
<td>4035</td>
<td>0</td>
<td>14/10/2011</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
SET FLAGS (CLEAR PREVIOUS STOCKTAKE DATE FROM ITEM HISTORY)

General Information

- Each stock item counted during a Stocktake is flagged with a StockTake date (the date that it was counted). This can be seen in the Stockitem Circulation History screen of each item:

  1. Launch the Amlib client
  2. Go to Main > StockItems > Stockitem – the Stockitem screen will display
  3. Enter a search for an item
  4. Once the item is displayed, from the menu, select: Item > History – the Stockitem Circulation History screen will display:

- The date that the item was last counted in a Stocktake displays in the StockTake field (displayed above)
- The Set Flags process removes any pre-existing StockTake dates from the items in the system (by replacing it with a null value), ready for a new Stocktake
- This makes it easier to detect the items not counted in the Stocktake, which helps make the reporting process easier (as the user is only checking for a NULL StockTake date value, rather than a specific range of dates)
- If the flags are NOT set, the report must use the LastStockTake date parameter to measure a specific date range in order to locate items missing prior to the start of the current Stocktake
- The Set Flags process can be done at the beginning of each new Stocktake (if desired). The time this takes depends on the number of the items in the range selected
- The Set Flags process only clears the StockTake dates for the chosen range of Call Numbers
- It is not possible to Set Flags for only one location, so before setting flags check that no other location is performing a Stocktake (for multi-campus sites it may be preferable NOT to set flags)
To Set the Flags

Please Note: DO NOT set the flags at any other time than the beginning of the Stocktake as this “wipes” the slate clean for those items already counted.

1. Launch the Amlib client
2. Go to Main > StockItems > StockTake – the Stocktakes in Progress screen will display
3. Highlight the Stocktake range in the table
4. Select the F7 SetFlags button – a prompt with the following message will display:

Are you sure you wish to prepare items within the highlighted Line for Stocktake?
If you answer YES then this also means that the last date checked will also be removed from all items in the selected range!!
NB …………. Circulation windows will not recognize any new Stock Take Groups until those applications are re-entered.

6. Click the Yes button if you wish to continue

Please Note: All circulation users will need to Log Out and back into any Circulation module screen (Issues, Returns, etc) so that the system can be made “aware” that a range has been set for circulation counting.

COUNTING ITEMS

Counting of items is performed using day-to-day circulation, as well as deliberate counting within the Stocktake module.
Circulation Module (Issue/Returns)

Once the Stocktake entry has been set, any return or issue of the item will result in the item being counted on that date (renewals do not count items).

Stocktake Module

There are two options for counting:

1. Offline circulation: this is the ability to download data from a portable barcode reader or from a File
2. Online circulation: this is the ability to wand items directly into the application and count “live”

Both can be conducted at the same time. For example: both Offline files of barcodes and Online barcodes can be wanded through the F8 Upload option.

Both options will alert the user to items that are outside of the specified range:

- If the Stocktake Range for the Call No has been set, but is not the current Range, an Out of Range message will display:

- If the Stocktake Range has not been set, a Part of other Stock Take message will display:
ONLINE STOCKTAKE

On Line Counting

1. Launch the *Amlib* client

2. Go to **Main > StockItems > StockTake** – the *Stocktakes in Progress* screen will display:

![Stocktake in Progress Screen](image)

3. Highlight the data line and select the **F8 Upload** button – the *Stock Counting* screen will display:

![Stock Counting Screen](image)

4. Wand each barcode into the **Bar Code** field

5. Watch the screen for any change of colour on the listing:

   - **Black**: No errors, and in the Stocktake Range
   - **Red**: Error
   - **Blue**: Not in Range
Barcode Errors

1. Any Barcode errors encountered will display as follows – for example: Not in Database

![Barcode Errors Example](image1)

2. A prompt will display: XX of the wanded items are not in the database. Do you want to save these items to a file of missing items?

![Barcode Error Prompt](image2)

3. Usually the Yes button is chosen in case a list is required later

Actual Count

As the items are counted, the Stocktakes in Progress table is updated to show the Actual Count:

![Actual Count](image3)
OFFLINE COUNTING

Performed by wanding items by:

- Using a portable barcode reader or scanner device
- The Offline module
- Saved into a text file

Portable Barcode Reader or Scanning Device

A Portable barcode wand/scanner enables the operator to scan the barcodes of the items at the shelf.

1. Clear the barcode reader so that there are no scans in the memory (follow the manufacturer’s instructions for this)
2. Scan the barcodes of the items: each device has a set amount of memory but the download can be done at any time convenient for example, after a bay of books is complete
3. Download into Amlib:
   a. Launch Amlib client
   b. Go to Main > StockItems > StockTake – the Stocktakes in Progress screen will display
   c. Click the F8 Upload button – the Stock Counting screen will display:
   d. Put the cursor in the Bar Code field and begin the download process (you will need to follow the manufacturer’s instruction for this)

Please Note: It is possible to download the items wanded from the device and save as a text file which can then be uploaded into the Stocktake – see: Load Barcodes (Items Numbers) from a Text File.
BARCODE ERROR STATUSES ENCOUNTERED

The barcode entered is **Not in Database** OR has **Invalid Check Digit** so **Amlib** cannot give the Title, Call number, etc.

1. It is possible to find the item by checking the item previously wanded, and checking the Call No.

![Barcode Error Statuses Encountered](image)

2. It is likely to be the next item on the shelf. Take note of the barcode for checking.

3. Select the [X] to close the window – a prompt with the following message will display: **XX of the wanded items are not in the database. Do you want to save these items to a file of missing items?**

![Stock Take - Missing Items](image)

4. Click the **Yes** button to save these items to a missing items folder to be checked later

**Not in the Database Items**

A list of barcodes not in the database can be seen in **Query Analyser for SQL Server sites**. A query string will bring up a list of unidentified item barcodes:

**Query Analyser (for SQL Server sites only)**

1. On the server locate **Query Analyser**
2. Logon as **SYSADM**
3. Select **AMLIB** from the database drop-down
4. Enter the script (note the different date format)
5. Select * from stk_check_miss where stk_date > '14 Sep 2015'
6. Click on the green arrow or press <F5> to execute the script
7. A list of barcodes that did not match an item on the database will display:

<table>
<thead>
<tr>
<th>STR_ITEM_NO</th>
<th>STR_DATE</th>
</tr>
</thead>
<tbody>
<tr>
<td>02145347735</td>
<td>21-MAY-2004</td>
</tr>
</tbody>
</table>

**Invalid Check Digit**

The barcode entered does not match the barcode validations set up in **Main > Supervisor > CheckDigits**.

If the barcode is a legitimate barcode and is to be used, ensure that a validation is set up correctly in the **Check Digits** table.

**Out of Range**

The barcode scanned is not in the range set for the current Stocktake. If the range does not exist, then the item is not counted.

**Part of Other Stocktake**

The barcode scanned is not in the range selected for the current Stocktake line but is within another range that has been set. If the range exists, it will still be counted and the date registered in the History of the item:
REPORTING ON MISSING ITEMS

Check Individual Items

Individual items can be checked from the Main> Stockitems > Stockitem - Item > History. This screen displays the last StockTake date. If the flags have been set, this will be empty (until counted). This is the field that is updated if the item has been wanded using Offline, Online, on Issue or on Return.

![Stockitem Circulation History](image)

Reports

Reports can be done either via a Where Search or set up as a Stockitem Report.

Recommended Where Searches for Stocktake missing items:

- They can be saved and adapted to report various sections of the database, for example, Missing NF can be set up for Call Numbers > 0 and < 299 ZZZ, saved and adapted for Call Numbers > 300 and < 499 ZZZ
- The same report can be viewed as a Count, a Query table or QueryInto File
- When the items are to be changed (for example: to Missing 2011) as a Process, then a Stockitem Wand Change can be used to save the Where Search or File created:

![Stockitem Where Search - STAFF at Chelsea Library](image)
Where Statement

The Where Clauses used will depend on the site and the report required. The most important Where clauses will be Stocktake Date is NULL. Other conditions to include could be:

- Location – for example: Branch, Campus, Dept, LIB only, etc
- Stats Code – for example: JF (Junior Fiction) only
- Form Code – for example: BK (Books) only
- Loan Status – for example: On Loan = N
- Call Number range – for example: F AAA to F CZZ
- Item received by date – for example: Items received before Stocktake started
- Process – for example: exclude Damaged or Missing
- On Order – for example: exclude On Order items
- InterLibrary Loan – for example: exclude all ILLs

This table contains a list of column names from which to choose (use the scroll bar to move up and down this list):

<table>
<thead>
<tr>
<th>OPERATOR</th>
<th>DESCRIPTION</th>
<th>EXAMPLE</th>
</tr>
</thead>
<tbody>
<tr>
<td>LIKE</td>
<td>Where the required data in this field begins with the text entered</td>
<td>LIKE ELD (for Eldorado)</td>
</tr>
<tr>
<td>LIKE</td>
<td>Where the required data in this field does not begin with the text entered</td>
<td>LIKE ELD (for all except Eldorado)</td>
</tr>
<tr>
<td>IN</td>
<td>Useful for multi-selections of codes</td>
<td>IN F,JF (for all Fiction, Junior Fiction)</td>
</tr>
<tr>
<td>IN</td>
<td>Useful for multi-selections of data not to be included.</td>
<td>IN F,JF (to exclude these codes)</td>
</tr>
<tr>
<td>=</td>
<td>Where the text entered is exactly equal to the data required</td>
<td>= BK (for only this Form)</td>
</tr>
<tr>
<td>≠</td>
<td>Where the text entered is not equal to the data required. Useful for “not equal to null” – choose this operator but do not enter any data and press paste</td>
<td>≠ BK (to exclude the Form of BK)</td>
</tr>
<tr>
<td>&lt;</td>
<td>Where the text entered is less than the data required</td>
<td>&lt; 01/10/15 (less than 1 October 2015)</td>
</tr>
<tr>
<td>≤</td>
<td>Where the text entered is equal or less than the data required</td>
<td>≤ 01/10/15 (less than or equal to 1 October 2015)</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>&gt;01/10/15 (greater than 1 October 2015)</td>
</tr>
<tr>
<td>≥</td>
<td>Equal or greater than the text entered</td>
<td>≥ 01/10/15 (greater than or equal to 1 October 2015)</td>
</tr>
</tbody>
</table>
1. Type the Where Condition (box 1)

2. Choose an Operator (box 2)

3. Type your search term for the chosen field (box 3) OR use the Special button, which enables you to choose useful fields (for example: Current Date) that can be used for any mathematical operand (for example: =, ≠, <, ≤, >, ≥)

4. Click the Paste button to add in each statement

**Description of buttons:**

<table>
<thead>
<tr>
<th>BUTTON</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>Adds the Where Condition to the Query box</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the Highlighted Where Condition from the Query box</td>
</tr>
<tr>
<td>And</td>
<td>Includes the “and” separator to the multiple Where Conditions in the Query box. This is the default</td>
</tr>
<tr>
<td>Or</td>
<td>Includes the “or” separator to the multiple Where Conditions in the Query box</td>
</tr>
<tr>
<td>(</td>
<td>Adds a beginning bracket to the Where Condition in the Query box</td>
</tr>
<tr>
<td>)</td>
<td>Adds a closing bracket to the Where Condition in the Query box</td>
</tr>
</tbody>
</table>

**Get Your Results**

- Click the F5 Query button to view the records contained in the Query
- Click the F6 Count button to Display the number of matching records
- Click the F7 QtoFile button to save the results of the query in a file. Either select a file or create a new file and then click the F9 Select button. The number of records inserted into the file will be displayed. If the file already contains data the new records will be added to the file and existing data remains. It is possible to empty the contents of the file by selecting the F2 Empty button before selecting the file:
Saving Where Searches

1. Where searches can be saved by selecting the **F2 Insert** button
2. Type a **Description** so that they can be recalled for execution at another time from Stockitem (Item menu)

Alternatively the search can be saved from the **Where Search** screen by choosing the **F4 Select** button. This is useful for calling up queries used on a regular basis and can be used when updating Process to **MISSING** in Stockitem Wand Change.

It is also very useful for **Stocktake Reports** as the parameters can be set and then altered slightly for a different area of Stocktake – for example: the **Missing Fiction Where search** can be edited when the non-fiction area is counted – just change the **Stats code** to be **NF** rather than **F**.

Accessing the Saved Searches

Saved Where Searches can be accessed either through:

- The **Where Search Window** by clicking the **F4 Select** button OR
- From the Stockitem screen menu, select **Item > SavedWhereSearch** (the searches can be executed or counted from this option)
- Reports cannot be edited here; editing is only done within the **Where Application**

Printing a List

A printed listing of missing items is usually required so they can be checked on the shelf.

1. From the table of items generated from the **Where Search** (by using **F5 Query**) highlight the items to be included in the report
2. Click the **F6** (to print) or **F7** (to report) key on your keyboard OR from the **Amlib** client menu, select **Table > Print** or **Table > Report**

**F6 Print**

This is a preset Format, giving details of each item.
F7 Report

All the available templates for Reports will display, where a specific style can be chosen.

1. In many templates, the heading can be typed in the Report Description:

![Image of Report Description]

To select the sequence in which the items display (for example: Call No):

2. Select the F9 Order button – the Order By screen will display

![Image of Order By screen]

3. Highlight the item to order by in the Columns list, click the arrow to add to the Order By list

4. Click the F3 Save button
To View/Print:

5. Click the **F8 View** button

![Image of Stocktake Report]

**Check the Shelves:**

6. The Report can then be printed by using the **Print** icon

7. The shelves can then be checked for missing items, using the Report as a guide as to those items to be searched

8. If an item is found it can be wanded into the **F8 Upload** button of Stocktake or **Returned** through circulation
MASS CHANGING MISSING ITEMS

Identify Missing Items

Once the shelves have been checked and the items showing on the where search are definitely missing, the database can be updated to show them as missing.

A decision as to how to identify these missing items on the system needs to be made. It is suggested that a Stockitem process be made to show that they were made missing during Stocktake – for example: **MISSING STOCKTAKE 2015** or similar. Some sites may choose to identify them by giving them a different location, etc.

**Please Note:** If it is a new Process (for example: **MISSING STK**) you will need to add this as a new Process (Main > StockItems > Stockitem - Application > StockProcess). If you want a new Floor Location add this in (Main > StockItems > Stockitem - Application > StockLocFloor):

![Process Codes](image)

Methods of Mass Changing Items

There are 3 main methods for Mass Changing the items:

1. Stock Wand Change
2. Where Search (Save to File)
3. Mass Delete of items Missing from Last Stocktake

Each will be documented separately and you can choose which you will use.
Stockwand Change

Advantages

Stockwand change has several advantages for mass changing items:

- The Process can be saved for further use
- The codes (for example: Process code) can be searched (for example: ? and press <Tab> in box 2)
- The change can be implemented using a saved Where search F8 FrWhere or a saved File F7 FrFile
- The Special button is available for selecting Current Date
- A clear confirmation is displayed prior to any changes, outlining the number of items and the changes that will apply

Please Note: If the buttons are not visible (for example: F8FrWhere, these can be added in Main > Supervisor > Usernames > Viewing Menu for the Login User (See Appendix A for more information).

There are three (3) options for initiating the Stockitem Wand Change process:

Option 1: Create a Stockitem Wand Change Selection Process

1. Navigate to Main > StockItems > StockitemWandChange – the Stockitem Wand Change screen will display:

   ![Stockitem Wand Change Screen]

   2. Enter your selection criteria

   Please Note: The Current Date is selected via the Special button – for example: Process Date = Current Date.

   3. Click the F6 Start button to execute the process
Save the Selection Process

1. Click the **F2 Insert** button – the **Saved Stock Wand Changes** screen will display:

   ![Saved Stock Wand Changes](image)

   - Type a description in the field at the bottom of the screen
   - Click the **F3 Save** button
   - These can then be recalled using the **F4 Select** button

Option 2: Select a Saved Where Search

1. Go to **Main > StockItems > StockitemWandChange** – the **Stockitem Wand Change** screen will display

2. Click the **F8 FrWhere** button – the **Saved Queries** screen will display:

   ![Saved Queries](image)

3. Select the **Where search** saved previously – for example: **Stocktake - Items Missing FICTION**

4. Click the **F9 Execute** button
Option 3: Select a Saved File

1. Go to Main > StockItems > Stockitem Wand Change – the Stockitem Wand Change screen will display
2. Click the F7 FrFile button – the Stockitem Saved Query Results screen will display:

![Stockitem Saved Query Results](image)

3. Select the file – for example: Stocktake 2011 – Missing Items
4. Click the F9 Select button

Execute the Changes

Once a process has been initiated (via F6 Start, F9 Execute or F9 Select):

1. A prompt with the following message will display:
   The XXXXX Stockitems found Using the ‘STOCKTAKE – ITEMS MISSING FICTION’ Saved Where Search will be Mass Changed. Change:

   1. Process to 'MISSING STK 2015'
   2. For Loan (Y/N) to 'N'
   3. Alert Oper (Y/N) to 'Y'
   4. Show Opac (Y/N) to 'N'
   5. Process Date to XXXXX 2011

   Proceed with Mass Change from Saved Where?

   ![Mass Change from Saved Where](image)

2. Click the Yes button to continue with the Update
3. When complete a prompt with the following message will display:
   The XXX Stockitems have been Updated.
4. Click the OK button
Where Search (Save to File)

An alternative to using a Saved Where search is to use a File for Mass changing missing items.

1. Launch the Amlib client
2. Go to Main > StockItems > StockitemWhere – the Stockitem Where Search screen will display
3. Set the parameters as required within the Where search – for example: Items not counted that are Videos
4. Click the F7 QtoFile button

5. The Stockitem Saved Query Results screen will display
6. Click the F1 New button
7. Add a Description – for example: Stocktake – Items Missing Video Items
8. Click the F3 Save button when complete

9. Once the file is saved, highlight the file and click the F9 Select button
10. Exit the table by selecting the red [X] in the top right hand corner
11. Navigate to Main > StockItems > Stockitem – the Stockitems screen will display
12. From the menu, select File > DisplayFile – the Stockitem Saved Query Results screen will display
13. Select the saved file previously created – for example: **Stocktake 2011 – Missing Video** Items – a Stockitem List of results will display:

![Stocktake List](image1.png)

14. From the menu, select **Table > MassItemChange** – Mass Change of Stock Within a File screen will display:

![Mass Change Screen](image2.png)

15. Enter the processes, floor locations, etc to update – for example:

- Process = MISSING
- For Loan(Y/N) = N
- Alert? = Y
- Opac? = N

16. Click the **F3 Update** button to perform the mass update

17. A prompt with the following message will display: **Update the XXX items in the 'XXXXX' file?**

18. Click the **Yes** button

**Finding an Item after the Change to Missing Process (Clear Missing Process)**

1. If an item is found after the Process is made to be Missing, go to the Stockitem screen for that particular item:
2. Delete the Process of MISSING

3. Click the F3 Update button – a prompt with the following message will display:
   The Item has been Updated.

4. Click the OK button

5. The correct Alert and Opac? will be restored, and the Process date will clear
MASS DELETE MISSING ITEMS

Identify Items to Delete

A Where search could be created for those items that had a status of **Missing** from the previous Stocktake (for example: **MISSING 2011**) and are still missing at the current Stocktake.

Once identified, these items could be Mass Deleted or have their Process mass changed to **WEED**.

![Stocktake Where Search](image.png)

**Mass Delete from Stockitem List**

Stockitems can be deleted “en masse” by creating a table of Stockitems.

1. Launch the **Amlib** client
2. Go to **Main > StockItems > Stockitem** – the **Stockitems** screen will display
3. Perform a **F5 Query** search
4. From a resulting **Stockitem List** table, select the stockitems to be deleted by highlighting the rows (to highlight more than one Stockitem, press the **Ctrl** key and click with the left mouse button)
5. From the menu, select **Table > MassItemDeletion** – the **Mass Delete Items** prompt will display with the following options:
   a. **Items**:
      i. **Confirm Delete Item Message Required?** Do you want a confirmation prompt for each item to be deleted? (not recommended for numerous deletions)
      ii. **Last item Message for Cat Required?** Do you want to receive a message if this is the last item of a catalogue record?
b. **Catalogue:**
   i. **Delete Catalogue if Last?** If this is the last catalogue record do you want it deleted?
   ii. **Confirm Delete Cat. Message Required?** When a catalogue record is deleted do you want a confirmation prompt telling you?

c. **Catalogue File:**
   i. **If a catalogue record has no more items after an item is deleted then save in the file below (Do not choose Delete ** above !)**
   ii. **Get File** (browse to where you want this information saved to)

![Mass Delete Items dialog box](image)

6. Once you have made your selections, click the **OK** button to proceed with deletion

**Please Note:** Items on loan, reserved or with memos will **not** be deleted.
CLOSING OFF THE STOCKTAKE

Close Stocktake in Progress

Once the Stocktake mass changes have been processed, and the counting of the items issued and returned are no longer required, the Stocktake can be closed or deleted.

1. Launch the Amlib client
2. Go to Main > StockItems > StockTake – the Stocktakes in Progress screen will display
3. Highlight the Stocktake row to be closed
4. Change the Closed column to be Y (or delete the Stocktake row completely using the F4 Delete button)
5. Click the F3 Save button when complete

Set the Closed column to Y or delete the Stocktake row
OTHER WHERE SEARCHES

Items Counted

The parameters that must be set include:

1. Enter the following parameter: **Stock Take Date IS NOT NULL**
   a. In box 1: **Stock Take Date**
   b. In box 2: != (not equal to)
   c. Click the Paste button
2. Enter additional parameters as required – for example: Location, Form code, Stats code
Items Counted Today

The parameters that must be set include:

1. Enter the following parameter: **Stock Take Date = Current Date**
   a. In box 1: **Stock Take Date**
   b. In box 2: = (equals)
   c. Click the **Special** button
   d. Select **Current Date**
   e. Click the **Paste** button

2. Enter additional parameters as required – for example: Location, Form code, Stats code
Items Not Counted But On Loan

The parameters that must be set include:

1. Enter the following parameter: **Stock Take date IS NULL AND On Loan =Y**
   a. In box 1: **Stocktake Date**
   b. In box 2: \(=\) (equals)
   c. Click the **Paste** button
   d. In box 1: **On Loan**
   e. In box 2: \(=\) (equals)
   f. In box 3: type **Y**

2. Enter additional parameters as required – for example: Location, Form code, Stats code
Value of Missing Items

A useful report at the end of Stocktake, is a report on the value of Missing items.

1. Launch the Amlib client
2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
3. Click the F1 New button – the Select Report Format screen will display:

4. Select this report template: &STKCSF.QRP – Count by Form & Stats and click the Select button
5. Type in a Report Description – for example: Value of Missing Items (Stocktake 2011)

6. Click the F3Save button
7. Highlight the report and click the F7 Where button – the Where screen will display:
8. Create your **Where Statements** for your collection you want to run this report on

9. Enter the following statement: **Process = MISSING STK 2015**
   a. In box 1: **Process**
   b. In box 2: **=** (equals)
   c. In box 3: type **MISSING STK 2011** (or the appropriate Process Description)

10. Enter additional parameters as required – for example: Location, Form code, Stats code

11. Click the **F3 Save** button when complete

12. If not **greyed** out, click the **F9 Order** button – the **Order By** screen will display

13. The order must be **Form** and then **Stats Code**

14. Click the **F3 Save** button when complete

15. Click the **F8 View** button to display the Report

**Please Note:** This report will take some time to display, depending on the Where parameters selected
APPENDIX A: STOCKITEM WAND CHANGE BUTTONS

If the Stockitem Wand Change buttons are not all available, it is possible to change the user permissions to get access these extra buttons.

1. Launch the Amlib client
2. Go to Main > Supervisor > UserNames – the User Names screen will display:

3. Select the User Name (this process must be performed for each user)
4. Click the F8 Choose button – the User Security screen will display:

5. From the menu, select ViewingMenu > StockItems > StockWandChange
6. The StockWandChange buttons will display:
7. Click any **red** button to make them **green**

8. Close out of the **StockWandChange** and **User Security** screens by clicking on the red [X]

9. Exit and restart the **Amlib** client for the changes to take effect
APPENDIX 2: OFFLINE MODULE FACILITY

The Offline module can be used to create a file on a portable laptop, which can then be transferred to the server or networked PC for upload.

1. Go to your Amlib folder on your C: drive or server (for example: C:\Amlib) and locate the Offline.exe application file
2. Right-click with mouse and drag onto your desktop to create a short-cut
3. Double-click the icon – the Amlib Offline Module will launch
4. From the menu, select Standard Options > StockTake

4. A Windows dialogue box will display: the date and time displays as part of a default File name (it is possible to rename the file, but this format is usually adequate for most offline stocktake collection purposes)

5. Navigate to the location where you would like to save the file (we recommend creating a separate folder for the Offline Stocktake files)
6. Click the Save button
7. The **Offline StockTake** screen then displays (ready for you to scan in your barcodes):

![Offline StockTake screen](image)

**Please Note:** If you are capturing numerous offline barcodes across a long period of time it may be a good idea to periodically to start a new file. To change to a new file, just click the **File ?** icon and the **Windows** dialogue box will display allowing you to save to a different file.

**Check Digits**

In order for the program to correctly validate **CheckDigits** there must be a file of the name **Offline.ini** in the working directory of the PC.

1. Launch the **Amlib** client
2. Go to **Main > Supervisor > CheckDigits** – the **Check-digit Calculations** screen will display:

![Check-digit Calculations screen](image)

3. Make changes OR just click the **F3 Save** button (if nothing needs to be changed) – a prompt with the following message will display: **A new OFFLINE.INI file has been created for use with Offline Issues, Offline Returns and Offline Stocktake.**

![Update message](image)
**Please Note:** Once created, it will be in your Amlib client folder (for example: C:\Amlib\Offline.ini) for you to copy if you are using this Offline module on a different non-networked PC

4. Go to your Amlib client folder on your C: drive or server (for example: C:\Amlib) and locate the file named Offline.ini

5. Copy and paste this file (into the corresponding location) on the PC where you are using the Offline module

**Please Note:** This file is updated whenever you change the Check Digits screen in the Supervisor module.

**Load Barcodes (Item Numbers) from a Text File**

**Manually Enter Item Numbers into a Saved File**

It is possible for the barcodes to be entered directly into a text file (using WordPad or Notepad, etc). It is therefore possible for a staff member at a different campus or department to create a file and send it to another user for uploading.

**Please Note:** The Stocktake file created should contain only one stock item item number per line, as below:

![Barcode Image]

**Save the File as a Text Document**

It is important to know where the file is saved as you will need to access it later. You may wish to create a new folder named Stocktakes. You need to save the file as a text only file (.txt format).

If saving the file in WordPad:

1. **Save as Type:** Text Document (*.txt)

2. A prompt with the following message will display:

   *You are about to save the documents in a Text-only format, which will remove all formatting. Are you sure you want to do this? To save in other format, click No.*

3. Click the **Yes** button, as the file is to be downloaded into Amlib without the formatting.
Load (Count) Items from a Saved File

1. Launch Amlib client
2. Go to Main > StockItems > StockTake – the Stocktakes in Progress screen will display
3. Locate the file you want to use and highlight it
4. Click the F8 Upload button – the Stock Counting screen will display:

   ![Stock Counting Screen]

5. Click the F7 FrFile button – a Windows dialogue box will display:

   ![Windows Dialogue Box]

6. Navigate to the file, select the file and click the Open button

   The system will read the file and process the barcodes into the Stocktake.
APPENDIX 3: OTHER USEFUL REPORTS

Counts of Collections (Where Search)

The Parameters can be set according to what is to be counted – for example: Location, Form code, Stats Code, Process code, etc.

1. Launch the Amlib client
2. Go to Main > Stockitems > StockitemWhere – the Stockitem Where Search screen will display
3. Set the parameters as required within the Where search

4. Select the F6 Count button to get a total number, or
5. Click the F9 Execute button to get a listing

Save Where Search

1. Save by clicking the F2 Insert button – the Saved Queries screen will display
2. Type a description in the field at the bottom of the screen
3. Click the F3 Save button

Accessing Saved Searches

1. Saved Searches can be accessed from the Stockitem screen: Item > SavedWhereSearches
2. Highlight the desired search and click the **F9 Execute** button

**Opac Form Description (Form/Stats Combination Counts)**

Counts of stock items can also be seen in the **Opac Form Descriptions** screen.

1. Launch the **Amlib** client
2. Go to **Supervisor > Opacs > OpacFormDesc** – the **Opac Form Descriptions** will display:

![Opac Form Descriptions screenshot](image)

3. A **F6 Print** button is available

**Please Note:** The Opac Description is a user-friendly description designed for use in the **Opac or NetOpacs (not OpenOPAC because the Filters are useful for separating the Items by Forms and Stats codes).**

If the **F6 Print** button is not viewable:

1. Go to: **Main > Supervisor > UserNames**
2. Select the user and click the **F8 Choose** button
3. Select **ViewingMenu > Supervisor > OpacFormDesc**
4. If any buttons are **red** click on them, they will then turn green and be viewable in **Amlib**
5. Exit and restart the **Amlib** client for changes to take effect
Call Set Count Report

If Call Sets are defined, it is possible to get a Collection “map” of your library based on call numbers.

1. Launch the Amlib client
2. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
3. Click the F1 New button, highlight the &CALLSET.QRP template and click the Select button
4. If the template is not listed:
   a. Go to Main > Reports > RepAddNew – the Report Files screen will display
   b. Ensure that Report Entity: Stockitem
   c. Click the F1 New button – the New Report File screen will display:
   d. Enter the following:
      i. Description – for example: Call Set Count Report
      ii. Template: &CALLSET.QRP
      iii. Choose Type: Stockitem (Default)
      iv. Update Entity (Y/N): N
   e. Click the F3 Update button when complete
5. Type in a Report Description – for example: Call Set Stocktake Report 2011
6. Click the F3 Save button

7. Highlight the report and click the F7 Where button – the Stockitem Reports - Where screen will display

8. Enter the Where parameters and click the F3 Save button when complete

9. Highlight the report and select the F8 View button

- Call Sets are defined in Main > StockItems > StockCallSets
Statistics (Summary)

Stats Parameters

The statistics that Amlib collects are selected from the Statistics Codes table:

- Main > Supervisor > StatsParams

![Statistics Codes - STAFF at Chelsea Library](image)

Statistics are kept on the database until deleted, so there is no urgency in getting certain reports by a certain time (not from the system aspect anyway!).

For example: statistics can be gathered for January in June. (As long as you have been using Amlib that long, and that the Statistics Codes table was set to collect the statistics).

Where Parameters

The parameters applied to the reports can determine the data presented – for example: new Stockitems for this hour, this day, yesterday, week only, for a month, a term, a semester, a calendar year, a financial year etc. etc.

Because Amlib reports are very flexible in the data to be selected it is important to understand how to set up the parameters for the report.
Order Parameters

Many reports now have the Order pre-determined. The **F9 Order** button will be *greyed out* in these cases. If the **F9 Order** button is not grey, the Report type gives an indication of the Report Order sequence.

If the incorrect sequencing is chosen, the report will not present correctly and can take forests of trees if printed!!

<table>
<thead>
<tr>
<th>06 - Issues</th>
<th>2005</th>
<th>2006</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>January</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>April</td>
<td>16</td>
<td>16</td>
<td>32</td>
</tr>
<tr>
<td>May</td>
<td>139</td>
<td>139</td>
<td>278</td>
</tr>
<tr>
<td>June</td>
<td>2</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>August</td>
<td>2</td>
<td>2</td>
<td>4</td>
</tr>
<tr>
<td>September</td>
<td>1</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td>December</td>
<td>1</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td>4</td>
<td>158</td>
<td>162</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>06 - Renewals</th>
<th>2005</th>
<th>2006</th>
<th>Total</th>
</tr>
</thead>
<tbody>
<tr>
<td>May</td>
<td>1</td>
<td>5</td>
<td>5</td>
</tr>
<tr>
<td>August</td>
<td>1</td>
<td>1</td>
<td>2</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td>1</td>
<td>5</td>
<td>6</td>
</tr>
</tbody>
</table>
Statistics Detailed Report

Gives more details depending on the template chosen and the Where parameters selected.

For example: to see the Form and Stats codes of the New and Deleted items created this year, the Stats Report &STAT526.QRP – Details by Form & Stats:

![Image](image.png)

Report Formats for Stockitem Counts

- &XSTKCS.QRP: Count by Stats Code
- &XSTKCLS.QRP: Count by Location and Stats Code
- &XSTKFS.QRP: Count by Form Code
Procedure to Save reports as .Txt File and Import into Excel

There are several Excel report templates available which can be used to save to a file.

In this example, we are going to use the &XSTKCSV.QRP template in the Reports > RepStockitem module:

1. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will display
2. Click the F1 New button – the Select Report Format screen will display
3. Highlight the &XSTKCSV.QRP template and click the Select button
4. Type in an appropriate Description and click the F3 Save button
5. Enter an appropriate F7 Where search – for example: Title LIKE Harry Potter

6. Order the Report – for example: Title | ASC
7. Select Application > RepStartSchedule – the Report Scheduler screen will display
8. Ensure that Save to File is ticked and click the OK button
9. Click the **F6 Print** button – change the **To:** option to **File** and click the **OK** button

10. A **Report – Save As** dialogue box will display:
   a. To save it for a Word document, leave the **Save as type:** as **Rich Text Format (RTF)**
   b. To be able to open it in Excel, change the **Save as type:** to **Text Document**

11. You can check the progress of your report in **Reports > RepPrintProgress**
12. If you’ve saved the report to open in *Excel* (Text Document) then you will need to follow these steps so it is displayed correctly:

   a. Open *Microsoft Excel*

   b. Use *File > Open* to open the text file you’ve saved – ensure that the *Files of type*: = *All Files* (*.*)

   c. The *Text Import Wizard* will display:

   d. Excel will recognise your file as *Delimited*, so click the *Next* button

   e. Delimiters: select *Semicolon* and add a pipe | in the *Other* box

   f. Click the *Next* button and then the *Finish* button

13. Your data will be transferred into the *Excel* sheet and you can now use the formatting tools to customise it:
Never Borrowed (via Stockitem Where)

1. Launch the Amlib client
2. Go to Main > StockItems > StockitemWhere – the Stockitem Where Search screen will display
3. Enter the following Query Description:
   a. Times Borrowed = 0
   b. On Loan = N
   c. (optional) Location Perm =
   d. (optional) Form – for example: Form = DVD
   e. (optional) Sts Code – for example: Sts Code = FIC
4. Click the F5 Query button to see a list of items
5. Click the F6 Count button to see a count of items
6. Click the F7 QtoFile button to save the list to a Saved File

Last Borrowed 12 Months Ago (via Stockitem Where)

1. Go to Main > StockItems > StockitemWhere – the Stockitem Where Search screen will display
2. Enter the following Query Description:
   a. Last Active <= Current Date – 12 months (via the Special button)*
   b. (optional) Location Perm =
   c. (optional) Form – for example: Form = DVD
   d. (optional) Sts Code – for example: Sts Code = FIC
3. Click the F5 Query button to see a list of items
4. Click the F6 Count button to see a count of items
5. Click the F7 QtoFile button to save the list to a Saved File

Usage Reports

There are several report templates to count Stockitem usage. The report templates are designed to show usage statistics displayed in a number of ways:

- &STKHCC.QRP – usage count in Call Number order giving details of each Stockitem
- &STKHCSC.QRP – usage count in Stats Code order giving details of each Stockitem
- &STKHCSS.QRP – usage count in Call Number order giving summary only (by Call No)
- &STKHCSS.QRP - usage count in Stats Code order giving summary only (by Stats Code)

The reports are run against the Stockitem History. Users that delete data from the Stockitem History table need to be aware of the limitations of results.

Create Report
7. Launch the Amlib client
8. Go to Main > Reports > RepStockitem – the Stockitem Reports screen will open
9. Select the F1 New button – the Select Report Format screen will appear
10. Highlight the Stockitem History report template you would like to use – &STKHCC.QRP (Usage by Call No using History), &STKHCS.QRP (Usage by Stats Code using History), &STKHC.S.QRP (Usage by Call No – Summary – Using History) or &STKHCSS.QRP (Usage by Stats Code – Summary – Using History).
11. Click the OK button
12. Type in a Description – for example: Usage Count (DVDs)
13. Ensure the Create Fin (Y/N) column is set to N

```
<table>
<thead>
<tr>
<th>Report Code</th>
<th>Report Type</th>
<th>Report Description</th>
<th>Report Format</th>
<th>Template</th>
</tr>
</thead>
<tbody>
<tr>
<td>N</td>
<td>Stock Item Details</td>
<td>Med. Items</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHCC.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Stock Item Barcodes</td>
<td>Stock Barcodes</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHCS.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Stock Item History Test</td>
<td>Stock Item History</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHC.S.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Stock Item Details (CSV)</td>
<td>Stock Item Details (CSV)</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHCSS.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Stock Item Turnover Test</td>
<td>Stock Item Turnover</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHCC.QRP</td>
</tr>
<tr>
<td>N</td>
<td>Stock Item Usage Count</td>
<td>Stock Item Usage Count</td>
<td>&amp;Stockitem_08P</td>
<td>&amp;STKHCS.QRP</td>
</tr>
</tbody>
</table>
```

14. Click the F3 Save button

**Where Search and Order By Parameters**

1. Highlight the report and select the F7 Where button – this will bring up the Stockitem Reports – Where screen
2. Enter the following Where search:
   a. **History Type = ISSUE**
      You can use ISSUE, RENEW OR RETURN
      (Use the Paste button to insert the parameter into the list at the bottom of the screen)
   b. If using **History Type = Issue**, you may want to exclude any alterations made to the due date after renewals: **History Contents NOT LIKE Due Date Altered**
   c. Enter a start date: **History Date >=** enter a date in DD/MM/YYYY format – for example: 01/01/2015
   d. Enter a finish date: **History Date <=** enter a date in DD/MM/YYYY format – for example: 11/11/2015 (a finish date is optional – if not inserted, the report will go up to the current date).
e. You can further restrict your list to a particular **Form** or **Stats Code** - for example: **Form = DVD** or **StatsCode = FIC**

f. Click the **F3 Save** button when complete – this will close the **Stockitem Reports – Where** screen and return you to the **Stockitem Reports** screen

![Stockitem Reports - Where](image)

**View Report**

1. Highlight the report you wish to run and select the **F8 View** button

2. The following message will appear: **This type of report may use a Saved File as the Source. Do you want to select the file now?**

![Select File for View](image)

3. If you would like the report to run using the entire database (rather than a Saved List) then select the **No** button

4. The report will then display:

**Summary**
5. Select the **print** button to print the report

**Sending List of Barcodes to SLWA (W.A. Public Libraries)**

**Where Search**

The Parameters that must be set include:

1. **Stock Take Date ≠** and select the **Paste** button to get **Stocktake Date IS NOT NULL**
2. Select **On Loan = Y**
3. Ensure the Operand is set to **OR** (Also includes items on loan that may not have been counted)
4. Highlight the **top line** and click on the Opening Bracket (`
5. Click on the second line and then click the closing bracket `)

**Please Note:** When only State Government Stock is needed to be included in your report, include the following statements:
(a) Select **Item No** in box 1

(b) Select **LIKE** in box 2

(c) Type **3111** in box 3

(d) Click the **Paste** button

(a) Select **Item No** in box 1

(b) Select **LIKE** in box 2

(c) Type **ASLIB** in box 3

(d) Click the **Paste** button

(e) Click on the first of the Item Barcode Statements

(f) Select the Operand of **OR**

(g) Click on the opening bracket { 

(h) Click on the second of the Item Barcode Statements

(i) Click on the closing bracket )
The following screen for your Where Statement should look as below:

6. Click the **F7 QtoFile** button – the *Stockitem Saved Query Results* screen will display
7. Click the **F1 New** button
8. Type in a Description – for example: **SLOWA barcodes**
9. Click the **F3 Save** button
10. Ensure the file is highlighted and click the **F9 Select** button – a prompt with the following message will display: *The 'STOCKTAKE RESULTS ASLIB' file contains XX stockitems.*

11. Click the **OK** button
12. Once the file has been saved, from the menu select **Application > Stockitem** – the *Stockitems* screen will display
13. From the menu, select **File > WriteSaveFileIntoDosFile**
14. Highlight the correct File and click the **F9 Select** button
15. A Windows dialogue box will display:

![Windows dialogue box](image)

16. Navigate to the location where you would like to save the file and enter a **File name** – for example: **SLWA**

17. Click the **Save** button

18. This can then be emailed to **State Library** or opened in **WordPad**, **MS Word** or **Notepad**, etc. [It will result in a page of barcodes, each on a separate line]