TABLE OF CONTENTS

WELCOME .................................................................................................................. 5
OVERVIEW .................................................................................................................. 5
BEFORE YOU BEGIN THE INSTALLATION ................................................................. 5
  Read the Installation Notes First .............................................................................. 5
  Serial Numbers Required for Installation of Amlib Modules .................................. 5
  Frequently Asked Questions .................................................................................... 5
AMLIB SUPPORTED OPERATING SYSTEMS & SYSTEM REQUIREMENTS .................. 7
  Database Server ....................................................................................................... 7
  NetOpacs (Web Opac) Application Web Server ....................................................... 7
  PC Client (for Client Server Modules including Offline) .......................................... 7
  IIS Requirements ..................................................................................................... 7
SECTION 1: NETOPACS CLIENT INSTALLATION ......................................................... 8
  Default Installation Folders ..................................................................................... 8
  Step 1: Shutdown the Old NetOpacs (Server Migrations Only) .................................. 8
  Step 2: Install the NetOpacs 5.4 Client .................................................................... 10
SECTION 2: NETOPACS CONNECTION SETTINGS CONFIGURATION ....................... 15
  Step 1: NetOpacs Amlib.ini Settings ....................................................................... 15
  Step 2: NetOpacs SQL.ini Settings ......................................................................... 18
    SQL Server Users .................................................................................................. 18
    Oracle Users ......................................................................................................... 19
SECTION 3: WEBCONSOLE CONFIGURATION .............................................................. 20
SECTION 4: SETUP NETOPAC PAGES ......................................................................... 23
  Location of NetOpac Pages ...................................................................................... 23
  Step 1: Copy the NetOpac Web Pages ..................................................................... 23
  Step 2: Amlibweb Virtual Directory Files ............................................................... 24
SECTION 5: COMPILE THE NETOPAC PAGES ............................................................. 26
  Step 1: Compile the NetOpac Pages ....................................................................... 26
  Step 2: Restart the NetOpac WebConsole (Non-Service Installations Only) .......... 27
SECTION 6: FIREDAEMON OEM SERVICE MANAGER INSTALLATION .................... 28
SECTION 7: FIREDAEMON OEM SERVICE MANAGER CONFIGURATION ................. 31
  Step 1: Create the NetOpacs Service Instance ....................................................... 31
  Step 2: Start the NetOpacs as a Service ................................................................. 32
  Step 3: Test Access to NetOpacs “Pages” via Browser .......................................... 32

Last Updated: 9 October 2013
Page 3
Step 4: Check Communications to Database Server .............................................................. 33

SECTION 8: TROUBLESHOOTING TIPS .................................................................................. 34

Step 1: Check Communication to Database Server using Microsoft Port Query .................. 34
  Query Results ......................................................................................................................... 35

Step 2: Next Level of Amlib Troubleshooting .................................................................. 36

APPENDICES .......................................................................................................................... 39

Appendix A: Install IIS on Windows 7 or Vista ................................................................. 39
  Note on Configuring NetOpacs on 64-bit Windows Machine ........................................... 41

Appendix B: IIS Virtual Directory Configuration ............................................................... 44
  IIS 6.0 .................................................................................................................................. 44
  IIS 7.0 .................................................................................................................................. 48

Appendix C: Setup SQL Server User Security .................................................................. 55
  Clear User Schema .............................................................................................................. 55
  Map User Schema ............................................................................................................. 56

Appendix D: Running the Amlib Icon Setup Facility ......................................................... 58
  Option 1: Access the Programs from the Server ............................................................ 59
  Option 2: Install the Amlib programs from the PC ......................................................... 59

Appendix E: Configure a WEB Location in Amlib .............................................................. 63
  Setup a Web Location ....................................................................................................... 63
  Web Location Settings ..................................................................................................... 63

Appendix F: Install .NET Framework ............................................................................... 65

Appendix G: Install a Additional Instance of the NetOpacs ........................................... 66
  IIS 5.0/6.0 ......................................................................................................................... 67
  IIS 7.0 ............................................................................................................................... 69

Appendix I: Edit Access Control....................................................................................... 75
Welcome to the NetOpacs 5.4 Installation Guide.

Details on installing other components (such as the Amlib Client, ZServer and DIY Self Issues) are available in separate module specific Installation Guides.

Overview

The installation of the NetOpacs involves the following steps:

1. Install the Amlib NetOpacs 5.4 application
2. Configure the Amlib NetOpacs connection settings
3. Configure the NetOpacs WebConsole
4. Install the FireDaemon Service Manager
5. Configure the FireDaemon Service Manager
6. Start the Amlib NetOpacs as a Service

Before you begin the installation...

Read the Installation Notes First

Please carefully read the entire installation guide prior to commencing the actual NetOpacs release update.

If you have any questions please log a support call on TOPdesk at https://servicedesk.oclc.org/tas/public/index.jsp. If you do not know your TOPdesk login please email support-amlib@oclc.org and we will send it to you.

Serial Numbers Required for Installation of Amlib Modules

The Amlib NetOpacs 5.4 installation requires a serial number. If you did not receive a serial key for the modules that your library has purchased you should contact OCLC (UK) Limited before commencing the installation.

Frequently Asked Questions

Question: How much space do I need to have on my server?

• This will vary from library to library. Generally libraries should ensure they have at least 5 Gb free space on their database server

Question: Do I need to install IIS?

• Yes. Windows must be installed with full IIS (see Appendices for more details)

Question: Do I need to have a completed backup of my system before proceeding? (Server Migrations Only)
Yes. **OCLC (UK) Ltd** recommends that the library verify that you backup your *Amlib NetOpacs* folder (for example: `C:\Netopacs`)

**Question:** Do all users need to be logged out of *Amlib*? (Server Migrations Only)

- Yes. All users should be completely logged out from all *Amlib* client modules
- The *NetOpacs* WebConsole should also be shutdown

**Question:** Can **OCLC (UK) Ltd** install *Amlib NetOpacs* for me?

- Yes. **OCLC (UK) Ltd** can arrange for the remote installation for a small fee

**Question:** How do I know whether *Amlib* is loaded locally on my *NetOpacs* server?

- Right-click on the *Amlib* icon on your desktop and select **Properties** – the *Amlib Toolbar Properties* window will display
- The **Target** field will show you where your *Amlib* is installed:
  a. If it has something like `C:\Amlib` (or `D:\Amlib, E:\Amlib` depending on the hard drives in your computer) then it is installed locally
  
  ![Amlib Toolbar Properties](image)

  - `Target type`: Application
  - `Target location`: Amlib
  - `Target`: `C:\Amlib\Amlibtop.exe`
  
  b. If it starts with two back slashes (`\\`) and then a name or IP address, it is installed on a server:
  
  ![Amlib Toolbar Properties](image)

  - `Target type`: Application
  - `Target location`: Amlib
  - `Target`: `\\amlbserv\Amlib\Amlibtop.exe`

- If you are having trouble identifying where *Amlib* is installed please contact your IT department or *Amlib Support* for assistance
# AMLIB Supported Operating Systems & System Requirements

## Database Server

|                 | • Linux (and Unix)  
| RDBMS | • Microsoft SQL Server 2000, 2005, 2008 R2  
|       | • Oracle 9i, 10g  
| Memory (RAM) | • Depends on operating system, volume & RDBMS selected  
|             | • Minimum 2GB RAM for SQL Server  
|             | • Minimum 2GB RAM for Oracle  
| Hard Disk | • Depends on volume. Using multiple Fast SCSI-3 Disk Drives (for example: more SCSI drives provides better performance)  
| Backup | • Removable backup device (for example: 4mm DAT Tape Drive)  

## NetOpacs (Web Opac) Application Web Server

| Operating System | • Windows 2000, 2003, 2008 with IIS pre-installed  
| Memory (RAM) | • Depends on operating system and volume  
|             | • Minimum 2GB RAM for Windows 2003/2008  

Please Note: Although NetOpacs can operate on the same Amlib Database Server, it is recommended that medium to large libraries should implement a dedicated NetOpacs Server for maximum performance & security.

## PC Client (for Client Server Modules including Offline)

| Operating System | • Windows XP, 2000, Vista, Windows 7  
| Memory (RAM) | • Minimum 256 Mb for Windows XP  
|             | • Minimum 256 Mb for Windows 2000  
|             | • Minimum 1GB for Windows 7  
| Display | • SVGA (800x600) minimum  
| Web Browser | • Internet Explorer 7 and above (will also work with other JAVA enabled browsers)  

- **Important Note:** the above requirements are provided as a general guideline only

## IIS Requirements

The following features/service roles will be required prior to NetOpacs installation:

- IIS Management Compatibility (IIS 6 Compatibility) and all sub items
- ISAPI Extensions
SECTION 1: NETOPACS CLIENT INSTALLATION

Please Note: This process is only for libraries that have purchased this optional module.

Depending on the library configuration the *Amlib NetOpacs* module will either be installed on the library database server (generally most school libraries) OR will be installed on a separate web server (generally public and all other libraries).

The advantages of installing on a separate web server rather than on the database server are:

- increased security by preventing external access to the database server
- increased performance with separate server dedicated to handle *NetOpacs* processing requirements

Before installing *NetOpacs* on your server you will need to ensure that *Microsoft IIS* components (*Internet Information Services*) have been installed within your *Windows* server environment.

For most *Windows* operating systems *IIS* is not installed by default. To check whether *IIS* has been installed on your server, see: Appendix A: Install IIS on Windows 7 or Vista.

Default Installation Folders

To assist with email support we highly recommend that the default installation folders suggested in the following notes are retained.

For example:

- *Amlib NetOpacs* software: C:\*Netopacs* (or D:\*Netopacs*, E:\*Netopacs*)

Step 1: Shutdown the Old NetOpacs (Server Migrations Only)

It is important that before installing the new *NetOpacs* release software that the *NetOpacs* WebConsole is shutdown (including all *NetOpacs* processes). Alternatively, if you may be running your *NetOpacs* as a Service or using a Service Manager to run your *NetOpacs* (for example: *FireDaemon*) then you should stop your *NetOpacs* processes in the Manager.

To shut down your *NetOpacs* (run via the WebConsole)

1. On your *NetOpacs* server, right-click on the *NetOpacs* WebConsole “traffic lights” in your Windows system tray at the bottom-right of the screen and select **Exit**:
2. The “traffic lights” and all NetOpacs icons on the Windows taskbar will disappear once NetOpacs has successfully shutdown

To shut down your NetOpacs (run as a service)

If your server has the Amlib Web Monitor icon (icon is a PC with “cog”) in your Windows “tray it means that NetOpacs has been installed as a service.

1. On your NetOpacs server, stop the NetOpacs service either by a right-clicking on the Amlib Web Monitor and choosing Stop, or via the Windows Services screen:

To shut down your NetOpacs (run via a Service Manager – for example: FireDaemon)

If your web server has neither the “traffic light” nor “cog icon” in the system tray, the NetOpacs may be running as a FireDaemon service.

1. On your NetOpacs server, go to Start > All Programs > FireDaemon OEM > FireDaemon Service Manager – the FireDaemon OEM Service Manager screen will display:

2. Highlight the Amlib NetOpacs service and click the Stop button
Step 2: Install the NetOpacs 5.4 Client

**IMPORTANT:** Please ensure that you have full read/write access to the `\NetOpacs` folder on your server (for example: `C:\NetOpacs`) and that you are logged in with Administrative Privileges.

1. The NetOpacs 5.4 installer is available on the OCLC Website, under Setup Programs>NetOpacs: https://www.oclc.org/support/services/amlib/downloads-software-updates/version5-4/setup-programs.en.html (contact AmLib support if you require a login to this website)

2. Download the `NetOpacs54Setup.exe` and save it on your AmLib NetOpacs server

3. Double-click the `NetOpacs54Setup.exe` to launch the installation Wizard – the Setup – AmLib NetOpacs screen will open displaying the Welcome message

4. Click the Next button – the Serial screen will display, prompting you for valid Serial Number:

```
[Image of Serial Screen]
```

4. Enter the Serial Key supplied by OCLC (UK) Limited (case sensitive) then

5. Click the Next button – the Installation Location screen will display

6. Enter the drive/folder location where you would like to install the AmLib NetOpacs – we recommend that the AmLib NetOpacs be installed in `C:\Netopacs` (or `D:\Netopacs`, etc)

```
[Image of Installation Location Screen]
```
7. Click the **Next** button – the **Select Components** screen will display:

8. **Choose** which components should be installed:
   a. **Select Modules To Install:**
      - **Amlib NetOpacs Module and Program Files**
   b. **Select Web Server Tasks:**
      - **Create NetOpacs Virtual Directory in IIS (amlibweb)**
        (DO NOT select this option if you are reinstalling the *NetOpacs Client* and the *Amlibweb* virtual folder already exists)
        Please Note: see [Appendix B: IIS Virtual Folder Configuration](#) if you would like to manually configure the virtual folder (or would like to create an additional virtual folder)

9. Select ALL options and click the **Next** button – the **Database Relation Management System (RDBMS)** screen will display:
Please Note: Gupta SQLBase is not supported by Amlib version 5.4.

10. Please select the RDBMS you are using:

   a. If your library is using Microsoft SQL Server for Amlib:
      i. Select the Microsoft SQL Server radio button
      ii. Click the Next button – the Configure the SQL ini file screen will display prompting you for additional information:

         ![Configure the SQL ini file screen]

         (The SQL.ini file is configuration file containing the pathway information which allows the Amlib NetOpacs Client to connect with the Amlib databases)

         • Please enter the (SQL Server) database server name – default display is current local machine name (for example: tardis)
         • Please enter the database server IP address – default display is current local machine IP address (for example: 127.0.0.1 for localhost)
         • Please enter the SQL Server ODBC driver name – the driver name is normally SQL Server so there is no need to change this field
      iii. Enter options and click the Next button

   b. If your library is using Oracle for Amlib:
      i. Select the Oracle radio button
      ii. Click the Next button
11. The Select Start Menu Folder screen will display:

![Select Start Menu Folder]

12. To accept the default name (for most customers), click the **Next** button – the **Select Additional Tasks** screen will display, prompting if you wish to install a desktop icon for the **Amlib Client**:

![Select Additional Tasks]

13. (You can unselect **Install desktop icons for selected Components** if you do not wish to install the **Amlib** icons on the desktop)
14. Click the **Next** button to continue – the **Ready to Install** screen will display with a summary of the installation tasks to be performed:

![Ready to Install screen](image)

15. Click the **Install** button – the **Installing** screen will display:

16. Once the installation is complete, click the **Finish** button

17. The setup Wizard will close

Installation of the **Amlib 5.4 NetOpacs** is now complete.

---

**Notes (Server Migrations Only)**

For libraries who have configured their web server with multiple **NetOpacs** installation folders on the one server (for example: have **NetOpacs** installed in `c:\Netopacs` and `c:\Netopacs2`) will need to repeat the installation steps 3 – 15 for each additional **NetOpacs** folder, remembering to change the name of the Installation Location at step 6.
SECTION 2: NETOPACS CONNECTION SETTINGS CONFIGURATION

Step 1: NetOpacs Amlib.ini Settings

1. On the NetOpacs server, navigate to your Netopacs folder and open up the Amlib.ini file in Notepad:

2. Under the heading [NetOpacs] the following settings will need to be verified:
   a. SQL Databases: this should match the name of the Live (or production) databases set up in SQL Server (these databases utilise a default AM prefix):
      - DatabaseLib=Amlib
      - DatabaseCat=Amcat
      - DatabaseLocal=Amlocal
      - DatabaseStats=Amstats
      - DatabaseWeb=Amweb

      Please Note: Most Amlib customers prior to 2007 will need to configure this as DatabaseWeb=Amcat if they do not have an AMWEB database.
   b. SQL Databases Login: this should utilise the NETOPACS Login previously setup in your SQL Server – this Login MUST be mapped to ALL the Amlib SQL databases with db_owner role membership (see Appendix C: Setup SQL Server User Security for more information):
• DatabaseUser =NETOPACS
• DatabasePw=NETOPACS

Please Note: It is possible to utilise the SYSADM Login in place of the NETOPACS Login, or the user can define (and use) their own SQL Server Login.
c. Location: this should utilise the WEB Location previously setup in your Amlib client (see Appendix E: Configure a WEB Location in Amlib for more information):

- Location=WEB

Please Note: It is possible to utilise a different (branch) Location in place of the WEB Location (for example: LIB or CHELSEA). The use of a separate WEB Location is so that a unique set of loan rules can be configured for NetOpac users.

d. Hostname={name or TCP/IP address of webserver}/amlibweb
   For example: Hostname=localhost/amlibweb
   or Hostname=tardis/amlibweb
   or Hostname=203.192.150.3/amlibweb
Step 2: NetOpacs SQL.ini Settings

1. On the NetOpacs server, navigate to your Netopacs folder and open up the SQL.ini file in Notepad:

![Image of Notepad open on SQL.ini]

2. Under the heading [win32client.dll] ensure that the correct database connector is being used:
   a. SQL Server: comdll=sqlodb32
   b. Oracle: comdll=sqlora32
   c. SQL Base (no longer in use in Amlib 5.4): comdll=sqlws32

   ![Code Snippet]

SQL Server Users

Under the heading [Odbcrt] enter in the SQL Server file paths for the Live databases:

- REMOTEDBNAME=AMCAT,DRIVER=SQL Server;SERVER=SERVERNAME\INSTANCENAME;DATABASE=AMCAT
- REMOTEDBNAME=AMLIB,DRIVER=SQL Server;SERVER=SERVERNAME\INSTANCENAME;DATABASE=AMLIB
- REMOTEDBNAME=AMLOCAL,DRIVER=SQL Server;SERVER=SERVERNAME\INSTANCENAME;DATABASE=AMLOCAL
- REMOTEDBNAME=AMSTATS,DRIVER=SQL Server;SERVER=SERVERNAME\INSTANCENAME;DATABASE=AMSTATS
- REMOTEDBNAME=AMWEB,DRIVER=SQL Server;SERVER=SERVERNAME\INSTANCENAME;DATABASE=AMWEB

If there is “;NETWORK=dbmssocn;ADDRESS=ipaddress” on the end of each line please remove it

Replace SERVERNAME with the actual SQL Server name and INSTANCENAME with the actual instance (the default instance name is usually SQLEXPRESS).
These can be seen when you log into SQL Server:

HINT: It is possible to open the Amlib folder SQL.ini file in Notepad and copy (and paste) the same settings from within that file.

Oracle Users

If Oracle was selected (commdll=sqloracle32) was selected in the [win32client.dll] section then this section is used to determine the Oracle database alias used within the Oracle SQL*Net (also known as Net8 Client).

Under the heading [ORAGTWY] enter in the Oracle file path(s) for the Live database(s):

- REMOTEDBNAME=AMLIB,@AMLIB
- REMOTEDBNAME=TELIB,@TELIB
- SUBSTITUTE=SYSSQL.,
- SUBSTITUTE=syssql.,
- longbuffer=900000
- MAPERROR=OFF
- fetchrow=100

The format of this keyword is remotedbname={[(database name),@[SQL*Net database alias]]}.
SECTION 3: WEBCONSOLE CONFIGURATION

After installation, the NetOpacs WebConsole requires some additional configuration via the WebConsole application interface.

1. Install FireDaemon which can be located within the NetOpacs installation directory:

   Drive:\Netopacs\Utility\firedmn_setup.exe – for example: C:\Netopacs\Utility\firedmn_setup.exe

2. Continue the installation with all default settings. Also answer Yes to the two prompts during the installation. After the installation is complete, if possible restart the server.

3. From the Start menu, select the Run... command (or type run in the Search programs and files box and press <enter>) – the Run prompt will display:

   ![Run prompt](image)

   Type in the path to open the WebConsole in the following format:

   Drive:\Netopacs\webcon.exe /configure – for example: C:\Netopacs\webcon.exe /configure

4. The Amlib WebConfigure screen will display with:

   ![Amlib WebConfigure](image)

5. From the menu, select Service > Configure
7. The Service – Configure screen will display:

![Service - Configure screenshot]

8. Ensure the following field settings are selected:

   a. **Application**: `netopacs.exe`

   b. **Display Name**: *Amlib WebConsole* – this can be changed to be something more appropriate – for example: *Senior Library NetOpacs*

   c. **Application Instances**: number of instances when running the *NetOpacs* as an application (multiple instances allows for multiple simultaneous transactions – public libraries should change the number to 5 or more; libraries with only one *NetOpacs* terminal can change to 1; Recommended 3)

   d. **Service Instances**: number of instances when running the *NetOpacs* as a service

   e. **Virtual Directory**: `amlibweb` (this is the default *IIS* virtual directory name) – it is possible to setup the *IIS* virtual directory as part of the *NetOpacs* installation – see Section 1: Step 2.8

   f. **Script Name**: `webquery.dll`

9. Now select the **WebQuery** tab – the **WebQuery** screen will display:

![Service - Add screenshot]
10. Ensure the parameters settings are correct with the following field settings:
   a. **Error Template**: C:\Netopacs\Error.htm (if the NetOpacs have been installed anywhere other than the default location, you may need to click the **Browse** button and navigate to the location where the Error.htm is held and select it)
   b. **TimeOut**: default = 60 seconds. This can changed to a higher value if necessary.
   c. **If more than one Web Application is loaded use**: select **All Applications evenly**

11. Click the **OK** button – a prompt with the following message will display:
   **The changes you have made will not take effect until 'Amlib WebConsole' is restarted. Do you want to restart 'Amlib WebConsole'?**

   ![Service Change](image)

12. Click the **Yes** button

**Configure NetOpacs as a FireDaemon Service**

We recommend that NetOpacs is configured as a FireDaemon Service. This is covered in **Section 6**.
SECTION 4: SETUP NETOPAC PAGES

Location of NetOpac Pages

Most libraries will be running one (or more) set(s) of customised NetOpacs pages. These pages (and the associated image, CSS and JavaScript files) are usually located in the Netopacs/Samples folder on the NetOpacs server – for example:

- C:\Netopacs\Samples\A99_NewStyle
- C:\Netopacs\Samples\oclcweb

Some libraries may have their NetOpac pages located in an entirely separate folder – for example:

- C:\Netopacs\Live\oclcweb

A typical NetOpac web older will contain a set of pages (and folders) as follows:

- css folder
- Icons folder
- Javascript folder
- Webpics folder
- .htm files (web pages)
- .ini configuration file

Step 1: Copy the NetOpac Web Pages

1. On the (old) Netopacs server, navigate to the folder containing your current NetOpacs pages and make a copy of the folder (and its contents) [Server Migrations Only]
2. On the (new) Netopacs server, paste in the folder containing your NetOpac pages (and its contents) into the NetOpacs/Samples folder
Step 2: Amlibweb Virtual Directory Files

As part of the NetOpacs client installation, an Amlibweb virtual directory folder will installed in the NetOpacs folder (for example: C:/Netopacs/Amlibweb). This is the folder that IIS uses foundation of the NetOpacs web site. As such, it needs to contain a copy of any files being referred to by these pages. The Amlibweb folder also contains the webquery.dll file, which essentially “powers” many of the NetOpac operations and is called by the netopacs.exe to execute certain operations.

1. Navigate to the Amlibweb virtual folder on your NetOpac server (for example: C:/Netopacs/Amlibweb)

2. Highlight all existing files (EXCEPT the webquery.dll and the web.config files) and DELETE them

3. Navigate to the folder containing your NetOpac pages (and its contents) in the NetOpacs/Samples folder (for example: C:/Netopacs/Samples/A99_NewStyle)

4. Copy all folders and any non .htm file (excepting the .ini configuration file)
5. Navigate back to the AmLibWeb virtual directory folder

6. Paste in the previously copied folders (and files) from the NetOpac pages folder

The NetOpac pages are now ready to be compiled.
SECTION 5: COMPILE THE NETOPAC PAGES

Step 1: Compile the NetOpac Pages

Before starting the *Amlib Netopacs* module you will need to load (compile) a set of *NetOpac* web pages (search screens, result lists, etc.).

If the *Netopacs* have been setup on a separate server to the *Amlib* client application files, then access to the *Amlib* client will need to be setup and configured by running the *IconSetup.exe* – see **Appendix D: Running the Amlib Icon Setup Facility**. Alternatively, the *Amlib* client application can be installed (and configured) locally on the *NetOpacs* server (see separate *Amlib* client installation instructions).

**WARNING:** Do not attempt to compile the *Netopac* pages from the *Amlib* application server (if installed separately) or from a client PC, as the filepaths of the compiled pages will be incorrect.

1. On the *Netopacs* server, launch the *Amlib* client
2. Go to **Main** > **Supervisor** > **WebParams** – the *Web Opacs Parameters* screen will display
3. From the menu, select **Html Parameters** > **Compile**

4. The *Net Opacs Compile* screen will display – navigate to the folder containing your *Netopacs* pages (this folder is usually contained in the *Netopacs/Samples* folder on the *Netopacs* server – for example: C:\Netopacs\Samples\A99_NewStyle)
5. You will find an *.ini* configuration file. Most recent *Netopac* installations will have *.ini* file called *Item_Result.ini* – if this is the case, then select that. Alternative names include *ReserveOn.ini* and *ReserveOff.ini*. Then click on the **Open** button.
6. You will then be asked to type in a Web User Code. This code denotes your NetOpac instance. If you are running more than one set of NetOpac pages (for example: a junior and senior set of pages) then you will be using more than one code. Typically, the first instance is designated a and the second b and so on. If you have only one set of pages, then just type in a.

7. Click on the OK button

8. Amlib will now compile these pages (and the amlib.ini file) – once complete, a prompt with the following message will display: All the Web Parameters have been created.

Step 2: Restart the NetOpac WebConsole (Non-Service Installations Only)

Once the compile is complete, you will need to restart the NetOpac WebConsole.

To restart the WebConsole:

1. Now the WebConsole is probably already running, so maximise the WebConsole window

2. You will then need to reload it using the code you entered at step 6. So in the Style box, type the code you used at step 6 (leave as ‘a’ if you compiled as ‘a’) and then press the orange ReLoad button. That will take a few seconds and then it will be ready to test.

3. The WebConsole has now been restarted
SECTION 6: FIREDAEMON OEM SERVICE MANAGER INSTALLATION

IMPORTANT: Please ensure that you have full read/write access to the \Program Files folder on your server (for example: C:\ Program Files) and that you are logged in with Administrative Privileges.

Please ensure that you have the latest version of the .NET Framework installed prior to beginning installation of FireDaemon – see: Appendix F: Install .NET Framework for more information

1. The FireDaemon installer can be found in the NetOpacs/Utility folder – for example: C:\Netopacs\Utility

2. Double-click the firedmn_setup.exe to launch the installation Wizard – the Setup – FireDaemon OEM Service Manager screen will open displaying the Welcome message

3. Click the Next button – the Installation Location screen will display:

4. Enter the drive/folder location where you would like to install FireDaemon – we recommend that the FireDaemon be installed in C:\Program Files\FireDaemon OEMB and click the Next button

5. The Select Components screen will display:
6. **Choose** which components should be installed:

   a. **Install FireDaemon**

   b. **Modify Registry Values:**
      - Set Registry Values

   c. **PanelDaemon Web Services Manager:**
      - Install PanelDaemon Web Services Manager
      - Install PanelDaemon ReadMe

7. **Select ALL** options and click the **Next** button – the **Select Start Menu Folder** screen will display

8. To accept the default name (for most customers), click the **Next** button

9. The **Ready to Install** screen will display with a summary of the installation tasks to be performed:

   ![Ready to Install Screen]

10. Click the **Install** button – two **Setup** prompts may display:

   ![Setup Prompts]

11. Click the **Yes** button both times – the **Installing** screen will display
12. If the latest version of the .NET Framework is not installed, a prompt with the following message will display: This setup requires the .NET Framework 1.1.4322. Please install the .NET Framework and run this script again. The .NET Framework can be obtained from the web. Would you like to do this now?

![Windows Installer Loader]

13. Click the Yes button

14. Once the installation is complete, you will be prompted to restart the computer – select the Yes, restart the computer now option and click the Finish button

![Setup - FireDaemon OEM Service Manager Installation Wizard]

15. To complete the installation of FireDaemon, the machine will have to be restarted – select the Yes, restart the computer now option and click the Finish button

NB: A restart it not always required but is recommended.

16. The setup Wizard will close and the machine will restart

Installation of the FireDaemon application is now complete.
SECTION 7: FIREDAEMON OEM SERVICE MANAGER CONFIGURATION

Step 1: Create the NetOpacs Service Instance

1. From the Start menu, select the Run... command (or type run in the Search programs and files box and press <enter>) – the Run prompt will display:

![Run prompt](image)

2. Type in the path to open the WebConsole in the following format:
   Drive:\Netopacs\webcon.exe /configure – for example: C:\Netopacs\webcon.exe /configure

3. The Amlib WebConfigure screen will display with:

![Amlib WebConfigure](image)

4. From the menu, select Options > Startup... – the Startup Options screen will display:

![Startup Options](image)
5. In the FireDaemon Service Startup section, click the Install button – the Service Settings screen will display:

   ![Service Settings](image)

   In the Service Settings, the following options are visible:
   - **Create service** = ticked
   - **Short Name** – for example: AmlibNetOpacs
   - **Display Name** – for example: **Amlib NetOpacs** or **Senior Library NetOpacs**, etc
   - **Description**: enter a description
   - **Desktop Interact** option – this will allow the service to run without opening the WebConsole (as it does when running as an application)
   - **Create monitor shortcut** – there should already be a shortcut on the desktop

6. Enter the following settings:
   - **Create service** = ticked
   - **Short Name** – for example: AmlibNetOpacs
   - **Display Name** – for example: **Amlib NetOpacs** or **Senior Library NetOpacs**, etc
   - **Description**: enter a description
   - **Desktop Interact** option – this will allow the service to run without opening the WebConsole (as it does when running as an application)
   - **Create monitor shortcut** – there should already be a shortcut on the desktop

7. Click the OK button – the NetOpacs will be installed as a service in the FireDaemon OEM

8. Once completed, a prompt will display with the following message:
   - **The service has been installed.**

9. Click the OK button

**Step 2: Start the NetOpacs as a Service**

1. Open the Service manager from your Programs listing:

   ![Service Manager](image)

2. Select the **Net Opacs WebConsole**, click on the start button

3. The service has now been started

**Step 3: Test Access to NetOpacs “Pages” via Browser**
To access the NetOpacs Main Menu using a web browser use the address stored in the Fullhost field within \Netopacs\amlib.ini configuration file.

For example:

- http://localhost/amlibweb/WebQuery.dll?

Or if the default document of webquery.dll has been defined in the previous section you will only need to enter:

- http://localhost/amlibweb

**Step 4: Check Communications to Database Server**

Before starting the NetOpacs WebConsole or FireDaemon Service you may wish to confirm that the NetOpacs server can communicate to the Amlib database server. To test the communications to the Amlib database server you can try:

- *Windows* “Ping” command. At the NT command (DOS) prompt type: ping {server address} – for example: ping 10.0.0.10
  
  Please Note: your firewall settings may prevent ping commands

- Simply perform a search using the NetOpacs!
SECTION 8: TROUBLESHOOTING TIPS

The first step in troubleshooting problems that you may be experiencing with *Amlib* (Client or *NetOpacs*) connecting to the database is to first check the following:

- Can you connect to the *Amlib* database using the *Amlib Client* on the server?
- Can you connect to the *Amlib* database using the *Amlib Client* from another workstation?

The next step is to try and isolate the problem and ensure that the problem is not due to the hardware, network or firewall.

**Step 1: Check Communication to Database Server using Microsoft Port Query**

Microsoft Port Query is an easy to use tool that enables you to test whether you can connect from a Workstation (or Web Server) to the database server, and whether the RDBMS is listening for connection requests.

1. Launch the *Microsoft Port Query* program which will be located:
   - *NetOpacs*: `c:\netopacs\utility\PortQryUI\portqueryui.exe`  
   *(Please Note: Replace `c:\amlib` or `c:\netopacs` with the actual path where the applications have been installed)*

2. Enter the *Destination IP* address of database server used when installing *Amlib* (for example: `tardis`, `127.0.0.1`, `localhost`, etc.)
3. **Select** the **Manually input query ports** option

4. **Ports to query:**
   
   - If using *Microsoft SQL Server* enter: **1433**
   - If using *Oracle* enter **1521** (older versions of *Oracle* may be using **1525**)

5. **Protocol**: **TCP**

6. Then click the **Query** button to start the search

---

**Query Results**

1. If the Query result is **LISTENING** (for example: TCP port 1433 (ms-sql-s service): LISTENING) then this indicates:
   
   - The Workstation (or Web Server) can communicate to the database server **OK**
   - You will need to proceed to the next level of *Amlib* troubleshooting to identify the problem you are experiencing

2. If the Query result is **NOT LISTENING** (for example: TCP port 1433 (ms-sql-s service): NOT LISTENING) then this indicates:
   
   - The Workstation (or Web Server) is unable to communicate to the RDBMS on the database server

   **You should refer this problem to your organisation’s database or network administrator to follow up.**

   **Possible reasons why it is unable to communicate to the RDBMS on the database server:**
   
   - The database server is not running
   - The database server is disconnected from the network
   - The workstation (or web server) is disconnected from the network
   - There is a problem with the network (for example: switch is faulty, DHCP is not running, etc.) or network configuration
   - The RDBMS is not running on the database server (check in Windows Services whether the RDBMS (*Microsoft SQL Server* or *Oracle*) is running
   - The enterprise firewall is preventing connectivity via this Port
   - The workstation firewall (for example: *Windows XP Service 2* firewall) is preventing connectivity via this Port
   - There a problem with hardware (for example: network card in either database server, workstation or web server)

3. If the Query result is **FILTERED** (for example: TCP port 1433 (ms-sql-s service): FILTERED)
then this indicates:

- the enterprise firewall is preventing connectivity via this Port
- the workstation/server firewall (for example: Windows XP Service 2 firewall) is preventing connectivity via this Port

You should refer this problem to your organisation’s database or network administrator to follow up.

**Step 2: Next Level of Amlib Troubleshooting**

Message **Unable to connect to database**

A message “**Cannot connect to database**” is displayed if the PC is unable to connect via the WAN (or if **SQL.ini** is not correctly configured).

The following steps can be used to track down the problem:

1. Review the RDBMS error message displayed on the “cannot connect” screen – for example in the above example refers to **Error No. 20016...SQL Server does not exist....** is a SQL Server error and should be following up with your database administrator (the error number is **not** an **Amlib** error number)

2. Can the PC connect to the database server?
   - Refer to the previous section: [Check Communication to Database Server using Microsoft Port Query](#)

3. If step 2) above is OK, then ensure that you DO NOT have any ODBC Data Sources with the same name as the database (for example: make sure there is NOT an ODBC data source called **AMCAT, AMLIB, AMLOCAL** or **AMSTATS**)
   - In Windows: Go to **Control Panel > Administrative Tools > Data Sources (ODBC)**, and check within the **User DSN, System DSN** or **File DSN** tabs

4. If step 3) above is **OK**, then identify whether the **SQL.ini** is correctly configured or whether there is a connection error:
   - To test start the `\amlib\upgrade.exe` SQL interface program:
a) From the menu, select **File > Advanced Login** – the **Advanced Login** prompt will display:

![Advanced Login Prompt]

b) Enter the login of **NETOPACS**, the password (usually **NETOPACS**) and database **AMLIB** and click the **OK** button.

c) If Upgrade is able to connect **OK** to the selected database and will return to the main Upgrade screen and display the username and database.

d) For **SQL Server** RDBMS - repeat the above Advanced Login step for each other database (**AMCAT**, **AMLOCAL** and **AMSTATS**) to see whether the problem is due to being unable to connect to only 1 of the databases.

If Upgrade is unable to connect to the selected database then take a detailed copy of the displayed error message (for example: press **PrtScn** on your keyboard and paste into a **Word** document) and contact **Amlib Support** for further assistance.

![Login Error]

It is also suggested that you take a note of the Error number and research with the RDBMS vendor the explanation and resolution for the Error number:

- For **Microsoft SQL Server** – go to [http://support.microsoft.com](http://support.microsoft.com)
- For **Oracle** – go to [http://www.oracle.com/support/index.html](http://www.oracle.com/support/index.html)
Some of the reasons that the **Upgrade.exe** is unable to connect to the selected database:

- The database does not exist within the RDBMS (for example: if an administrator had deleted the *AMLIB* database)
- The administrator had moved the *Amlib* databases to another server
- The database server has insufficient disk space
- The *Amlib SQL.ini* configuration file (located in the `c:\netopacs` for the *NetOpacs* module) is not correctly configured – see: NetOpacs SQL.ini Settings for more information
- For libraries using *Oracle* RDBMS – the *Oracle Net8 (SQL*Net) Client* is not correctly configured (using the *Oracle TNSPING* utility on the Workstation to test)
- For libraries using *Microsoft SQL Server* – an old version of the *Windows MDAC (ODBC)* drivers are installed

5. If step 4) above is OK, then perhaps the *Amlib* database connection settings held in `{windows}\amlib.ini` are incorrect (these are different to the *DIY DefaultUser* and *Login* settings)
APPENDICES

Appendix A: Install IIS on Windows 7 or Vista

Before installing your NetOpacs, you will need to ensure that the NetOpacs server is running Internet Information Services (IIS).

1. From the Start menu, select Control Panel – the Control Panel screen will display:

![Control Panel screenshot]

2. Select the Programs link – the Programs screen will display:

![Programs screenshot]

3. Select the Turn Windows features on or off link
4. The Turn Windows Features On or Off screen will display:

![Turn Windows Features On or Off](image)

5. If you expand the Internet Information Services tree node, you can see that there are a lot of options beneath it:

a. In the Web Management Tools section, ensure IIS Management Compatibility is checked, including ALL its sub items

b. In the World Wide Web Services/Application Development Features section, ensure ISAPI Extensions is checked

![Internet Information Services](image)
6. Once complete, click the **OK** button – **IIS** will then be installed

7. Once complete, a prompt will display with the following message: **You must restart the computer to apply these changes**

![Image showing the restart confirmation dialog]

8. Click the **Restart Now** button

Once restarted, when you navigate in your browser to localhost, you’ll see the new default page:

---

**Note on Configuring NetOpacs on 64-bit Windows Machine**

If a site is using the 64-bit version of **Windows 2003** or above you will need to implement some additional configuration changes within **Windows** to support running 32-bit applications (the **NetOpacs** are a 32-bit application) on 64-bit **Windows** machine.

The following information is from the **Microsoft TechNet** article located at:

- [http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/0aaf9a0-1b1c-4a39-ac9a-994adc902485.mspx](http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/0aaf9a0-1b1c-4a39-ac9a-994adc902485.mspx)

**Windows Server 2003TM, Service Pack 1** enables **IIS 6.0** to run 32-bit web applications on 64-bit **Windows** using the Windows-32-on-Windows-64 (WOW64) compatibility layer. **IIS 6.0** using WOW64 is intended to run 32-bit personal productivity applications needed by software developers and administrators, including 32-bit **Internet Information Services (IIS)** Web applications. On 64-bit **Windows**, 32-bit processes cannot load 64-bit DLLs, and 64-bit processes cannot load 32-bit DLLs. If you plan to run 32-bit applications on 64-bit **Windows**, you must configure **IIS** to create 32-bit worker processes. Once you have configured **IIS** to create 32-bit worker processes, you can run the following types of **IIS** applications on 64-bit **Windows**:

- Internet Server API (ISAPI) extensions
- ISAPI filters
- Active Server Page (ASP) applications
- ASP.NET applications

**IIS** can, by default, launch **Common Gateway Interface (CGI)** applications on 64-bit **Windows**, because **CGI** applications run in a separate process.
Configuring IIS to run 32-bit Web applications on 64-bit Windows:

Before you configure IIS to run 32-bit applications on 64-bit Windows, note the following:

- IIS only supports 32bit worker processes in Worker Process Isolation mode on 64-bit Windows
- On 64-bit Windows, the World Wide Web Publishing service can run 32-bit and 64-bit worker processes. Other IIS services like the IIS Admin service, the SMTP service, the NNTP service, and the FTP service run 64-bit processes only
- On 64-bit Windows, the World Wide Web Publishing service does not support running 32-bit and 64-bit worker processes concurrently on the same server

To enable IIS to run the NetOpacs on a 64-bit Windows Machine:

1. From the Start menu, select Administrative Tools > Internet Information Services (IIS) Manager or type iis in the Search programs and files box and press <enter> and select Internet Information Services (IIS) Manager
2. Expand the server listing > click on Application Pools
3. Click on the site’s application pool to select it. The default pool for NetOpacs is DefaultAppPool
4. In the right hand column, click on Edit Application Pool > Advanced Settings...
6. In the popup, go to General> Enable 32 bit Applications > change to “True”

7. Click OK

8. In the right hand column, click on Application Pool Tasks > Recycle... (or you can stop and start the app pool, if you prefer)
Appendix B: IIS Virtual Directory Configuration

IIS 6.0

Please Note: This example uses Amlibweb3 where normally it would be Amlibweb2 (if creating a second (b) instance). Amlibweb3 would be used to create a third (c) instance, etc.

Creating the Virtual Directory

1. From the Start menu, select Administrative Tools > Internet Information Services (IIS) Manager or type iis in the Search programs and files box and press <enter> and select Internet Information Services (IIS) Manager
2. Expand the [Server] > Sites > [Web Site] tree, where [Server] and [Web Site] refer to the appropriate server name and web site name
3. Right-click the appropriate web site (for example: Default Web Site) and choose New > Virtual Directory...

4. The Virtual Directory Creation Wizard screen will display
5. Click the Next button to continue
6. The Virtual Directory Alias screen will display:

7. Enter the following:
   - ** Alias: ** which will be the same as the name given to your virtual directory folder created at step 1 (usually **Amlibweb2**, although in this example, **Amlibweb3**)

8. Click the **Next** button – the Web Site Content Directory screen will display:

9. Enter the following:
   - ** Directory:** click on the **Browse...** button and navigate to the **Netopacs** folder, select the folder created at step 1 (usually **Amlibweb2**, although in this example **Amlibweb3**) and click the **OK** button

10. Click the **Next** button
11. The Access Permissions screen will display:

12. Ensure the Read and Run scripts (such as ASP) options are selected and click the Next button.

13. Click the Finish button.

Adjusting the Settings

1. Right-click on the virtual directory you have set up (usually Amlibweb2, although in this example Amlibweb3) and select Properties:

2. The Properties screen will display:
3. On the **Virtual Directory** tab:
   a. **When connecting to this resource, the content should come from:** ensure a **directory located on this computer** is selected
   b. **Execute Permissions:** ensure **Scripts and Executables** is selected
   c. **Local Path:** this should match the pathway to the virtual directory folder created earlier (for example: `C:/Netopacs/Amlibweb2`, although in this example `C:/Netopacs/Amlibweb3`)
   d. The **Read**, **Log visits** and **index this resource** settings should also be selected

4. Select the **Documents** tab:
   a. Click the **Add...** button – the **Add Default Document** prompt will display: type in **WebQuery.dll** and click the **OK** button
b. To help save time and system resources, use the arrows at the side to move *WebQuery.dll* to the top of the list:

5. Click the **OK** button when complete

Creation and configuration of the virtual directory is now complete.

*IIS 7.0*
Creating the Application

1. From the Start menu, select **Administrative Tools > Internet Information Services (IIS) Manager** or type `iis` in the Search programs and files box and press <enter> and select **Internet Information Services (IIS) Manager**

2. Expand the [Server] > Sites > [Web Site] tree, where [Server] and [Web Site] refer to the appropriate server name and web site name:

3. Right-click the appropriate web site (for example: Default Web Site) and choose **Add Application...**

4. The **Add Application** screen will display:
5. Enter the following settings:

- **Alias**: amlibweb (if setting up a second *NetOpacs* instance, then this will be Amlibweb2)

- **Physical path**: click the ... button and navigate to the *Netopacs* virtual directory folder containing the webquery.dll file (this will typically be the Amlibweb folder – for example: C: \Netopacs\Amlibweb)

If setting up a second *NetOpacs* instance, then this will be the Amlibweb2 folder.

6. Select the newly created application (for example: amlibweb) and double-click the **Handler Mappings** icon

7. The **Handler Mappings** screen will display:

8. Right-click the **ISAPI-dll** item and select **Edit Feature Permissions...**
9. The Edit Feature Permissions prompt will display:

![Edit Feature Permissions](image)

10. **Check** the **Execute** option (Read and Script should already be selected) and click the **OK** button

11. Re-select the application again and then double-click the **Default Document** icon

12. The **Default Document** screen will display

13. Click the **Add...** action in the **Actions** column – the **Add Default Document** prompt will display:

![Add Default Document](image)

14. Type in **webquery.dll** and click the **OK** button

15. Select and remove all other items

16. If a message indicating the default document feature has been disabled appears in the **Actions** column, you can click the **Enable** action
Creating Web Service Extensions

1. Select the server that contains the dlls you want to allow (this will usually be the default server) and double-click the ISAPI and CGI Restrictions icon:

2. The ISAPI and CGI Restrictions screen will display:

3. Click Add... in the Actions column – the Add ISAPI and CGI Restriction screen will display:
4. Enter the following settings:
   a. **ISAP and CGI path**: Click the ... button and navigate to the Netopacs directory folder, open the virtual directory folder (this will typically be the Amlibweb folder – for example: C:\Netopacs\Amlibweb) and select the webquery.dll file
   b. **Description**: Amlibweb (or Amlibweb2, etc)
   c. **Check** the **Allow extension path to execute** option

5. Click the **OK** button when complete

The application has been created and is now able to be executed on the server. The last step is to configure the security settings for all related NetOpacs executables.

To run NetOpacs, you will have to run it as a service thru FireDaemon Service Manager.

**Configuring UAC Security**

1. For each of the following four files, please do the steps detailed below:
   - **Netopacs.exe** (located in the C:\Netopacs folder)
   - **Webcon.exe** (located in the C:\Netopacs folder)
   - **FireDaemon.exe** (located in the C:\Program Files\FireDaemon OEM folder)
   - **FireDaemonUI.exe** (located in the C:\Program Files\FireDaemon OEM folder)
2. Right-click on the file and select **Properties** – the Properties screen will display:

![Properties Screen](image)

3. Click on the **Compatibility** tab

4. **Check** the box **Run this program as an administrator** which is located in the **Privilege Level** section

5. Click the **OK** button when complete
Appendix C: Setup SQL Server User Security

The *NetOpacs* require the setup of a **NETOPACS** Login which will then be associated with the Live (production) SQL databases.

**Clear User Schema**

It may be necessary to clear the old user schema first.

1. Click the *New Query* button – this will open up a new *SQL Query* screen

2. Type (or copy) in the following:

   ```
   use AMCAT
   drop schema NETOPACS
   drop user NETOPACS

   use AMLIB
   drop schema NETOPACS
   drop user NETOPACS

   use AMLOCAL
   drop schema NETOPACS
   drop user NETOPACS

   use AMSTATS
   drop schema NETOPACS
   drop user NETOPACS

   use AMWEB
   drop schema NETOPACS
   drop user NETOPACS
   ```

3. Click the ![Execute](image) button
Map User Schema

1. In the sidebar, expand the Security folder, right-click on Logins folder and select New Login...

2. The Login - New screen will display:

3. On the General page (select from sidebar):
   a. Select the SQL Server authentication radio button
   b. Enter the following details:
      i. Login name: NETOPACS
      ii. Password: NETOPACS
      iii. Confirm password: NETOPACS
   c. Deselect the Enforce password policy tick box
4. On the **User Mapping** page (select from sidebar):

5. In the *Map* column tick the **AMCAT** database option

6. Then tick the **db_owner** option in the lower screen

7. Repeat steps 5 and 6 for the **AMLIB**, **AMLOCAL**, **AMSTATS** and **AMWEB** (where installed) databases

8. Click the **OK** button to exit out of this screen

9. When you are done, your **NETOPACS** login will show under **Security > Logins**:

![User Mapping Screen](image)
Appendix D: Running the Amlib Icon Setup Facility

This is used to set up PC Icons, set the Database Login, and for installing Active X.

1. Locate the Icon Setup application (IconSetup.exe) on your Amlib server or client PC in the Drive:Amlib\Utility\Icons folder (for example: C:\Amlib\Utility\Icons and copy it onto your NetOpacs server

2. Double-click on the IconSetup.exe to open the Amlib Shared Client Installation Wizard:

3. Click the Next button – the Setup screen will display:

4. Enter the filepath (for example: C:\Amlib or F:\Library\Amlib) to the folder containing the Amlib program files or click the Browse button and locate the folder (the Amlib program files will be located on either a mapped server drive or somewhere on the PC)
Amlib Application Files Location

When re-running `Iconsetup.exe` to install a new client, you need to be sure where you are accessing the Amlib programs, which will be one of the two following options:

- Access to Amlib programs from the Server or
- Install the programs locally and access from the new PC

If you are not sure where you currently access the Amlib program from you can find out by:

1. Right-click on the Amlib Icon of a different Amlib Client machine and select Properties – the Amlib Toolbar Properties will display
2. On the Shortcut tab, locate the Target field and note the file path

- If the Target point to a different drive – for example a library drive or I:/ drive etc then you are most likely accessing Amlib from a server: follow **Option 1**
- If the Target file path points to C:/Amlib/Amlibtop.exe then you are most likely accessing the program locally installed on the PC – follow **Option 2**

Option 1: Access the Programs from the Server

1. In the Amlib folder on the server, navigate to Amlib > Utilities > Icons > Iconsetup.exe
2. Copy the Iconsetup.exe file to the new PC and run the file on the PC as per the instructions above, browsing to the Amlib folder on the server

Option 2: Install the Amlib programs from the PC

1. Copy the Amlib folder from an existing PC that is running Amlib (or from the Server). This will ensure that the programs are the version suitable for the Database.
2. Run the Amlib > Utilities > Icons > Iconsetup.exe file on the PC and browse to the Amlib folder on the local PC where you have just saved it
5. Highlight the folder and click the **OK** button

6. Click **Next** button – the Select Components screen will display:

7. Select (tick) the following options:
   - **Choose Module Icons & Functions to Install**
   - **Admin Tasks** (to ensure the Database connection is correct in the *Amlib* configuration file)

8. Click the **Next** button – the RDBMS Login to be used with *Amlib* screen will display:
a. You will be prompted for a hidden Amlib Database (DBA) Login to connect the *Amlib* SQL database:
   
   - AmlibNet DBA User
   - AmlibNet DBA Password

b. Please Note:
   
   - This will be the RDBMS Login that *Amlib* will use as a *HIDDEN* Amlib Database (DBA) Login to connect the *Amlib Client* to the *Amlib* database
   
   - An encrypted User and Password can be entered (generated using the *Amlib nopasswd.exe* utility)
   
   - This will be stored in within the *Windows\amlib.ini* configuration file

c. To accept the *defaults*, click the Next button (this will be most customers)

17. The *Select Start Menu Folder* screen will display:

18. Enter a *Start* menu folder name (or leave as *Amlib Library Management System*) and click the Next button – the *Select Additional Tasks* screen will display:

19. Ensure the *Install desktop icons for selected Components* is selected
20. Click the **Next** button – the **Ready to Install** screen will display with a summary of the installation tasks to be performed:

21. Click the **Install** button – the **Installing** screen will display:

22. When complete click the **Finish** button

23. The setup Wizard will close

Installation of the **Amlib Client (Shared)** is now complete.
Appendix E: Configure a WEB Location in Amlib

Setup a Web Location

1. Launch the Amlib client
2. Go to Main > Supervisor > Locations – the Locations screen will display:

   ![Locations screen](image)

3. Click the F1 New or F2 Insert button
4. Enter the following details:
   a. Library Group Code = (enter a group code – for example: LIBRARY)
   b. Locn Code = WEB
   c. Location Description = Web
5. Click the F3 Save button

Web Location Settings

1. Launch the Amlib client
2. Go to Main > Supervisor > Installation – the Installation (DEFAULT) screen will display
3. From the menu, select Installation > Choose Location – the Location prompt will display
4. Select the WEB location and click the OK button
5. The **Installation** (WEB) screen will display

6. Select the **Other** tab

[Image showing the Installation - WEB screen with settings highlighted]

7. Scroll down and enter the following settings:
   a. **Location is Valid for Holdings** = N (some installation may make this Y, so as to be able to associate this Location with online holdings)
   b. **Location is Valid for OPAC Enquiries** = Y
   c. **Location is Valid for Registrations & Circulation** = N

8. Click the **F3 Save** button

9. Exit the *Amlib* client for these settings to take effect
Appendix F: Install .NET Framework

1. Open Internet Explorer

3. Select the Download .NET 4 link – the Download Center page will display:

4. Click the Download button – the following prompt will display:

5. Click the Run button – the .NET Framework 4 installer will open
6. Follow the remaining prompts to update/repair the .NET Framework
7. Click the Finish button when complete (and then restart the computer)
Appendix G: Install a Additional Instance of the NetOpacs

It is possible to install up to 26 sets (or instances) of NetOpacs pages. The following instructions show how to set up a second (b) instance. However, the same instructions can be used to create third (c), fourth (d), etc instances.

Some examples where this may be used:

**Example One – Schools:**
- *Instance 1 (a)* runs the **Senior** school NetOpacs
- *Instance 2 (b)* runs the **Junior** school NetOpacs

**Example Two – Test Pages:**
- *Instance 1 (a)* runs the **public** NetOpacs
- *Instance 2 (b)* runs the **test** NetOpacs

**Example Three – Internal & External:**
- *Instance 1 (a)* runs the **internal** NetOpacs
- *Instance 2 (b)* runs the **external** NetOpacs

The installation of a second (or third, etc) set of NetOpacs involves the following steps:

1. Create a virtual directory folder
2. Setup the NetOpacs folder files
3. Create and configure the virtual directory/application in IIS
4. Configure the NetOpacs WebConsole
5. Configure the NetOpacs Amlib.ini file
6. Compile the NetOpacs pages
7. Restart the FireDaemon Service Manager

Please see: [NetOpacs 5.4 (Second Instance) Installation Guide](#) for further information.
Appendix H: Enabling NetOpacs for Safari

A common error when attempting to access NetOpacs from a Safari web browser is that the browser attempts to download the webquery.dll file rather than open it.

This can be solved in IIS.

IIS5.0/6.0

Webquery.dll

1. Open your Internet Information Services and expand your folders to see the Amlibweb virtual directory:

![Internet Information Services]

2. Right-click on the webquery.dll file and select Properties

![Properties]

3. Select the HTTP Headers tab

![webquery.dll Properties]
4. In the Custom HTTP Headers section, click on the **Add** button – the Add/Edit Custom HTTP Header screen will display:

5. Enter the following settings:
   a. **Custom Header Name**: content-type
   b. **Custom Header Value**: text/html

6. Click the **OK** button

7. Click the **Apply** button

8. Click the **OK** button – you should now be back at the main IIS screen

**CSS**

This will also need to be done to any CSS files you have, which are any files ending in `.css`. You may have some in the `amilibweb` folder, but more commonly you will have a `css` folder that you can open by double-clicking it.

1. As with the above steps, right-click on one of your `css` files and select **Properties**
2. Select the **HTTP Headers** tab

3. In the **Custom HTTP Headers** section, click on the **Add** button – the **Add/Edit Custom HTTP Header** screen will display:

4. Enter the following settings:
   a. **Custom Header Name**: *content-type*
   b. **Custom Header Value**: *text/html*

5. Click the **OK** button
6. Click the **Apply** button
7. Click the **OK** button

This will need to be repeated for any other CSS files you have. When you are done, you can exit **IIS** and your **NetOpacs** should now work correctly in **Safari**.

**IIS7.0**
Webquery.dll

1. Open your Internet Information Services and expand your folders to see the Amlibweb virtual directory:

![Image of Internet Information Services with Amlibweb virtual directory open]

2. Right-click on the amlibweb folder and select Switch to Content View
3. Right-click on the `webquery.dll` file and select **Switch to Features View**

4. In the **ISS** section, double-click the **HTTP Response Headers** icon:

5. The **HTTP Response Headers** screen will display:

6. In the **Actions** section, click on the **Add...** link – the **Add Custom HTTP Response Header** screen will display:

7. Enter the following settings:
NetOpacs 5.4 Installation Guide

8. Click the **OK** button

CSS

This will also need to be done to any CSS files you have, which are any files ending in `.css`. You may have some in the **amlilibweb** folder, but more commonly you will have a **css** folder.

1. Expand the **amlilibweb** folder and select the **css** folder

2. Right-click on a `.css` file and select **Switch to Content View**

3. Right-click on a `.css` file and select **Switch to Features View**
4. In the ISS section, double-click the **HTTP Response Headers** icon:

5. The **HTTP Response Headers** screen will display:

6. In the Actions section, click on the **Add...** link – the **Add Custom HTTP Response Header** screen will display:

7. Enter the following settings:
   
   c. **Name**: `content-type`
   
   d. **Value**: `text/html`

8. Click the **OK** button
This will need to be repeated for any other CSS files you have. When you are done, you can exit IIS and your NetOpacs should now work correctly in Safari.
Appendix I: Edit Access Control

Due to the additional extra security measures on Windows Server 2008, Windows 7 and Vista, you may need to edit the installation’s access control list settings before being able to customise the SQL.ini (and Amlib.ini) files.

1. Locate the drive containing the Amlib Client – for example C:\
2. Right-click on the Amlib folder and select Properties

3. The Amlib FinTransUpgrade Properties screen will display
4. Select the Security tab

5. Click the Edit... button – the Permissions for Amlib FinTransUpgrade screen will display
6. In the Group or user names: pane, click on the Users entry
7. Then in the Permissions for Users pane, check the Allow checkbox for the Modify setting – this will give Users the necessary group permission to apply modifications to files and folders in the **FinTransUpgrade** folder:

![Permissions for Users](image)

8. This action will automatically check the Allow checkbox for the Write setting:

![Permissions for Users](image)

9. Click on the OK button on the Permissions for Amlib FinTransUpgrade and the Amlib FinTransUpgrade Properties screens to complete the change of permissions