Quick Start Guide

Engineer's Toolset

Version 11.0.6

Retrieve the latest version from: https://support.solarwinds.com/Success_Center/Engineer's_ToolSet_(ETS)/ETS_Documentation
© 2016 SolarWinds Worldwide, LLC. All rights reserved.

This document may not be reproduced by any means nor modified, decompiled, disassembled, published or distributed, in whole or in part, or translated to any electronic medium or other means without the prior written consent of SolarWinds. All right, title, and interest in and to the software and documentation are and shall remain the exclusive property of SolarWinds and its respective licensors.

SOLARWINDS DISCLAIMS ALL WARRANTIES, CONDITIONS OR OTHER TERMS, EXPRESS OR IMPLIED, STATUTORY OR OTHERWISE, ON SOFTWARE AND DOCUMENTATION FURNISHED HEREUNDER INCLUDING WITHOUT LIMITATION THE WARRANTIES OF DESIGN, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE, AND NONINFRINGEMENT. IN NO EVENT SHALL SOLARWINDS, ITS SUPPLIERS, NOR ITS LICENSORS BE LIABLE FOR ANY DAMAGES, WHETHER ARISING IN TORT, CONTRACT OR ANY OTHER LEGAL THEORY EVEN IF SOLARWINDS HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

The SolarWinds and other SolarWinds marks, identified on the SolarWinds website, as updated from SolarWinds from time to time and incorporated herein, are registered with the U.S. Patent and Trademark Office and may be registered or pending registration in other countries. All other SolarWinds trademarks may be common law marks or registered or pending registration in the United States or in other countries. All other trademarks or registered trademarks contained and/or mentioned herein are used for identification purposes only and may be trademarks or registered trademarks of their respective companies.

SolarWinds Engineer's Toolset 11.0.6

Document revised: 2/6/2017
Introduction ................................................................. 5
Benefits of SolarWinds Toolset .............................................. 6
Key features of SolarWinds Toolset ........................................ 6
Install Engineer's Toolset ....................................................... 8
System requirements for Desktop Engineer's Toolset .................. 8
System requirements for Engineer's Toolset on the Web ............... 10
Install Desktop Engineer's Toolset .......................................... 12
Silent installation for Desktop Engineer's Toolset ....................... 12
Install Desktop Engineer's Toolset .......................................... 12
Install Engineer's Toolset on the Web ..................................... 14
Uninstall Desktop Engineer's Toolset ..................................... 16
Utilities ............................................................................. 17
License Management ......................................................... 17
Enter licensing information ................................................... 18
Upgrade Engineer's Toolset .................................................. 18
Back up or migrate Engineer's Toolset .................................... 19
Getting started with Desktop Engineer's Toolset ....................... 20
SNMP communication ....................................................... 20
Discover your network ........................................................ 20
Set up the Workspace Studio ............................................... 22
Understand the Workspace Studio layout ................................. 22
Get started ........................................................................ 23
Add dashboard gadgets ....................................................... 23
Add devices ...................................................................... 23
Manage tabs ...................................................................... 24
Analyze your network traffic ................................................ 24
View and compare router configurations .................................. 26
Map your switch ports ....................................................... 27
Manage your network IP addresses ....................................... 27
View real time network device statistics ................................................................. 28

**Getting Started with Engineer's Toolset on the Web** ........................................ 30

   Engineer's Toolset on the Web tools ................................................................. 30

Configure devices for monitoring .......................................................................... 31

Grant access to Engineer's Toolset on the Web .................................................... 32
Introduction

SolarWinds Toolsets contain desktop applications ranging from configuration management, bandwidth and network performance monitoring to discovery and fault management. The size and complexity of your network will determine which Toolset solution best meets your needs.

The following is a list of available tools in Engineer's Toolset:

- Advanced CPU Load
- Advanced Subnet Calculator
- Bandwidth Gauges
- Compare Configs
- Config Editor and Viewer
- Config Uploader
- Config Downloader
- DHCP Scope Monitor
- DNS Audit
- DNS Analyzer
- DNS or Whols Resolver
- Edit Dictionaries
- Enhanced PING
- IP address Management
- IP Network Browser
- MAC Address Discovery
- MIB Browser
- MIB Updates System Field
- MIB Scanner
- MIB Walk
- MIB Viewer
- NetFlow Configurator
- NetFlow Realtime
- Network Monitor
- Network Performance Monitor
- Network Sonar
- PING
- PING Sweep
- Proxy PING
- Port Scanner
- Realtime Interface Monitor
- Remote TCP Reset
- Router CPU Load
- Router Password Decryption
- SNMP Brute Force Attack
- SNMP Dictionary Attack
- SNMP Graph
- SNMP Sweep
- SNMP Trap Editor
- SNMP Trap Receiver
- Spam Blacklist
- Subnet List
- Switch Port Mapper
- Syslog Server
- TFTP Server
- Trace Route
- Wake-on-LAN
- WAN Killer
- Watch It!
- Workspace Studio
- SSH Client

**Benefits of SolarWinds Toolset**

**Advanced troubleshooting**

Toolset enables deep troubleshooting capabilities that go far beyond basic up or down status monitoring or network statistics.

**Broad functionality**

Toolset provides a rich set of applications to address virtually every network engineering challenge from configuration management, network discovery and mapping and fault management to bandwidth and network performance monitoring.

**Ease-of-use**

While Toolset provides comparable functionality, cost and maintenance of your Toolset installation is less than the initial cost of most other solutions.

**Scalable**

Toolset is friendly enough for even the smallest networks but powerful enough to manage the largest, most complex multi-vendor networks.

**Key features of SolarWinds Toolset**

Considering the previously mentioned benefits of Toolset, coupled with the following features, Toolset is a simple choice to make.
**Performance monitoring**

Network performance monitoring is a critical component of a complete network management toolset. With SolarWinds Toolset, you receive several tools that provide the ability to monitor everything from the traffic on a single port to the response time and availability of every server in your network. Several tools also provide graphical reporting and trending capabilities.

**IP address management**

Management of IP addresses is a complex task. With the current rate of growth of many companies, it is often difficult to eliminate errors, much less go back and clean up addresses on decommissioned equipment. The IP address management tools from SolarWinds were designed with speed and ease of use in mind.

**MIB browsing**

Using the MIB browser tools, you can view MIB values a number of different ways: you can browse through different MIB values on a device, display all MIB values, or find just one specific value. With more than 400,000 MIBs in the SolarWinds MIB database, you can view virtually any statistic stored on your network devices.

**Diagnostic tools**

SolarWinds Toolset includes several diagnostic tools to evaluate network problems. You can analyze your DNS settings, graph response times, trace TCP and IP routes, Ping devices from a remote router and more.

**Network discovery**

The network discovery tools were some of the first tools developed by SolarWinds. The majority of the discovery tools use SNMP protocol to collect information on the devices in the network. You can discover something as specific as a reverse DNS error to an entire enterprise of thousands of networks.

**Engineer's Toolset on the Web**

Using the Engineer's Toolset on the Web, you can access real-time monitoring tools within the Orion Web Console. You can display monitored statistics for individual devices not only in tables, but also as interactive charts which display only the metrics you want to see.
Install Engineer's Toolset

Toolset provides a simple, wizard-driven installation process. For an enterprise-class product, the requirements are rather nominal.

Engineer's Toolset v11 uses multiple installation packages because there are more installation scenarios now:

- Install Desktop Engineer's Toolset
- Install Engineer's Toolset on the Web

System requirements for Desktop Engineer's Toolset

The following lists the minimum requirements for Desktop Engineer's Toolset:

<table>
<thead>
<tr>
<th>SOFTWARE AND HARDWARE</th>
<th>REQUIREMENTS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating System</td>
<td>One of the following 32-bit or 64-bit operating systems is required:</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2008 R2</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2008 R2 SP1</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012</td>
</tr>
<tr>
<td></td>
<td>• Windows Server 2012 R2</td>
</tr>
<tr>
<td></td>
<td>• Windows 7 (x32 and x64)</td>
</tr>
<tr>
<td></td>
<td>• Windows 8</td>
</tr>
<tr>
<td></td>
<td>• Windows 8.1</td>
</tr>
<tr>
<td></td>
<td>• Windows 10</td>
</tr>
<tr>
<td>CPU Speed</td>
<td>500 MHz or faster</td>
</tr>
<tr>
<td>Memory</td>
<td>128 MB or greater</td>
</tr>
<tr>
<td>Hard Drive Space</td>
<td>3 GB or more</td>
</tr>
<tr>
<td>Window Account</td>
<td>Installation requires an account with administrator privileges.</td>
</tr>
<tr>
<td>Network</td>
<td>Must be accessible from the computer on which the Toolset is installed to successfully use any network tools.</td>
</tr>
<tr>
<td>.Net Framework</td>
<td>3.5 SP1 and 4.0</td>
</tr>
<tr>
<td>Database</td>
<td>Syslog Server additional component, used to capture and decode syslog messages sent from network devices, supports Access databases.</td>
</tr>
<tr>
<td>SOFTWARE AND HARDWARE</td>
<td>REQUIREMENTS</td>
</tr>
<tr>
<td>-----------------------</td>
<td>------------------------------------</td>
</tr>
</tbody>
</table>
| Browsers              | • Internet Explorer versions 8 and later  
|                       | • Firefox version 40.0  
|                       | • Chrome version 44.0  |

Microsoft Vista has implemented User Account Control (UAC), a layer of security that ensures hostile programs cannot run unnoticed with administrator privileges. Consider the following when installing or running any Toolset application:

- You may be prompted for administrator credentials.
- You may be prompted to grant the application access to the computer.
## System requirements for Engineer’s Toolset on the Web

The following lists the minimum requirements for Engineer’s Toolset on the Web:

<table>
<thead>
<tr>
<th>SOFTWARE AND HARDWARE</th>
<th>REQUIREMENTS</th>
</tr>
</thead>
</table>
| Operating System       | - Windows Server 2008 R2 SP1  
                          - Windows Server 2012  
                          - Windows Server 2012 R2  
                          - Windows 7 x64  
                          - Windows 8  
                          - Windows 8.1  
                          - Windows 10 |
| CPU                    | Dual-core processor |
| RAM                    | 4 GB |
| HDD                    | 4 GB |

- Support for SQL 2008 and 2008 R2 is deprecated as of this release. Future releases will no longer support SQL 2008 or 2008 R2. SolarWinds recommends that you upgrade directly to SQL 2016 at your earliest convenience.
- Support for Windows Server 2008 R2 is deprecated as of this release. Future releases will no longer support Windows Server 2008 R2. SolarWinds recommends that you upgrade to Windows Server 2012, 2012 R2, or 2016 at your earliest convenience.

<table>
<thead>
<tr>
<th>SQL Server</th>
</tr>
</thead>
<tbody>
<tr>
<td>- SQL Server 2008</td>
</tr>
<tr>
<td>- SQL Server 2008 R2</td>
</tr>
<tr>
<td>- SQL Server 2008 R2 SP1</td>
</tr>
<tr>
<td>- SQL Server 2008 R2 SP2</td>
</tr>
<tr>
<td>- SQL Server 2008 R2 SP3</td>
</tr>
<tr>
<td>- SQL Server 2008 SP1</td>
</tr>
<tr>
<td>- SQL Server 2008 SP2</td>
</tr>
<tr>
<td>- SQL Server 2008 SP3</td>
</tr>
<tr>
<td>- SQL Server 2008 SP4</td>
</tr>
<tr>
<td>- SQL Server 2012</td>
</tr>
<tr>
<td>- SQL Server 2012 SP1</td>
</tr>
<tr>
<td>- SQL Server 2012 SP2</td>
</tr>
<tr>
<td>- SQL Server 2014</td>
</tr>
<tr>
<td>SOFTWARE AND HARDWARE</td>
</tr>
<tr>
<td>-----------------------</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Browsers</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
Install Desktop Engineer's Toolset

Before you start the program:

- Confirm that your computer meets or exceeds the requirements to run a Desktop Toolset.
- Disable FIPS before installing SolarWinds Toolset.
  b. Set Use FIPS compliant algorithms for encryption, hashing and signing to Disabled.
- Toolset must be installed for All Users instead of for Individual users.
- If .Net 4.0 is installed in the machine, use SolarWinds-DesktopToolset-v11.exe.
- If .Net 4.0 is not installed in the machine, use SolarWinds-DesktopToolset-v11-WithDotNet.exe.

Silent installation for Desktop Engineer's Toolset

You can now silently install Desktop Engineer's Toolset on your system with command switches.

1. Open a Command Prompt window.
2. Go to the .exe upgrade path.

Your silent installation should start. A series of windows may open and close, these can be ignored.

Install Desktop Engineer's Toolset

1. Log in to Windows as an Administrator.
2. Go to your download location and launch the Solarwinds Toolset executable. In the Toolset Setup wizard, click Next.
3. Select I accept the terms in this License Agreement from the License Agreement window, and then click Next.
4. Specify the location folder where you want Toolset program files to install, and then click Next. The default location is C:\Program Files(x86)\SolarWinds\Toolset.
5. Click Install to start installing Desktop Toolset.

- Nothing has been modified on your computer at this point. Click Back if you want to configure anything before this window.

6. In the Toolset dialogue box, select one of the following:
   - Buy Now! to buy the full version of Engineer's Toolset.
   - Continue Evaluation to continue with the evaluation.
   - Enter Licensing Information to add licensing information for your product. For more information, see Software License Key.

- In the SolarWinds Improvement Program window, select Yes, I wish to participate anonymously (recommended).
7. Click Finish to exit the Setup wizard.

If you want to integrate other Orion products, select I want to load Orion Toolset Integration Tray.

In adherence to Microsoft security policies, Toolset cannot be installed from a remote machine with UAC enabled.
Install Engineer's Toolset on the Web

Before you start the program:

Confirm that your computer meets or exceeds the requirements to run Toolset on the web.

For more information about installing Desktop Engineer's Toolset, see Install Desktop Engineer's Toolset.

1. Log in to Windows as an Administrator.
2. Browse to your download location and launch SolarWinds Toolset On the Web executable. The setup program has either an exe or msi or extension.
3. If you are installing Engineer's Toolset on a server with no other Orion module, select English as your preferred language, and then click Next.
   
   Engineer's Toolset is not localized. If you select any other language, it is applied in the Orion Web Console, but all Toolset areas are still in English. If there is a SolarWinds module already installed, the language is automatically applied and this step is skipped.

4. If there is an existing SolarWinds Orion module, back up your Orion database, enter YES in the provided field, and then click Next.
5. If the installer detects that Internet Information Service (IIS) is not installed, select Continue with Orion installation, and click Next.
6. Accept the license agreement on the License Agreement window, and then click Next.
7. Browse to a file system folder where you want to install the Toolset program files, and then click Next. The default location is \Program Files\SolarWinds\Toolset.
   
   This step is not necessary if you are already running other Orion modules on the server. Engineer's Toolset on the Web is installed in the default credential.

8. If you are installing Engineer's Toolset on the Web on a server where you already have SolarWinds NPM installed, select an Orion installation, and then click Next.
   
   - To use an existing Orion SQL database, select Advanced, and then select the Orion SQL database.
   - To evaluate Engineer's Toolset on the Web or use a new MS SQL Express database, select Express.
9. Click Next to start the installation.
   
   At this time, nothing has been modified on your computer. If you want to change anything before this window, click Back.

10. If prompted to restart IIS, select Restart after installation.
11. Click Finish.
12. Click Enter Licensing Information, and then enter the license key in the Activate Web Toolset window. Complete the Activate Web Toolset wizard.

If you are evaluating Engineer's Toolset on the Web, click Continue Evaluation. You can activate your license later. For more information, see Software License Key.

In adherence to Microsoft security policies, Toolset cannot be installed from a remote machine with UAC enabled.
Uninstall Desktop Engineer's Toolset

Remove the following programs from the Control Panel:

- SolarWinds Toolset
- SolarWinds NetFlow Realtime
- SolarWinds SCP Server
- SolarWinds TFTP Server

Configuration files, Microsoft Access databases, and registry keys are not removed by this procedure.
Utilities

This section provides information on the following:

- Licensing
- Upgrading
- Downgrading
- Creating backup and migrating
- Command Line Interface

License Management

Toolset uses a seat-based license. The tools are made accessible from the Orion Web Console. This feature is only available for Engineer's Toolset license.

- **Web Toolset Per Seat License activation key**: the number of users who can access the application is based on the number of seats purchased per license.
- **Desktop Toolset activation key**: can be used for one desktop installation of Toolset.
- **Use Web Toolset as a stand-alone product**: monitor up to ten resources, regardless of the number of seats purchased.
- **Use Web Toolset with other Orion products**: monitor as many resources as the other product licenses, and additional 10 resources from the Toolset license.

- For more information about licensing change, see Licensing FAQ
- For more information about the licensing change, see the SolarWinds knowledge article "Licensing Engineer's Toolset v11.0 (FAQ)
- For more information about licensing your Engineer's Toolset, see Software License Key
- For more information about managing licenses for Engineer's Toolset, see User License Management for Toolset
Enter licensing information

1. After installation, the Toolset Setup program opens the Activate Toolset window.
2. Click Enter Licensing Information.

To install Toolset on a computer with internet access:

a. Click I want to activate my license over the Internet.
b. Log in to the Customer Portal using your CustomerID and password.
c. Click License Management.
d. Go to SolarWinds Engineer's Toolset, and then locate the unregistered licenses list.
e. Copy your unregistered Toolset activation key to the clipboard, and then paste it in the Activation Key field on the Activate Toolset window.
f. Connect with a proxy server to access the Internet, select Proxy Server, and then enter the proxy address and port number.
g. Click Next. The software license key should now be active.

To install Toolset on a computer without Internet access:

a. Click I want to activate my license through the Customer Portal.
b. Follow the steps in the Activate Toolset window to complete the registration.

Upgrade Engineer's Toolset

To upgrade to the current version of SolarWinds Toolset, find the upgrade path that matches your implementation in the following list:

- Upgrade earlier versions of Engineer's Toolset to version 10.9 and then to version 11.0.6.
- Upgrade Engineer's Toolset:

<table>
<thead>
<tr>
<th>10.9</th>
<th>11.06</th>
</tr>
</thead>
<tbody>
<tr>
<td>11.0</td>
<td>11.06</td>
</tr>
<tr>
<td>11.0.1</td>
<td>11.06</td>
</tr>
<tr>
<td>11.0.2</td>
<td>11.06</td>
</tr>
<tr>
<td>11.0.3</td>
<td>11.06</td>
</tr>
<tr>
<td>11.0.5</td>
<td>11.06</td>
</tr>
</tbody>
</table>

- Uninstall your current Engineer's Toolset version, and install the latest version. Enter your current license activation key. In this case, no manual uninstallation is required, and no data is lost.
- Upgrade Engineer's Toolset from an Evaluation version to a Licensed version requires a license activation key.
- Upgrade from TFTP Server Free Tool to the current Engineer's Toolset.
- Upgrade from NetFlow Real Time Free Tool to the current Engineer's Toolset.
Back up or migrate Engineer's Toolset

The following files **must** be included when creating a backup of your Toolset implementation.

The same version of Toolset must be installed on the computer from which the files are copied. If a file cannot be located, run the associated program and skip the file.

<table>
<thead>
<tr>
<th>FILES TO BACK UP OR MOVE</th>
<th>PURPOSE</th>
</tr>
</thead>
<tbody>
<tr>
<td>*.BandwidthGauges</td>
<td>Bandwidth gauge settings files</td>
</tr>
<tr>
<td>Bandwidth-Monitor.cfg</td>
<td></td>
</tr>
<tr>
<td>dictionaries.cfg</td>
<td></td>
</tr>
<tr>
<td>DNS.cfg</td>
<td></td>
</tr>
<tr>
<td>IP-BrowserWeb.cfg</td>
<td></td>
</tr>
<tr>
<td>Network-Monitor.cfg</td>
<td></td>
</tr>
<tr>
<td>PortScan.cfg</td>
<td></td>
</tr>
<tr>
<td>SWDiscovery.cfg</td>
<td></td>
</tr>
<tr>
<td>SWNetPerfMon.cfg</td>
<td></td>
</tr>
<tr>
<td>TraceRoute.cfg</td>
<td></td>
</tr>
<tr>
<td>Watchit.cfg</td>
<td></td>
</tr>
<tr>
<td>*.IPDB</td>
<td>IP address management database</td>
</tr>
<tr>
<td>*.mdb</td>
<td>Syslog database</td>
</tr>
<tr>
<td>*.SNMP-Graph</td>
<td>SNMP Realtime graphs</td>
</tr>
<tr>
<td>*.SDB</td>
<td>Network Sonar databases</td>
</tr>
</tbody>
</table>

These files are located in the following locations by default, where UserName is the Windows user account.

C:\Documents and Settings\UserName\Local Settings\Application Data\SolarWinds
C:\Documents and Settings\All Users\Application Data\SolarWinds

Some Toolset applications prompt you for a location to save specific files. If you have saved any files in a location other than the paths listed above, you will need to locate these saved files.
Getting started with Desktop Engineer's Toolset

A quick launching interface that provides immediate access to all Toolset applications has been added. Direct access is also provided to host network configuration, including IP configuration, ARP, DNS, and Route information for the local client.

The Toolset Launchpad should start up automatically after the installation has completed. You can also start it by clicking Start > All Programs > SolarWinds Toolset > SolarWinds Toolset Launchpad.

The Toolset Launchpad features include the following:

- Click Recently Used Tools to display the last five tools that were launched. On initial installation, a default set of the top five tools is displayed in this category. Click a tool to display more details about the specific functionality.
- Add, rename, and delete tool groups by right-clicking any group and selecting the action.
- Add tools to your new group by clicking a tool in another group and dragging it into the launching pane.
- Change the group listing order by clicking a group and moving it up or down the list.
- Click Host Network Info for a quick view of the ARP, DNS, IP configuration, and Route information for the local host.
- Click Settings to configure automatic startup and to add Toolset Launchpad to your Windows Task Tray. Click Reset settings to restore all out of the box settings, including tool groupings.

SNMP communication

Toolset takes advantage of SNMP communication to collect inventory information. Ensure that all devices from which you want to collect detailed information have SNMP properly configured.

Discover your network

IP Network Browser is an interactive network discovery where users can scan an IP address range or a subnet and show details for discovered devices, including System MIB, ARP table, interfaces, IOS, drives, flash memory and more.

1. Open the Toolset Launch Pad.
2. Click Network Discovery and then click Launch on the IP Network Browser.
3. Enter the required information to scan a single device, a subnet, or an IP address range and then click the associated Scan button.
4. Use the browsing tree to expand node information categories and initiate real-time discovery of details.

5. Click Discovery > Expand and Discover details for selected Node to initiate real time discovery of all node details at once.
Set up the Workspace Studio

The SolarWinds Workspace Studio can implement tabbed views displaying a wide range of your vital network statistics. You can create views that show graphs, gauges and tables of response times, current bandwidth, percent utilization and more. You can also incorporate network discovery views to perform quick ping sweeps and map network switches.

The dashboard utilizes an intuitive drag-and-drop interface that quickly and easily moves and sizes objects as you see fit. The real-time data collected by the Workspace Studio is always easy to find and manage.

Understand the Workspace Studio layout

The Workspace Studio consists of tabs and gadgets presented in a fully-customizable layout.

Gadgets

Gadgets can be discovery tools, interface monitors, CLI tools, or response time monitors. See Add dashboard gadgets for more information.

Tabs

Tabs are panes containing multiple gadgets. With multiple tabs, you can create numerous customized views. Each open tab is listed on the tab bar. See Manage tabs for more information.

Explorer pane

The Explorer pane contains all the gadgets, tools and devices accessible within the Workspace Studio.
**Toolbar**

The toolbar is used to save devices, gadgets and tabs that have already been configured for quick access to the items you use most.

**Zoom panel**

The zoom panel is shown at the bottom of all charts and is used to adjust the time period displayed. The zoom panel can be locked to prevent incoming data from affecting the current chart.

**Get started**

To begin using the Workspace Studio, add a dashboard gadget to a tab. See Add dashboard gadgets for more information. After a gadget has been added to a tab, you need to configure or add a device to the gadget. See Configure Gadgets in the Administrator Guide for more information.

The following procedure demonstrates how to add a response time chart for SolarWinds.com.

2. Click Dashboard Gadgets > Response Time Monitors and then drag the chart gadget to a tab.
3. Click Devices in the explorer pane, expand Monitored Devices and then drag SolarWinds.com to the response time chart.
4. If you want to add more devices to the chart, drag the additional devices to the chart.

**Add dashboard gadgets**

Dashboard gadgets can be added by dragging a gadget from the explorer pane to a tab.

1. Click Dashboard Gadgets in the explorer pane.
2. Expand the type of gadget you want to add and then drag the gadget to a tab.

Note: You can also double-click a gadget in the explorer pane to open it within a new tab.

After a gadget has been added, it will need to be configured. See Add gadgets in the Administrator Guide for more information.

**Add devices**

When using gadgets, you can provide device details when you configure the gadget, or you can add devices to be saved for later use.

1. Click Devices > Add New Device.
2. Enter the IP address or host name of the device.
3. Select an option for when to display the device status.

![Tip] When monitoring a large number of devices, it is a good idea to set your devices to show the status Only When Monitored in a Gadget to reduce unnecessary overhead.

4. If you want to discover the device credentials based on the existing credential sets, click Discover a credential.
5. If you want to select an existing credential set, select the credential set from the list and then click Test this credential.
6. If you want to create a new credential set, click Add a new credential, provide the information and then click OK.
7. Click Add new device.

Manage tabs

Tab layout and design is fully customizable for creating multiple tabs containing multiple sets of gadgets. You can switch from a tab showing you details on a core switch to a tab showing you discovery information. Tabs can be saved so that you can return to your customized view.

1. Click Tabs > New Tab.
2. Drag and drop any gadgets you want to the tab.
3. If you want to save the tab, right-click the tab name and then click Save Selected Tabs.

You can also create horizontal or vertical groups of tabs. This way you can move multiple groups of tabs in a split-view on your monitor.

- To split tabs horizontally, click Tabs > Move Selected tabs to New Horizontal Tab Group.
- To split tabs vertically, click Tabs > Move Selected tabs to New Vertical Tab Group.

You can copy gadgets from one tab to a newly-created tab by dragging the gadget to a blank area next to an existing tab.

**Analyze your network traffic**

SolarWinds Engineer's Edition Toolset includes a real time capture and analysis tool that can store up to one hour of Cisco NetFlow data. It displays inbound and outbound traffic separately for granular analysis and troubleshooting.

1. Click Network Monitoring in the Launch Pad and then click Launch on the NetFlow Realtime tool.
2. If you have Cisco routers configured properly to send NetFlow data to the Toolset host machine, these are listed in the dialog with green check marks next to the interfaces the tool is receiving NetFlow data about. Select an interface and then click Start Flow Capture to begin analyzing NetFlow data.
3. Navigate to the view categories in the left pane to granularly analyze NetFlow data being received.
4. If you want to view application data, complete the following procedure:
   a. Click Applications to display the distribution of traffic utilization of the Top XX applications (Top 5 is default).
   b. Expand this category to display a list of all applications in the NetFlow data being received.
   c. Select an application in this list to display the distribution of traffic utilization of all the nodes that are utilizing the selected application or port.
   d. Map unknown ports to application names by right-clicking on the port and then clicking Map Port.

5. If you want to view conversation data, complete the following procedure:
   a. Click Conversations to display the distribution of traffic utilization among the Top XX nodes that are the source of conversations (Top 5 is default).
   b. Expand this category to display a complete list of all the source nodes of the conversations. The entries will display the host name of the node if reverse DNS resolution is successful, otherwise the IP address will be displayed.
   c. Select a host or IP address to display the distribution of traffic utilization of all the hosts with which the selected host is communicating.

6. If you want to view domain data, complete the following procedure:
   a. Click Domains to display the distribution of traffic utilization among the Top XX domains (Top 5 is default).
   b. Expand this category to list all the domains that have been resolved. If reverse DNS resolution is unsuccessful, an IP address will be displayed.
   c. Select a domain or IP address to display the distribution of traffic utilization of all the domains with which the selected domain is communicating.
7. If you want to view endpoint data, complete the following procedure:
   a. Click Endpoints to display the traffic utilization distribution across the Top XX nodes (Top 5 is default).
   b. Expand this category to list all nodes. The entries will typically display the host name of the node if reverse DNS resolution is successful, otherwise the IP address will be displayed.
   c. Select an endpoint to display the traffic utilization distribution of all nodes that transmitted to and from the selected node.

8. If you want to view protocol data, complete the following procedure:
   a. Select and view this category to display the traffic utilization distribution by protocol (for example, TCP, UDP, and so on) for the Top XX nodes utilizing the protocol (Top 5 is default).
   b. Expand this category to list the individual protocols in the NetFlow data being received.
   c. Select one of the protocols to display the traffic utilization of nodes that utilized the protocol.

**View and compare router configurations**

SolarWinds Toolset includes a collection of Cisco router and switch configuration tools for downloading, modifying, comparing and uploading device configurations using the SolarWinds TFTP server.

1. Click Configuration Management in the Launch Pad and then launch Config Viewer.
2. Click Select Router.
3. Enter the host name or IP address of your router or switch.
4. Enter the read and write community string and then click OK.
5. Click Download to start the transfer process.
6. Select the type of configuration you want to download and then click OK.
7. To compare startup versus running configuration on a particular router, click File > Compare Startup vs. Running Configs.

8. To compare previously downloaded configuration files, click File > Compare Two Config Files.
Map your switch ports

Switch Port Mapper is an automated tool used to remotely discover the devices connected to each switch or hub port, including the MAC address, IP address and host name of the connected devices as well as details about each port. Reports can be easily exported to Excel, PDF, CSV, and HTML.

Only switches and hubs that support the BRIDGE-MIB can be mapped.

1. Click Network Discovery in the Toolset Launch Pad and then launch Switch Port Mapper.
2. Click Select Switch and then enter the target host name or IP address of the switch or hub and a read and write community string.
3. Click Select Router and enter the router or server host name or IP address (must be directly connected to the same subnet as the target switch or hub) and a read community string. This device will be used to resolve MAC to IP address and then reverse DNS will be used to resolve IP address to host name.
4. Click Map Ports to start the switch port mapping process.
5. If you want to save the results, click Export and select the format you want to use (CSV, text file, HTML, Excel, or Adobe PDF).

Manage your network IP addresses

IP address Management is a tool for actively monitoring which IP addresses are in use on your network, including:

- IP address status
- DNS name
- Number of days from the last response
- Machine enter
- System name
- Location
- Response time
- User-defined comments

Manage your IP addresses by performing the following:

1. Click IPAM/DNS/DHCP in the Toolset Launch Pad and then launch IP address Management.
2. Click New to add a new subnet.
3. Enter your subnet information in the New Subnet window. Click Subnet Calculator to get help on selecting the subnet mask and the number of IP addresses that will be included in the scan.
4. Click OK to save your subnet information, and perform a scan.

5. **If you want to save the results**, click Export and then select the format you want to use (CSV, text file, HTML, Excel, Adobe PDF, image, or XML).

**View real time network device statistics**

Real Time Interface Monitor is a network interface monitor capable of displaying statistics from multiple routers and switches simultaneously, including:

- Interface and port status
- Time of last change
- Current receive and transmit traffic rates
- Interface percent utilization
- Duplex settings
- Collisions
- Alignment errors
- Runts
Giants

This release supports over 400 standard and vendor proprietary statistics.

View real time network statistics by performing the following:

1. Click Network Monitoring in the Launch Pad and then launch Real Time Interface Monitor.
2. Enter the host name or IP address and SNMP community string of your device and then click OK.
3. Click Monitor to start network interface monitoring.

4. To change the interface details being displayed, select a new group from the Statistics Group list.
5. To add new statistics groups click File > Settings and then click the Statistics Groups tab.
6. If you want to launch a graphical bandwidth monitor, click an interface and then click Edit > Bandwidth Gauge.
Getting Started with Engineer's Toolset on the Web

Engineer's Toolset on the Web is a feature of Desktop Engineer's Toolset, providing you with real time monitoring tools within the Orion Web Console.

You can view monitored statistics for separate devices not only in tables, but also as interactive charts which display only the metrics you want to see.

1. Monitored statistics are only saved when you keep a monitor running for an object. All history records are lost after closing a tool.
2. You can keep a maximum of three Engineer's Toolset on the Web tools running at the same time.

1. Install Enginee's Toolset on the Web. For more information, see Installing Engineer's Toolset on the Web.
2. Log in to your Orion Web Console using an account with administrative privileges.

Using Engineer's Toolset on the Web requires that it is enabled for your user account. For more information, see Enable a User to Use Engineer's Toolset on the Web.

3. Click the Toolset tab.
4. Select the tool.
5. Configure the objects you want to monitor and click Monitor. See Configure Devices for Monitoring for more information.

If you are using Trace Route, define the host name or IP address of the server whose route you want to trace.

Engineer’s Toolset on the Web tools

Engineer's Toolset on the Web contains the following tools:

**Trace Route**

Analyzes the performance and latency of hops across a communication path.

**Interface Monitor**

- Find out and monitors the speed of your Internet connection
- Detects suspicious network activity
- Finds and monitors backup links and interfaces
- Finds and monitors multiple interface instances
**Response Time Monitor**
- Monitors real time response of a web server
- Graphical PING monitor
- Monitors response time on multiple nodes

**CPU Monitor**
- Monitors CPU load on multiple devices in real time

**Memory Monitor**
- Monitors memory utilization in real time
- Finds out and monitors free, total and used memory of multiple nodes in real time.

**Configure devices for monitoring**

You can either select devices for monitoring in the Orion Web Console, or define them from Engineer's Toolset on the Web tools.

To configure what devices you want to monitor in the tool:

1. Log in to the Orion Web Console.
2. Click the monitor to open the tool.
3. If you have already been using the monitor, click Configure monitor to go to the Configure Monitor page.
4. Find the node whose interfaces, CPU, memory, or response time you want to monitor.
   - Select the node for monitoring in the Orion Nodes area and click the green arrow.
   - The node moves into the Selected objects (interfaces, ..) area.
   - If you are monitoring interfaces, CPU or memory, click the + in front of the node to display available objects within the node.

To discover objects within:

- a selected node, select the node and click Discover All.
- all nodes in the Selected objects area, click Select All, and then click Discover All.

4. Select boxes for objects which you want to monitor. If you need to select all items, click the Select All button.

If you are using Toolset:

- as a stand-alone product, you can monitor a maximum of ten resources, regardless of the number of seats purchased.
- together with other Orion products, you can monitor as many resources as the other product licenses can, and additional ten resources from the Toolset license.
To monitor nodes not available in the Orion Web Console:

a. Click Add Non-Orion Device.
b. Enter the IP address or host name of the device that you want to monitor.
c. Select the credentials set.

If you do not have any credentials defined in your Engineer's Toolset on the Web, click Manage Credentials. Add the credentials, click Refresh Credential List, and then select the new credentials.

d. Click Add Device to add the device to the Selected Objects area.
e. If you are monitoring interfaces, CPU or memory, click the + in front of the node to display available objects within the node.

To discover objects within:

- a selected node, select the node and click Discover All.
- all nodes in the Selected objects area, click Select All, and then click Discover All.

f. Select boxes for objects which you want to monitor. If you need to select all items, click the Select All button.

5. Select how the monitoring results should be presented in the View Enter list:

- Select Table to see all configured metrics for all selected objects in a table.
- Select Chart to see monitored objects in an interactive chart where you can easily display required metrics for object(s) in a graph.

6. Click Monitor Devices to start monitoring the selected objects.

**Grant access to Engineer's Toolset on the Web**

To enable a user to use Engineer's Toolset on the Web, you need to assign him one of available seat licenses contained in your Engineer's Toolset license. For more information about licenses, see License management.

1. Log in to the Orion web Console using an account with administrator rights.
2. Go to Toolset settings:
   a. Click the Toolset tab in the menu bar.
   b. Click Toolset settings in the upper-right corner view.

   - You can also access Toolset settings if you click Settings > Toolset settings.
   - View the license summary of all SolarWinds products available to you in the Orion Web Console. Go to Toolset settings > Orion License Summary.

3. Click Toolset User Licenses in the License Summary grouping.
4. Select a user and click Enable. One of the seats will be assigned to the user and the number of free seats will decrease by one.
For more information about Engineer's Toolset, see *Engineer's Toolset Administrator Guide*, Engineer's Toolset online help, or visit the Engineer's Toolset forum on thwack.