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Chapter 1

About this release
The release notes document contains late-breaking information about Kofax MarkView for Oracle EBusiness Suite. Please read this document carefully, as it contains information that is not available in
other documentation.

Version information
Kofax MarkView 9.1.1 R2 is identified by build number 9.1.1.0.67531. You can verify the build number as
follows:
1. In <distribution_directory>, open build-number.txt, where <distribution_directory> is the
location where you downloaded and extracted the MarkView installation files.
2. Verify that the version number is 9.1.1, and the build number is 67531.
Install this service pack to take advantage of enhancements made to the product since Kofax MarkView
9.1.1.0.67017 was released. For details about the enhancements and fixes, see the next section, "Content
changes."

Content changes
This section lists changes that were made to the Kofax MarkView 9.1.1 release notes since they were
initially published on December 8, 2017.
The "Reintegrate _CUSTOM packages" section was added to the Apply the service pack chapter.
The following items were added to the Resolved issues chapter:
• 1107978
• 1104209
• 1097256

System requirements
The primary source of information about Kofax MarkView requirements and dependencies is the
Technical Specifications document, which is available on the Kofax website. The document is updated
regularly, and we recommend that you review it carefully to ensure success with your Kofax MarkView
product.
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Oracle patches
Oracle Accounts Payable processing requires Oracle patch 20725445:R12.AP.
If you plan to use the WebLogic 12.2 application server, apply Oracle patches 21043834 and 19028811
on WebLogic.
See the Oracle website for more information.

New features
AUSS interface update
Kofax MarkView 9.1.1 uses HTML5 corporate standard for web applications involving the update and
redesign of the Automated User Setup and Synchronization (AUSS) Administrator user interface.
The updated AUSS version adds the following new features and options:
• Synchronize one user: Use this option to manually synchronize a specified user. You can only
synchronize one user at a time.
• Reset configuration: Use this option to return the AUSS default settings. MarkView AUSS will only keep
the Journal and System Statistics information.
Before you click "Reset configuration", verify that you backed up your current AUSS configuration.
• Journal: The Journal tab displays the synchronization history and change tracking.
For information about configuring and using AUSS, see the Kofax MarkView Administrator's Guide,
Volume 1.

Import/Receive PDF files
With this feature, MarkView can receive PDF files when Kofax Capture/Kofax Transformation Modules
(KC/KTM) and Kofax Invoice Processing Agility will be able to export PDF files to MarkView. In addition
to accepting the incoming invoice files in the PDF format, MarkView is able to split and combine the
incoming PDF files if necessary.
MarkView can import PDF files from the disk storage via MarkView Import Server.

Support for Blanket PO
With this feature, MarkView can import invoice lines against specific Blanket PO Releases. In MarkView
and Kofax Capture/Kofax Transformation Modules, you can manually match invoice lines to Blanket PO
Release lines and Receipts against Release lines.
Kofax Transformation Modules does not support auto-matching against Blanket PO Releases and
Shipments. Also, MarkView does not support Shipments.
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Support for SAML
Kofax MarkView authentication feature includes Single Sign-On (SSO) implementation based on passing
user credentials to MarkView by the Security Assertion Markup Language standard (SAML). Kofax
recommends that you use SAML to enable SSO in MarkView.
Kofax MarkView 9.1.1 adds a new tab MarkView SAML Service Providers Metadata to
Administration > Authentication Configuration.
For information about configuring and using SAML, see the Kofax MarkView Administrator's Guide,
Volume 2.

Support for WebLogic 12.2
Kofax MarkView 9.1.1 supports WebLogic Server 12.2.
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Apply the service pack
This chapter describes how to apply Kofax MarkView 9.1.1.
Once your system has a minimum of Kofax MarkView 9.1.0 installed and configured, follow the
instructions in these release notes to apply the service pack. Have your completed installation worksheet
available.

Before you start
This section describes the steps that you must follow before applying the service pack.

Download and decompress distribution files
Your Kofax representative will give you the location from which to download the compressed MarkView
system setup files.
1. Log in to the application server host operating system as the application server owner.
2. Create a temporary distribution directory for the compressed MarkView installer and verification files.
For example, <home_directory>/mvdist where <home_directory> is the user home directory.
3. In the distribution directory, create the following subdirectories:
• <distribution_directory>/verify
• <distribution_directory>/installer
Where <distribution_directory> is the name of the directory you just created.
4. Download KofaxMarkView-9.1.1_Oracle_Verify.zip into the verify directory.
5. Download KofaxMarkView-9.1.1_Oracle.zip into the installer directory.
6. Extract the files.
Note The built-in ZIP utilities in certain versions of Windows, have issues with lengthy directory
paths. Use a third-party extraction utility if your directory paths are more than 200 characters long.

Back up your MarkView schema
Before you apply the service pack, back up your MarkView schema. See the Kofax MarkView 9.1.1
Administrator's Guide, Volume 1, "Maintaining the System "for information about backup strategies.
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End MarkView components in process
Stop all MarkView components, unless needed when you apply the service pack, including all Capture
and Output services, as well as Capture and Kofax Transformation Modules services.

Delete MarkView synonyms for Advisor (Oracle EBS 12.2 only)
If MarkView AP Advisor was never installed on your system and you integrate MarkView with Oracle EBusiness Suite 12.1 or earlier, skip this section.
Follow the steps in this section even if you deleted the MarkView synonyms for Advisor when you
upgraded to MarkView 9.1.0.
1. Log in as the MarkView database user.
2. Navigate to <distribution_directory>\installer\scripts, where <distribution_directory>
is the location where you downloaded and decompressed the installation files.
3. Run synonym_drop_in_all_editions.sql and when prompted, enter the MarkView schema username
and MarkView database logging directory name.
The synonym_drop_in_all_editions.sql script creates synonym_drop_in_all_editions_autogen.sql in
the MarkView database logging directory.
4. Log in to the MarkView database as SYSDBA.
5. Navigate to the MarkView database logging directory and run
synonym_drop_in_all_editions_autogen.sql to drop synonyms that connect the MarkView and
Advisor user schemas in database editions.
Do not modify this script.

Back up _CUSTOM packages
The _CUSTOM packages contain functionality and scripting that is unique to an installation of MarkView
database objects.
Back up all _CUSTOM packages and store a copy of the SQL script files that create the current version of
your _CUSTOM packages.
To extract the current version of your _CUSTOM packages from the database, use the tool associated
with Extracting custom package bodies from your MarkView schema.
See the Kofax MarkView 9.1.1 Administrator's Guide, Volume 2 for more information about _CUSTOM
packages.

Back up the Kofax Transformation Modules project and batch classes
If your system includes Kofax Transformation Modules, copy your customized Kofax Transformation
Modules project files and batch classes to a safe location before you apply this service pack. When you
apply this service pack, MarkView automatically installs a new Kofax Transformation Modules project in C:
\KTM\Markview.
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After you apply this service pack, refer to your customized Kofax Transformation Modules project files and
batch classes, manually edit the new Kofax Transformation Modules project files and batch classes, and
save them in your runtime directory, for example C:\KTM\Markview\MyProject.

Back up XSLT files
If you have any customizations of the following XSLT files used by MVImportAPIConfig, back up these
XSLT files:
• KofaxCapture82Generic.xslt
• KofaxCapture82ImportServer.xslt
• KofaxCapture82Parse.xslt

Upgrade Kofax Transformation Modules
If you plan to upgrade Kofax Transformation Modules, do it before applying the service pack. Follow the
instructions in the Kofax Transformation Modules Upgrade Guide.

Getting ready to run the installer
Before running the installer, verify that your application server is running. For information about the
application server configuration, see the Kofax MarkView 9.1.0 installation or upgrade guides.

The JAR file modification (for WebLogic 12.2 only)
If you use MarkView with WebLogic Server 12.2, locate <installation_directory>/Oracle/

Middleware/Oracle_Home/wlserver/modules/com.oracle.weblogic.security.opensaml2.jar,
where <installation_directory> is the location where you installed WebLogic Server 12.2 and remove

the file or change the file extension.

This JAR file modification is required even if you are not using SAML.

JBoss EAP additional configuration
If you use MarkView with JBoss EAP, you must perform the following configuration:
1. Make a backup copy of JBOSS_HOME\bin\jboss-cli.xml.
Open jboss-cli.xml for editing, locate and change the following string and save the changes.
From:
<jboss-cli xmlns="urn:jboss:cli:1.3">

To:

<jboss-cli xmlns="urn:jboss:cli:2.0">

Note After you apply the service pack, you must restore jboss-cli.xml.
2. Modify the following scripts depending on the installation type and your operating system:
• install.sh or install.bat
• install_silent.sh or install_silent.bat
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• verify.sh or verify.bat
• verify_silent.sh or verify_silent.bat
You must open the required file for editing and add the Dmarkview.jboss.protocol parameter.
For example, change:
java -Xmx1024m -cp ${CLASSPATH} -Doracle_home=${ORACLE_HOME}
com.markview.installer.Installer "$@"

to:

java -Xmx1024m -cp ${CLASSPATH} -Doracle_home=${ORACLE_HOME} Dmarkview.jboss.protocol=remoting com.markview.installer.Installer "$@"

Verify the Target Registry Service
After MarkView version 9.1.0 is installed, the Target Registry Service (TRS) stores information such as
module versions in the MarkView database. The TRS URL is an entry on the installation worksheet. For
example, http://<application server host>:<port>/mvastrs/markview where <application server
host> and <port> are the pre-upgrade host name and port number. When you upgrade, the TRS must be
running to provide this information to the installer.
• If you are upgrading and installing a new application server, leave the TRS on the existing application
server running. After you upgrade, shut down the old application server.
To verify that the TRS is running, open your browser and enter the URL. If the TRS is running, the
MarkView TRS web page appears. If the browser cannot find the page, the TRS is not running. If
necessary, restart the TRS.
• If you are upgrading and your old application server is not available, manually deploy the TRS in the
new application server, and then run the installer.

Start the Target Registry Service on the application server
WebLogic
1. Log in to the application server Admin Console and navigate to Deployment.
2. Locate and verify that the mvastrs status is Active.
3. If the status is not Active, select the application and click Start.

WildFly or JBoss EAP
1. Log in to the application server Admin Console and navigate to Deployments.
2. Locate and verify that the mvastrs status is Enabled.
3. If the status is not Enabled, select mvastrs and click Enable.

Install MarkView
Before you run the MarkView installer, run verify on all systems where MarkView products are being
upgraded:
• Application server hosts
• Oracle E-Business Suite hosts
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• Capture and Output Server hosts for:
•
•
•
•
•

Fax Server
Bar Code Server
Mail Gateway Server
MarkView Data Export Server
Kofax Capture Server

Verify checks the following:
• Version information for

•
•
•
•

• Operating System
• Database
• Database Server
• Application Server
• Forms Server
MarkView Oracle RDBMS user privileges
Oracle XML DB
Oracle Advanced Queuing
MarkView schema user setup

Verify generates logs that contain information about issues that can cause the process to fail.
Have your completed MarkView Installation Worksheet available for reference and select the type of
installation to perform:
• To use the silent-mode installation, see Silent-mode installation.
• To use the installer application interface, see Run the MarkView installer.

Silent-mode installation
In silent-mode installation, you set installation properties in a script, which the installer reads. The installer
does not prompt for input during the installation process. Because you can reuse the install_silent script, it
can automate identical installations on multiple systems.

Edit the preliminary_interview.properties file
1. Navigate to <distribution_directory>/installer/conf where <distribution_directory> is
the location where you downloaded and decompressed the installation files.
2. Back up the preliminary_interview.properties file.
3. Open the preliminary_interview.properties file and enter the following information.
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Note For installations running on Windows, when modifying manually populated fields, use a
double backslash (\\) or a forward slash (/) as a path delimiter.
Field

Allowed Values

AppServerType. app_server_type

• WebLogic
• JBoss (use for WildFly and JBoss EAP)

InstallDirectory. install_directory

Installation directory. This is user-defined and must exist prior to
applying the service pack. This cannot be the same as the temporary
distribution directory. See the MarkView Installation Worksheet.

InstallerAction. installer_action

upgrade

InstallationType. installation_type

• Standard Full Install: Select this option the first time you apply
the service pack. This option installs the application server
components and database objects.
• Partial Install: Select this option if you already applied the service
pack and need to reinstall application server components. This
option installs only the application server components.

SelectedProducts.
selected_products

These must exactly match what appears in the install_script.xml
file. To verify product names, open install_script.xml and search for
display = <product name>.
For example:
• MarkView for AP 9.1.1 with Transformation
• MarkView for Expense Management 9.1.1
• MarkView Document Library 9.1.1
• MarkView Self Service Invoice 9.1.1
To list multiple products, separate product names with commas.

ERPType.erp_type

(Optional) Oracle or blank

Run the generateInterviewTemplate file
The generateInterviewTemplate script uses the information in the preliminary_interview.properties file to
generate the installer_interview.properties file.
1. Navigate to <distribution_directory>\installer\bin, where <distribution_directory> is
the location where you downloaded and decompressed the installation files.
2. Run either:
• UNIX: generateInterviewTemplate.sh
• Windows: generateInterviewTemplate.bat

Edit the installer_interview.properties File
1. Navigate to <distribution_directory>\installer\conf where <distribution_directory> is
the location where you downloaded and decompressed the installation files.
2. Back up the installer_interview.properties file.
3. Open the installer_interview.properties file.
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4. Enter information for the fields identified with bold type in the following table. These fields appear in
the same alphabetical order in the installer_interview.properties file. Use this list as a reference for all
possible fields in the installer_interview.properties file. Your file may not contain all of the listed fields.
Field names and values cannot contain spaces.
Note Modifying automatically populated fields may cause unexpected results while applying the
service pack.
Also, for installations running on Windows, when modifying manually populated fields, use a double
backslash (\\) or a forward slash (/) as a path delimiter.
Field

Values

Source

Product

AppServer Type. app
_server_type

• WebLogic

Automatically
populated. Do
not change this
value.

All

AppServerType. type

SimpleQuestion

Automatically
populated. Do
not change this
value.

All

Documentum Integration.
enabled

Valid values are N or Y.

Automatically
populated. Do
not change this
value.

AP

Documentum
Integration .type

Documentum Integration

Automatically
populated. Do
not change this
value.

AP

Folder Location.
location

Directory for the Document Server. Must
exist prior to applying the service pack.

Enter the data
from your
Installation
Worksheet.

AP

FolderLocation. type

FolderLocation

Automatically
populated. Do
not change this
value.

AP

InstallDirectory. install
_directory

From the preliminary _interview. properties
file

Automatically
populated. Do
not change this
value.

All

InstallDirectory. type

SimpleQuestion

Automatically
populated. Do
not change this
value.

All

InstallationType.
installation _type

From the preliminary _interview. properties
file

Automatically
populated. Do
not change this
value.

All

• JBoss (use for WildFly and JBoss EAP)
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Field

Values

Source

Product

InstallationType. type

SimpleQuestion

Automatically
populated. Do
not change this
value.

All

JBossAppServer.
adminUserName

JBoss administrator name

Enter the data
from your
Installation
Worksheet.

All

JBossAppServer.
adminPassword

JBoss application server administrator
password

Enter the data
from your
Installation
Worksheet.

All

JBossAppServer.
adminPort

The admin HTTP port (for example, 9090)

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

JBossAppServer.asSSL

For SSL with WildFly or JBoss EAP: true

Enter the data
from your
Installation
Worksheet.

All

Valid values: true, false

JBossAppServer.domain For domain mode, enter your domain name
as follows:

For domain
mode, enter
JBossAppServer.domain=<domainName> the data from
your Installation
For standalone mode, leave the field value
Worksheet.
blank:

All

JBossAppServer.domain=
JBossAppServer. host

Fully qualified hostname of this machine

JBossAppServer. port

The HTTP port where MarkView applications To change
listen (for example, 26000)
the default
value, enter
the data from
your Installation
Worksheet.

All

JBossAppServer. type

JBossAppServer

All

Enter the data
from your
Installation
Worksheet.

Automatically
populated. Do
not change this
value.

All
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Field

Values

Source

Product

JBossAppServer.
jbossLocation

Defaults to
<distribution_directory>/../
wildfly,

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

Defaults to
<distribution_directory>/distr/
ojdbc6-11.2.0.3.jar,

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

JBossAppServer.
needsDeploy

Defaults to <empty>

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

MarkView DBConn.
dbType

oracle

Automatically
populated. Do
not change this
value.

All

MarkView DBConn.
host

Fully qualified hostname where MarkView
resides

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn.
indexspace

Tablespace for MarkView indexes

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn.
loggingDirectory

Oracle logging directory for MarkView
processes

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn.
password

Password for MarkView schema user

Enter the data
from your
Installation
Worksheet.

All

Enter the data
from your
Installation
Worksheet.

All

where <distribution_directory> is
the location where you downloaded and
extracted the MarkView installation files.
If <distribution_directory>/../
wildfly does not exist prior to applying
the service pack, the installer creates the
directory.
JBossAppServer.
oracleDriver

where <distribution_directory> is
the location where you downloaded and
extracted the MarkView installation files.
Valid values: no, yes

MarkView DBConn. port Port for MarkView schema
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Field

Values

Source

Product

MarkView DBConn. sid

SID for MarkView schema

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn.
tablespace

Tablespace for MarkView data

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn. type OracleDatabase Connection

Enter the data
from your
Installation
Worksheet.

All

MarkView DBConn.
user

Username for the MarkView schema user

Enter the data
from your
Installation
Worksheet.

All

OracleEBS. password

Oracle APPS user password

Enter the data
from your
Installation
Worksheet.

All except Doc
Lib

OracleEBS.type

OracleEBSInstance

Automatically
populated. Do
not change this
value.

All except Doc
Lib

OracleEBS. user

Oracle APPS username

Enter the data
from your
Installation
Worksheet.

All except Doc
Lib

OracleEBSCodes.
holdCode

170_SYSTEMS _HOLD

Automatically
populated. Do
not change this
value.

All except Doc
Lib

OracleEBSCodes.
releaseCode

170_SYSTEMS _RELEASE

Automatically
populated. Do
not change this
value.

All except Doc
Lib

OracleEBSCodes. type

OracleEBS Codes

Automatically
populated. Do
not change this
value.

All except Doc
Lib

OracleText. password

Oracle Text user password

OracleText.type

OracleText

OracleText.user

CTXSYS

Doc Lib
Automatically
populated. Do
not change this
value.

Doc Lib

Doc Lib
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Field

Values

Oracle Text user

Doc Lib

SelectedProducts.
selected_ products

Products selected in the preliminary
_interview. properties file

Automatically
populated. Do
not change this
value.

All

Selected Products. type

MultipleAnswer Question

Automatically
populated. Do
not change this
value.

All

SMTPInfo. password

SMTP password, if necessary

Enter the data
from your
Installation
Worksheet.

All

SMTPInfo. serverName

Fully qualified SMTP server address

Enter the data
from your
Installation
Worksheet.

All

SMTPInfo. type

Custom Resource

Automatically
populated. Do
not change this
value.

All

SMTPInfo. username

SMTP username if necessary

Enter the data
from your
Installation
Worksheet.

All

WebLogic AppServer.
adminPassword

WebLogic application server password

Enter the data
from your
Installation
Worksheet.

All

WebLogic AppServer.
adminPort

The admin HTTP port (default 7001)

Enter the data
from your
Installation
Worksheet.

All

WebLogic AppServer.
adminUserName

WebLogic administrator name

Enter the data
from your
Installation
Worksheet.

All

WebLogicAppServer.
asSSL

For SSL with WebLogic: true

Enter the data
from your
Installation
Worksheet.

All

WebLogic AppServer.
domainLocation

Defaults to ${WL_HOME}/../markview)

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

Valid values: true, false

Source

Product
Doc Lib
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Field

Values

Source

Product

WebLogic AppServer.
domainName

Defaults to MarkView

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

WebLogic AppServer.
host

Fully qualified hostname of this machine

Enter the data
from your
Installation
Worksheet.

All

WebLogic AppServer.
jarLocation

Defaults to ${WL_HOME}/server/lib/
weblogic.jar

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

WebLogic AppServer.
javaHomeDir

Defaults to %WL_HOME/../jrockit_*

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

WebLogic AppServer.
nodeManagerPort

Defaults to 5556

To change
the default
value, enter
the data from
your Installation
Worksheet.

All

WebLogic
AppServer.port

The HTTP port where MarkView applications To change
listen (default 8001)
the default
value, enter
the data from
your Installation
Worksheet.

All

WebLogic
AppServer.type

WebLogicAppServer

All

Automatically
populated. Do
not change this
value.

Run the verify_silent script
To ensure that your environment is configured properly to successfully apply the service pack, run the
verify script, which is a smaller version of the installation script.
1. Copy the installer_interview.properties file that you generated in Run the generateInterviewTemplate
file and edited in Edit the installer_interview.properties File from <distribution_directory>/
installer/conf to <distribution_directory>/verify/conf, (where
<distribution_directory> is the location where you downloaded and decompressed the
installation files).
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2. Ensure that all the paths entered in the install_interview.properties file exist.
3. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate to
<distribution_directory>/verify/bin, (where <distribution_directory> is the location
where you downloaded and decompressed the installation files), open for editing verify_silent.sh or
verify_silent.bat and change the following string:
• For UNIX:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.Installer %*

4. In <distribution_directory>/verify/bin, run either:
• UNIX: verify_silent.sh
• Windows: verify_silent.bat
If no errors occur, verify_silent returns to a command prompt with no further messages.

Run the install_silent script
1. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate to
<distribution_directory>/installer/bin, (where <distribution_directory> is the location
where you downloaded and decompressed the installation files), open for editing install_silent.sh or
install_silent.bat and change the following string:
• For UNIX:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
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-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.Installer %*

2. In <distribution_directory>\installer\bin, run either:
• UNIX: install_silent.sh
• Windows: install_silent.bat
Note If the installer encounters an error, the process stops. Review the log files located in the log
folder in the MarkView installation directory. Resolve the issue, and then rerun the install_silent
script.
Upon successful completion, the install_silent script returns to the command prompt with no further
messages.

Silent-mode setup for Oracle Objects
Copy target_registry_service.properties file from the MarkView installation directory to the Oracle Objects
installation directory.

Edit the preliminary_interview.properties file for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Navigate to <distribution_directory>/installer/conf (where <distribution_directory> is
the location where you downloaded and decompressed the installation files).
3. Back up the preliminary_interview.properties file.
4. Open the preliminary_interview.properties file and enter the following information.
Field

Allowed Values

AppServerType.app_server_type

• WebLogic
• JBoss (use for WildFly and JBoss EAP)

InstallDirectory.install_directory

Installation directory. This is user-defined and
must exist prior to installation. See the MarkView
Installation Worksheet.

InstallerAction.installer_action

upgrade
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Field

Allowed Values

InstallationType.installation_type

Standard Full Install
Partial Install (Any value other than Standard Full
Install will perform a partial installation)

SelectedProducts.selected_products

Must be an exact match to contents of the
install_script.xml file. To verify product names, open
install_script.xml and search for display = <product
name>. To list multiple products, separate product
names with commas.

ERPType.erp_type

(Optional) Oracle or blank

Run the generateInterviewTemplate file for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Navigate to <distribution_directory>\installer\bin where <distribution_directory> is
the location where you downloaded and decompressed the installation files.
3. Run either:
• UNIX: generateInterviewTemplate.sh
• Windows: generateInterviewTemplate.bat

Edit the Oracle Objects installer_interview.properties file
1.
2.
3.
4.
5.

Log in to the Oracle EBS server as the EBS user.
Navigate to the conf folder in the MarkView installation directory.
Back up the installer_interview.properties file.
Open the Oracle Objects installer_interview.properties file.
Enter information for the fields marked with bold type. There are no spaces in field names.
Note Modifying fields populated by the preliminary_interview.properties file may cause unexpected
results while applying the service pack.
Field

Values

Source

Product

InstallDirectory.
install_directory

MarkView installation
directory from the
preliminary_ interview.
properties file

preliminary_ interview.
properties

All

InstallDirectory. type

Simple Question

preliminary_ interview.
properties

All

InstallationType.
installation_type

Install type seeded from
preliminary_ interview .
properties

preliminary_ interview.
properties

All

InstallationType . type

SimpleQuestion

preliminary_ interview.
properties

All

MarkView DBConn.
dbType

Enter oracle.

preliminary_ interview.
properties

All

Installation Worksheet

All

MarkView DBConn. host Fully qualified hostname
where MarkView resides
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Field

Values

Source

Product

MarkView DBConn.
indexspace

Tablespace where
MarkView indexes will
reside

Installation Worksheet

All

MarkView DBConn.
logging Directory

Oracle logging directory
for MarkView processes

Installation Worksheet

All

MarkView DBConn.
password

Password for MarkView
schema user

Installation Worksheet

All

MarkView DBConn. port

Port for MarkView
schema

Installation Worksheet

All

MarkView DBConn. sid

SID for MarkView schema Installation Worksheet

All

MarkView DBConn.
tablespace

Tablespace where
MarkView data will reside

Installation Worksheet

All

MarkView DBConn. type Oracle Database
Connection

Installation Worksheet

All

MarkView DBConn. user Username for MarkView
schema user

Installation Worksheet

All

OAForms EnvInfo.
appl_top

install_silent.sh

Forms

OAForms EnvInfo. au_top

install_silent.sh

Forms

OAForms EnvInfo.
c_markview_ top

install_silent.sh

Forms

OAForms EnvInfo.
fnd_top

install_silent.sh

Forms

OAForms EnvInfo. type

install_silent.sh

Forms

OAFrameworks EnvInfo.
appl_top

install_silent.sh

OA Frameworks, OA
Expense

OAFrameworks EnvInfo.
common_top

install_silent.sh

OA Frameworks, OA
Expense

OAFrameworks EnvInfo.
java_top

install_silent.sh

OA Frameworks, OA
Expense

OAFrameworks EnvInfo.
type

OAFramework EnvInfo
Resource

install_silent.sh

OA Frameworks, OA
Expense

OracleEBS password

Oracle APPS user
password

Installation Worksheet

All except Doc Lib

OracleEBS .type

Oracle EBSInstance

preliminary_ interview.
properties

All except Doc Lib

OracleEBS. user

Oracle APPS username

Installation Worksheet

All except Doc Lib

Selected Products.
selected_products

Products selected from
preliminary_ interview.
properties

preliminary_ interview.
properties

All
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Field

Values

Source

Product

Selected Products. type

Multiple Answer Question

preliminary_ interview.
properties

All

Run the verify_silent script for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. Copy the installer_interview.properties file from <distribution_directory>/installer/conf to
<distribution_directory>/verify/conf (where <distribution_directory> is the location
where you downloaded and decompressed the installation files).
3. Ensure that all the paths entered in the install_interview.properties file exist.
4. In <distribution_directory>/verify/bin, run either:
• UNIX: verify_silent_oracle_objects.sh
• Windows: verify_silent_oracle_objects.bat
If no errors exist, verify_silent_oracle_objects returns to a command prompt with no further
messages.

Run the install_silent script for Oracle Objects
1. Log in to the Oracle EBS server as the EBS user.
2. If the Target Registry Service is already deployed, copy the existing
target_registry_service.properties file to the MarkView installation directory for Oracle Objects.
3. In <distribution_directory>/installer/bin, (where <distribution_directory> is the
location where you downloaded and decompressed the installation files), run either:
• UNIX: install_silent.sh
• Windows: install_silent.bat
Note If the installer encounters an error, the process stops automatically. Review the log files
located in the log directory in the target installation directory. Resolve the issue, and then rerun the
install_silent script.
If no errors exist, the install_silent file returns to the command prompt with no further messages.

Run the MarkView installer
Use the information that you entered on the Kofax MarkView Installation Worksheet to respond to the
Verify prompts. Run Verify before running the MarkView installer.
1. Log in to the application server host operating system as the application server owner.
2. Ensure that the MarkView application server is running.
3. Ensure that the environment variables are correct.
4. Skip this step if you do not use SSL for the application server. If you plan to use SSL, navigate to
<distribution_directory>/verify/bin, (where <distribution_directory> is the location
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where you downloaded and decompressed the installation files), open for editing verify.sh or
verify.bat and change the following string:
• For UNIX:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} com.markview.installer.InstallerVerify "$@"

to:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.InstallerVerify "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% com.markview.installer.InstallerVerify %*

to:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.InstallerVerify %*

5. Navigate to <distribution_directory>/verify/bin, (where <distribution_directory> is the
location where you downloaded and decompressed the installation files), and run the command for
your operating system:
• UNIX: verify.sh
• Windows: verify.bat
6. On the Which products do you want to verify for this environment? page, select only the
products that you plan to upgrade.
• MarkView for AP with Transformation
• MarkView for Expense Management
• MarkView Self Service Invoice
7. Follow the on-screen prompts and click Verify.
Note On the Installation Progress window, click Show Details to display the progress.
8. If the system prompts you to enter the URL of the Target Registry Service, enter the value from
the installation worksheet (for example, http://<application server host>:<port>/mvastrs/
markview).
After Verify finishes running, a confirmation message appears.
9. Review the generated reports located in the MarkView installation directory you selected during the
verification. Save these logs in another directory to avoid overwriting them.
The log file reports/EnvironmentReport.txt describes issues with your environment.
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10. Make changes as indicated in the failure reports. You are now ready to apply the service pack.

Restart the application server
1. For WebLogic:
1. Log in to the WebLogic Administration console.
2. Navigate to Environments > Servers, click the Control tab and select markview_server.
3. Click Shutdown and select Force Shutdown Now.
When you restart markview_server the first time after installing or upgrading applications, not all
applications transition to the Active state. At this point, not all applications need to be active.
2. For WildFly or JBoss EAP:
Skip this section, if you want to use the MarkView installer to install and configure WildFly and
proceed to running the MarkView installer.
If you use manually configured WildFly or JBoss EAP, make sure that the application server is
started.

Modify installation scripts (for SSL only)
Skip this section if you are not using SSL for the application server.
1. Navigate to <distribution_directory>/installer/bin where <distribution_directory> is
the location where you downloaded and extracted the installation files, and open for editing:
• UNIX: install.sh
• Windows: install.bat
2. Locate and change the string as follows:
• For UNIX:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} com.markview.installer.Installer "$@"

to:
java -Xmx1024m -cp ${CLASSPATH}
-Doracle_home=${ORACLE_HOME} -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>
com.markview.installer.Installer "$@"

• For Windows:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% com.markview.installer.Installer %*

to:
java -Xmx1024m -cp "%CLASSPATH%"
-Doracle_home=%ORACLE_HOME% -Dmarkview.ssl.alias=<alias>
-Djavax.net.ssl.keyStore=<keystore>
-Djavax.net.ssl.keyStorePassword=<keystorepassword>
-Djavax.net.ssl.trustStore=<truststore>
-Djavax.net.ssl.trustStorePassword=<truststorepassword>

27

Kofax MarkView Release Notes for Oracle E-Business Suite

com.markview.installer.Installer %*

Where:
• <alias> is a keystore attribute that defines the string alias used to store and retrieve the server
private key.
• <keystore> is a repository that contains private keys and the certificates with the corresponding
public keys.
• <keystorepassword> is a password of <keystore>.
• <truststore> is a repository that contains trusted certificates from other parties that it expects to
communicate with, or from Certificate Authorities that it trusts to identify other parties.
• <truststorepassword> is a password of <truststore>.

Run the installation scripts for WebLogic
The installer populates some fields based on entries in the Target Registry Service (TRS) file. (Installing
MarkView for Accounts Payable creates the TRS file.) Some information, like passwords, is not saved.
Have your completed Installation Worksheet available when you start the installer.
1. Log in to the application server host operating system as the application server owner.
2. Verify that the application server is running.
3. Ensure that the environment variables are correct.
4. Navigate to <distribution_directory>\installer\bin where <distribution_directory> is
the location where you downloaded and extracted the installation files, and run the command for your
operating system:
• UNIX: install.sh.
• Windows: install.bat.
5. On the Which products do you want to install? window, select the products to update.
6. Click Next.
7. Select Standard Full Install and click Next.
8. On the Which type of J2EE application server will MarkView use? window, select WebLogic and
click Next.
9. Use the installation worksheet to complete the windows as prompted by the installer.
The windows and prompts that appear vary based on your selections.
10. When prompted, click Install.
Note If you are keeping your existing Application Server, select the same MarkView installation
directory where MarkView is installed. See your Kofax MarkView Installation Worksheet.
11. Click Exit to complete the process.
The installer finishes with a message indicating whether you successfully applied the service pack.
12. The installer creates a log file in the MarkView installation directory. Save the installation log files in a
safe place in case you need this information for Technical Support.
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Run the installation scripts for WildFly or JBoss EAP
The installer populates some fields based on entries in the Target Registry Service (TRS) file. (Installing
MarkView for Accounts Payable creates the TRS file.) Some information, like passwords, is not saved.
Have your completed Installation Worksheet available when you start the installer.
1. Log in to the application server host operating system as the application server owner.
2. If you use manually installed WildFly, verify that the application server is running.
3. If you use manually installed WildFly, ensure that the environment variables are correct.
4. Navigate to <distribution_directory>\installer\bin where <distribution_directory> is
the location where you downloaded and extracted the installation files, and run the command for your
operating system:
• UNIX: install.sh.
• Windows: install.bat.
5. On the Which products do you want to install? window, select the products to update.
6. Click Next.
7. Select Standard Full Install and click Next.
8. On the Which type of J2EE application server will MarkView use? window, select WildFly/JBoss
and click Next.
9. Use the installation worksheet to complete the windows as prompted by the installer.
The windows and prompts that appear vary based on your selections.
• Admin Username
• Admin User Password
• Domain
For the domain mode, enter your domain name in the Domain field.
For the standalone mode, leave the Domain field blank.
• App Server Directory
For manually configured WildFly or JBoss EAP, specify <JBOSS_HOME>.
If you are using the MarkView installer to install and configure WildFly, specify the location to store
your WildFly installation files.
• Host Name
Specify your application server host name.
• Admin Port
The admin ports for manually configured WildFly and JBoss EAP may differ.
• SSL
Select the check box if you are using SSL.
• HTTP Port
• Install WildFly
Select Install WildFly, to use the MarkView installer to install and configure the WildFly
application server.
Clear Install WildFly, to use the manually installed WildFly.
10. On the installer screen, check the summary of your selections.
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Note In the Application server field, the value JBoss is set.
11. When prompted, click Install.
Note If you are keeping your existing Application Server, select the same MarkView installation
directory where MarkView is installed. See your Kofax MarkView Installation Worksheet.
Note In Show Details > Output, Installing or verifying JBoss server... line indicates the WildFly
installation and verification process.
12. Click Exit to complete the process.
The installer finishes with a message indicating whether you successfully applied the service pack.
13. The installer creates a log file in the MarkView installation directory. Save the installation log files in a
safe location in case you need them later for Technical Support.

After you apply the service pack
Restart the application server
WebLogic
1. Log in to the WebLogic Administration console.
2. Navigate to Environments > Servers and restart markview_server.
Note When you restart markview_server the first time after installing or upgrading applications, not all
applications transition to the Active state. At this point, not all applications need to be active.

WildFly
If you used the MarkView installer to install and configure WildFly, before starting the application server,
configure the memory properties.
1. Set the JBOSS_HOME environmental variable, such as:
JBOSS_HOME=<drive&path>/wildfly

2. Start the WildFly application server in standalone or domain modes. See the JBoss website for more
information about the operating modes.

JBoss EAP
1. Restore jboss-cli.xml that you modified in Getting ready to run the installer.
2. Start the JBoss EAP application server in standalone or domain modes.

Reintegrate _CUSTOM packages
There are several changes to the _CUSTOM packages.
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If you have not customized your _CUSTOM packages, compile these packages to upgrade them to the
current versions.
Compile these custom packages from the distribution directory (/modules/erp-

integration-dist-9.1.1/erp-integration-db/schema/custom_package_bodies/
custom_package_bodies_private/):

• @mverp_dfm_custom_pb.sql
• @mverp_dfm_descr_flex_custom_pb.sql
• @mverp_dfm_lov_custom_pb.sql
If you have customized your _CUSTOM packages, modify and compile your packages before you can
test other aspects of the system such as entering invoices into the system, and displaying and marking up
these invoices.
See the Kofax MarkView 9.1.1 Administrator's Guide, Volume 2 for more information about custom
packages.
To support Oracle R12, MarkView divides the definition of distribution line into distributions and invoice
lines. These custom packages have changed as a result of this division and although the changes
are applicable only for Oracle 12, you must edit and recompile these packages for all Oracle and SAP
environments.
• MVERP_DFM_DESCR_FLEX_CUSTOM: This package has a new function, a new procedure, and a
change to an existing procedure:
• New function, SetContextValueForLine. Derives Descriptive FlexField (DFF) content for an invoice
line. This is only applicable for Oracle R12 environments when the DFM is created with the
DFM_FIELD_DFF field enabled.
• New Procedure, PopulateSegmentForLine. Populates DFF segments for a distribution line. This is
only applicable for Oracle R12 environments when the DFM is created with the DFM_FIELD_DFF
field enabled.
• MVERP_DFM_CUSTOM: This package has new procedures and a new function.
• New function, GetDefaultAccountForLine. Gets the default concatenated account segments
whenever the amount is entered on an invoice line and the account has not already been entered.
This is only applicable for Oracle R12 environments when the DFM has been created with
UseProjects set to FALSE.
• New procedures, SetLineTypeDefaultsForLine and SetLineTypeDefaults. Set the default values
for the Tax fields when the Line Type of an invoice line or a distribution line changed. This is only
applicable for Oracle environments when the DFM has been created with EnableLineTypeDefaults
set to TRUE.
• New procedure, SetProjectDefaultsForLine. Sets the default values for additional project-related
fields when the Project has been changed on an invoice line. This is only applicable for Oracle R12
environments when the DFM has been created with UseProjects set to TRUE.
• New procedure, ValidateInvoiceLine. Performs custom validation on an invoice line. This procedure
cannot change values on an invoice line. This is only applicable for Oracle R12 environments.
• MVERP_DFM_LOV_CUSTOM: This package has a new procedure.
• New procedure, PopulateFlexSegmentForLine. Populates LOV for flex segment values for an
invoice line. This is only applicable for Oracle R12 environments when the DFM is created with the
DFM_FIELD_DFF field enabled.
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Check for invalid packages
1. Log in as the MarkView database user.
2. Enter the following SQL statement:
SELECT OBJECT_NAME, OBJECT_TYPE FROM USER_OBJECTS WHERE STATUS
= 'INVALID';

3. If invalid database objects exist, save the output from the SQL statement and run @gencomp.sql
in <distribution_directory>\installer\scripts, where <distribution_directory> is the
location where you downloaded and decompressed the installation files.
A message similar to the following appears:
Recursively compiling 2 object(s).
Please wait...
All objects compiled successfully.

4. Review the information in the COMPILE.LOG. If the message says that it is recursively compiling
more than 0 objects, rerun @gencomp.sql. Dependencies between objects can require more than
one execution to complete compilations successfully.
5. If any objects still fail to compile, run SQL*Plus SHOW ERRORS to view the error messages. Use
the following format for this command:
SHOW ERRORS { FUNCTION | PROCEDURE | PACKAGE | PACKAGE BODY | TRIGGER | VIEW }

name

For example, to view the PL/SQL errors for the package body
MVERP_DFM_DESCR_FLEX_CUSTOM, enter:
SQL> SHOW ERRORS PACKAGE BODY MVERP_DFM_DESCR_FLEX_CUSTOM

The errors that occurred during compilation of the object are displayed.

Update Accounts Payable workflow filters
To ensure that all workflow filters are up-to-date, log in to the database as the MarkView schema owner
and run the following SQL statement:
begin
SF_Designer.RebuildFilterDispatch;
end;
/
exec SF_Filter_Util.UpdateAllFilterResults;
commit;

Note In production environments, this can be a lengthy process.

Verify that database jobs are running
1. Log in to MarkView with administrator privileges.
2. Navigate to Utilities > System Status and locate DBMS User Jobs Broken.

32

Kofax MarkView Release Notes for Oracle E-Business Suite

Status

Current
Value

Limit

Over Limit

Description

DBMS User Jobs
Broken

2

0

Y

The number of current MarkView database user
jobs that are in error.

Disconnected Bar
Code Server

1

0

Y

Checks v$session to see if the Bar Code server
has a connection to the database.

3. Contact Kofax Technical Support if the current value for DBMS User Jobs Broken is greater than 0.

Install MarkView Oracle Objects
Follow the steps in this section if you installed MarkView manually as described in Run the MarkView
installer.

Download the Oracle Objects installer and Verify files
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-Business
suite owner. The default account for this user is applmgr.
2. Create a temporary distribution directory for the compressed MarkView installer and verification
files. For example, <home_directory>/mvforms_dist where <home_directory> is the user home
directory.
3. In the distribution directory, create these subdirectories:
• <distribution_directory>/verify
• <distribution_directory>/installer
Where <distribution_directory> is the temporary distribution directory you just created.
4. Download KofaxMarkView-9.1.1_Oracle_Objects_Verify.zip into the verify directory.
5. Download KofaxMarkView-9.1.1_Oracle_Objects.zip into the installer directory.
6. Decompress the files.

Run Verify on the Oracle E-Business Suite host
Use the information that you entered on the Installation Worksheet to respond to the Verify prompts.
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-Business
Suite owner. The default account for this user is APPLMGR.
2. Ensure that the environment variables are correct.
3. Ensure that the MarkView application server is running.
4. Navigate to <distribution_directory>/verify/bin, where <distribution_directory> is the location
where you downloaded and decompressed the installation files.
5. Run Verify:
• On Unix, enter ./verify_oracle_objects.sh.
• On Windows, enter verify_oracle_objects.bat.
6. Select the products you are planning to install with the Oracle Objects installer.
• Oracle Forms Integration
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• OA Framework Integration for AP (Oracle EBS 12.x only)
• OA Framework Integration for Expense (only if you are running MarkView for Expense
Management)
Consider these points when you select products:
• Only systems running Oracle EBS 12.x that also include MarkView for Account Payables can
select OA Framework Integration for AP.
• Only systems running MarkView for Expense Management can select OA Framework Integration
for Expense
7. Follow the prompts.
8. Review the generated reports. The reports are located in the MarkView installation directory you
selected during the verification. Save these logs in another directory to prevent overwriting them.
The file reports/EnvironmentReport.txt describes issues with your environment that will prevent
successful installation.
9. Make changes as indicated in the failure reports. Now you are ready to run the MarkView Oracle
Objects installer.

Run the MarkView Oracle Objects installer
1. On the Oracle E-Business Suite server, open a command shell and log in as the Oracle E-Business
suite owner. The default account for this user is applmgr.
2. Make sure that all environment variables are correctly set up for this account, check:
• $PATH: Confirm the appropriate Java version comes first (or run java –version). For the Java
version, see the Technical Specifications document on the Kofax website.
• $APPL_TOP: Confirm this is the correct instance of Oracle E-Business Suite
• $FORMS_PATH: Confirm that it includes $AU_TOP/resource and $AU_TOP/forms/US.
3. Ensure that the application server is running.
4. Navigate to <distribution_directory>/installer/bin, where <distribution_directory> is the
temporary distribution directory.
5. Start the installer by running either:
• For Unix: ./install.sh
• For Windows: install.bat
6. Select the applications to install. Available choices are:
• Oracle Forms Integration
• OA Framework Integration for AP (R12 only)
• OA Framework Integration for Expense
Consider the following when selecting products:
• Only systems running Oracle Release 12 that also include MarkView for Account Payables can
select OA Framework Integration for AP.
• Only systems running MarkView for Expense Management can select OA Framework Integration
for Expense.
7. Click Next.
8. Select Standard Full Install and click Next.
9. Click Select Folder to navigate to the MarkView installation directory and click Next.
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10. If prompted, enter or select the Target Registry Services URL and click Next.
11.
12.
13.

14.
15.
16.

17.

For example, http://my_host.company.com:7777/mvastrs/markview
Enter your MarkView schema password and click Next.
Enter your Oracle applications schema password and click Next.
The order and appearance of the next few steps vary depending on the installation options.
Review the values displayed and click Next:
• Location of APPL_TOP value: Confirm this is the instance of Oracle E-Business Suite where you
want to install Forms.
• Location of AU_TOP and FND_TOP values: Confirm this is the instance of Oracle E-Business
Suite where you want to install Forms (both directories should be under $APPL_TOP).
• Location of $c_MARKVIEW_TOP value
Verify the Oracle Framework Environment Variable values APPL_TOP, COMMON_TOP, and
JAVA_TOP and click Next.
Review the Summary and click Next.
Click Install.
The process can take several minutes. To track the progress, click Show Details.
The installation finishes with a message indicating whether the installation is successful.
The installation script creates log files in the MarkView installation directory.
Click Exit.

Restart the Oracle EBS processes
You must restart the Oracle EBS processes to pick up the new components.
Oracle R12:
$ADMIN_SCRIPTS_HOME/adapcctl.sh stop
$ADMIN_SCRIPTS_HOME/adoacorectl.sh stop
$ADMIN_SCRIPTS_HOME/adapcctl.sh start
$ADMIN_SCRIPTS_HOME/adoacorectl.sh start

Oracle 12.2:
$ADMIN_SCRIPTS_HOME/adapcctl.sh stop
$ADMIN_SCRIPTS_HOME/admanagedsrvctl.sh stop oacore_server1
$ADMIN_SCRIPTS_HOME/adapcctl.sh start
$ADMIN_SCRIPTS_HOME/admanagedsrvctl.sh start oacore_server1

Add the log4j logging library to the class path (Oracle EBS 12.2 only)
After running the Oracle Objects installer on Oracle EBS 12.2, manually add the log4j library to the class
path. If you do not add the log4j library, you may encounter errors while working with Oracle Forms. For
example, an unexpected error may occur in the iExpenses module.
1. Extract the $JAVA_TOP/log4j.jar file into a temporary directory.
For example, from a UNIX shell, run the following commands:
$ cd $JAVA_TOP
$ mkdir /tmp/log4j
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$ cp -p log4j.jar /tmp/log4j
$ cd /tmp/log4j
$ jar xf log4j.jar

2. Move or copy the org directory from the temporary directory to $JAVA_TOP. The unpacked org
directory contains one directory called log4j.
For example, from a UNIX shell, run the following command:
$ mv /tmp/log4j/org $JAVA_TOP

3. Run the Oracle Adadmin utility to generate the new .jar files.
1. From the Oracle Adadmin utility, select option 1: Generate Applications Files menu.
2. Select option 4: Generate product JAR files.
3. If you wish to force regeneration of all .jar files, when prompted, enter Y.

Capture and Output modules
Before you upgrade any Capture and Output module, verify that you upgraded the MarkView Application
Server and Database components.

Download and extract the Installer and Verify files
Download the compressed MarkView System setup files from the location provided by your Kofax
representative.
• Capture and Output Server host for the following servers:
• Fax Server
• Barcode Server
• Mail Gateway Server
• MarkView Import Server
• Data Export Server
• Kofax Capture Server host
• Kofax Transformation Modules Server host
To access the files:
1. Log in as the local administrator for the operating system for the Windows Capture and Output
server.
2. Create a temporary distribution directory for the compressed MarkView installer and verification files,
for example, C:\mvcodist.
3. In the distribution directory, create the following subdirectories:
• C:\mvcodist\verify
• C:\mvcodist\installer
4. Download KofaxMarkView-9.1.1_Capture_Output.zip into the installer directory.
5. Extract the files.
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Note The built-in ZIP utilities in certain versions of Windows, have issues with lengthy directory
paths. Use a third-party extraction utility if your directory paths are more than 200 characters long.

Update the path
For the MarkView Capture and Output installer Java JDK version, see the Technical Specifications
document on the Kofax website.
To check your version, run java -version.
Add the location of Java to the beginning of the Windows Path statement.

Uninstall Brooktrout drivers
Before upgrading MarkView Fax Server, stop it and uninstall the Brooktrout 6.2 drivers. When you
upgrade the MarkView Fax Server, it automatically installs the Brooktrout 6.5 drivers. If you do not
uninstall the Brooktrout 6.2 drivers, the MarkView Fax Server installation completes correctly, but you
will need to uninstall the Brooktrout 6.2 drivers and reinstall the Brooktrout 6.5 drivers manually after you
upgrade MarkVIew.

Run the Capture and Output modules installer
Use the information that you entered on the Installation Worksheet to respond to the prompts.
1. Stop MarkView Capture and Output server components before running the installer.
2. Log in as the local administrator for the operating system for the Windows Capture and Output
server.
3. Navigate to <distribution_directory>\installer\bin and run install.bat.
4. All products available on all installers are listed on the Which products do you want to install for
this environment? page. Select only the products you are planning to upgrade with the Capture and
Output installer and click Next.
• MarkView Fax Server: Supports RightFax
• MarkView Barcode and Mail Gateway
• MarkView Import Server: Supports the Fax Server and is silently upgraded when you upgrade the
fax server software. You do not need to upgrade the MarkView Import Server separately.
• MarkView Data Export Server
The Installation Type window opens.
5. Select Standard Full Install and click Next.
Use the Partial Install option only if client components are installed in multiple locations and the
database components should not be installed again.
6. Browse to the MarkView Installation Directory where the target_registry_service.properties file
resides and click Next.
The MarkView Installation Directory stores the install logs and the
target_registry_service.properties file. This file contains the TRS URL, the location where the values
entered in response to Installer prompts and module version information are stored. This document
refers to the installation directory as <installation_directory>.
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The system prompts you for the MarkView schema connection information.
7.
8.
9.
10.
11.

Enter the MarkView Schema Password and click Next.
Review the summary of your selections and click Next.
Click Show Details to display the process status.
Click Install to start the InstallShield Wizard.
Follow the prompts to upgrade the components you selected. If you selected Fax, the system
automatically upgrades Import Server.
12. When prompted to select the upgrade directories, browse to the base directories where the Capture
and Output components were originally installed.
13. Follow the prompts to complete the process. The prompts depend on your system configuration and
which Capture and Output modules you are upgrading. These prompts may include items similar to
the following:
• Export Server Instance: If you are prompted for an Export Server Instance, click Close to
accept the default.
• Import Server Instance: If you are prompted for an Import Server Instance, click Close to
accept the default.
• Restart: If the system prompts you to restart:
• If the system has not upgraded all the Capture and Output modules you selected, select No, I
will restart later and click Finish.
• If the system has completely upgraded all the Capture and Output modules you selected, select
Yes, I will restart now and click Finish.
• Setup Type: If you are prompted for the Setup Type, select Typical and follow the prompts.
14. Click Finish on the Maintenance Complete window.
15. Reboot the system to activate the changes.

Integrate with Kofax Capture and Kofax Transformation Modules
Before you upgrade Kofax MarkView Export Connector, verify that your system meets minimum system
requirements. See the Technical Specifications document on the Kofax website for the version numbers.
MarkView requires:
• Kofax Capture and 32-bit ODBC drivers
• ODAC with the following required components:
• Oracle Data Provider for .NET
• Oracle Provider for OLE DB
• For transformation, you also need Kofax Transformation Modules

Upgrade Kofax MarkView Export Connector
Perform the following procedure on all machines running Kofax Capture or Kofax Transformation
Modules, including all scan and validation stations. Make sure that you backed up the files described in
Back up the Kofax Transformation Modules project and batch classes and Back up XSLT files.
1. Log in as an administrator.
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2. On the MarkView Application Server host, navigate to the MarkView installation directory, open the
export connector directory, and locate the kcec-markview.msi file.
For example: <installation_directory>/export-connector/kcec-markview.msi
3. Copy kcec-markview.msi to a temporary directory on the Windows machine on which Kofax Capture
is installed.
4. To start the installation, run kcec-markview.msi as Administrator or use the Administrator command
line.
5. When the installation wizard opens, follow the prompts.
When the installation is complete, a message indicates that Kofax MarkView Export Connector is
successfully installed.
6. Click Finish.
7. Verify that the Kofax Capture service is running.
8. Repeat these steps on all scan and validation stations.

Kofax Transformation Modules project templates
Note The Kofax Transformation Modules project was updated as part of the service pack.
Follow the instructions in this section to prepare the project template and batch class templates. For
more information, see the user documentation for Kofax Transformation Modules and Kofax Capture.
MarkView automatically installs the project template MarkView KTM Invoices 50 in C:\KTM\Markview.
When you customize the project, create a new runtime version of the project directory that stores the
Kofax Transformation Modules project .fpr file and all the files needed for the project.
Copy your customized Kofax Transformation Modules project files to a safe location before you upgrade.
After you upgrade, refer to your customized project files when you manually edit the new project files.
Then, save the edited project files in your runtime directory, such as C:\KTM\Markview\MyProject.

Prepare the Kofax Transformation Modules project template for use
1. Ensure that you have read-write access to the Kofax Transformation Modules project:
1. In Windows, navigate to your Kofax Transformation Modules project directory, such as C:\KTM
\Markview.
2. Select the Kofax Transformation Modules project and right-click Properties.
3. Select the General tab and clear Read-only.
4. Select Apply changes to this folder subfolders and files and click OK.
5. Click OK.
2. Start Kofax Transformation Modules Project Builder.
3. Open the Kofax Transformation Modules project:
1. Select File > Open Project.
2. Locate the MarkView KTM Invoices project folder, such as C:\KTM\Markview.
3. Open the MarkView KTM Invoices 50 project file.
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A warning may appear. Click Close to close the warning. You will address any warnings later in
this process.
4. Click Save Project As and save the edited project to a new name.
MarkView creates a new directory under C:\KTM\Markview, such as C:\KTM\Markview\MyProject
and stores the Kofax Transformation Modules project .fpr file and all the files needed for the project.
5. Select Project > Script Variables and set the following script variables:
• Project type : Enter Oracle.
• Oracle Version : Enter the Oracle version.
• Demo: Select True or False (set to False when connecting to a live MarkView environment).
• DatabaseDataSource: Specify the connection string for the Oracle database where the MarkView
schema is located in the format of tns_names_entry.SID.
• DatabaseUID: Enter the MarkView schema name.
• DatabasePWD: MarkView database password.
6. For R12 environments, point the TaxCodes database to a blank TaxCodes.txt file.
The data export service properties for TaxCodes do not apply to R12. However, for the Oracle
R12 environment, you need to point the database to a blank TaxCodes.txt file to prevent Kofax
Transformation Modules project validation errors.
• Create a blank TaxCodes.txt file in your Kofax Transformation Modules project directory, such as
C:\KTM\Markview\KTMSourceFiles\Databases.
• In the Kofax Transformation Modules project, select Project > Project Settings > Databases.
• Select TaxCodes and click Properties.
• Specify the full path to the blank text file. For example, C:\KTM\Markview\KTMSourceFiles
\Databases\TaxCodes.txt.
7. Set the LineItems properties:
1. Select Project > Project Settings.
The Project Settings window opens.
2. Select the Tables tab.
3. In the Table Models area, highlight LineItems and click the Edit Table Model Properties icon.
The Properties window opens.
4. In the Visible column, enable the check boxes for the following fields for Oracle EBS 12.x:
• R. Code
• Tax
• Tax Status
• J. Code
5. In the Visible column, clear the check boxes for the following fields for Oracle EBS 12.x:
•
•
•
•

Receipt Year
Service Entry Sheet Number
Service Entry Sheet Line Number
Tax Code

6. Click OK to close the window.
7. Click the Show Extraction Design icon on the icon bar in the middle of the window.

40

Kofax MarkView Release Notes for Oracle E-Business Suite

8. Double-click the LineItems field definition.
The Properties window opens.
9. In the Always Valid column, enable the check boxes for the following fields for Oracle EBS
12.x:
• Receipt Year
• Service Entry Sheet Number
• Service Entry Sheet Line Number
• Tax Code
10. In the Always Valid column, clear the check boxes for the following fields for Oracle EBS 12.x:
• R. Code
• Tax
• Tax Status
• J. Code
11. Click OK to close the window.
8. (Optional) If you need to set the default Organization ID value, configure the DefaultOrgId variable.
For example, if the Organization ID field is blank, the vendor list is not filtered by Organization ID
correctly. The DefaultOrgId variable value used by Vendor Locator (VL locator) filters vendors.
1. Navigate to Project > Script Variables.
2. In Name, locate DefaultOrgId.
3. For the DefaultOrgId variable, set the appropriate Organization ID value and click OK.
9. For Kofax Transformation Modules version 6.2.0, manually add the reference "Kofax Transformation
database lookup for script integration (11.0)."
1. In Project Tree, right-click Project Class and select Show Script.
2. In the Project - Script Code window, click Edit and select References.
To add the reference to the list, browse to the location of DatabaseDialog.tlb, such
as: C:\Program Files (x86)\Common Files\Kofax\Components. To select the
DatabaseDialog(11.0) reference, open DatabaseDialog.tlb.
3. In Project Tree, right-click Invoice Class and select Show Script.
4. In the Project - Script Code window, click Edit, select References, and add the same
reference.
5. Click Validate Project.
The warning message "The scripted database lookup window is deprecated" may still appear
during the validation. After you added the required reference, this is expected behavior and
does not influence the validation process.

Validate the Kofax Transformation Modules project
1. Select File > Validate Project.
Kofax Transformation Modules displays any error messages related to the project.
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2. If you see database validation warning messages, reestablish links in the project to correct the
database text files.
1. Select Project > Project Settings.
2. Select the Databases tab. Find and correct any database validation issues.
3. If you see library errors, reestablish links in the project to correct the dictionary text files.
1. Select Project > Project Settings.
2. Select the Dictionaries tab.
3. Select the dictionary with validation errors and click Properties.
4. In the Referenced import file box, select the text file of the server with the same name
as the dictionary (such as C:\KTM\MarkView\KTM Source Files\Dictionaries
\DocumentType_Validation.txt) and click OK.
5. Click Import to reimport the dictionaries.
4. Repeat the validation until the process no longer generates errors.
5. If you want to change the default online learning folder defined for the Kofax Transformation Modules
project.
1. Select Project > Project Settings.
2. Select the General tab.
3. Under Online Learning, select Enable online learning.
4. In the Path to online learning box, browse to the appropriate folder (such as C:\KTM
\OnlineLearning_MarkView) and click OK.
6. Select File > Save Project Settings.
7. Click File > Exit to close Project Builder.

About Kofax Capture batch class templates
The following batch class templates are available when imported:
• MarkView Document: Used to separate documents that are not processed by Kofax Transformation
Modules.
• MarkView Invoice: Used to separate documents that are processed by Kofax Transformation Modules.
The batch class templates are set up with batch fields based on Kofax Capture Values, such as Batch
Name, Batch ID, Batch Creation Date, Batch Creation Time, and Scan Operator.

Import the batch class templates
1. Log in to Kofax Capture as an administrator.
2.
3.
4.
5.
6.
7.

Select Import.
In the Open window, select C:\KTM\MarkView\Markview.cab and click Open.
In the Import/Export window, click OK when the unpacking is completed.
In the Import window, click Add All.
Select Save duplicates to new name.
Click Import.
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8. Follow the prompts to save the batch classes to a new name.
9. Click OK when the import is completed.

Prepare the batch class templates
1. Highlight the MarkView Document batch class.
2. Select Properties.
3. On the Separation and Form Identification tab, select Custom. From the list, select MarkView Bar
Code Separators and click Edit Profile.
The Custom Separation and Form Identification Profiles window opens.
4. Enter the following values:
• Enable Bar Code.
• From the list, select MarkView Bar Code.
• Set Found on stand-alone separator sheet as follows:
• To discard the bar code cover sheet after import, select this option.
• To keep the bar code cover sheet with imported documents, clear this option.
• In the Search Text field, enter:
^(CP|DT)ID• Enable Treat search as regular expression.
5. Click Save and Close.
6. Click Apply.
7. Select the MarkView Invoice batch class and repeat steps 2 through 6.

Customize the batch class templates
If you customized your batch classes, copy your customized batch classes to a safe location before you
upgrade. After you upgrade, refer to your customized batch classes when you manually edit the new
batch classes. Then, save the edited batch classes in your runtime directory, such as C:\KTM\Markview
\MyProject.

Synchronize the MarkView batch classes with the Kofax Transformation Modules
project
1. In the Kofax Capture Administration module Batch tab, right-click the MarkView Invoice batch class
and select Synchronize Kofax Transformation Project.
2. In the Synchronization Tool window, select the Classes tab.
3. Select File > Load Project.
4. In the Project File window, open the project (the .fpr file).
5. When the system notifies you that you are replacing the project, click Yes to keep the existing class
and field settings.
6. Click Next Step.
The Synchronization Tool window displays data in two columns: Extraction Field and Index Field.
7. If you have Kofax Capture 10, verify that Unit Price is set correctly in both the Extraction Field and
Index Field columns:
1. Scroll down in the Extraction Field list until you see Unit Price.
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2. If necessary, use the drop-down list to change the value in the Index Field column to Unit
Price.
8. Click Next Step.
9. Click Synchronize.
10. When synchronization is complete, verify the batch class image folder location.
1. Right-click the batch class and select Properties.
2. In the Batch Class Properties window Image folder field, verify the path.
11. Click OK to save and exit.

Set up Kofax MarkView Export Connector
After you associate a document class with a batch class in Kofax Capture, specify and set up Kofax
MarkView Export Connector to use when exporting your documents.
1. Start Kofax Capture Administration.
2. Select the Batch tab.
3. Expand the batch class to view associated document classes.
4. Right-click the MarkView Document class and select Export Connectors.
The Export Connectors window lists all available export connectors. Available export connectors
are those that are registered with Kofax Capture.
5. Under the Available Export Connectors column on the left side of the window, select Kofax
MarkView Export Connector.
6. Click Add to add Kofax MarkView Export Connector to the list of assigned export connectors.
7. In the Assigned Export Connectors section, select Kofax MarkView Export Connector and click
Setup.
8. In the Kofax Capture Export Connector - MarkView window, specify the settings for exporting
documents.
• Name: MarkView Document EC
• Export Settings Instance: MarkView Document
• Skip first page of each document: Clear this check box
• Threshold: Select Enable
9. Click Apply and click OK.
10. Close the Export Connectors window.
11. Right-click the MarkView Invoice class and select Export Connectors.
The Export Connectors window lists all available export connectors. Available export connectors
are those that are registered with Kofax Capture.
12. Under the Available Export Connectors column on the left side of the window, select Kofax
MarkView Export Connector.
13. Click Add to add Kofax MarkView Export Connector to the list of assigned export connectors.
14. In the Assigned Export Connectors section, select Kofax MarkView Export Connector and click
Setup.
15. In the Kofax Capture Export Connector - MarkView window, specify the settings for exporting
invoices.
• Name: MarkView Document EC

44

Kofax MarkView Release Notes for Oracle E-Business Suite

• Export Settings Instance: MarkView Invoice EC
• Skip first page of each document: Clear this check box.
• Threshold: Select Enable
16. Click Apply and click OK.
17. Close the Export Connectors window.

Publish a batch class
After you select the batch class settings, publish the batch class. The publishing process checks the
integrity of the settings in your batch class and makes the batch class available for use. If problems exist
with any of the settings, error and warning messages appear along with the recommended actions for
fixing the problems.
If you edit your batch class, you must publish your batch class again before using it. Changes are not
applied to batches created before the new publication date.
1. Start the Kofax Capture Administration module.
2. Select the Batch class tab.
3. Right-click the batch class and select Publish from the Context menu.
The Publish window opens.
4. Select your batch class and click Publish. Kofax Capture checks all of your batch class settings and
displays the results in the Results box.
• If no problems exist, the message "Publishing successful" appears.
• If problems exist, error and warning messages appear along with the recommended actions to
resolve the problems. Perform the recommended actions, and then try to publish the batch class
again.
After successfully publishing, you can create batches based on your batch class. As your batches flow
through your Kofax Capture system, they are routed from module to module. The batch class definition
specifies the modules that process a batch and the order in which processing occurs.

XSLT files modification
If you customized your existing XSLT file, apply your customizations to the new XSLT files and restart the
Kofax Capture service.
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Resolved issues
This chapter lists issues that are resolved when you install Kofax MarkView 9.1.1.

Synchronization of a manually created user
The AUSS synchronization with the Synchronize one user tool failed for a manually created user.
(1107978)

Error during deployment to the application server
The following error message appeared during deployment to the application server during the installation
(1104209):
Encountered problem while trying to execute InstallInstructions: Failure executing
target 'install' in project 'erp-integration-oracle' Exception thrown while performing
action DEPLOY to the application server.

Reintegrate _CUSTOM packages instruction missing
The "Reintegrating _CUSTOM packages" instruction was not outlined in the "Apply the service pack"
chapter in the release notes. (1097256)

Vendor Data Export service errors
The MarkView Vendor Data Export service did not populate the vendors.txt file as expected. The following
error message appeared in the Event Viewer log file (964608):
Error processing data function:
Exception of type 'System.OutOfMemoryException' was thrown.
at System.Data.Common.StringStorage.SetCapacity(Int32 capacity)
at System.Data.RecordManager.set_RecordCapacity(Int32 value)
at System.Data.RecordManager.GrowRecordCapacity()
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Origin Information not displayed for new batches
The Origin Information section for the Document displayed "No data to view". (960074)

Batch Print not working from Invoice Audit
In Invoice Audit, after you clicked Print to print an invoice, the following error appeared (957359):
An error occurred in submitting the print request. An incorrect print queue setup could
cause this error. Contact your MarkView System Administrator.

Custom authentication issues
The custom authentication was not working correctly. (894100)
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Known issues
This chapter lists issues that you may encounter while using Kofax MarkView 9.1.1. Workarounds are
provided, as applicable.

Inconsistent date format in AUSS
On the AUSS Current Status, AUSS Options, Synchronization, and Journal pages, characters used as
date separators are different. (1077018)

Incorrect time sorting in AUSS Journal
The AUSS Journal page displays the synchronization history by time in descending order, but the sorting
does not take into account the AM and PM format. (1076962)

Error during MarkView installation with WebLogic 12.2
If you use MarkView with WebLogic Server 12.2, the installation may fail with the error (1075168):
Failure executing target 'install' in project 'frameworks' Exception thrown while
performing action DEPLOY to the application server.

Workaround:
1. Locate the following file:
<installation_directory>/Oracle/Middleware/Oracle_Home/wlserver/modules/
com.oracle.weblogic.security.opensaml2.jar

Where <installation_directory> is the location where you installed WebLogic Server 12.2.
2. Remove the file or change the file extension.

Incorrect version number
In Kofax Capture Administration, the Workflow Agent Manager window displays incorrect Kofax MarkView
Batch Number version. (980199)
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Missing references in the MarkView KTM Invoice project
For Kofax Transformation Modules version 6.2.0, the following warning message may appear (961092):
The scripted database lookup window is deprecated.

Workaround:
1. In Kofax Transformation Modules Project Builder, open the Kofax Transformation Modules project.
2. In Project Tree, right-click Project Class and select Show Script.
3. In the Project - Script Code window, click Edit and select References.
To add the reference to the list, browse to the location of DatabaseDialog.tlb, such as: C:\Program
Files (x86)\Common Files\Kofax\Components. To select the DatabaseDialog(11.0) reference,
open DatabaseDialog.tlb.
4. In Project Tree, right-click Invoice Class and select Show Script.
5. In the Project - Script Code window, click Edit, select References, and add the same reference.
6. Click Validate Project.
The warning message "The scripted database lookup window is deprecated" may still appear during
the validation. After you add the required reference, the warning is expected, even though it does not
influence the validation process.
7. Select File > Save Project Settings.
8. Click File > Exit to close Project Builder.
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